Основные принципы настройки - Понятия

Основные принципы настройки
Понятия
Процедуры
Команды

AutoCAD® является универсальной графической системой с открытой архитектурой, поэтому многие ее функции можно настраивать и дополнять. Открытость архитектуры AutoCAD позволяет настраивать и расширять возможности среды в соответствии с требованиями пользователя.

  • Основные возможности настройки
  • Организация программных и вспомогательных файлов
    Пользователь может изменять структуру папок AutoCAD в соответствии со своими нуждами.
  • Настройка шаблонов Интернет-публикаций
    Можно настроить шаблоны публикаций, чтобы использовать их в "Мастере публикаций в Интернете", изменяя PWT-файлы, поставляемые с AutoCAD. Для настройки шаблонов можно использовать любой текстовый или HTML-редактор.
  • Создание пользовательских команд
    Можно определить внешние команды, выполняемые в программе AutoCAD. Для команд AutoCAD можно создать псевдонимы в файле acad.pgp (текстовый файл ASCII, в котором хранятся все описания команд).
Ваш комментарий об этой странице


Основные принципы настройки - Процедуры

Основные принципы настройки
Понятия
Процедуры
Команды

Для быстрого доступа к шаблону публикаций

Настройка шаблона "Публикации в Интернете"

Открытие файла параметров программ (acad.pgp)


Основные принципы настройки - Команды

Основные принципы настройки
Понятия
Процедуры
Команды
Команды
ДАКОМ | Восстановление внутренних команд AutoCAD, подавленных командой НЕТКОМ
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
НЕТКОМ | Замена внутренней команды другой командой, определенной в приложении
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
ОПУБЛИКОВАТЬ | Создание HTML-страниц с изображениями выбранных чертежей
ПЕРЕИН | Повторная инициализация портов ввода-вывода, дигитайзера, монитора и файла параметров программ
Системные переменные
CMDECHO | Управление повтором подсказок и ввода при выполнении функции команды AutoLISP.
LOCALROOTPREFIX | Сохраняет полный путь к корневой папке, в которую были установлены локальные адаптируемые файлы
ROAMABLEROOTPREFIX | Сохраняет полный путь к корневой папке, в которую были установлены перемещаемые адаптируемые файлы
TOOLTIPS | Управляет отображением подсказок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Основные возможности настройки - Понятия

Основные принципы настройки
Основные возможности настройки
Понятия
Процедуры
Команды

Программа AutoCAD легко настраивается. Например, можно изменять структуру каталогов или перемещать кнопки с одной панели на другую. Для более сложной настройки интерфейса можно редактировать НПИ-файл и использовать DIESEL-выражения для создания меню с собственными пунктами.

Кроме того, для настройки AutoCAD в соответствии с требованиями пользователя применяются различные мощные интерфейсы программирования приложений (API).

Основные возможности приведены далее в порядке увеличения сложности.

  • Организация файлов. Существует возможность организации программных и вспомогательных файлов, а также файлов чертежей AutoCAD. Например, в каждом проекте можно создать отдельные папки для вспомогательных файлов.
  • Настройка инструментальных палитр. Инструмент может быть создан простым перетаскиванием объектов из чертежа в область инструментальной палитры. Чтобы создать инструмент, нажмите правую кнопку мыши на заголовке окна "Инструментальные палитры" и выберите "Создать". Для получения сведений о настройке инструментальных палитр см. раздел “Настройка инструментальных палитр” в Руководстве пользователя.
  • Создание пользовательских шаблонов. Шаблоны применяются для задания общих параметров при публикации чертежа с помощью "Мастера публикации в Интернете".
  • Запуск внешних программ и утилит из среды AutoCAD. Например, определив в файле параметров программы acad.pgp соответствующую внешнюю команду, можно непосредственно из среды AutoCAD скопировать диск или удалить файл.
  • Задание псевдоимен команд. Для часто используемых команд можно задать простые аббревиатуры или альтернативные имена непосредственно из среды AutoCAD. Для этого необходимо добавить команду в PGP-файл acad.pgp. Например, может оказаться удобнее вызывать команду БЛОК вводом единственной буквы б.
  • Создание пользовательских типов линий, образцов штриховок, форм и текстовых шрифтов. Имеется возможность создавать собственные типы линий, образцы штриховок, формы и шрифты, которые соответствуют используемым при черчении стандартам.
  • Настройка интерфейса пользователя. НПИ-файл управляет многими элементами пользовательского интерфейса, включая кнопочные меню устройства указания, а также раскрывающиеся, планшетные меню, меню мозаики изображений, панели инструментов и клавиши быстрого вызова. Можно отредактировать существующий или создать новый НПИ-файл, чтобы добавить команды или создать группу команд и назначить их меню, панели инструментов или другому элементу интерфейса.
  • Настройка строки состояния. С помощью языка строковых выражений DIESEL и системной переменной MODEMACRO в строку состояния можно выводить такую дополнительную информацию, как дата, время и параметры системных переменных, а с помощью языка AutoLISP® - другую используемую информацию.
  • Автоматизация часто выполняемых последовательностей операций с помощью сценариев. Сценарий представляет собой текстовый ASCII-файл, содержащий набор команд AutoCAD, который при выполнении обрабатывается так же, как командный файл операционной системы. Например, если необходимо определенным образом вывести на печать набор чертежей, можно написать файл сценария, который поочередно открывает чертежи, включает и отключает определенные слои и выполняет команду ПЕЧАТЬ. Файлы сценариев можно использовать совместно со слайдами для создания презентаций. Слайд представляет собой нередактируемую “фотографию” области рисования. Слайды можно использовать для вывода графической информации в меню мозаики изображений и диалоговые окна.
  • Переопределение или отключение выбранных команд AutoCAD либо из командной строки, либо как составляющей приложения AutoLISP или ObjectARX®. Например, можно переопределить команды AutoCAD таким образом, чтобы они соответствовали дополнительным сообщениям и операторам, или создать систему управления чертежами, в которой команда ПОКИНУТЬ переопределена и перед завершением сеанса редактирования выполняет запись информации о стоимости в файл журнала.

Кроме способов настройки, описанных в Руководстве по настройке, можно воспользоваться интерфейсами прикладного программирования (API) для AutoCAD. Раздел Введение в интерфейсы программирования содержит краткое описание этих интерфейсов.

См. также

Организация программных и вспомогательных файлов

Настройка панелей инструментов

Настройка шаблонов Интернет-публикаций

Псевдоимена команд

Настройка типов линий

Пользовательские образцы штриховки

Настройка интерфейса пользователя

DIESEL

Настройка строки состояния

Введение в интерфейсы программирования

Слайды и командные сценарии


Основные принципы настройки
Основные принципы настройки
Понятия
Процедуры
Команды

Нет процедур.


Основные возможности настройки - Команды

Основные принципы настройки
Основные принципы настройки
Основные возможности настройки
Понятия
Процедуры
Команды

Команды
ДАКОМ | Восстановление внутренних команд AutoCAD, подавленных командой НЕТКОМ
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
НЕТКОМ | Замена внутренней команды другой командой, определенной в приложении
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
TOOLTIPS | Управляет отображением подсказок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Организация программных и вспомогательных файлов - Понятия

Основные принципы настройки
Организация программных и вспомогательных файлов
Понятия
Процедуры
Команды

Пользователь может изменять структуру папок AutoCAD в соответствии со своими нуждами.

  • Коротко об организации файлов
  • Работа с несколькими конфигурациями
    При использовании нескольких устройств указания или при работе с различными плоттерами можно создать несколько конфигураций для упрощения процесса переключения между устройствами.
  • Хранение чертежей в нескольких папках
    Хранение чертежей и связанных с ними файлов в отдельных папках значительно упрощает проведение основных файловых операций.


Организация программных и вспомогательных файлов - Процедуры

Основные принципы настройки
Организация программных и вспомогательных файлов
Понятия
Процедуры
Команды

Нет процедур для этой темы.


Организация программных и вспомогательных файлов - Команды

Основные принципы настройки
Организация программных и вспомогательных файлов
Понятия
Процедуры
Команды
Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
CMDECHO | Управление повтором подсказок и ввода при выполнении функции команды AutoLISP.
LOCALROOTPREFIX | Сохраняет полный путь к корневой папке, в которую были установлены локальные адаптируемые файлы
ROAMABLEROOTPREFIX | Сохраняет полный путь к корневой папке, в которую были установлены перемещаемые адаптируемые файлы
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко об организации файлов - Понятия

Основные принципы настройки
Коротко об организации файлов
Понятия
Процедуры
Команды

Файлы поддержки используются программой AutoCAD для хранения описаний настроек, загрузки приложений AutoLISP и ObjectARX и описания текстовых шрифтов.

Структура папок AutoCAD, используемая по умолчанию, отражает организацию программных и вспомогательных файлов AutoCAD по логическим группам. Пользователь может изменить структуру папок, если она по каким-либо причинам его не устраивает. Однако, следует учитывать, что для работы некоторых приложений требуется наличие файлов в определенных папках; поэтому изменения следует выполнять так, чтобы не возникало конфликтов. Если имена диска и папки не указаны, файл может быть найден программой AutoCAD только если он располагается по стандартному пути поиска библиотек.

В версии AutoCAD 2007 изменилось расположение папки support. Пути к локальным настраиваемым файлам хранятся в системной переменной LOCALROOTPREFIX. Пути к перемещаемым настраиваемым файлам хранятся в системной переменной ROAMABLEROOTPREFIX. Если сеть поддерживает перемещаемые профили, то настраиваемые файлы, находящиеся в перемещаемом профиле пользователя, доступны для него при работе на любом компьютере в сети.

Следующая LISP-процедура создает команду CUSTFILES, которая запускает Проводник Windows® в нужной папке.

(defun c:custfiles ()
  (command "_shell"
    (strcat "explorer \"" (getvar "roamablerootprefix") "\"")
  )
  (princ)
)
Путь поиска библиотек

Поиск вспомогательных файлов осуществляется в соответствии с установленным путем поиска библиотек, т.е. в следующем порядке:

  • Текущая папка. Как правило, она задается в поле “Рабочий каталог” окна свойств ярлыка программы.
  • Папка, в которой находится текущий файл чертежа.
  • Папки, перечисленные при задании пути доступа в команде НАСТРОЙКА. (См. раздел Укажите "Пути поиска" и "Местоположения файлов" в Руководстве пользователя.)
  • Папка, в которой находятся программные файлы AutoCAD.

В зависимости от установок среды, имена двух или более папок из приведенной последовательности могут совпадать.

Если файл не находится ни в одной из папок, просматриваемых при поиске, необходимо задавать его полное имя (включая путь), чтобы AutoCAD мог найти его. Например, для того чтобы вставить в чертеж блок, хранящийся в файле part5.dwg и располагающийся вне пути поиска библиотек, необходимо сделать следующее.

Команда: вставить

Ввести имя блока или [?]: /files2/olddwgs/part5

Если вставляемый чертеж найден в указанной папке, AutoCAD продолжает выдавать стандартные запросы на прекращение выполнения команды ВСТАВИТЬ.

Структура папок

AutoCAD использует иерархическую структуру папок. Рекомендуется хранить дополнительные файлы (например, приложения на языке AutoLISP и файлы настройки) отдельно от программных и вспомогательных файлов AutoCAD. Это упрощает разрешение возможных конфликтов и дает возможность обновлять версии приложений, не воздействуя на другие приложения.

По умолчанию файлы AutoCAD хранятся в папке Program Files. Можно создать на том же уровне новую папку (например, /AcadApps), затем создать в ней вложенные папки для макросов AutoLISP и VBA, файлов настроек и сторонних приложений. В случае, когда на одном компьютере параллельно выполняется несколько проектов, можно создать отдельную папку для чертежей (например, /AcadJobs), создать в ней группу вложенных папок для каждого проекта.

Последовательность поиска команд

При вводе команды AutoCAD совершает ряд действий по оценке корректности ее имени. Командами могут являться встроенные команды или системные переменные, внешние команды или псевдонимы, определенные в файле acad.pgp, а также команды приложений AutoLISP. Кроме того, команды могут описываться в приложениях ObjectARX и в драйверах устройств. Команды вводятся в командной строке или инициируются путем выбора соответствующего пункта меню. Команды могут вызываться из файла сценария, а также из приложений AutoLISP или ObjectARX.

Ниже приведено описание последовательности поиска, применяемой в программе AutoCAD для проверки имени команды.

  1. При пустом вводе (нажатии клавиши ПРОБЕЛ или ENTER без ввода имени команды), AutoCAD повторно обращается к последней выполненной команде. Если команды еще не вводились, по умолчанию вызывается команда СПРАВКА.
  2. AutoCAD проверяет имя команды на соответствие встроенным командам. Если имя обнаружено и ему не предшествует точка (.), AutoCAD проверяет имя команды на соответствие неопределенным командам. Если это переопределенная команда, то поиск продолжается. В противном случае команда выполняется (если нет каких-либо веских причин, препятствующих этому — например, невозможность прозрачного выполнения или выполнения в режиме перспективы).
  3. AutoCAD сначала проверяет имя команды на соответствие командам, описанным в драйвере устройства, а затем командам, описанным в драйвере монитора.
  4. AutoCAD проверяет имя команды на соответствие внешним командам, описанным в файле параметров программ (acad.pgp). Если имя соответствует определению внешней команды, то эта команда выполняется и поиск прекращается.
  5. AutoCAD проверяет имя команды на соответствие командам, описанным в приложениях AutoLISP или ObjectARX. В этот момент происходит загрузка в память автоматически загружаемых команд.
  6. AutoCAD проверяет имя команды на соответствие системным переменным. При обнаружении совпадения AutoCAD выполняет команду УСТПЕРЕМ с использованием в качестве имени переменной введенного имени.
  7. Если имя команды соответствует псевдониму команды, определенному в файле параметров программы, AutoCAD использует развернутое имя команды и начинает новый цикл поиска (проверка имени на соответствие встроенным командам).
  8. Если поиск оказался безуспешным, выдается сообщение о том, что команда неизвестна.

См. также

Коротко об автоматической загрузке процедур AutoLISP

Укажите "Пути поиска" и "Местоположения файлов" в Руководстве пользователя


Организация программных и вспомогательных файлов

Основные принципы настройки
Организация программных и вспомогательных файлов
Понятия
Процедуры
Команды

Нет процедур.


Коротко об организации файлов - Команды

Основные принципы настройки
Основные принципы настройки
Коротко об организации файлов
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
LOCALROOTPREFIX | Сохраняет полный путь к корневой папке, в которую были установлены локальные адаптируемые файлы
ROAMABLEROOTPREFIX | Сохраняет полный путь к корневой папке, в которую были установлены перемещаемые адаптируемые файлы
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа с несколькими конфигурациями - Понятия

Основные принципы настройки
Работа с несколькими конфигурациями
Понятия
Процедуры
Команды

При использовании нескольких устройств указания или при работе с различными плоттерами можно создать несколько конфигураций для упрощения процесса переключения между устройствами.

При создании конфигурации введенная информация об устройствах AutoCAD (указания, печати и др.) записывается в файл настройки. По умолчанию файл настройки acad2007.cfg размещается в папке, указанной на вкладке "Файлы" диалогового окна "Параметры" в группе "Имена файлов справки и других файлов". Но возможно сохранить файл в другой папке или изменить его имя.

Обычно одного набора настроек достаточно, но в некоторых случаях требуется несколько наборов настроек. Например, если на протяжении всей работы используется мышь, но иногда требуется использовать большой графический планшет, можно настроить систему для использования нескольких наборов настроек вместо того, чтобы перенастраивать конфигурацию при каждой смене устройства.

В файле настройки запоминаются значения некоторых системных переменных AutoCAD и некоторые параметры, установленные в диалоговом окне настройки. Если требуется часто менять значения этих системных переменных и параметров, можно сохранить их в отдельных файлах настройки. Для получения сведений о системных переменных см. раздел "Системные переменные" в Справочнике команд.

Для того чтобы AutoCAD использовал файл настройки, отличный от стандартного, нужно дать программе соответствующее указание. Задание альтернативного файла настройки производится с помощью атрибута командной строки /c.

См. также

Настройка запуска в Руководстве пользователя


Работа с несколькими конфигурациями - Команды

Основные принципы настройки
Основные принципы настройки
Работа с несколькими конфигурациями
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Хранение чертежей в нескольких папках - Понятия

Основные принципы настройки
Хранение чертежей в нескольких папках
Понятия
Процедуры
Команды

Хранение файлов чертежей и связанных с ними файлов в отдельных папках значительно упрощает проведение основных файловых операций. В дальнейшем изложении предполагается, что файлы и папки организованы в структуру, описанную в разделе Коротко об организации файлов. Пользователь может модифицировать ее в соответствии со своими требованиями.

Можно создать папку /AcadJobs и завести в ней вложенные папки для чертежей, относящихся к выполняемым проектам. В них, в свою очередь, могут содержаться другие папки для вспомогательных файлов, относящихся к данному конкретному типу чертежа или задания. Папка /AcadJobs/Job1/Support может хранить блоки и файлы AutoLISP, требуемые для чертежей из папки /AcadJobs/Job1. Если при задании пути к файлам поддержки введено support (без указания полного пути от начала структуры), поиск таких файлов производится в папке Support, вложенной в текущую папку. Следует учитывать, что при задании имен папок в диалоговом окне "Параметры" AutoCAD сам формирует для них жестко запрограммированный путь. Чтобы воспользоваться возможностью работы с относительными путями, необходимо задать путь доступа с помощью атрибута /s в командной строке. См. раздел Настройка запуска в Руководстве пользователя.

Создайте ярлык программы или пункт меню "Пуск" для каждой рабочей папки. Это позволит проверять, является ли требуемая папка с чертежами текущей при запуске AutoCAD и ко всем ли находящимся в ней файлам и вложенным папкам обеспечивается простой доступ. Эта функция работает, только если в AutoCAD системной переменной REMEMBERFOLDERS присвоено значение 0.

В качестве альтернативы можно запускать продукт из командного файла, где выполняются различные операции с папками. В следующем примере командного файла сначала производится проверка существования папки проекта, ее установка текущей, а затем запуск AutoCAD.

@echo off
C:
if exist \AcadJobs\Jobs\%1 goto RUNACAD
echo.
echo *** Создание папки \AcadJobs\Jobs\%1
echo *** Для прерывания нажмите Ctrl+C.
echo.
pause
mkdir \AcadJobs\Jobs\%1
:RUNACAD
cd \AcadJobs\Jobs\%1
start C:\ AutoCAD\acad.exe

Набранный в текстовом редакторе ASCII (например, Блокноте) текст пакетной программы необходимо сохранить в файле acad.bat. Не забудьте изменить имена дисков и папок в соответствии с требованиями системы. Файл должен быть помещен в папку, указанную в переменной, которая определяет пути поиска в системе (например, C:\winnt). Для того чтобы запустить командный файл, можно воспользоваться пунктом "Выполнить" меню "Пуск", или дважды нажать на ярлыке файла в Проводнике. Если файл сохранен под именем acad.bat, для его вызова используется следующий синтаксис:

acadимя_проекта

где имя_проекта - это имя папки, в которой хранятся файлы текущего проекта.


Хранение чертежей в нескольких папках - Команды

Основные принципы настройки
Основные принципы настройки
Хранение чертежей в нескольких папках
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
CMDECHO | Управление повтором подсказок и ввода при выполнении функции команды AutoLISP.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка шаблонов Интернет-публикаций - Понятия

Основные принципы настройки
Настройка шаблонов Интернет-публикаций
Понятия
Процедуры
Команды

Можно настроить шаблоны публикаций, чтобы использовать их в "Мастере публикаций в Интернете", изменяя PWT-файлы, поставляемые с AutoCAD. Для настройки шаблонов можно использовать любой текстовый или HTML-редактор.

Для создания пользовательского шаблона необходимо добавить или изменить следующие компоненты:

  • Изображения
  • Текст
  • Гиперссылки
  • Цвет
  • Заголовки
  • Видеофрагменты, анимации и т.д.

В поставку продукта входит четыре типа настраиваемых шаблонов Интернет-публикаций:

  • Массив образцов: Создание Web-страницы, содержащей массив изображений-образцов.
  • Массив образцов с пояснениями: Создание Web-страницы, содержащей массив изображений-образцов и область для пояснений.
  • Список чертежей: Создание Web-страницы, содержащей список чертежей и рамку для изображений.
  • Список чертежей с пояснениями: Создание Web-страницы, содержащей список чертежей, рамку для изображений и область для пояснений.

Примечание Для настройки шаблонов публикаций пользователь должен быть хорошо знаком с синтаксисом языка HTML.

Изменения и добавления можно производить в строгом соответствии с подсказками, приведенными в файле шаблона. Например, в шаблоне Массив образцов изображения-образцы на странице организованы по рядам. Изменять расположение этих образцов не разрешается. Однако пользователь может изменять изображения и текст, расположенные вне таблицы образцов.

Предупреждение Для того чтобы не потерять исходный файл шаблона публикаций, перед внесением в него изменений рекомендуется сделать резервную копию файла.


Настройка шаблонов Интернет-публикаций - Процедуры

Основные принципы настройки
Настройка шаблонов Интернет-публикаций
Понятия
Процедуры
Команды

Для быстрого доступа к шаблону публикаций

Настройка шаблона "Публикации в Интернете"


Для быстрого доступа к шаблону публикаций - Процедуры

Основные принципы настройки
Настройка шаблонов Интернет-публикаций
Понятия
Процедуры
Команды

Для быстрого доступа к шаблону публикаций

  1. Из меню "Сервис" выберите "Параметры".
  2. В диалоговом окне "Параметры" откройте вкладку "Файлы" и нажмите значок "плюс" (+) для параметров шаблона. Затем нажмите значок "плюс" для параметра "Папка для шаблона чертежа".
  3. Наведите курсор на имя пути и нажмите левую кнопку мыши, нажмите F2 , затем скопируйте путь, используя сочетание клавиш CTRL + C.
  4. Нажмите кнопку "ОК" или "Отмена" для закрытия диалогового окна "Параметры".
  5. Из меню "Файл" выберите "Открыть".
  6. В диалоговом окне "Выбор файла" нажмите правую кнопку в любом месте пустой части левой области окна, где располагаются хранилища информации, и выберите из раскрывшегося меню команду "Добавить".
  7. В поле "Имя" введите любое имя (например, Шаблоны).
  8. Для вставки имени пути в поле "Путь" можно использовать сочетание клавиш CTRL+V, затем нажмите кнопку "OK".

    9. Теперь доступ к папкам с шаблонами можно осуществлять с помощью кнопок в левой области диалогового окна "Выбор файла".


Настройка шаблона "Публикации в Интернете" - Процедуры

Основные принципы настройки
Настройка шаблонов Интернет-публикаций
Понятия
Процедуры
Команды

Настройка шаблона "Публикации в Интернете"

  1. Откройте папку шаблонов публикаций, выбрав из меню "Файл" пункт "Открыть".

    2. См. раздел Для быстрого доступа к шаблону публикаций.

  2. Двукратным нажатием кнопки мыши откройте папку PTWTemplates. На экран выводится список папок, каждая из которых содержит файл шаблона и изображения для просмотра (BMP), которые пользователь видит в "Мастере публикаций".
    • Шаблон1. Содержит шаблон Массив образцов и соответствующее изображение для просмотра
    • Шаблон2. Содержит шаблон Массив образцов с пояснениями, изображение для просмотра и HTML-фреймы
    • Шаблон3. Содержит шаблон Список чертежей, изображение для просмотра и HTML-фреймы.
    • Шаблон4. Содержит шаблон Список чертежей с пояснениями, изображение для просмотра и HTML-фреймы.
  3. Нажмите правую кнопку мыши на нужную папке и выберите из контекстного меню пункт "Копировать".
  4. Нажмите ALT + 2, затем нажмите правую кнопку на папке PTWTemplates и выберите "Вставить".
  5. Заново откройте папку PTWTemplates, нажмите правую кнопку на новой папке и переименуйте ее.
  6. Нажмите правую кнопку на новой папке и выберите из контекстного меню пункт "Открыть" для просмотра ее содержимого.
  7. Измените расширение файла шаблона (PWT-файла) на .htm или .html.
  8. Откройте файл шаблона в текстовом или HTML-редакторе.

    9. В файле шаблона содержатся комментарии, помогающие пользователю определить, какие части кода следует изменить для создания новой Web-страницы.

  9. Просмотрите комментарии и внесите изменения в те части шаблона, которые требуется настроить.
  10. Сохраните измененный шаблон в PWT- файле (файле с расширением PWT). Файл следует сохранять в папке, созданной в пункте 3.

    11. Примечание Папка шаблона может содержать только один PWT-файл. При создании в папке нового PWT-файла следует убедиться, что из этой папки удалены все остальные PWT-файлы.

    При запуске "Мастера публикаций в Интернете" настроенный шаблон отображается в списке шаблонов.


Настройка шаблонов Интернет-публикаций

Основные принципы настройки
Настройка шаблонов Интернет-публикаций
Понятия
Процедуры
Команды

Нет процедур.


Настройка шаблонов Интернет-публикаций - Команды

Основные принципы настройки
Основные принципы настройки
Настройка шаблонов Интернет-публикаций
Понятия
Процедуры
Команды

Команды
ОПУБЛИКОВАТЬ | Создание HTML-страниц с изображениями выбранных чертежей
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание пользовательских команд - Понятия

Основные принципы настройки
Создание пользовательских команд
Понятия
Процедуры
Команды

Можно определить внешние команды, выполняемые в программе AutoCAD. Для команд AutoCAD можно создать псевдонимы в файле acad.pgp (текстовый файл ASCII, в котором хранятся все описания команд).

  • Описание внешних команд
    При работе в AutoCAD с помощью внешних команд можно запускать другие программы и утилиты.
  • Псевдоимена команд
    Вместо полных имен команд можно использовать их сокращенные псевдоимена.


Создание пользовательских команд - Процедуры

Основные принципы настройки
Создание пользовательских команд
Понятия
Процедуры
Команды

Открытие файла параметров программ (acad.pgp)


Создание пользовательских команд - Команды

Основные принципы настройки
Создание пользовательских команд
Понятия
Процедуры
Команды
Команды
ПЕРЕИН | Повторная инициализация портов ввода-вывода, дигитайзера, монитора и файла параметров программ
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Описание внешних команд - Понятия

Основные принципы настройки
Описание внешних команд
Понятия
Процедуры
Команды

При работе в AutoCAD с помощью внешних команд можно запускать другие программы и утилиты.

При работе в AutoCAD можно вызывать другие программы и утилиты, например:

  • Системные команды и утилиты Windows, такие как start, type, dir и copy
  • Приложения (например, текстовые редакторы)
  • Системы управления базами данных, электронные таблицы, коммуникационные программы
  • Созданные пользователем программы (командные файлы, макросы VBA)

При вводе внешней команды AutoCAD производит поиск этой команды в acad.pgp. В первом разделе acad.pgp определяются внешние команды. Чтобы добавить описание команды, необходимо отредактировать acad.pgp в текстовом редакторе ASCII (например, Блокноте). Чтобы открыть PGP-файл, в меню "Сервис" необходимо выбрать "Настройка" » " Изменение параметров программы (acad.pgp)".

Примечание Перед редактированием файла acad.pgp следует создать его резервную копию для восстановления в случае необходимости.

Процесс создания описания внешней команды заключается в указании ее имени, вводимого в командной строке AutoCAD, и строки, передаваемой в операционную систему. Каждая запись в разделе внешних команд состоит из пяти полей, разделенных запятыми:

команда,[исполняемая_команда],флаги[,[*]подсказка[,код_возврата]]

команда

Команда вводится в командной строке. Если имя совпадает с именем встроенной команды AutoCAD, оно игнорируется. Имя может быть введено в любом регистре.

исполняемая_команда

Строка, передаваемая в операционную систему при вводе имени команды. Такой строкой может быть любая команда, которую можно выполнить в ответ на подсказку операционной системы. Она может содержать параметры и атрибуты. Чувствительность строки к регистру зависит от исполняемого приложения.

флаги

Обязательный параметр, представляющий собой сумму битовых значений (битовый вектор). Для получения необходимого результата следует сложить приведенные ниже целые значения.

0 Запустить приложение и дождаться завершения его работы.

1 Не дожидаться завершения работы приложения.

2 Запустить приложение в свернутом окне.

4 Запустить приложение в скрытом режиме. ”

8 Заключить строку аргументов в кавычки.

Значения 2 и 4 - взаимоисключающие; если заданы оба, используется только значение 2. Следует избегать использования значений 2 или 4 без значения 1, т.к. в этом случае AutoCAD становится недоступным до тех пор, пока не завершится выполнение внешнего приложения.

Значение 8 позволяет командам, подобным del, правильно обрабатывать файлы, в именах которых имеются пробелы. Это ограничивает возможность передачи в команды списка имен файлов, в котором элементы разделены пробелами. Для того чтобы выполнять групповую обработку файлов, не следует использовать значение 8.

подсказка

Этот элемент не обязателен. Он задает подсказку, выводимую в командной строке AutoCAD. Ответ на нее присоединяется к постоянной командной строке, указанной в элементе "исполняемая_команда". Если первым символом элемента является звездочка (*), ответ может содержать пробелы, и для завершения ответа необходимо нажать клавишу ENTER. В остальных случаях ответ заканчивается нажатием клавиши ПРОБЕЛ или ENTER. Если подсказка не требуется, но за ней должны следовать какие-либо поля данных, в описании команды ставится просто запятая. Запятую также нужно ставить, чтобы отделить подсказку от последующего текста пробелом.

код_возврата

Необязательный параметр, представляющий собой сумму битовых значений (битовый вектор). Значение параметра строится путем суммирования перечисленных ниже значений. Например, если активными должны быть значения 1 и 2, в качестве кода возврата следует ввести 3. Коды 0 и 4 не имеют смысла в графической многооконной среде, и поэтому здесь не описаны.

1 Загрузить файл DXB. После завершения команды AutoCAD выполняет загрузку DXB-файла $cmd.dxb в чертеж. После загрузки файл $cmd.dxb удаляется с диска. Процесс подобен вызову команды ИМПОРТД.

2 Создать описание блока по DXB-файлу. AutoCAD создает описание блока из объектов DXB-файла $cmd.dxb. В качестве имени блока используется ответ на запрос. Введенное имя должно быть допустимым именем блока, еще не определенного в данном чертеже. После загрузки программой AutoCAD файл $cmd.dxb удаляется. Имя по умолчанию для команды ВСТАВИТЬ становится именем созданного блока.

Файл также может содержать строки комментариев, которые должны начинаться символом точки с запятой (;).

Вызов системных команд Windows

При описании внешних команд AutoCAD часто используются системные команды Windows start и cmd. Если в строке исполняемой команды не присутствует команда start или cmd, AutoCAD остается недоступным до тех пор, пока не будет закрыто окно внешнего приложения.

Команда start открывает новое окно и запускает в нем указанную в аргументе программу. Если команда start вызвана без параметров, она открывает новое окно командной строки. Команда может сопровождаться атрибутами, которые определяют вид нового окна. Для того чтобы запустить приложение Windows в обычном режиме, нужно использовать start без атрибутов. Команда start также может применяться для открытия документов, для которых в системе имеются соответствующие приложения. Таким образом, например, открывают текстовые документы, HTML-файлы и т.п.

Команда cmd открывает окно командной строки, являющееся оболочкой AutoCAD. Для того чтобы управление было возвращено командной строке AutoCAD, необходимо закрыть это окно. Для выполнения внешних команд можно использовать атрибуты /c и /k. Ввод атрибута /c вызывает выполнение указанной команды с последующим закрытием окна. Ввод атрибута /k вызывает выполнение указанной команды, но по ее завершении окно командной строки остается открытым. При использовании атрибута/k окно следует закрывать вручную (с помощью команды exit).

Итак, команду start следует использовать для запуска приложений, которые должны выполняться отдельно от AutoCAD. Команда cmd используется для запуска командного файла или командного сценария, для выполнения которых не нужно отдельное окно, а также для выполнения приложений в отдельном окне, которое закрывается до передачи управления AutoCAD. Подробнее об упомянутых здесь командах и атрибутах можно узнать в документации по Windows.

Пользовательские команды

В следующем примере описано создание трех новых команд: RUN, LISTSET, и DXB2BLK.

RUN, cmd /c,0,*Имя командного файла: ,
LISTSET,cmd /k SET,0
DXB2BLK,cmd /c DXBCOPY,0,DXB-файл: ,2

Команда RUN запускает командный файл или командный сценарий. Команда cmd, за которой следует атрибут /c, открывает окно командной строки, выполняет командный файл, а затем закрывает окно.

Команда LISTSET выводит на экран перечень текущих значений переменных среды операционной системы. Так как в описании команды использовано cmd /k, а не start, перед возвратом в AutoCAD необходимо вручную закрыть окно командной строки. Если же требуется, чтобы окно и далее оставалось активным, нужно вызывать команду с помощью start /realtime. Подробнее об упомянутых здесь командах и атрибутах можно узнать в документации по Windows.

Команда DXB2BLK создает описание блока из указанного DXB-файла. Все объекты в DXB-файлах представлены в виде отрезков. Полезный побочный эффект данной процедуры — возможность простого преобразования текстовых объектов в отрезки.

DXB2BLK передает указанное имя DXB-файла в командный файл dxbcopy, который копирует DXB-файл в файл с именем $cmd.dxb. Затем AutoCAD создает блок из указанного DXB-файла. В качестве имени блока принимается имя, введенное в ответ на запрос имени DXB-файла. Для того чтобы создать файл dxbcopy.cmd, нужно ввести в ответ на запрос Windows следующее:

echo copy %1.dxb $cmd.dxb > dxbcopy.cmd

С помощью этой записи создается файл dxbcopy.cmd в текущей папке. Этот файл можно переместить в одну из папок, путь к которым известен операционной системе, или можно указать полный путь к файлу в файле acad.pgp. Например, если dxbcopy.cmd располагается в папке D:\cad, в разделе описания внешних команд файла acad.pgp необходимо ввести:

DXB2BLK, cmd /c D:\CAD\DXBCOPY,0,файл_DXB: ,2

Для того чтобы создать файл DXB, необходимо установить в качестве текущего устройства печати специальный драйвер DXB AutoCAD, а затем выполнить печать в файл. Подробнее о настройке устройств печати см. раздел Настройка плоттеров и принтеров в Руководстве по драйверам и устройствам .


Открытие файла параметров программ (acad.pgp) - Процедуры

Основные принципы настройки
Описание внешних команд
Понятия
Процедуры
Команды

Открытие файла параметров программ (acad.pgp)

  • В меню "Сервис" выберите "Настройка" » "Изменение параметров программы" (acad.pgp).


Описание внешних команд - Команды

Основные принципы настройки
Основные принципы настройки
Описание внешних команд
Понятия
Процедуры
Команды

Команды
ПЕРЕИН | Повторная инициализация портов ввода-вывода, дигитайзера, монитора и файла параметров программ
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Псевдоимена команд - Понятия

Основные принципы настройки
Псевдоимена команд
Понятия
Процедуры
Команды

Вместо полных имен команд можно использовать их сокращенные псевдоимена.

Например, можно вместо слова круг ввести единственную букву к для вызова команды КРУГ. Следует отличать псевдоимена от комбинаций клавиш быстрого вызова (например CTRL+S для команды СОХРАНИТЬ).

Псевдонимы можно создавать для всех команд AutoCAD, команд драйверов устройств и внешних команд. Во втором разделе файла acad.pgp определяются псевдонимы команд. Чтобы изменить существующие псевдонимы или добавить новые, необходимо отредактировать файл acad.pgp в любом текстовом редакторе ASCII (например, Блокноте). Чтобы открыть PGP-файл, в меню "Сервис" необходимо выбрать "Настройка" » "Изменение параметров программы (acad.pgp)". Файл также может содержать строки комментариев, которые должны начинаться символом точки с запятой (;).

Примечание Перед редактированием файла acad.pgp следует создать его резервную копию для восстановления в случае необходимости.

Чтобы описать псевдоним команды, необходимо в соответствующий раздел файла acad.pgp добавить строку со следующим синтаксисом:

псевдоимя,*команда

где псевдоимя - это сокращенное имя команды, которое должно вводиться в командной строке, а команда - имя команды AutoCAD. Перед командой надо ввести звездочку (*), чтобы строка описания интерпретировалась именно как псевдоимя.

Если команда может быть вызвана прозрачно, то же относится и к ее псевдоимени. При вводе псевдоимени программа отображает в командной строке полное имя команды и начинает ее выполнение.

В раздел псевдонимов можно включать и команды, начинающиеся со знака "минус" (-). Таким образом создаются псевдонимы для вариантов команд, использующих интерфейс командной строки.

-КШ, *-КШТРИХ
-КО, *-КОНТУР

Примечание Нельзя использовать псевдоимена в командных сценариях. Не рекомендуется использовать псевдонимы команд в файлах настройки.

Если файл acad.pgp редактируется при выполнении AutoCAD, для того чтобы изменения в файле вступили в силу, необходимо ввести ПЕРЕИН. Для автоматической перезагрузки файла можно перезапустить AutoCAD.


Создание пользовательских команд

Основные принципы настройки
Создание пользовательских команд
Понятия
Процедуры
Команды

Нет процедур.


Псевдоимена команд - Команды

Основные принципы настройки
Основные принципы настройки
Псевдоимена команд
Понятия
Процедуры
Команды

Команды
ПЕРЕИН | Повторная инициализация портов ввода-вывода, дигитайзера, монитора и файла параметров программ
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка типов линий - Понятия

Настройка типов линий
Понятия
Процедуры
Команды

Библиотека стандартных типов линий находится в файлах acad.lin и acadiso.lin. Можно использовать имеющиеся типы линий, изменять их или создавать собственные.

  • Обзор описаний типов линий
    Типы линий хранятся в файлах описаний типов линий, которые имеют расширение LIN.
  • Создание простых типов линий
    Описание каждого типа линий занимает в LIN-файле две строки. Первая строка содержит имя типа линий и текстовое пояснение к нему (последнее можно опустить). Вторая строка описания типа линий задает начертание.
  • Текстовые объекты в пользовательских типах линий
    В состав сложных типов линий могут входить текстовые объекты.
  • Формы в пользовательских типах линий
    Сложные типы линий могут содержать встроенные формы, которые хранятся в файлах форм. Линии сложных типов используются для обозначения инженерных сетей, границ, контуров и т.д.


Настройка типов линий - Процедуры

Настройка типов линий
Понятия
Процедуры
Команды

Создание простого типа линий

Включение текстовых объектов в сложные типы линий


Настройка типов линий - Команды

Настройка типов линий
Понятия
Процедуры
Команды
Команды
ТИПЛИН | Загрузка, установка и изменение типов линий
ФОРМА | Вставка формы из файла форм, загруженного с помощью команды ЗАГРУЗИТЬ
Системные переменные
MEASUREINIT | Определяет, какая система единиц по умолчанию (британская или метрическая) используется в чертеже, созданном на основе простейшего шаблона
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обзор описаний типов линий - Понятия

Настройка типов линий
Обзор описаний типов линий
Понятия
Процедуры
Команды

Типы линий хранятся в файлах описаний типов линий, которые имеют расширение LIN.

Типы линий различаются по именам; а сама последовательность штрихов и точек, относительные длины штрихов и пробелов, а также характеристики включаемых текстовых элементов и форм задаются в описании типа линий. Можно использовать имеющиеся в AutoCAD типы линий или создавать собственные.

Типы линий хранятся в файлах описаний типов линий. Эти файлы имеют расширение LIN. В одном LIN-файле может храниться множество описаний простых и сложных типов линий. Пользователь может добавлять новые типы линий в существующие LIN-файлы, а также создавать новые LIN-файлы. Чтобы создать или изменить описания типов линий, отредактируйте LIN-файл с помощью текстового редактора или текстового процессора или воспользуйтесь командой ТИПЛИН в ответ на подсказку "Команда".

Прежде чем использовать какой-либо тип линий, его нужно загрузить.

Файлы acad.lin и acadiso.lin являются файлами LIN программы AutoCAD. Чтобы лучше понять принцип формирования типов линий, эти файлы можно распечатать.


Настройка типов линий
Настройка типов линий
Понятия
Процедуры
Команды

Нет процедур.


Обзор описаний типов линий - Команды

Настройка типов линий
Настройка типов линий
Обзор описаний типов линий
Понятия
Процедуры
Команды

Команды
ТИПЛИН | Загрузка, установка и изменение типов линий
Системные переменные
MEASUREINIT | Определяет, какая система единиц по умолчанию (британская или метрическая) используется в чертеже, созданном на основе простейшего шаблона
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание простых типов линий - Понятия

Настройка типов линий
Создание простых типов линий
Понятия
Процедуры
Команды

Описание каждого типа линий занимает в LIN-файле две строки. Первая строка содержит имя типа линий и текстовое пояснение к нему (последнее можно опустить). Вторая строка описания типа линий задает начертание.

Строка начинается с кода выравнивания (используется только A), а затем через запятую следует список описаний элементов начертания линии пробелов (перо поднято), штрихов (перо опущено) и точек. Если строка в LIN-файле начинается с точки с запятой (;), она считается комментарием.

Формат описания типов линий

Описание типа линий выглядит так:

*имя_типа_линии,описание
A,элемент1,элемент2, ...

Например, вот описание типа линий ШТРИХПУНКТИРНАЯ:

*ШТРИХПУНКТИРНАЯ,Штрих пунктирная __ . __ . __ . __ . __ . __ . __ . __
A,.5,-.25,0,-.25

Это показывает повторяющиеся образцы, начинающиеся со штриха длиной 0,5 единиц, затем пробел длиной 0,25 единиц, точка и еще один пробел, длиной также 0,25 единиц. При формировании линии такая структура повторяется требуемое число раз; линия начинается и заканчивается штрихом длиной 0,5 единиц.

__ . __ . __ . __ . __ . __ . __ . __

LIN-файлы необходимо сохранять в формате ASCII с расширением LIN. Далее приведены сведения об отдельных элементах описания типов линий.

Имя типа линий

Имя типа линий должно уникально характеризовать создаваемый тип. Перед каждым именем в файле ставится звездочка.

Описание

В пояснение, как правило, включают последовательность текстовых символов, визуально похожую на линию данного типа. Пояснение отображается в "Диспетчере типов линий" и диалоговом окне "Загрузка/перезагрузка типов линий".

Оно может включать в себя:

  • Образец представления типа линий из текстовых символов (точек, дефисов и др.)
  • Более подробное словесное описание типа линий
  • Комментарии (например, "служит для представления линий невидимого контура")

Если пояснение отсутствует, запятую после имени типа линий ставить не нужно. Пояснение может содержать не более 47 символов.

Тип выравнивания (A)

Определяет поведение образца на концах отрезков и дуг. В настоящее время AutoCAD поддерживает только тип A, согласно которому линии начинаются и заканчиваются штрихами.

Пусть, например, создается тип линии ОСЕВАЯ, которая представляет собой последовательность штрихов и точек, обычно используемых в качестве осевой линии. Программа AutoCAD размещает чередующиеся штрихи и точки на отдельной линии таким образом, что штрихи и конечные точки линии совпадают. Образец накладывается на линию таким образом, что она начинается и заканчивается штрихом. Если необходимо, то для выполнения этого условия первый и последний штрихи удлиняются. Если отрезок слишком короткий, и в нем не умещается даже одно штрихпунктирное звено, AutoCAD строит такой отрезок сплошной линией. Это справедливо и для дуг, которые также должны начинаться и заканчиваться штрихами. Отображение окружностей, хотя они и не имеют конечных и начальных точек, также регулируется AutoCAD, чтобы образец располагался равномерно.

Тип выравнивания A необходимо указать путем ввода буквы a в поле для указания типа выравнивания.

Элементы начертания

Каждый элемент начертания задает длину сегмента линии соответствующего типа. Элементы записываются через запятую, без пробелов.

  • Если значение длины положительно, включается режим "перо опущено", и строится штрих.
  • Если значение длины отрицательно, включается режим "перо поднято", и строится пробел.
  • Если длина штриха равна нулю, строится точка.

Для каждого типа линий можно определить до двенадцати элементов. Длина строки описания не должна превышать 80 символов. В описании достаточно задать один элементарный неповторяющийся фрагмент начертания. Первый элемент начертания используется AutoCAD для штрихов в начале и в конце линии. За начальным штрихом строятся второй и все последующие элементы начертания. Затем вся последовательность элементов повторяется нужное количество раз до тех пор, пока не будет обнаружен завершающий штрих.

Выравнивание типа A предполагает, что длина первого сегмента должна быть больше или равна нулю (т.е. строится точка или штрих). Если длина второго сегмента отрицательна, то строится пробел; если положительна — то строится сплошная линия (перо будет опущено при построении этого сегмента). Выравнивание производится при наличии не менее двух сегментов.


Создание простого типа линий - Процедуры

Настройка типов линий
Создание простых типов линий
Понятия
Процедуры
Команды

Создание простого типа линий

  1. В командной строке введите-тип лини.
  2. Введите с (Создать).
  3. Введите имя типа линий и нажмите ENTER.

    4. Имя типа линий может содержать не более 255 символов. Имена типов линий могут состоять из букв, цифр и специальных символов: знаков доллара ($), дефиса (-) и подчеркивания (_). В именах типов линий нельзя использовать пробелы.

  4. В диалоговом окне "Создание или добавление файла типов линий" выберите LIN-файл библиотеки или введите его имя в поле "Имя файла".

    5. Если выбран существующий LIN-файл, новый тип линий будет добавлен к уже имеющимся.

  5. Введите пояснение к создаваемому типу линий (не обязательно).
  6. В ответ на запрос "Введите образец типа линий" введите элементы начертания. Рекомендуется придерживаться следующих правил.
    • Все типы линий должны начинаться со штриха.
    • Точки в описании представляются нулями.
    • Пробелы в описании представляются отрицательными числами. Длина пробела (в единицах чертежа) равна абсолютной величине числа в описании.
    • Штрихи в описании представляются положительными числами. Длина штриха (в единицах чертежа) равна абсолютной величине числа в описании.
    • Элементы начертания в описании типа линий разделяются запятыми.
    • Между элементами, задающими штрихи и точки, должны стоять элементы, задающие пробелы.
  7. Нажмите ENTER для завершения команды.

Примечание Вновь созданный тип линий не загружается в чертеж автоматически. Для загрузки следует воспользоваться параметром "Загрузить" команды ТИПЛИН.


Создание простых типов линий - Команды

Настройка типов линий
Настройка типов линий
Создание простых типов линий
Понятия
Процедуры
Команды

Команды
ТИПЛИН | Загрузка, установка и изменение типов линий
Системные переменные
MEASUREINIT | Определяет, какая система единиц по умолчанию (британская или метрическая) используется в чертеже, созданном на основе простейшего шаблона
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Текстовые объекты в пользовательских типах линий - Понятия

Настройка типов линий
Текстовые объекты в пользовательских типах линий
Понятия
Процедуры
Команды

В состав сложных типов линий могут входить текстовые объекты. Линии, в состав которых входят текстовые объекты, используются для обозначения инженерных сетей, границ, топографических горизонталей и т.д. Как и простые, сложные линии строятся динамически между задаваемыми пользователем вершинами. Текстовые объекты, являющиеся частью сложных линий, всегда отображаются полностью и никогда не обрезаются.

Текст в описании связан с некоторым текстовым стилем в чертеже. Этот стиль должен быть загружен в чертеж перед загрузкой использующего его типа линий.

При описании элементы начертания линий сложного типа, так же как и в простых линиях, отделяются друг от друга запятыми.

Формат текстовых элементов начертания

Текстовые элементы начертания типов линий записываются следующим образом:

["строка",стиль,масштаб,поворот,x-отступ,y-отступ]

Элемент добавляется в описание начертания простого типа линий. Например, вот описание типа линий ГОРЯЧАЯ_ВОДА:

*ГОРЯЧАЯ_ВОДА,---- ГВ ---- ГВ ---- ГВ ---- ГВ ---- ГВ ----
A,.5,-.2,["ГВ",STANDARD,S=.1,R=0.0,X=-0.1,Y=-.05],-.2

Это показывает повторяющиеся образцы, начинающиеся со штриха длиной 0,5 единиц, затем пробел длиной 0,2 единиц, последовательность символов ГВ и еще один пробел, длиной также 0,2 единиц. Текстовые символы записываются стилем СТАНДАРТ с масштабом 0,1, относительным углом поворота 0 градусов, смещением по X -0,1 единиц и смещением по Y -0,05 единиц. При формировании линии такая структура повторяется требуемое число раз; линия начинается и заканчивается штрихом длиной 0,5 единиц. Ниже показано, как это выглядит.

При таком описании, кстати, длина штриха составляет 0,2 + 0,2 = 0,4, а начальная точка текста смещена от конца штриха на расстояние -0,1 единицы в направлении X. Точно такой же на вид тип линий можно описать по-другому:

*ГОРЯЧАЯ_ВОДА,---- ГВ ---- ГВ ---- ГВ ---- ГВ ---- ГВ ----
A,.5,-.1,["ГВ",STANDARD,S=.1,R=0.0,X=0.0,Y=-.05],-.3

Здесь длина промежутка между штрихами также равна 0,4 (0,1 + 0,3), но текст не смещен в направлении X.

Далее приведены сведения об отдельных элементах описания текстового элемента. Значениями параметров должны быть положительные или отрицательные десятичные числа, такие как 1, -17 или 0,01.

текст

Текст, используемый в сложной линии.

стиль

Имя используемого текстового стиля. Если он не задан, AutoCAD использует текущий стиль.

масштаб

S=значение. Масштаб текстового стиля; т.е. коэффициент, на который умножается высота текстового стиля. Если высота текстового стиля равна 0, то в качестве высоты текста используется абсолютное значение S.

поворот

R=значение или A=значение. R= обозначает относительный или тангенциальный угол поворота относительно направления линии. A= обозначает абсолютный угол поворота текста, т.е. относительно начала координат все текстовые объекты поворачиваются одинаково, независимо от их положения относительно линии. К значению можно добавить букву для обозначения единиц измерения угла поворота: d для градусов (если буква опущена, градусы используются по умолчанию), r для радиан, g для градов. Если угол поворота не указан, то его значение принимается равным 0.

Центр поворота располагается посередине между базовой линией и границами текста номинальной высоты.

x-отступ

X=значение. Этот параметр задает отступ текста по оси X, отсчитываемый вдоль линии. Если x-отступ не задан или равен нулю, то текст располагается без отступа. Этот параметр употребляется, если необходима сплошная линия, включающая текст. На значение не влияет масштаб, заданный выражением S=значение, но масштаб типа линий к нему применяется.

y-отступ

Y=значение. Этот параметр задает отступ текста по оси Y, которая направлена перпендикулярно линии. Если y-отступ не задан или равен нулю, то текст располагается без отступа. Параметр определяет поперечное расположение текста относительно линии. На значение не влияет масштаб, заданный выражением S=значение, но масштаб типа линий к нему применяется.


Включение текстовых объектов в сложные типы линий - Процедуры

Настройка типов линий
Текстовые объекты в пользовательских типах линий
Понятия
Процедуры
Команды

Включение текстовых объектов в сложные типы линий

  1. Создайте простой тип линий, как описано в разделе Создание простого типа линий .
  2. Добавьте элемент начертания для текстового объекта в формате:

    3. ["текст",стиль,масштаб,поворот,x-отступ,y-отступ]

  3. Нажмите ENTER для завершения команды ТИПЛИН.


Текстовые объекты в пользовательских типах линий - Команды

Настройка типов линий
Настройка типов линий
Текстовые объекты в пользовательских типах линий
Понятия
Процедуры
Команды

Команды
ТИПЛИН | Загрузка, установка и изменение типов линий
Системные переменные
MEASUREINIT | Определяет, какая система единиц по умолчанию (британская или метрическая) используется в чертеже, созданном на основе простейшего шаблона
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Формы в пользовательских типах линий - Понятия

Настройка типов линий
Формы в пользовательских типах линий
Понятия
Процедуры
Команды

Сложные типы линий могут содержать встроенные формы, которые хранятся в файлах форм. Линии сложных типов используются для обозначения инженерных сетей, границ, контуров и т.д.

Как и простые, сложные линии строятся динамически между задаваемыми пользователем вершинами. Формы и текстовые объекты, являющиеся частью сложных линий, всегда отображаются полностью и никогда не обрезаются.

При описании элементы начертания линий сложного типа, так же как и в простых линиях, отделяются друг от друга запятыми. В качестве элементов начертания описания сложных типов линий могут содержать, помимо точек и штрихов, формы и текстовые объекты.

Формы в типах линий описываются следующим образом:

[[имя_формы,имя_файла_shx] или [имя_формы,имя_файла_shx,преобразование]

Здесь атрибут преобразование является необязательным и может задавать любую последовательность следующих параметров (через запятую):

R=## Относительный угол поворота

A=## Абсолютный угол поворота

S=## Масштаб

X=## Смещение по X

Y=## Смещение по Y

В данном случае ## обозначает десятичное число со знаком (1, -17, 0,01 и т.д.). Угол поворота измеряется в градусах, остальные величины в единицах чертежа в соответствии с масштабом типа линий. После букв, обозначающих операции преобразования, ставятся знак равенства и число.

Ниже приведено описание линии с именем CON1LINE, повторяющееся звено которой состоит из линейного участка, пробела и формы CON1 из файла ep.shx. (Обратите внимание, что для правильной работы следующего примера необходимо, чтобы путь к файлу es.shx был известен системе.)

*CON1LINE, --- [CON1] --- [CON1] --- [CON1]
A,1.0,-0.25,[CON1,ep.shx],-1.0

За исключением выражения в квадратных скобках, описание полностью совпадает с описанием простого типа линий.

Как было отмечено ранее, в общей сложности для описания формы, входящей в состав линии сложного типа, можно использовать 6 параметров. Только первые два из них являются обязательными и фиксированными, остальные четыре можно опустить или поменять местами. Ниже приведены два примера описания форм с использованием различных параметров.

[CAP,ep.shx,S=2,R=10,X=0.5]

Строится форма с именем CAP, описанная в файле ep.shx, в масштабе, в два раза превышающем масштаб единиц данной линии, повернутая относительно касательной к линии на 10 градусов против часовой стрелки и с отступом в 0,5 единиц по оси X.

[DIP8,pd.shx,X=0.5,Y=1,R=0,S=1]

С помощью кода, приведенного выше, можно построить форму с именем DIP8, описанную в файле pd.shx, со смещением по оси X на 0,5 единиц чертежа, по оси Y на 1 единицу чертежа, с нулевым углом поворота и в масштабе, равном масштабу единиц данной линии.

Для описания форм в сложных типах линий принят следующий синтаксис.

[имя_формы,файл_формы,масштаб,поворот,смещение_по_x,смещение_по_y]

Ниже приведена расшифровка параметров описания.

имя_формы

Имя используемой формы. Обязательный параметр. При его отсутствии тип линий не определяется. Если форма с таким именем отсутствует в указанном файле, линия строится без формы.

файл_формы

Имя скомпилированного файла описания формы (SHX). При его отсутствии тип линий не определяется. Если путь к файлу формы не задан, программа ищет его в папке библиотечных файлов. Если путь задан, но программа не может найти файл по заданному пути, то поиск осуществляется в папке библиотечных файлов. Если заданный файл не найден, линия строится без формы.

масштаб

S=значение. Масштаб формы, т.е. коэффициент, на который умножается изначальный масштаб формы. Если изначально форма определена с масштабом 0, то в качестве масштаба используется только S=значение.

поворот

R=значение или A=значение. R= обозначает относительный или тангенциальный угол поворота относительно направления линии. A= обозначает абсолютный угол поворота формы, т.е. относительно начала координат все формы поворачиваются одинаково, независимо от их положения относительно линии. Значение угла поворота может быть дополнено буквами d, r, или g. Буквы соответствуют единицам измерения угла — градусам, радианам или градам. Если угол поворота не указан, то его значение принимается равным 0.

x-отступ

X=значение. Этот параметр задает отступ формы по оси X, отсчитываемый от вершины линии. Если отступ по оси X не задан или равен нулю, форма строится без отступа. Этот параметр употребляется, если необходима сплошная линия, включающая формы. На значение не влияет масштаб, заданный выражением S=.

y-отступ

Y=значение. Этот параметр задает отступ формы по оси Y, отсчитываемый от вершины линии. Если отступ по оси Y не задан или равен нулю, форма строится без отступа. На значение не влияет масштаб, заданный выражением S=.

См. также

Формы и шрифты


Формы в пользовательских типах линий - Команды

Настройка типов линий
Настройка типов линий
Формы в пользовательских типах линий
Понятия
Процедуры
Команды

Команды
ТИПЛИН | Загрузка, установка и изменение типов линий
ФОРМА | Вставка формы из файла форм, загруженного с помощью команды ЗАГРУЗИТЬ
Системные переменные
MEASUREINIT | Определяет, какая система единиц по умолчанию (британская или метрическая) используется в чертеже, созданном на основе простейшего шаблона
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Пользовательские образцы штриховки - Понятия

Пользовательские образцы штриховки
Понятия
Процедуры
Команды

Библиотеки стандартных образцов штриховки хранятся в файлах acad.pat и acadiso.pat. Можно использовать имеющиеся образцы штриховки, изменять их или создавать собственные.

  • Коротко об описании образцов штриховки
    В дополнение к стандартным образцам штриховки, поставляемым вместе с программой, пользователь имеет возможность создавать дополнительные образцы.
  • Образцы штриховки из прерывистых линий
    Длина штрихов в образце штриховки, состоящем из прерывистых линий, задается параметрами, добавляемыми в конец описания.
  • Образцы штриховки из составных линий
    В сложных образцах начало смещено относительно начала координат, а семейство их линий является составным, т.е. включает в себя набор линий разного вида.


Пользовательские образцы штриховки - Процедуры

Пользовательские образцы штриховки
Понятия
Процедуры
Команды

Создание простого образца штриховки

Создание образца штриховки из прерывистых линий

Создание образца штриховки из составных линий


Пользовательские образцы штриховки - Команды

Пользовательские образцы штриховки
Понятия
Процедуры
Команды
Команды
ЗАКРАСИТЬ | Управление закрашиванием таких объектов, как штриховки, фигуры и широкие полилинии
КШТРИХ | Создает градиентную заливку или штриховку для замкнутой области или выбранных объектов
РЕДШТРИХ | Изменяет существующую штриховку или заливку
ФИГУРА | Создание закрашенных многоугольников
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
ШТРИХ | Заполняет замкнутую область или выбранные объекты штриховкой, сплошной заливкой или градиентной заливкой
Системные переменные
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
HPANG | Указывает угол поворота образца штриховки
HPBOUND | Управляет типом объекта, созданного с помощью команд КШТРИХ и КОНТУР
HPDOUBLE | Указывает режим штрихования крест-накрест для созданных пользователем штриховок
HPNAME | Устанавливает имя образца штриховки по умолчанию длиной до 34 символов (без пробелов)
HPSCALE | Указывает масштабный коэффициент образца штриховки, который должен быть ненулевым
HPSPACE | Указывает расстояние между линиями образца штриховки для созданных пользователем штриховок, которое должно быть ненулевым
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко об описании образцов штриховки - Понятия

Пользовательские образцы штриховки
Коротко об описании образцов штриховки
Понятия
Процедуры
Команды

В дополнение к стандартным образцам штриховки, поставляемым вместе с программой, пользователь имеет возможность создавать дополнительные образцы. Создание новых образцов штриховки требует определенных знаний, опыта и терпения. Так как настройка образцов штриховки требует знаний о внутренней структуре их описаний, начинающим пользователям заниматься этим не рекомендуется.

Образцы штриховки, имеющиеся в программе AutoCAD, хранятся в текстовых файлах acad.pat и acadiso.pat. Новые штриховки можно добавлять в этот файл или записывать в собственные файлы.

Формат описания не зависит от того, где оно хранится. Описание начинается с заголовка, состоящего из звездочки, имени образца (не больше 31 символа) и текстового пояснения.

*имя_образца, пояснение

Затем следует одна или несколько строк описания:

угол, начало_по_x,начало_по_y, дельта-x,дельта-y,штрих-1,штрих-2, …

Стандартный образец ANSI31, который можно найти в списке образцов штриховки в диалоговом окне "Штриховка/закраска по контуру", выглядит так

и описывается следующим образом:

*ANSI31, чугун ANSI, кирпич, каменная кладка
45, 0,0, 0,.125

В первой строке за именем образца, *ANSI31, следует текстовое пояснение: чугун ANSI, кирпич, каменная кладка. Линия проводится под углом 45 градусов, первая линия семейства проходит через точку (0,0), а интервал между соседними линиями равен 0,125 единиц чертежа.

Описания образцов подчиняются следующим правилам.

  • Каждая строка в описании образца штриховки может содержать до 80 символов. В него могут входить буквенные символы, цифры и специальные символы (знак доллара ($), минус (-) и знак подчеркивания (_)). Однако, начинаться описание может только с буквы или с цифры.
  • AutoCAD игнорирует пустые строки и текст после точки с запятой.
  • Каждая линия образца рассматривается как первый элемент бесконечного семейства линий, расстояние между которыми задается смещениями по обеим осям координат.
  • Значение дельта-x задает расстояние между линиями семейства вдоль оси, совпадающей с направлением линий; оно имеет смысл только для прерывистых линий штриховки.
  • Значение дельта-y задает интервал между линиями семейства; оно отсчитывается в направлении, перпендикулярном линиям.
  • Считается, что каждая линия штриховки бесконечна в пространстве. На нее накладывается структура штрихов, определяющая вид линии.

Процесс штрихования заключается в построении бесконечного семейства параллельных линий на основе каждой линии образца. Все объекты проверяются на пересечение с этими линиями; в зависимости от выбранного стиля штриховки, при пересечении с графическими объектами линии штриховки включаются или отключаются. Надлежащее размещение штриховки в смежных областях гарантируется тем, что семейство линий образца строится параллельным переносом начальной линии, проходящей через определенную точку абсолютной системы координат.

Если наносимая штриховка слишком плотна, AutoCAD может отказать в ее построении и вывести сообщение о недопустимо малом масштабе или слишком малой длине штриха. Допустимое максимальное число отрезков, создаваемых в результате штрихования, можно задавать переменной реестра MaxHatch с помощью вводимого в командной строке выражения (setenv MaxHatch n), где n означает число от 100 до 10000000 (десяти миллионов).

Примечание При изменении значения переменной реестра MaxHatch необходимо соблюдать регистр символов в имени этой переменной.


Создание простого образца штриховки - Процедуры

Пользовательские образцы штриховки
Коротко об описании образцов штриховки
Понятия
Процедуры
Команды

Создание простого образца штриховки

  1. Откройте файл acad.pat или acadiso.pat в текстовом редакторе, сохраняющем файлы в формате ASCII (например, в Блокноте Microsoft® Windows®).
  2. Введите заголовок, состоящий из звездочки и имени образца. Длина имени образца штриховки не может быть больше 31 символа.
  3. (Не обязательно) Введите пояснение, отделив его от имени образца запятой.
  4. Введите строку описания, в которую входят:
    • Угол наклона линии
    • Координаты X,Y начальной точки
    • Смещение по X, равное 0
    • Смещение по Y (любое)


Коротко об описании образцов штриховки - Команды

Пользовательские образцы штриховки
Пользовательские образцы штриховки
Коротко об описании образцов штриховки
Понятия
Процедуры
Команды

Команды
ЗАКРАСИТЬ | Управление закрашиванием таких объектов, как штриховки, фигуры и широкие полилинии
КШТРИХ | Создает градиентную заливку или штриховку для замкнутой области или выбранных объектов
РЕДШТРИХ | Изменяет существующую штриховку или заливку
ФИГУРА | Создание закрашенных многоугольников
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
ШТРИХ | Заполняет замкнутую область или выбранные объекты штриховкой, сплошной заливкой или градиентной заливкой
Системные переменные
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
HPANG | Указывает угол поворота образца штриховки
HPBOUND | Управляет типом объекта, созданного с помощью команд КШТРИХ и КОНТУР
HPDOUBLE | Указывает режим штрихования крест-накрест для созданных пользователем штриховок
HPNAME | Устанавливает имя образца штриховки по умолчанию длиной до 34 символов (без пробелов)
HPSCALE | Указывает масштабный коэффициент образца штриховки, который должен быть ненулевым
HPSPACE | Указывает расстояние между линиями образца штриховки для созданных пользователем штриховок, которое должно быть ненулевым
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Образцы штриховки из прерывистых линий - Понятия

Пользовательские образцы штриховки
Образцы штриховки из прерывистых линий
Понятия
Процедуры
Команды

Длина штрихов в образце штриховки, состоящем из прерывистых линий, задается параметрами, добавляемыми в конец описания. Каждый параметр задает длину одного сегмента линии. Если значение длины положительно, включается режим опущенного пера и строится сегмент линии. Если значение длины отрицательно, то сегмент строится в режиме поднятого пера, т.е. рисуется пробел. За начальным штрихом строятся второй и все последующие элементы начертания. Затем циклически повторяется вся последовательность сегментов. Если длина штриха равна нулю, строится точка. Каждая линия образца штриховки может содержать до шести сегментов.

Образец ANSI33, который можно найти в списке образцов штриховки в диалоговом окне "Штриховка/закраска по контуру", выглядит так

и описывается следующим образом:

*ANSI33, бронза ANSI, латунь, медь
45, .176776695,0, 0,.25, .125,-.0625

Возьмем образец в виде наклоненных под углом 45 градусов линий и модифицируем его так, чтобы отрисовывались штриховые линии с длиной штриха 0,5 и интервалом между штрихами 0,5. Такой образец может быть описан следующим образом:

*DASH45, штрихи под 45 градусов
45, 0,0, 0,.5, .5,-.5

Этот образец похож на образец штриховки под углом 45 градусов, описанный в разделе Коротко об описании образцов штриховки, но к концу строки описания добавлена спецификация штриха. При этом длина сегмента "перо опущено" составляет 0,5 и длина сегмента "перо поднято" также 0,5. Предположим, что требуется отрисовать сначала штрих длиной 0,5, затем сделать пробел длиной 0,25, потом поставить точку и перед следующим штрихом вновь сделать пробел длиной 0,25. В этом случае описание будет иметь вид:

*DDOT45,штрих-пунктир под 45 градусов
45, 0,0, 0,.5, .5,-.25, 0,-.25

Проанализируем влияние параметра дельта-x на семейства прерывистых линий. Сначала рассмотрим следующее описание:

*GOSTAK
0, 0,0, 0,.5, .5,-.5

Согласно нему будет отрисовываться семейство линий с шагом 0,5, с одинаковой длиной штрихов и пробелов между ними. Так как значение дельта-x равно нулю, то штрихи в каждой линии, входящей в семейство, будут выстроены в один ряд. Область, заштрихованная данным образцом, будет иметь вид:

Теперь изменим описание шаблона следующим образом:

*SKEWED
0, 0,0, .5,.5, .5,-.5

Оно осталось почти таким же, за исключением того, что для дельта-x было установлено значение, равное 0,5. При этом происходит смещение каждого последующего члена семейства на 0,5 в направлении линии (в данном случае параллельно оси X). Теперь, ввиду того, что линии считаются бесконечными, будет наблюдаться эффект смещения штрихов на заданную величину. Заштрихованная область будет иметь следующий вид.


Создание образца штриховки из прерывистых линий - Процедуры

Пользовательские образцы штриховки
Образцы штриховки из прерывистых линий
Понятия
Процедуры
Команды

Создание образца штриховки из прерывистых линий

  1. Откройте файл acad.pat или acadiso.pat в текстовом редакторе, сохраняющем файлы в формате ASCII (например, в Блокноте).
  2. Введите заголовок, состоящий из звездочки и имени образца. Длина имени образца штриховки не может быть больше 31 символа.
  3. (Не обязательно) Ввести пояснение, отделив его от имени образца запятой.
  4. Введите строку описания, в которую входят:
    • Угол наклона линии
    • Координаты X,Y начальной точки
    • Смещение по X (если требуется, чтобы соседние линии были смещены друг относительно друга)
    • Смещение по Y (любое)
    • Значение длины штриха
    • Значение длины точки
    • Значение длины следующего штриха (не обязательно)
    • Значение длины следующей точки (не обязательно)


Образцы штриховки из прерывистых линий - Команды

Пользовательские образцы штриховки
Пользовательские образцы штриховки
Образцы штриховки из прерывистых линий
Понятия
Процедуры
Команды

Команды
ЗАКРАСИТЬ | Управление закрашиванием таких объектов, как штриховки, фигуры и широкие полилинии
КШТРИХ | Создает градиентную заливку или штриховку для замкнутой области или выбранных объектов
РЕДШТРИХ | Изменяет существующую штриховку или заливку
ФИГУРА | Создание закрашенных многоугольников
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
ШТРИХ | Заполняет замкнутую область или выбранные объекты штриховкой, сплошной заливкой или градиентной заливкой
Системные переменные
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
HPANG | Указывает угол поворота образца штриховки
HPBOUND | Управляет типом объекта, созданного с помощью команд КШТРИХ и КОНТУР
HPDOUBLE | Указывает режим штрихования крест-накрест для созданных пользователем штриховок
HPNAME | Устанавливает имя образца штриховки по умолчанию длиной до 34 символов (без пробелов)
HPSCALE | Указывает масштабный коэффициент образца штриховки, который должен быть ненулевым
HPSPACE | Указывает расстояние между линиями образца штриховки для созданных пользователем штриховок, которое должно быть ненулевым
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Образцы штриховки из составных линий - Понятия

Пользовательские образцы штриховки
Образцы штриховки из составных линий
Понятия
Процедуры
Команды

Не все образцы штриховки используют в качестве начальной точки (0,0). В сложных образцах начало смещено относительно начала координат, а семейство их линий является составным, т.е. включает в себя набор линий разного вида. Создавая такие образцы, пользователь должен очень внимательно подбирать начальную точку, смещения линий и смещения штрихов, чтобы образец формировался правильно.

Образец штриховки AR-B816, показанный в диалоговом окне "Штриховка/закраска по контуру", выглядит следующим образом:

Определяется он на основе семейства линий:

*AR-B816, 8x16 Block elevation stretcher bond
0, 0,0, 0,8
90, 0,0, 8,8, 8,-8

Предположим, что требуется получить образец наподобие буквы "П", т.е. штрих вверх, штрих вправо и штрих вниз. Шаг повторения будет равен 1 ед.; каждая фигура будет иметь высоту и ширину 0,5, как показано на чертеже.

Описание такого образца может выглядеть следующим образом:

*IUS,Буква П
90, 0,0, 0,1, .5,-.5
0, 0,.5, 0,1, .5,-.5
270, .5,.5, 0,1, .5,-.5

Первый штрих, направленный вверх, представляет собой простую штриховую линию с началом в точке (0,0). Второй штрих должен начинаться в конце первого штриха, поэтому его начало имеет координаты (0,0.5). Третий штрих (направленный вниз) начинается в конце верхнего штриха, или в точке с координатами (0.5,0.5) относительно исходной точки образца. Третий штрих образца можно определить следующим образом:

90, .5,0, 0,1, .5,-.5

или

270, .5,1, 0,1, -.5,.5

Образец штриховки начинается с исходной точки и продолжается в направлении, определяемом заданным углом. Поэтому два семейства штриховых линий, различающиеся только ориентацией на 180 градусов, не являются одинаковыми. В то же время два семейства сплошных линий одинаковы.

Рассмотрим следующий образец из шестиконечных звезд.

Это хороший пример для практики. Число 0,866 — это синус 60 градусов.

Вот как этот образец описывается в AutoCAD.

*STARS,шестиконечная звезда
0, 0,0, 0,.866, .5,-.5
60, 0,0, 0,.866, .5,-.5
120, .25,.433, 0,.866, .5,-.5


Создание образца штриховки из составных линий - Процедуры

Пользовательские образцы штриховки
Образцы штриховки из составных линий
Понятия
Процедуры
Команды

Создание образца штриховки из составных линий

  1. Откройте файл acad.pat или acadiso.pat в текстовом редакторе, сохраняющем файлы в формате ASCII (например, в Блокноте).
  2. Введите заголовок, состоящий из звездочки и имени образца. Длина имени образца штриховки не может быть больше 31 символа.
  3. (Не обязательно) Введите пояснение, отделив его от имени образца запятой.
  4. Введите строку описания, в которую входят:
    • Угол наклона линии
    • Координаты X,Y начальной точки
    • Смещение по X (если требуется, чтобы соседние линии были смещены друг относительно друга)
    • Смещение по Y (любое)
    • Значение длины штриха
    • Значение длины точки
    • Значение длины следующего штриха (не обязательно)
    • Значение длины следующей точки (не обязательно)
  5. Описать вторую линию, включив для нее все перечисленные выше параметры.
  6. Если нужно, описать последующие линии образца.


Образцы штриховки из составных линий - Команды

Пользовательские образцы штриховки
Пользовательские образцы штриховки
Образцы штриховки из составных линий
Понятия
Процедуры
Команды

Команды
ЗАКРАСИТЬ | Управление закрашиванием таких объектов, как штриховки, фигуры и широкие полилинии
КШТРИХ | Создает градиентную заливку или штриховку для замкнутой области или выбранных объектов
РЕДШТРИХ | Изменяет существующую штриховку или заливку
ФИГУРА | Создание закрашенных многоугольников
ЦУВКЛ | Управление содержимым блоками, внешними ссылками и образцами штриховки
ШТРИХ | Заполняет замкнутую область или выбранные объекты штриховкой, сплошной заливкой или градиентной заливкой
Системные переменные
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
HPANG | Указывает угол поворота образца штриховки
HPBOUND | Управляет типом объекта, созданного с помощью команд КШТРИХ и КОНТУР
HPDOUBLE | Указывает режим штрихования крест-накрест для созданных пользователем штриховок
HPNAME | Устанавливает имя образца штриховки по умолчанию длиной до 34 символов (без пробелов)
HPSCALE | Указывает масштабный коэффициент образца штриховки, который должен быть ненулевым
HPSPACE | Указывает расстояние между линиями образца штриховки для созданных пользователем штриховок, которое должно быть ненулевым
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка интерфейса пользователя - Понятия

Настройка интерфейса пользователя
Понятия
Процедуры
Команды

Для эффективного выполнения задач при работе в программе используйте меню, панели инструментов, сочетания клавиш для быстрого выбора команд и другие элементы интерфейса. Работу можно ускорить, настроив следующие элементы рабочей среды.

  • Обзор диалогового окна "Настройка интерфейса пользователя"
    С помощью инструментов настройки AutoCAD можно настроить среду рисования в соответствии с требованиями пользователя.
  • Работа с файлами настройки
    Файлы настройки (НПИ) используются для хранения команд, элементов пользовательского интерфейса и ссылок на частичные файлы НПИ и AutoLISP. Файлы НПИ могут быть основными, частичными или корпоративными. Назначение файла НПИ определяет порядок его загрузки. Элементы пользовательского интерфейса можно передавать между файлами НПИ, что облегчает процесс переноса.
  • Команды настройки
    Можно легко создавать, редактировать и повторно использовать команды. На вкладке "Настройка" редактора настройки пользовательского интерфейса отображается основной список команды, загруженных в программе. Команды из этого списка можно добавлять в панели инструментов, меню и другие элементы интерфейса пользователя.
  • Создание макросов
    С помощью макроса меню описывается действие, которое будет выполнено при выборе какого-либо элемента интерфейса. Макрос реализует задачу построения, для выполнения которой пользователю потребовалось бы произвести несколько операций. Макрос может содержать команды, специальные символы, а также программные коды на языке DIESEL (Direct Interpretively Evaluated String Expression Language) или AutoLISP.
  • Настройка панелей инструментов
    Для повышения эффективности рисования или использования рабочего пространства можно настроить панель инструментов, что также просто, как ее размещение или изменение размеров в области чертежа. Также можно создавать или редактировать панели инструментов и их подменю, добавляя элементы управления или команды и создавая или редактируя кнопки панелей инструментов.
  • Создание раскрывающихся и контекстных меню
    В раскрывающемся меню под строкой меню отобразится список. Меню быстрого вызова (также называемые контекстными меню) появляются на перекрестье или рядом с ним или курсором при нажатии правой кнопкой мыши в окне рисования, текстовом окне, окне команд или на панелях.
  • Задание клавиш быстрого вызова и временной замены
    Для часто используемых команд можно воспользоваться специально назначенными комбинациями клавиш (или клавишами быстрого вызова), а клавишами временной замены для выполнения команды или изменения параметра при нажатии клавиши.
  • Создание операции при двукратном нажатии
    Операции при двукратном нажатии используются для обеспечения доступа к командам редактирования. Для этого необходимо поместить курсор на объект чертежа и зарегистрировать двойное нажатие кнопки устройства указания. Операции при двойном нажатии являются объектными, что позволяет настроить определенную команду для определенного типа объектов.
  • Настройка кнопок мыши
    Можно изменить стандартные действия указывающих устройств в программе.
  • Настройка элементов интерфейса предыдущей версии
    Выражение “унаследованный от предыдущей версии“ относится к тем элементам интерфейса, которые обычно не используются в текущей версии, но тем не менее поддерживаются программой, поскольку некоторые пользователи предпочитают их соответствующим элементам новой версии.
  • Загрузка файла AutoLISP
    Файлы AutoLISP (LSP или MNL) содержат сценарии, добавляющие настройки и операции в интерфейс. Файлы AutoLISP можно загружать в файл НПИ на вкладке "Настройка" в редакторе настройки пользовательского интерфейса.
  • Настройка рабочего пространства
    Можно настроить рабочее пространство таким образом, чтобы создать среду рисования, в которой бы отображались только выбранные вами панели инструментов, меню и закрепляемые окна.
  • Вопросы и ответы по настройке интерфейса пользователя
    В этом разделе можно найти ответы на наиболее часто задаваемые вопросы о том, как использовать редактор настройки интерфейса пользователя.


Настройка интерфейса пользователя - Процедуры

Настройка интерфейса пользователя
Понятия
Процедуры
Команды

Фильтрация отображения элементов настройки

Создание нового файла настройки

Создание файла НПИ из существующего файла НПИ

Восстановление резервной копии файла настройки

Сброс стандартного файла настройки

Переименование группы настройки

Назначение файла НПИ в качестве основного файла НПИ

Передача настроек

Загрузка частичного файла НПИ с использованием команды НПИЗАГР

Загрузка частичного файла НПИ с использованием вкладки "Настройка"

Выгрузка частичного файла НПИ с использованием команды НПИВЫГР

Выгрузка частичного файла НПИ с использованием вкладки "Настройка"

Добавление команд к частичным файлам НПИ

Назначение файла НПИ в качестве основного файла НПИ

Изменение корпоративного файла НПИ

Создание команды

Редактирование команды

Повторное использование команды

Обнаружение строки поиска

Поиск команды в панели "Список команд"

Замена строки поиска

Замена команды

Создание недоступным имя команды в меню

Пометка имени команды в меню

Одновременное создание недоступного и помеченного имени команды в меню

Редактирование и создание изображения для кнопки

Назначение стандартного изображения команде

Назначение нестандартного изображения команде

Создание сообщений справки строки состояния

Создание панели

Создание подменю панели инструментов заново

Создание подменю из другой панели

Добавление команды на панель

Изменение положения кнопки на панели

Удаление кнопки с панели

Изменение свойств панели инструментов

Добавление элемента управления на панель инструментов

Замена элемента управления на панели инструментов

Создание раскрывающегося меню

Добавление команды к раскрывающемуся меню

Создание контекстного меню

Создание подменю

Для задания сочетания клавиш

Изменение сочетания клавиш

Создание клавиши временной замены

Изменение клавиши временной замены

Для печати списка сочетаний клавиш или клавиш временной замены

Создание операции при двукратном нажатии

Изменение операции при двукратном нажатии

Добавление комбинации нажатий кнопок мыши

Определение рядов и столбцов в меню планшета

Удаление значений, присвоенных меню планшета

Отображение экранного меню

Настройка отображения текущей команды в экранных меню

Добавление команд в экранное меню

Создание подменю в экранном меню

Создание мозаичного слайда

Просмотр мозаичного слайда

Создание библиотеки мозаичных слайдов

Создание меню мозаичных изображений и назначение мозаичного слайда

Загрузка файла AutoLISP в редактор настройки пользовательского интерфейса

Создание рабочего пространства с помощью редактора настройки пользовательского интерфейса

Создание рабочего пространства с помощью панели "Рабочее пространство"

Изменение свойств рабочего пространства

Отображение раскрывающихся меню в строке меню

Изменение позиции раскрывающегося меню в строке меню

Отображение панелей

Изменение свойств панели инструментов

Изменение свойств закрепляемого окна

Копирование рабочего пространства

Установка рабочего пространства текущим

Установка рабочего пространства по умолчанию

Восстановление рабочего пространства с помощью атрибута командной строки

Импорт рабочего пространства в основной файл НПИ


Настройка интерфейса пользователя - Команды

Настройка интерфейса пользователя
Понятия
Процедуры
Команды
Команды
ВЫБРАТЬ | Занесение выбранных объектов в текущий набор
ДСЛАЙД | Создание файла слайда из текущего видового экрана пространства модели или текущего листа
ЗАГПРИЛ | Загрузка и выгрузка приложений; задание набора приложений для автозагрузки
МЕНЮ | Загружает файл адаптации
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
НПИВЫГР | Выгружает файл НПИ
НПИЗАГР | Загружает файл НПИ
НПИИМПОРТ | Импортирует пользовательские настройки из файла НПИ предприятия или частичного файла CUI в файл acad.cui.
НПИЭКСПОРТ | Экспортирует пользовательские настройки из файла acad.cui а файл частичной адаптации или в файл CUI предприятия.
ПАНЕЛЬ | Отображение, скрытие и настройка панелей
ПЛАНШЕТ | Настройка, калибровка, включение и отключение графического планшета
СЛАЙД | Просмотр файла слайда на текущем видовом экране
Системные переменные
ENTERPRISEMENU | Сохраняет имя файла НПИ (если определено), включая путь.
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
MENUCTL | Управляет переключением страниц экранного меню
MENUNAME | Хранит имя файла адаптации, включая путь
PICKADD | Управляет дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов)
PICKAUTO | Управляет автоматическим созданием рамки выбора объектов в ответ на запрос "Выберите объекты".
PICKFIRST | Определяет момент выбора объектов: до вызова команды (предварительный выбор) или после
SCREENBOXES | Сохраняет количество окон экранного меню области рисования
TEMPOVERRIDES | Включает и отключает клавиши временной отмены
TOOLTIPS | Управляет отображением подсказок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обзор диалогового окна "Настройка интерфейса пользователя" - Понятия

Настройка интерфейса пользователя
Обзор диалогового окна "Настройка интерфейса пользователя"
Понятия
Процедуры
Команды

С помощью инструментов настройки AutoCAD можно настроить среду рисования в соответствии с требованиями пользователя.

Возможности настройки, включая формат файлов НПИ (настройка интерфейса пользователя) и редактор настройки интерфейса пользователя, позволяют легко создавать и изменять пользовательские компоненты. Файл НПИ на основе XML заменяет файлы меню, которые использовались в версиях до AutoCAD 2006. Вместо использования текстового редактора для настройки файлов меню (MNU и MNS) пользовательский интерфейс можно настроить с помощью AutoCAD. Пользователь может:

  • Добавлять или изменять панели инструментов и меню (включая контекстные меню, меню мозаики изображений, меню планшета).
  • Создавать или изменять рабочие пространства.
  • Назначать команды для различных элементов интерфейса пользователя.
  • Создавать или изменять макросы.
  • Задавать строки DIESEL.
  • Создавать или изменять псевдонимы.
  • Создавать всплывающие подсказки
  • Отображать текст описания в строке состояния.
  • Термины, используемые при настройке
    Необходимо знать несколько терминов настройки, используемых в AutoCAD 2007.
  • Изменения в настройке
    Хотя основные методы настройки остались такими же, как и в предыдущих версиях программы, среда, используемая для настройки программа, изменилась в версии AutoCAD 2006.
  • Обзор редактора настройки интерфейса пользователя
    Редактор настройки интерфейса пользователя (НПИ) используется для изменения настройки, выполненной с помощью НПИ файла в формате XML.
  • Фильтр отображения элементов настройки
    Можно отобразить все или только выбранные элементы для настройки. Настройки фильтра отображения элементов настройки выполняется на вкладке "Настройка" в редакторе настройки пользовательского интерфейса.


Обзор диалогового окна "Настройка интерфейса пользователя" - Процедуры

Настройка интерфейса пользователя
Обзор диалогового окна "Настройка интерфейса пользователя"
Понятия
Процедуры
Команды

Фильтрация отображения элементов настройки


Обзор диалогового окна "Настройка интерфейса пользователя" - Команды

Настройка интерфейса пользователя
Обзор диалогового окна "Настройка интерфейса пользователя"
Понятия
Процедуры
Команды
Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
НПИВЫГР | Выгружает файл НПИ
НПИЗАГР | Загружает файл НПИ
НПИИМПОРТ | Импортирует пользовательские настройки из файла НПИ предприятия или частичного файла CUI в файл acad.cui.
НПИЭКСПОРТ | Экспортирует пользовательские настройки из файла acad.cui а файл частичной адаптации или в файл CUI предприятия.
Системные переменные
ENTERPRISEMENU | Сохраняет имя файла НПИ (если определено), включая путь.
MENUNAME | Хранит имя файла адаптации, включая путь
TOOLTIPS | Управляет отображением подсказок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Термины, используемые при настройке - Понятия

Настройка интерфейса пользователя
Термины, используемые при настройке
Понятия
Процедуры
Команды

Необходимо знать несколько терминов настройки, используемых в AutoCAD 2007.

Старый файл меню (MNS)

Файл на основе ASCII, в котором хранятся данные настройки меню для версии AutoCAD 2005 и более предыдущих версий. Большую часть файла требуется редактировать вне AutoCAD с помощью текстового редактора, например, Notepad, но некоторые функции можно настроить в AutoCAD с помощью команды НАСТРОЙКА. MNS-файл заменен файлом НПИ. Файл НПИ можно создать из MNS-файла с помощью вкладки "Передача" команды НПИ.

Шаблон меню предыдущей версии (MNU)

Файл на основе ASCII используется в качестве шаблона для определения содержимого MNS-файла при его загрузке в AutoCAD с помощью команды МЕНЮ и МЕНЮЗАГР. В AutoCAD 2005 и более ранних версиях используется MNU-файл, подобный MNS-файлу. MNU-файл был заменен файлом НПИ. Файл НПИ можно создать из MNU-файла с помощью вкладки "Передача" команды НПИ.

Файл настройки (НПИ)

Файл XML, в котором хранятся данные о настройке. Изменить файл настройки можно с помощью редактора настройки интерфейса пользователя. Файлы НПИ заменяют файлы MNU, MNS и MNC, которые использовались для определения меню в версиях до AutoCAD 2006.

Основной файл настройки

Файл НПИ с возможностью записи в него, определяющий большую часть элементов интерфейса пользователя (включая стандартные меню, панели инструментов, клавиши быстрого запуска и т.д.). Файл acad.cui (основной файл НПИ по умолчанию) загружается автоматически при запуске AutoCAD.

Корпоративный файл настройки

Файл НПИ, управление которым обычно происходит с помощью программы CAD manager. Обычно файл хранится в сетевой папке, и к нему имеют доступ многие пользователи. Пользователи имеют доступ только для чтения для предотвращения изменения данных в файле. Программа CAD manager создает корпоративный файл НПИ путем изменения основного файла НПИ и сохранения его в общедоступной сетевой папке. После этого этот файл можно указывать на вкладке "Файлы" диалогового окна "Параметры".

Файл частичной настройки

Любой файл НПИ, который не определен как основной или корпоративный файл НПИ. Частичные файлы НПИ можно загружать и выгружать по мере необходимости во время сеанса работы с чертежом.

Группа настройки

Имя, присвоенное файлу НПИ для определения содержимого настройки в файле НПИ. Файлу НПИ, загруженному в AutoCAD, должно быть присвоено уникальное имя группы настроек для предотвращения конфликтов между файлами НПИ в программе. В предыдущих версиях называлась группой меню.

Элемент интерфейса

Настраиваемыми могут быть такие объекты, как панель инструментов, контекстное меню, клавиша быстрого вызова и закрепляемое окно. Элементы интерфейса пользователя содержатся в панели "Настройки в <имя файла>".

Элемент интерфейса

Отдельные части элемента интерфейса пользователя, такие как панель инструментов, контекстное меню, клавиша быстрого вызова и клавиша временной замены.

Узел дерева

Иерархическая структура в редакторе настроек пользовательского интерфейса, содержащая элементы интерфейса и элементы, которые можно импортировать, экспортировать и настраивать.

Рабочее пространство

Семейство элементов интерфейса пользователя, включая содержимое, свойства, состояния отображения и папку.

Закрепляемое окно

Элемент интерфейса пользователя, который может быть плавающим или закрепленным в области рисования. К закрепляемым окнам относятся окно командной строки, палитры инструментов, палитра свойств и т.д.

Код элемента

Уникальный идентификатор элемента интерфейса. В предыдущих версиях назывался атрибутом.


Обзор диалогового окна "Настройка интерфейса пользователя"

Настройка интерфейса пользователя
Обзор диалогового окна "Настройка интерфейса пользователя"
Понятия
Процедуры
Команды

Нет процедур.


Термины, используемые при настройке - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Термины, используемые при настройке
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
НПИВЫГР | Выгружает файл НПИ
НПИЗАГР | Загружает файл НПИ
НПИИМПОРТ | Импортирует пользовательские настройки из файла НПИ предприятия или частичного файла CUI в файл acad.cui.
НПИЭКСПОРТ | Экспортирует пользовательские настройки из файла acad.cui а файл частичной адаптации или в файл CUI предприятия.
Системные переменные
ENTERPRISEMENU | Сохраняет имя файла НПИ (если определено), включая путь.
MENUNAME | Хранит имя файла адаптации, включая путь
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Изменения в настройке - Понятия

Настройка интерфейса пользователя
Изменения в настройке
Понятия
Процедуры
Команды

Хотя основные методы настройки остались такими же, как и в предыдущих версиях программы, среда, используемая для настройки программа, изменилась в версии AutoCAD 2006.

Параметры настройки из предыдущих версий все еще доступны. По-прежнему можно создавать, редактировать или удалять элементы интерфейса, можно создавать файлы частичной настройки, использовать макросы и дополнительные объекты, например, выражения DIESEL и процедуры AutoLISP.

Однако настройка более не выполняется вручную путем создания файлов MNU или MNS. Все настройки выполняются с помощью интерфейса программы в редакторе настроек интерфейса пользователя.

Файлы меню или файлы настройки?

В версиях до AutoCAD 2006, настройка пользовательского интерфейса выполнялась с помощью редактирования файла MNU или MNS в текстовом редакторе, например, в Notepad. Раньше процесс настройки представлял собой утомительный и содержащий ошибки процесс, поскольку данные настройки приходилось вводить в текстовый файл и проверять вручную. В этом случае единственная синтаксическая ошибка (например, скобка в неправильном месте) в текстовом файле делала весь файл меню непригодным для использования. При этом приходилось возвращаться к текстовому файлу и находить ошибку.

С помощью редактора настройки интерфейса пользователя можно перетаскивать команды в меню или на панель инструментов или использовать контекстное меню элемента интерфейса для его добавления, удаления или изменения. В редакторе настройки интерфейса пользователя отображаются свойства элементов и список параметров. Это позволяет исключить синтаксические или другие ошибки, которые могут появиться при ручном вводе текста в файлы MNU или MNS.

Ранее используемые файлы MNU и MNS были заменены одним типом файлов - файлами НПИ на основе XML.

Использование файлов НПИ на основе XML позволяет отслеживать настройки. При переходе на следующую версию программы все настройки автоматически интегрируются в нее. Формат XML также поддерживает обратную совместимость файлов настройки. Это значит, что файл НПИ, созданный с помощью более поздней версии программы, можно просматривать в данной версии программы с сохранением данных настройки. Нельзя редактировать в более ранней версии файл НПИ, созданный для более поздней версии. Дополнительную информацию о переносе данных настройки см. в разделе Перенос и передача настроек.

В следующей таблице приведены файлы меню, ранее поставлявшиеся с продуктом, а также показана их связь с AutoCAD 2007.

Файлы меню, связанные с файлами НПИ

Файл меню

Описание

В AutoCAD 2007

Описание изменения

MNU

Текстовый файл ASCII. В более ранних версиях использовался для определения большинства элементов интерфейса пользователя. Основной файл MNU acad.mnu был автоматически загружен при запуске программы.

Частичные файлы MNU можно было загружать и выгружать во время работы с чертежом по мере необходимости.

НПИ

Файл XML, определяющий большинство элементов интерфейса пользователя. Основной файл НПИ acad.cui загружается автоматически при запуске программы.

Частичные файлы НПИ можно загружать и выгружать во время работы с чертежом по мере необходимости.

MNS

Исходный файл меню. Аналогичен текстовому файлу MNU ASCII, но не содержит комментариев или специального форматирования.

НПИ

Файл XML, определяющий большинство элементов интерфейса пользователя. Основной файл НПИ acad.cui загружается автоматически при запуске программы.

Частичные файлы НПИ можно загружать и выгружать во время работы с чертежом по мере необходимости.

MNC

Скомпилированный текстовый файл ASCII. Содержал строки команд и синтаксис, определявшие функции и внешний вид элементов интерфейса пользователя.

НПИ

Файл XML, определяющий большинство элементов интерфейса пользователя. Основной файл НПИ acad.cui загружается автоматически при запуске программы.

Частичные файлы НПИ можно загружать и выгружать во время работы с чертежом по мере необходимости.

MNL

Файл LISP меню. Содержит выражения AutoLISP, используемые элементами интерфейса пользователя.

MNL

Без изменений.

MNR

Файл ресурсов меню. Содержит растровые изображения, используемые элементами интерфейса пользователя.

MNR

Без изменений.

Структура текстового файла меню или структура файла НПИ?

В версиях до AutoCAD 2006, добавление, редактирование или удаление сведений меню выполнялось непосредственно в текстовом файле. В AutoCAD 2006 и более поздних версиях используется редактор настройки интерфейса пользователя.

Далее представлен пример внешнего вида меню Window в старом файле меню acad.mnu.

Содержимое меню "Окно" в acad.mnu
Меню "Окно" | Описание
 | ***POP10 **WINDOW ID_MnWindow [&Окно] ID_DWG_CLOSE [&Закрыть]^C^C_close ID_WINDOW_CLOSEALL [З&акрыть все]^C^C_closeall [--] ID_WINDOW_CASCADE [&Каскадом]^C^C_syswindows;_cascade ID_WINDOW_TILE_HORZ [С&верху вниз]^C^C_syswindows;_hor ID_WINDOW_TILE_VERT [С&лева направо]^C^C_syswindows;_vert ID_WINDOW_ARRANGE [&Упорядочить значки]^C^C_syswindows;_arrange

Сравним данные меню, указанные выше, с теми же данными, представленными в редакторе настройки интерфейса пользователя в режиме просмотра структуры.

Для более подробного сравнения ниже приведены примеры свойств меню "Окно", команд "Закрыть", "Закрыть все" и контекстного меню "Окно", отображаемого в параметре "Вставить разделитель".

панель "Свойства" меню "Окно"

панель "Свойства" меню "Окно" для команды "Закрыть"

панель "Свойства" меню "Окно" для команды "Закрыть все"

Узел дерева меню "Окно", контекстное меню, отображаемое с параметром "Вставить разделитель"

Группа меню или группа настройки?

Между группой меню (термин, использовавшийся в предыдущих версиях) и группой настройки нет никакой разницы. Файлу НПИ, загруженному в AutoCAD, должно быть присвоено уникальное имя группы настроек для предотвращения конфликтов между файлами настроек в программе. Основному файлу НПИ acad.cui по умолчанию присваивается группа настройки под именем ACAD. В программу можно загрузить множество файлов настройки с уникальными именами групп настройки.

Далее представлен пример изменения имени группы настройки ACAD на вкладке "Настройка" редактора настройки интерфейса пользователя. Частичный файл НПИ (в данном примере с именем CUSTOM) можно изменить таким же способом.

См. также

Перенос и передача настроек

Создание и загрузка частичного файла НПИ

Создание корпоративного файла НПИ


Изменения в настройке - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Изменения в настройке
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
НПИВЫГР | Выгружает файл НПИ
НПИЗАГР | Загружает файл НПИ
НПИИМПОРТ | Импортирует пользовательские настройки из файла НПИ предприятия или частичного файла CUI в файл acad.cui.
НПИЭКСПОРТ | Экспортирует пользовательские настройки из файла acad.cui а файл частичной адаптации или в файл CUI предприятия.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обзор редактора настройки интерфейса пользователя - Понятия

Настройка интерфейса пользователя
Обзор редактора настройки интерфейса пользователя
Понятия
Процедуры
Команды

Редактор настройки интерфейса пользователя (НПИ) используется для изменения настройки, выполненной с помощью НПИ файла в формате XML. Редактор позволяет централизованно создавать и выполнять команды, используемые в файле НПИ. Кроме команд можно выполнить настройку большого числа различных элементов интерфейса пользователя. Редактор НПИ позволяет настроить следующие элементы:

  • Панели
  • Раскрывающиеся меню
  • Контекстные меню
  • Комбинации клавиш
  • Клавиши временной замены
  • Операции при двукратном нажатии
  • Кнопки мыши
  • Рабочие пространства
  • Старые элементы пользовательского интерфейса (планшеты, кнопки планшета, экранные меню и меню мозаики изображений)
Среда настройки

Перед началом настройки собственных меню, панелей инструментов и других элементов интерфейсов пользователя необходимо ознакомиться со средой настройки. Откройте редактор настроек пользовательского интерфейса (выберите в меню "Средства" » "Настройка" » "Интерфейс").

Выберите вкладку "Передача" для ознакомления с возможностями переноса или передачи настроек. Перейдите на вкладку "Настройка" для просмотра возможностей создания и изменения элементов интерфейса пользователя.

После ознакомления со средой можно начать использовать возможности инструментов. Дополнительную информацию о расширенных возможностях настройки см. в разделе Изменения в настройке.

Далее представлен пример вкладки "Настройка" редактора настройки пользовательского интерфейса. Эту вкладку можно использовать для настройки элементов интерфейса в файлах НПИ.

Настройте интерфейс пользователя для настройки среды рисования к отдельным видам задач. Например, если требуется создать панель инструментов с наиболее часто используемыми командами, в редакторе настройки пользовательского интерфейса можно создать новую панель инструментов "Избранное", а затем загрузить эту панель в AutoCAD.

Панель "Настройки в"

Панель "Настройки в" используется для навигации между элементами интерфейса, которые присутствуют в загруженных файлах настройки и принадлежат различным пользователям. В этой панели можно создавать и изменять элементы пользовательского интерфейса, например, рабочие пространства, панели инструментов и меню. В верхней части панели в режиме структуры расположены инструменты загрузки частичных файлов настройки в основной файл, сохранения изменений в загруженных файлах настройки, управления отображением загруженных файлов настройки и отображением элементов пользовательского интерфейса.

Режим просмотра структуры используется для создания новых элементов пользовательского интерфейса, например, панелей инструментов и меню. После того как создан новый элемент интерфейса пользователя, к нему методом перетаскивания с панели "Список команд" могут быть добавлены различные команды. Помимо возможности создавать элементы интерфейса пользователя и добавлять к ним команды, можно также изменить порядок, в котором эти команды отображаются на панелях и в меню, просто перетаскивая их вниз или вверх.

Панель "Список команд"

Панель "Список команд" используется для создания и поиска команд, содержащихся в загруженных файлах настройки. Для создания новой пользовательской команды используется кнопка "Создать". Необходимо вначале создать команду, а затем ее можно добавить к элементу интерфейса пользователя на панели "Настройки в".

В верхней части панели расположен раскрывающийся список с перечнем заранее заданных категории, используемых для управления командами, которые отображаются в списке ниже. Список "Пользовательская категория" содержит созданные команды.

Панель "Динамическое отображение"

Панель "Динамическое отображение" управляет отображением дополнительных панелей, соответствующих элементу, выбранному либо на панели "Настройки в", либо на панели "Список команд". В зависимости от того, какой элемент выбран, будут отображаться одна или несколько панелей из следующего списка:

  • Информация
  • Свойства
  • Значок
  • Ярлыки
  • Содержимое рабочих пространств


Обзор редактора настройки интерфейса пользователя - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Обзор редактора настройки интерфейса пользователя
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
НПИВЫГР | Выгружает файл НПИ
НПИЗАГР | Загружает файл НПИ
НПИИМПОРТ | Импортирует пользовательские настройки из файла НПИ предприятия или частичного файла CUI в файл acad.cui.
НПИЭКСПОРТ | Экспортирует пользовательские настройки из файла acad.cui а файл частичной адаптации или в файл CUI предприятия.
Системные переменные
ENTERPRISEMENU | Сохраняет имя файла НПИ (если определено), включая путь.
MENUNAME | Хранит имя файла адаптации, включая путь
TOOLTIPS | Управляет отображением подсказок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Фильтр отображения элементов настройки - Понятия

Настройка интерфейса пользователя
Фильтр отображения элементов настройки
Понятия
Процедуры
Команды

Можно отобразить все или только выбранные элементы для настройки. Настройки фильтра отображения элементов настройки выполняется на вкладке "Настройка" в редакторе настройки пользовательского интерфейса.

См. также

Фильтрация отображения элементов настройки (Процедура)


Фильтрация отображения элементов настройки - Процедуры

Настройка интерфейса пользователя
Фильтр отображения элементов настройки
Понятия
Процедуры
Команды

Фильтрация отображения элементов настройки

  1. Выберите в меню "Сервис" » "Настройка", » "Интерфейс"
  2. В редакторе настройки пользовательского интерфейса в панели "Настройка в" <имя файла> выберите из раскрывающегося списка файл НПИ.
  3. В панели "Настройки в <имя файла> нажмите кнопку "Открыть диалоговое окно фильтра отображения".

  4. Используйте флажок в диалоговом окне "Фильтры отображения" рядом с элементами, чтобы отобразить элемент или скрыть его. Если флажок рядом с элементом установлен, он отображается в области структуры в панели "Настройки в <имя файла>". Если флажок не установлен, элемент не отображается.
    • Панели
    • Меню
    • Контекстные меню
    • Операции при двукратном нажатии
    • Горячие клавиши
    • Кнопки мыши
    • Предыдущая версия
    • Файлы LISP
  5. Нажмите ОК для закрытия диалогового окна "Фильтры отображения".
  6. По завершении настройки нажмите OK.


Фильтр отображения элементов настройки - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Фильтр отображения элементов настройки
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа с файлами настройки - Понятия

Настройка интерфейса пользователя
Работа с файлами настройки
Понятия
Процедуры
Команды

Файлы настройки (НПИ) используются для хранения команд, элементов пользовательского интерфейса и ссылок на частичные файлы НПИ и AutoLISP. Файлы НПИ могут быть основными, частичными или корпоративными. Назначение файла НПИ определяет порядок его загрузки. Элементы пользовательского интерфейса можно передавать между файлами НПИ, что облегчает процесс переноса.

Редактор настройки пользовательского интерфейса позволяет выполнить следующие операции с файлами настройки:

  • Заново создавать новые файлы НПИ
  • Сохранять существующие файлы НПИ с другим именем
  • Переносить настройки из одного файла НПИ в другой
  • Сбрасывать и восстанавливать файлы НПИ
  • Загружать файл НПИ в качестве частичного файла НПИ
  • Основные сведения о файлах настройки
    Файлы настройки загружаются в AutoCAD для определения элементов ползовательского интерфейса. Для редактирования этих файлов используется редактор настройки пользовательского интерфейса.
  • Перенос и передача настроек
    Редактор настройки пользовательского интерфейса позволяет переносить пользовательские файлы MNU или MNS из предыдущих версий программы. Программа передает все данные из файла MNU или MNS в файл НПИ без изменения исходного файла меню. Новый файл НПИ - это файл на основе XML с таким же именем, как и исходный файл меню, но с расширением .cui.
  • Создание и загрузка частичного файла НПИ
    Частичные файлы настройки можно создавать, загружать и выгружать по мере необходимости. Загрузка и использование частичного файла НПИ позволяет создавать и изменять большинство элементов интерфейса (панели инструментов, меню и т.д.) в отдельном файле НПИ без необходимости импорта настроек в основной файл НПИ.
  • Создание корпоративного файла НПИ
    В корпоративном файле НПИ обычно хранится информация о настройке, совместно используемой несколькими пользователями, которая управляется с помощью программы-диспетчера CAD Manager. Корпоративные файлы настройки НПИ используются для упрощения сопровождения и изменения данных настройки для лиц, ответственных за управление корпоративными стандартами.


Работа с файлами настройки - Процедуры

Настройка интерфейса пользователя
Работа с файлами настройки
Понятия
Процедуры
Команды

Создание нового файла настройки

Создание файла НПИ из существующего файла НПИ

Восстановление резервной копии файла настройки

Сброс стандартного файла настройки

Переименование группы настройки

Назначение файла НПИ в качестве основного файла НПИ

Передача настроек

Загрузка частичного файла НПИ с использованием команды НПИЗАГР

Загрузка частичного файла НПИ с использованием вкладки "Настройка"

Выгрузка частичного файла НПИ с использованием команды НПИВЫГР

Выгрузка частичного файла НПИ с использованием вкладки "Настройка"

Добавление команд к частичным файлам НПИ

Назначение файла НПИ в качестве основного файла НПИ

Изменение корпоративного файла НПИ


Работа с файлами настройки - Команды

Настройка интерфейса пользователя
Работа с файлами настройки
Понятия
Процедуры
Команды
Команды
МЕНЮ | Загружает файл адаптации
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
НПИВЫГР | Выгружает файл НПИ
НПИЗАГР | Загружает файл НПИ
НПИИМПОРТ | Импортирует пользовательские настройки из файла НПИ предприятия или частичного файла CUI в файл acad.cui.
НПИЭКСПОРТ | Экспортирует пользовательские настройки из файла acad.cui а файл частичной адаптации или в файл CUI предприятия.
Системные переменные
ENTERPRISEMENU | Сохраняет имя файла НПИ (если определено), включая путь.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Основные сведения о файлах настройки - Понятия

Настройка интерфейса пользователя
Основные сведения о файлах настройки
Понятия
Процедуры
Команды

Файлы настройки загружаются в AutoCAD для определения элементов ползовательского интерфейса. Для редактирования этих файлов используется редактор настройки пользовательского интерфейса.

AutoCAD поставляется с различными файлами НПИ, которые могут быть настроены в соответствии с используемой рабочей средой. В AutoCAD файлы НПИ имеют два основных назначения: основные файлы и корпоративные файлы настройки. По умолчанию AutoCAD использует основные файлы НПИ. Можно настроить файлы, входящие в комплект поставки AutoCAD, или создать собственные файлы НПИ с помощью вкладки "Перенос" в редакторе настройки пользовательского интерфейса.

При настройке файлов НПИ, входящих в AutoCAD, или создании собственных файлов НПИ редактор настройки пользовательского интерфейса при изменении файла НПИ создает его резервную копию. Это позволяет восстановить файл в случае, если будет потеряна какая-то необходимая информация. Если изменен файл НПИ, входящий в комплект поставки AutoCAD, его можно восстановить.

См. также

Создание нового файла настройки (Процедура)

Создание файла НПИ из существующего файла НПИ (Процедура)

Восстановление резервной копии файла настройки (Процедура)

Сброс стандартного файла настройки (Процедура)

Переименование группы настройки (Процедура)

Назначение файла НПИ в качестве основного файла НПИ (Процедура)


Основные сведения о файлах настройки - Процедуры

Настройка интерфейса пользователя
Основные сведения о файлах настройки
Понятия
Процедуры
Команды

Создание нового файла настройки

Создание файла НПИ из существующего файла НПИ

Восстановление резервной копии файла настройки

Сброс стандартного файла настройки

Переименование группы настройки

Назначение файла НПИ в качестве основного файла НПИ


Создание нового файла настройки - Процедуры

Настройка интерфейса пользователя
Основные сведения о файлах настройки
Понятия
Процедуры
Команды

Создание нового файла настройки

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса в правой панели нажмите кнопку "Создать новый файл настройки".

  3. В правой панели выберите из раскрывающегося списка команду "Сохранить как".

  4. В диалоговом окне "Сохранить как" укажите папку, где будет сохранен новый файл настройки, а также введите его имя в текстовом поле "Имя файла".
  5. Нажмите кнопку "Сохранить".


Создание файла НПИ из существующего файла НПИ - Процедуры

Настройка интерфейса пользователя
Основные сведения о файлах настройки
Понятия
Процедуры
Команды

Создание файла НПИ из существующего файла НПИ

  1. В проводнике Windows перейдите в следующую папку:

    2. C:\Documents and Settings\<имя пользовательского профиля>\Application Data\Autodesk\<имя программы>\<номер версии>\<язык>\support\<имя файла настройки>.cui

    Примечание В некоторых операционных системах папки, находящиеся в профиле пользователя, по умолчанию являются скрытыми. Для просмотра этих файлов может потребоваться изменение параметров отображения. Выберите в меню "Пуск" » "Панель управления" » "Свойства папки". На вкладке "Вид" диалогового окна "Свойства папки" установите флажок "Показывать скрытые файлы и папки".

  2. Сохраните выбранный файл НПИ под другим именем (например, enterprise.cui) или скопируйте в другое место (например, в общедоступную сетевую папку для доступа к файлу пользователей), чтобы сохранить исходный файл НПИ (если в дальнейшем потребуется изменить его или использовать еще раз).

    3. Предупреждение Такой метод создания нового файла НПИ требует дополнительных действий, если не требуется копировать в файл НПИ все команды и элементы пользовательского интерфейса.


Восстановление резервной копии файла настройки - Процедуры

Настройка интерфейса пользователя
Основные сведения о файлах настройки
Понятия
Процедуры
Команды

Восстановление резервной копии файла настройки

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройки в <имя файла> " нажмите правую кнопку мыши на имени группы настройки.
  3. Выберите "Восстановить <имя файла>".

  4. Нажмите ОК.


Сброс стандартного файла настройки - Процедуры

Настройка интерфейса пользователя
Основные сведения о файлах настройки
Понятия
Процедуры
Команды

Сброс стандартного файла настройки

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройки в <имя файла> " нажмите правую кнопку мыши на имени группы настройки.
  3. Выберите "Сбросить <имя файла>".

  4. Нажмите ОК.


Переименование группы настройки - Процедуры

Настройка интерфейса пользователя
Основные сведения о файлах настройки
Понятия
Процедуры
Команды

Переименование группы настройки

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В панели "Настройки в <имя файла>" выберите файл НПИ в раскрывающемся списке.

  3. В панели "Настройки в <имя файла> выберите самый верхний узел группы настройки. Нажатием правой кнопки мыши выберите имя группы настройки и нажмите "Переименовать". Введите новое имя группы настройки.

    4. Примечание Имя группы настройки не может содержать пробелы.


Назначение файла НПИ в качестве основного файла НПИ - Процедуры

Настройка интерфейса пользователя
Основные сведения о файлах настройки
Понятия
Процедуры
Команды

Назначение файла НПИ в качестве основного файла НПИ

  1. Выберите в меню "Сервис" » " Параметры".
  2. На вкладке "Файлы" диалогового окна "Параметры" нажмите значок "плюс" (+) рядом с параметром "Файлы настройки", чтобы открыть список.

  3. Нажмите значок "плюс" (+) рядом с основным файлом настройки, чтобы открыть его.
  4. Выберите элемент в группе "Основной файл настройки" и нажмите кнопку "Обзор".

  5. В диалоговом окне "Выбор файла" укажите местоположение файла настройки и выберите его. Нажмите "Открыть".

    6. Выбранный файл теперь обозначен как основной файл НПИ для программы.


Основные сведения о файлах настройки - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Основные сведения о файлах настройки
Понятия
Процедуры
Команды

Команды
МЕНЮ | Загружает файл адаптации
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Перенос и передача настроек - Понятия

Настройка интерфейса пользователя
Перенос и передача настроек
Понятия
Процедуры
Команды

Редактор настройки пользовательского интерфейса позволяет переносить пользовательские файлы MNU или MNS из предыдущих версий программы. Программа передает все данные из файла MNU или MNS в файл НПИ без изменения исходного файла меню. Новый файл НПИ - это файл на основе XML с таким же именем, как и исходный файл меню, но с расширением .cui.

Информацию о настройке можно передавать из файла в файл. Например, можно передать панели инструментов из частичного файла НПИ в основной файл НПИ, чтобы в программе можно было отобразить информацию о панели инструментов.

Показать: Настройки переноса и передачи

Нажмите стрелку "Воспроизведение" под следующим изображением для запуска анимации.

На анимации ниже показано, как перенести в программу настройки меню, созданные в предыдущей версии программы. Помимо представления переноса настройки меню также показано как разместить меню в строке меню программы с помощью рабочего пространства. Подробней о рабочих пространствах см. раздел Настройка рабочего пространства.

Примечание Значки кнопок могут не отображаться в программе при передаче панели инструментов или меню из частичного файла НПИ. Если изображения загружаются из файла изображений, то они должны размещаться в папке, указанной в полях "Путь поиска вспомогательных файлов" или "Папка для пользовательских значков" на вкладке "Файлы" в диалоговом окне "Параметры". Если изображения относятся к библиотеке ресурсов DLL сторонних разработчиков, обратитесь к разработчикам этой библиотеки.

Примечание Диалоговое окно "Перенос пользовательских настроек" можно использовать для того, чтобы перенести настройку меню из предыдущих версий. Чтобы открыть диалоговое окно "Перенос пользовательских настроек", выберите в меню "Пуск" (Windows) "Все программы" (или "Программы") » Autodesk » [имя программы Autodesk] » "Перенос пользовательских настроек". В будущих версиях значки кнопок будут переносится в папку, определенную в поле "Папка для пользовательских значков" на вкладке "Файлы" диалогового окна "Параметры".

Кроме того, настройки можно перемещать из основного файла НПИ в частичный файл НПИ, а также из одного частичного файла НПИ в другой.

Если рабочее пространство или панель инструментов, которую требуется передать, содержит подменю с ссылками на другое меню, или панель инструментов или подменю, расположенное в исходном файле НПИ, то соответствующая информация для этого элемента интерфейса также передается. Например, при передаче панели инструментов "Черчение", содержащей ссылки на панель "Вставка", панель "Вставка" также передается.

В файле НПИ сохраняется история настройки. Данные настройки отслеживаются и сохраняются при выпуске новых версий, поэтому файл НПИ можно загружать в программу другой версии без потери или изменения текущих данных НПИ.

Далее представлен пример вкладки "Перемещение" редактора настройки пользовательского интерфейса. Эта вкладка используется для переноса настроек.

Примечание Файлы НПИ не отображаются и не могут быть использованы в версиях, предшествующих AutoCAD 2006.

См. также

Передача настроек (Процедура)


Передача настроек - Процедуры

Настройка интерфейса пользователя
Перенос и передача настроек
Понятия
Процедуры
Команды

Передача настроек

  1. Выберите в меню "Сервис" » "Настройка" » "Импорт настроек".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Перемещение" в левой панели нажмите кнопку "Открыть новый файл настройки".

  3. В диалоговом окне "Открытие файла" найдите файл настройки (MNU, MNS или НПИ), из которого необходимо экспортировать настройки, и выберите его.
  4. В правой панели нажмите кнопку "Открыть файл настройки".
  5. В диалоговом окне "Открытие файла" найдите файл настройки (MNU, MNS или НПИ), в который необходимо импортировать настройки, и выберите его.
  6. В левой панели нажмите значок "плюс" (+) рядом с узлом элементов интерфейса, чтобы открыть список. Откройте соответствующий список в правой панели.
  7. Перетащите элемент интерфейса с левой панели в соответствующее место правой панели. Меню можно перетаскивать в меню, панели инструментов - в панели инструментов, и т.д.

  8. По завершении передачи настроек нажмите кнопку OK.


Перенос и передача настроек - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Перенос и передача настроек
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
НПИИМПОРТ | Импортирует пользовательские настройки из файла НПИ предприятия или частичного файла CUI в файл acad.cui.
НПИЭКСПОРТ | Экспортирует пользовательские настройки из файла acad.cui а файл частичной адаптации или в файл CUI предприятия.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание и загрузка частичного файла НПИ - Понятия

Настройка интерфейса пользователя
Создание и загрузка частичного файла НПИ
Понятия
Процедуры
Команды

Частичные файлы настройки можно создавать, загружать и выгружать по мере необходимости. Загрузка и использование частичного файла НПИ позволяет создавать и изменять большинство элементов интерфейса (панели инструментов, меню и т.д.) в отдельном файле НПИ без необходимости импорта настроек в основной файл НПИ.

Показать: Загрузка частичного файла НПИ

Нажмите стрелку "Воспроизведение" под следующим изображением для запуска анимации.

На анимации ниже показано, как частично загрузить файл НПИ. Помимо демонстрации частичной загрузки файла НПИ также показано, как управлять отображением панелей инструментов и меню, содержащихся в частичном файле НПИ с помощью рабочего пространства. Подробней о рабочих пространствах см. раздел Настройка рабочего пространства.

Порядок частичных файлов НПИ в области структуры "Частичные файлы НПИ" определяет порядок их загрузки в программу. Иерархию в области структуры можно изменять для изменения порядка загрузки. Вкладка "Перемещение" в редакторе настроек пользовательского интерфейса используется для создания частичных файлов НПИ. Подробнее см. раздел Передача настроек . Для загрузки или выгрузки файла НПИ можно использовать команду программы НПИЗАГР или НПИВЫГР или вкладку "Настройка" в редакторе настройки пользовательского интерфейса.

Можно добавить команды и элементы к частичному файлу НПИ, загруженному в основной файл НПИ. Чтобы добавить команду к частичному файлу НПИ, этот файл должен быть выбран в раскрывающемся списке в верхней части панели "Настройки в <имя файла>". Как только частичный файл НПИ будет выбран, любая новая команда будет добавляться к этому файлу. Подробнее см. раздел Добавление команд к частичным файлам НПИ.

Примечание При загрузке частичного файла НПИ основной файл НПИ игнорирует информацию о его рабочем пространстве (меню, панели инструментов, закрепляемые окна). Для добавления содержимого рабочего пространства из частичного файла НПИ в основой файл НПИ необходимо переместить рабочее пространство. Дополнительную информацию см в разделе “Иморт рабочего пространства в основной файл НПИ” в теме Настройка рабочего пространства.

См. также

Загрузка частичного файла НПИ с использованием команды НПИЗАГР (Процедура)

Загрузка частичного файла НПИ с использованием вкладки "Настройка" (Процедура)

Выгрузка частичного файла НПИ с использованием команды НПИВЫГР (Процедура)

Выгрузка частичного файла НПИ с использованием вкладки "Настройка" (Процедура)

Добавление команд к частичным файлам НПИ (Процедура)


Создание и загрузка частичного файла НПИ - Процедуры

Настройка интерфейса пользователя
Создание и загрузка частичного файла НПИ
Понятия
Процедуры
Команды

Загрузка частичного файла НПИ с использованием команды НПИЗАГР

Загрузка частичного файла НПИ с использованием вкладки "Настройка"

Выгрузка частичного файла НПИ с использованием команды НПИВЫГР

Выгрузка частичного файла НПИ с использованием вкладки "Настройка"

Добавление команд к частичным файлам НПИ


Загрузка частичного файла НПИ с использованием команды НПИЗАГР - Процедуры

Настройка интерфейса пользователя
Создание и загрузка частичного файла НПИ
Понятия
Процедуры
Команды

Загрузка частичного файла НПИ с использованием команды НПИЗАГР

  1. В командной строке введите нпизагр.
  2. В поле "Имя файла" диалогового окна "Загрузка/выгрузка настроек" введите путь к файлу НПИ, который необходимо загрузить, или нажмите кнопку "Обзор" для поиска файла.
  3. Выберите "Загрузить", а затем "Закрыть".


Загрузка частичного файла НПИ с использованием вкладки "Настройка" - Процедуры

Настройка интерфейса пользователя
Создание и загрузка частичного файла НПИ
Понятия
Процедуры
Команды

Загрузка частичного файла НПИ с использованием вкладки "Настройка"

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройки в <имя файла>" выберите из раскрывающегося списка "Основной файл НПИ". Справа от раскрывающегося списка нажмите кнопку "Загрузить файл частичной настройки".

  3. В диалоговом окне "Открытие файла" найдите и выберите файл частичной настройки, который требуется открыть, и нажмите "Открыть".

    4. Примечание Если имя группы настройки частичного файла НПИ, который необходимо загрузить, совпадает с именем группы настройки основного файла НПИ, имя группы настройки необходимо изменить. В диалоговом окне "Настройка" откройте файл НПИ, выберите имя файла и нажмите правую кнопку мыши, чтобы изменить его.

  4. Чтобы убедиться, что файл загружен в основной файл НПИ, в панели "Настройки в" выберите в раскрывающемся списке основной файл НПИ.

  5. В области структуры основного файла настройки нажмите значок "плюс" (+) рядом с узлом "Частичные файлы НПИ", чтобы открыть список.

    6. Отобразятся все частичные меню, загруженные в основной файл НПИ.

  6. Для сохранения изменений и просмотра их в программе нажмите OK.


Выгрузка частичного файла НПИ с использованием команды НПИВЫГР - Процедуры

Настройка интерфейса пользователя
Создание и загрузка частичного файла НПИ
Понятия
Процедуры
Команды

Выгрузка частичного файла НПИ с использованием команды НПИВЫГР

  1. В командной строке введите нпивыгр.
  2. В поле "Загруженная группа настроек" диалогового окна "Загрузка/выгрузка настроек" выберите файл НПИ.
  3. Нажмите "Выгрузить", а затем - "Закрыть".


Выгрузка частичного файла НПИ с использованием вкладки "Настройка" - Процедуры

Настройка интерфейса пользователя
Создание и загрузка частичного файла НПИ
Понятия
Процедуры
Команды

Выгрузка частичного файла НПИ с использованием вкладки "Настройка"

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройки в <имя файла>" выберите из раскрывающегося списка "Основной файл НПИ".

  3. В области структуры основного файла настройки нажмите значок "плюс" (+) рядом с узлом "Частичные файлы НПИ", чтобы открыть список.

    4. Отобразятся все частичные меню, загруженные в основной файл НПИ.

  4. Нажмите правую кнопку мыши на частичном меню, которое требуется выгрузить. Выберите "Выгрузить файл НПИ".

    5. Файл будет удален из списка.

  5. Для сохранения изменений и просмотра их в программе нажмите OK.


Добавление команд к частичным файлам НПИ - Процедуры

Настройка интерфейса пользователя
Создание и загрузка частичного файла НПИ
Понятия
Процедуры
Команды

Добавление команд к частичным файлам НПИ

  1. Выберите меню "Сервис" " "Настройка" " "Интерфейс.
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройки в <имя файла>" выберите из раскрывающегося списка частичный файл НПИ.

  3. Нажмите кнопку "Создать" на панели "Список команд", чтобы создать новую команду.

  4. Настройе свойства новой команды в панели "Свойства".


Создание и загрузка частичного файла НПИ - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Создание и загрузка частичного файла НПИ
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
НПИВЫГР | Выгружает файл НПИ
НПИЗАГР | Загружает файл НПИ
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание корпоративного файла НПИ - Понятия

Настройка интерфейса пользователя
Создание корпоративного файла НПИ
Понятия
Процедуры
Команды

В корпоративном файле НПИ обычно хранится информация о настройке, совместно используемой несколькими пользователями, которая управляется с помощью программы-диспетчера CAD Manager. Корпоративные файлы настройки НПИ используются для упрощения сопровождения и изменения данных настройки для лиц, ответственных за управление корпоративными стандартами.

Для создания корпоративного файла НПИ выполните следующие действия.

  • Создайте корпоративный файл НПИ на основе существующего или нового файла НПИ. Создайте копию основного файла настройки (acad.cui) или другой файл настройки по своему выбору, содержащий все базовые элементы элемента пользователя, которые необходимы. Если необходимо создать новый файл настройки, используйте вкладку "Передача", чтобы подготовить пустой файл настройки.
  • Задайте этот файл в качестве основного файла НПИ. Используя диалоговое окно "Параметры", необходимо загрузить файл настройки в качестве основного файла настройки, чтобы можно было отредактировать все остальные элементы интерфейса пользователя. Запишите, какой файл настройки в данный момент является основным файлом настройки, возможно, позднее его придется восстановить.
  • Измените содержимое корпоративного файла НПИ. Если файл настройки предполагается использовать в качестве основного файла настройки, то, в случае необходимости, можно изменить имя группы настройки и содержимое файла НПИ. Изменение имени группы настройки позволяет загружать в программу несколько файлов НПИ одновременно. Файлы НПИ с одинаковым именем группы настройки невозможно загрузить в программу.
  • Замените основной файл НПИ.используя диалоговое окно "Параметры", замените предыдущий файл настройки, который был назначен в качестве основного файла настройки.
  • Сохраните корпоративный файл НПИ в общедоступной сетевой папке. При сохранении корпоративного файла НПИ в общедоступной сетевой папке все пользователи, имеющие доступ к этой папке, смогут обращаться к файлу.

    • Примечание Папка с размещенным корпоративным файлом НПИ должна быть общедоступной. Дополнительную информацию о создании общедоступной сетевой папки см. в разделе “Создание общего сетевого ресурса“ в Руководстве сетевого администратора.

  • Укажите местоположение корпоративного файла НПИ. При указании местоположения для корпоративного файла настройки в диалоговом окне "Параметры" программа автоматически отмечает, что он доступен только для чтения. Указание местоположения корпоративного файла настройки можно выполнить как на отдельной рабочей станции, так и с помощью "Мастера развертывания". Дополнительную информацию об указании местоположения с помощью "Мастера развертывания" см. в разделе "Выбор путей поиска и папок для файлов" в Руководстве сетевого администратора.

    • Предупреждение Несмотря на то, что редактор НПИ загружает корпоративный файл настройки открытым только для чтения, это не может полностью защитить этот файл от изменений. Корпоративный файл настройки можно загрузить в качестве основного файла настройки, а затем изменить его. Для защиты корпоративного файла настройки папку, в которой он хранится, следует сделать доступной только для чтения, доступ на запись в эту папку должен ограничиваться теми пользователями, которые должны редактировать этот файл.

См. также

Назначение файла НПИ в качестве основного файла НПИ (Процедура)

Изменение корпоративного файла НПИ (Процедура)


Создание корпоративного файла НПИ - Процедуры

Настройка интерфейса пользователя
Создание корпоративного файла НПИ
Понятия
Процедуры
Команды

Назначение файла НПИ в качестве основного файла НПИ

Изменение корпоративного файла НПИ


Назначение файла НПИ в качестве основного файла НПИ - Процедуры

Настройка интерфейса пользователя
Создание корпоративного файла НПИ
Понятия
Процедуры
Команды

Назначение файла НПИ в качестве основного файла НПИ

  1. На рабочей станции каждого пользователя в AutoCAD выберите "Сервис" » "Параметры".
  2. На вкладке "Файлы" диалогового окна "Параметры" нажмите значок "плюс" (+) рядом с параметром "Файлы настроек", чтобы открыть список.

  3. Нажмите значок "плюс" (+) рядом с корпоративным файлом настройки, чтобы открыть список.
  4. Выберите позицию в списке "Основные файлы настройки" и нажмите "Обзор".

  5. В диалоговом окне "Выбор файла" укажите местоположение корпоративного файла настройки. Нажмите "Открыть".

    6. Файл НПИ должен быть сохранен в сетевой папке, к которой имеют доступ все пользователи.

  6. В диалоговом окне "Параметры" нажмите "OK".

    7. Примечание В "Мастере развертывания" корпоративный файл НПИ указывается на странице "Изменение настроек". Дополнительную информацию о назначении корпоративного файла НПИ в "Мастере развертывания" см. в разделе "Выбор путей поиска и папок для файлов" в Руководстве сетевого администратора.


Изменение корпоративного файла НПИ - Процедуры

Настройка интерфейса пользователя
Создание корпоративного файла НПИ
Понятия
Процедуры
Команды

Изменение корпоративного файла НПИ

  1. Выберите в меню "Сервис" » " Параметры".
  2. На вкладке "Файлы" диалогового окна "Параметры" нажмите значок "плюс" (+) рядом с параметром "Файлы настроек", чтобы открыть список.
  3. Нажмите значок "плюс" (+) рядом с основным файлом настройки, чтобы открыть его.

    4. Сохраните информацию о текущем основном файле НПИ и его местоположении, поскольку эти сведения потребуются при его последующем восстановлении.

  4. Выберите позицию в списке "Основные файлы настройки" и нажмите "Обзор". В диалоговом окне "Выбор файла" укажите местоположение корпоративного файла настройки. Нажмите "Открыть".
  5. Нажмите значок "плюс" (+) рядом с корпоративным файлом настройки, чтобы открыть его.

    6. Запомните название текущего корпоративного файла НПИ и его местоположение, поскольку эти сведения потребуются при его последующем восстановлении.

  6. Выберите позицию в списке "Корпоративные файлы настройки" и нажмите "Обзор". В диалоговом окне "Выбор файла" укажите местоположение основного файла настройки. Нажмите "Открыть".
  7. В диалоговом окне "Параметры" нажмите OK, чтобы сохранить изменения.
  8. Выберите меню "Сервис" " "Настройка" " "Интерфейс.
  9. При необходимости в редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Список команд" создайте новые команды и элементы пользовательского интерфейса.
  10. После добавления новых команд и элементов интерфейса пользователя нажмите кнопку OK. Измените имена основного файла настройки и корпоративного файла настройки в диалоговом окне "Параметры".

    11. Основной и корпоративный файлы НПИ теперь должны напоминать исходную конфигурацию до внесения изменений.

Можно создать два разных профиля, которые будут использоваться для переключения между основным и корпоративным файлами НПИ. В одном профиле хранятся файлы НПИ нормальной конфигурации, используемые составителями проектов, а в другом профиле - переключаемые основной и корпоративный файлы НПИ.


Создание корпоративного файла НПИ - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Создание корпоративного файла НПИ
Понятия
Процедуры
Команды

Команды
МЕНЮ | Загружает файл адаптации
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
НПИВЫГР | Выгружает файл НПИ
НПИЗАГР | Загружает файл НПИ
НПИЭКСПОРТ | Экспортирует пользовательские настройки из файла acad.cui а файл частичной адаптации или в файл CUI предприятия.
Системные переменные
ENTERPRISEMENU | Сохраняет имя файла НПИ (если определено), включая путь.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Команды настройки - Понятия

Настройка интерфейса пользователя
Команды настройки
Понятия
Процедуры
Команды

Можно легко создавать, редактировать и повторно использовать команды. На вкладке "Настройка" редактора настройки пользовательского интерфейса отображается основной список команды, загруженных в программе. Команды из этого списка можно добавлять в панели инструментов, меню и другие элементы интерфейса пользователя.

При изменении свойств команды в основном списке или в области структуры свойства команды изменяются во всех элементах интерфейса пользователя.

В следующей таблице приведены свойства команды "Масштаб", отображающиеся в панели "Свойства".

Свойства команды "Масштаб" в меню "Изменить".
Элемент панели свойств | Описание | Пример
Имя | Строка, отображаемая как имя меню или как подсказка, при нажатии кнопки на панели инструментов. Строка должна содержать буквенно-цифровые символы. Использование знаков пунктуации за исключением дефиса (-) или символа подчеркивания (_) запрещено. | Масш&таб
Описание | Текстовая строка состояния. Эта строка отображается в строке состояния, если курсор наведен на кнопку панели инструментов или элемент меню. | Увеличивает или уменьшает объекты в одинаковой степени в направлениях X, Y и Z: МАСШТАБ
Макрос | Макрос команды. В нем применяется стандартный синтаксис для макросов. Примечание При изменении имени макроса имя соответствующего элемента меню или кнопки панели инструментов не изменяется. Имя элемента меню или кнопки панелей инструментов можно изменить, выбрав его в области структуры. | $M=$(if,$(eq,$(substr,$( getvar,cmdnames),1,4), GRIP),_scale,^C^C_scale)
Код элемента | Метка, уникально определяющая команду. | ID_Scale
Малое изображение | Идентификатор строки ресурса малого изображения (16 × 16-битовое изображение). Строка должна содержать буквенно-цифровые символы. Использование знаков пунктуации за исключением дефиса (-) или символа подчеркивания (_) запрещено. Она также может определять растровое изображение, заданное пользователем. Нажмите кнопку [...], чтобы открыть диалоговое окно "Выбор файла изображения". | RCDATA_16_SCALE
Большое изображение | Идентификатор строки ресурса большого изображения (32 × 32-битовое изображение). Если размер указанного растрового изображения отличается от 32 × 32, программа масштабирует его до этого размера. Строка должна содержать буквенно-цифровые символы. Использование знаков пунктуации за исключением дефиса (-) или символа подчеркивания (_) запрещено. Она также может содержать растровое изображение, заданное пользователем. Нажмите кнопку [...], чтобы открыть диалоговое окно "Выбор файла изображения". | RCDATA_16_SCALE
  • Создание, редактирование и повторное использование команд
    Можно создать новую команду заново или отредактировать свойства существующей команды. При создании или редактировании команды задаются такие ее свойства, как имя, описание, макрос, совместимость версий, код элемента (только для новых команд) и большое или малое изображение.
  • Имена команды "Найти" и строки поиска
    Команды и строки поиска можно искать в одном или нескольких файлах НПИ (включая имена команд, пояснения или макросы). Можно также заменять команды или строки поиска по одной или все сразу.
  • Управление отображением имен команд
    Можно управлять тем, как в меню отображается доступность команды в программе. Они могут быть серыми (недоступными для выбора), их можно помечать галочкой или рамкой, а также использовать сочетание этих способов.
  • Создание изображений для команд
    Изображения могут назначаться командам и отображаться на кнопках панелей или рядом с пунктами раскрывающихся меню. Можно использовать изображения, которые поставляются с программой, или создавать свои собственные изображения.
  • Создание подсказок в строке состояния
    Сообщения справки строки состояния - это элементарные описательные сообщения, которые отображаются в строке состояния (в нижней части области рисования) при наведении устройства указания на параметр меню или кнопку панели инструментов. Можно добавлять новые или изменять существующие описания для меню и кнопок при обновлении свойства описания для соответствующей команды.


Команды настройки - Процедуры

Настройка интерфейса пользователя
Команды настройки
Понятия
Процедуры
Команды

Создание команды

Редактирование команды

Повторное использование команды

Обнаружение строки поиска

Поиск команды в панели "Список команд"

Замена строки поиска

Замена команды

Создание недоступным имя команды в меню

Пометка имени команды в меню

Одновременное создание недоступного и помеченного имени команды в меню

Редактирование и создание изображения для кнопки

Назначение стандартного изображения команде

Назначение нестандартного изображения команде

Создание сообщений справки строки состояния


Команды настройки - Команды

Настройка интерфейса пользователя
Команды настройки
Понятия
Процедуры
Команды
Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
TOOLTIPS | Управляет отображением подсказок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание, редактирование и повторное использование команд - Понятия

Настройка интерфейса пользователя
Создание, редактирование и повторное использование команд
Понятия
Процедуры
Команды

Можно создать новую команду заново или отредактировать свойства существующей команды. При создании или редактировании команды задаются такие ее свойства, как имя, описание, макрос, совместимость версий, код элемента (только для новых команд) и большое или малое изображение.

При изменении любых свойств команды в панели "Список команд" команда обновляется для всех элементов интерфейса, ссылающихся на нее.

Показать: Создание команды

Нажмите стрелку "Воспроизведение" под следующим изображением для запуска анимации.

На анимации ниже показано, как создать пользовательскую команду в основном файле НПИ. В анимации показано назначение команде имени, описание и макроса. Подробней о назначении команде изображения см. в разделе Создание изображений для команд.

См. также

Создание макросов

Создание изображений для команд

Создание команды (Процедура)

Редактирование команды (Процедура)

Повторное использование команды (Процедура)


Создание, редактирование и повторное использование команд - Процедуры

Настройка интерфейса пользователя
Создание, редактирование и повторное использование команд
Понятия
Процедуры
Команды

Создание команды

Редактирование команды

Повторное использование команды


Создание команды - Процедуры

Настройка интерфейса пользователя
Создание, редактирование и повторное использование команд
Понятия
Процедуры
Команды

Создание команды

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настроек пользовательского интерфейса на вкладке "Настройка" в панели "Список команд" нажмите кнопку "Создать".

    3. Новая команда (под именем Команда1) отобразится в панелях "Список команд" и "Свойства".

  3. В панели "Свойства" выполните следующие действия.
    • В поле "Имя" введите имя команды. Это имя будет отображаться как подсказка или имя меню при выборе команды.
    • В поле "Пояснение" введите текстовое пояснение для команды. Это пояснение будет отображаться в строке состояния, если курсор наведен на кнопку панели инструментов или элемент меню.
    • В поле "Макрос" введите макрос для команды.
    • В поле "Код элемента" введите код элемента для команды (только для новых команд. Код элемента существующей команды изменить нельзя).

    Подробней о добавлении изображения для кнопки команды см. в Создание изображений для команд.


Редактирование команды - Процедуры

Настройка интерфейса пользователя
Создание, редактирование и повторное использование команд
Понятия
Процедуры
Команды

Редактирование команды

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настроек пользовательского интерфейса выполните одно из следующих действий:
    • В панели "Список команд" выберите команду, которую требуется отредактировать.
    • В панели области структуры найдите и выберите команду, которую требуется отредактировать.

  3. Для редактирования команды выполните одно из следующих действий в панели "Свойства":
    • В поле "Имя" введите новое имя команды. В программе имя будет отображаться в меню, для которого будет назначена команда.
    • В поле "Пояснение" введите новое текстовое пояснение для команды. Это пояснение будет отображаться в строке состояния при выборе команды в программе.
    • В поле "Макрос" введите новый макрос для команды.
    • В поле "Код элемента" введите новый код элемента для команды (только для новых команд. Код элемента существующей команды изменить нельзя).

    Информацию о добавлении изображения для кнопки к команде см. в Создание изображений для команд.


Повторное использование команды - Процедуры

Настройка интерфейса пользователя
Создание, редактирование и повторное использование команд
Понятия
Процедуры
Команды

Повторное использование команды

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настроек пользовательского интерфейса на вкладке "Настройка" выделите команду, которую требуется использовать повторно, и перетащите ее на элемент интерфейса.


Создание, редактирование и повторное использование команд - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Создание, редактирование и повторное использование команд
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Имена команды "Найти" и строки поиска - Понятия

Настройка интерфейса пользователя
Имена команды "Найти" и строки поиска
Понятия
Процедуры
Команды

Команды и строки поиска можно искать в одном или нескольких файлах НПИ (включая имена команд, пояснения или макросы). Можно также заменять команды или строки поиска по одной или все сразу.

Область поиска можно сужать или расширять в зависимости от желаемых результатов.

  • Ограничение поиска командами, расположенными в панели "Список команд".При этом в поиск не включаются свойства команд, например, пояснение к команде или назначенный для нее макрос. Например, если поиск сужен до команды "ОТРЕЗОК" в списке команд, при начале поиска отображается сообщение, аналогичное следующему: “Обнаруженная команда в узле дерева "Отрезок" (1/3).”
  • Расширение поиска для включения в него всех свойств во всех узлах области структуры в панели "Настройка в".При этом выполняется поиск всех вхождений строки поиска. Например, при поиске строки “отрезок“ и начале поиска в области структуры отображается сообщение, аналогичное следующему: “Обнаруженная команда в узле дерева "Линейный" свойство "имя" в положении 0 (1/358).“

См. также

Обнаружение строки поиска (Процедура)

Поиск команды в панели "Список команд" (Процедура)

Замена строки поиска (Процедура)

Замена команды (Процедура)


Имена команды "Найти" и строки поиска - Процедуры

Настройка интерфейса пользователя
Имена команды "Найти" и строки поиска
Понятия
Процедуры
Команды

Обнаружение строки поиска

Поиск команды в панели "Список команд"

Замена строки поиска

Замена команды


Обнаружение строки поиска - Процедуры

Настройка интерфейса пользователя
Имена команды "Найти" и строки поиска
Понятия
Процедуры
Команды

Обнаружение строки поиска

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса нажмите правую кнопку мыши в любом месте режима структуры в панели "Настройка в <имя файла>". Нажмите "Найти".

  3. В диалоговом окне "Поиск и замена" на вкладке "Найти" выполните следующие действия.
    • В поле "Искать" введите строку для поиска.
    • При необходимости поиска текста независимо от его регистра снимите флажок "Без учета регистра".
    • Если необходимо ограничить поиск только одним файлом НПИ, необходимо установить флажок "Ограничить поиск до". Затем в раскрывающемся списке выберите файл НПИ.

    • Нажмите "Найти далее", чтобы найти все вхождения строки поиска.

    Отобразится сообщение с подробной информацией о местонахождении текста в строке поиска и количеством вхождений, найденных в результате поиска.

  4. Нажмите "Найти далее" для продолжения поиска.
  5. По завершении нажмите кнопку "Закрыть".
  6. В редакторе настройки пользовательского интерфейса нажмите кнопку "Закрыть".


Поиск команды в панели "Список команд" - Процедуры

Настройка интерфейса пользователя
Имена команды "Найти" и строки поиска
Понятия
Процедуры
Команды

Поиск команды в панели "Список команд"

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса в списке "Список команд" нажмите правую кнопку мыши на имени команды, которую требуется найти. Нажмите "Найти".

  3. В диалоговом окне "Поиск и замена" на вкладке "Найти" выполните следующие действия.
    • В поле "Искать" введите имя команды.
    • При необходимости поиска текста независимо от его регистра снимите флажок "Без учета регистра".
    • Нажмите "Найти выбранную команду", чтобы найти все вхождения команды.

  4. В отображаемом тексте просмотрите каждое место положения команды, ее точное положение в области структуры или на панели "Свойства", а также количество фрагментов, в которых она встречается.
  5. Нажмите "Найти выбранную команду" для продолжения поиска.
  6. По завершении нажмите кнопку "Закрыть".
  7. В редакторе настройки пользовательского интерфейса нажмите кнопку "Закрыть".


Замена строки поиска - Процедуры

Настройка интерфейса пользователя
Имена команды "Найти" и строки поиска
Понятия
Процедуры
Команды

Замена строки поиска

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройка в <имя файла>" нажмите правую кнопку мыши в любом месте режима структуры. Нажмите "Заменить".

  3. В диалоговом окне "Поиск и замена" на вкладке "Замена" необходимо выполнить следующие действия:
    • В поле "Искать" введите строку для поиска.
    • В поле "Заменить на" введите фрагмент текста, которым следует заменить искомый фрагмент.
    • При необходимости поиска текста независимо от его регистра снимите флажок "Без учета регистра".
    • Если необходимо ограничить поиск только одним файлом НПИ, необходимо установить флажок "Ограничить поиск до". Затем в раскрывающемся списке выберите файл НПИ.
    • Чтобы просмотреть каждый найденный фрагмент искомой строки перед его заменой, необходимо нажать кнопку "Заменить". В отображаемом тексте просмотрите каждое место положения строки для поиска, ее точное положение в области структуры или на панели "Свойства", а также количество фрагментов, в которых она встречается. Это действие отменить нельзя.
    • Для поиска и замены сразу всех искомых фрагментов текста нажмите кнопку "Заменить все". Это действие отменить нельзя.

  4. По завершении нажмите кнопку "Закрыть".
  5. В редакторе настройки пользовательского интерфейса нажмите кнопку "Закрыть".


Замена команды - Процедуры

Настройка интерфейса пользователя
Имена команды "Найти" и строки поиска
Понятия
Процедуры
Команды

Замена команды

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Список команд" нажмите правую кнопку мыши на имени команды, которую требуется заменить. Нажмите "Заменить".

  3. Имя команды, выбранной на предыдущем шаге, отобразится в поле "Искать" на вкладке "Замена" диалогового окна "Поиск и замена". Для завершения операции необходимо выполнить следующие действия.
    • В поле "Заменить на" введите имя команды, которым следует заменить имя искомой команды.
    • При необходимости поиска команды независимо от регистра снимите флажок для параметра "Без учета регистра".
    • Чтобы просмотреть каждый найденный фрагмент искомого имени команды перед их заменой, необходимо нажать кнопку "Заменить". В отображаемом тексте просмотрите каждое место положения команды, ее точную позицию в области структуры или на панели "Свойства", а также количество фрагментов, в которых она встречается. При изменении имени команды в списке команд она будет переименована везде, если эта команда используется в файле НПИ. Это действие отменить нельзя.
    • Для поиска и замены сразу всех фрагментов, в которых встречается команда, нажмите кнопку "Заменить все". Это действие отменить нельзя.

  4. По завершении нажмите кнопку "Закрыть".
  5. В редакторе настройки пользовательского интерфейса нажмите кнопку "Закрыть".


Имена команды "Найти" и строки поиска - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Имена команды "Найти" и строки поиска
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Управление отображением имен команд - Понятия

Настройка интерфейса пользователя
Управление отображением имен команд
Понятия
Процедуры
Команды

Можно управлять тем, как в меню отображается доступность команды в программе. Они могут быть серыми (недоступными для выбора), их можно помечать галочкой или рамкой, а также использовать сочетание этих способов.

Команды меню могут содержать строковые выражения DIESEL, с помощью которых выполняется динамическая смена состояния, пометка и модификация текста пунктов меню. Для получения более подробных сведений об использовании выражений DIESEL, см. Выражения DIESEL в макросах.

Серые (недоступные для выбора) пункты меню

Для того чтобы пункты меню становились недоступными, его имя должно начинается с тильды (~). Команды и подменю, связанные с недоступным пунктом, не вызываются.

В приведенном примере тильда (~) вставлена в начале имени команды "Копировать вид" в ячейке "Имя" на панели "Свойства".

Это приводит к тому, что команда "Копировать вид" становится недоступной для выбора в меню "Правка".

Имена команд могут содержать строковые DIESEL-выражения, которые делают эти команды недоступными при определенных условиях. Например, при наличии строкового выражения DIESEL в ячейке "Макросы" на панели "Свойства" команда ПЕРЕНЕСТИ является недоступной, в то время как другие команды доступны.

$(if,$(getvar,cmdactive),~)MOVE^C^C_move

Функция menucmd приложения AutoLISP также может использоваться для того, чтобы делать элементы недоступными или доступными из макросов или приложений. Например, см. раздел Обращение к раскрывающимся и контекстным меню.

Пометка имен пунктов меню

Имена пунктов меню можно пометить, поставив восклицательный знак и точку (!.) в имени команды в ячейке "Имя" на панели "Свойства". Пункт меню может быть помечен одним из двух способов:

  • Флажок. Отображается, когда с элементом меню не связано изображение.
  • Рамка. Отображается, когда с элементом меню связано изображение. Изображение выделяется рамкой.

Ниже приведен пример, в котором в меню "Правка" команда "Копировать вид" отмечена флажком, а изображение команды "Вставить" выделено рамкой:

Имена команд могут содержать строковые выражения DIESEL, которые помечают имена команд при определенных условиях. Например, при добавлении следующего выражения DIESEL в ячейку "Макросы" для применяемой команды в панели "Свойства", флажок устанавливается слева от имени пункта меню, системная переменная которого используется в данный момент.

$(if,$(getvar,orthomode),!.)Орто^O
$(if,$(getvar,snapmode),!.)Шаг^B
$(if,$(getvar,gridmode),!.)Сетка^G

Функция menucmd приложения AutoLISP также может использоваться для пометки пунктов из макроса или приложения. Например, см. раздел Обращение к раскрывающимся и контекстным меню.

Одновременные недоступность и пометка имен команд

Команды можно одновременно сделать недоступными и пометить, используя один из следующих форматов:

~!. текст
!.~ текст

Тильда (~) - это специальный символьный код, который делает команду недоступной, а комбинация символов !. - специальный символьный код для пометки команды.

Тильда (~), восклицательный знак и точка (!.) вставляются в начале имени команды "Копировать вид" в ячейке "Имя" на панели "Свойства". Это приводит к тому, что команда "Копировать вид" помечается и становится недоступной для выбора в меню "Правка".

Как и в предыдущих примерах, для одновременной установки недоступности команды и ее пометки можно использовать выражения DIESEL.

См. также

Выражения DIESEL в макросах

Создание недоступным имя команды в меню (Процедура)

Пометка имени команды в меню (Процедура)

Одновременное создание недоступного и помеченного имени команды в меню (Процедура)


Управление отображением имен команд - Процедуры

Настройка интерфейса пользователя
Управление отображением имен команд
Понятия
Процедуры
Команды

Создание недоступным имя команды в меню

Пометка имени команды в меню

Одновременное создание недоступного и помеченного имени команды в меню


Создание недоступным имя команды в меню - Процедуры

Настройка интерфейса пользователя
Управление отображением имен команд
Понятия
Процедуры
Команды

Создание недоступным имя команды в меню

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройка в <имя файла>" нажмите значок "плюс" (+) рядом с меню, содержащем команду, которую требуется сделать недоступной.
  3. Выберите команду, которую необходимо сделать недоступной.

  4. На панели "Свойства" в ячейке "Имя" в начале имени команды вставьте тильду (~)

    5. Примечание Команда должна быть выбрана на панели "Настройки в", иначе будет изменено только имя команды, но не ярлыка, который видит пользователь .

  5. Нажмите ОК.

    6. Внесенные в команду изменения станут отображаться только после того, как они будут приняты и редактор НПИ закрыт.


Пометка имени команды в меню - Процедуры

Настройка интерфейса пользователя
Управление отображением имен команд
Понятия
Процедуры
Команды

Пометка имени команды в меню

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройка в <имя файла>" нажмите значок "плюс" (+) рядом с меню, содержащем команду, которую требуется пометить.
  3. Выберите команду, которую необходимо пометить.

  4. На панели "Свойства" в ячейке "Имя" вставьте восклицательный знак и точку (!.) в начале имени команды.

  5. Нажмите ОК.

    6. Внесенные в команду изменения станут отображаться только после того, как они будут приняты и редактор НПИ закрыт.


Одновременное создание недоступного и помеченного имени команды в меню - Процедуры

Настройка интерфейса пользователя
Управление отображением имен команд
Понятия
Процедуры
Команды

Одновременное создание недоступного и помеченного имени команды в меню

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройка в <имя файла>" нажмите значок "плюс" (+) рядом с меню, содержащем команду, которую требуется пометить.
  3. Выберите команду, которую необходимо пометить и сделать недоступной.
  4. На панели "Свойства" в ячейке "Имя" вставьте тильду, восклицательный знак и точку (~!. или !.~) в начале имени команды.
  5. Нажмите ОК.


Управление отображением имен команд - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Управление отображением имен команд
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание изображений для команд - Понятия

Настройка интерфейса пользователя
Создание изображений для команд
Понятия
Процедуры
Команды

Изображения могут назначаться командам и отображаться на кнопках панелей или рядом с пунктами раскрывающихся меню. Можно использовать изображения, которые поставляются с программой, или создавать свои собственные изображения.

Показать: Создание пользовательского изображения и назначение его команде

Нажмите стрелку "Воспроизведение" под следующим изображением для запуска анимации.

На анимации ниже показано, как создать пользовательское изображение и назначить его пользовательской команде. В анимации не показано, как создавать пользовательские команды. Подробней о создании пользовательских команды см. в разделе Создание, редактирование и повторное использование команд.

Autodesk предоставляет набор стандартных изображений для кнопок, вызывающих стандартные команды. Имеется возможность создавать пользовательские изображения для кнопок вызова пользовательских макросов. Для этого можно отредактировать одно из уже имеющихся изображений или создать новое с самого начала. Файлы BMP должны быть сохранены в одной папке с файлом НПИ, на которые в нем есть ссылка.

В описаниях кнопок в качестве параметров малое изображение и крупное изображение можно использовать как имена значков из файла ресурсов, так и имена пользовательских растровых картинок.

Малые изображения должны иметь размер 16 x 16 пикселов. Крупные изображения должны иметь размер 32 x 32 пикселов. Размер изображений, не соответствующих указанным значениям, изменяется в соответствии с ними.

См. также

Коротко об организации файлов

Редактирование и создание изображения для кнопки (Процедура)

Назначение стандартного изображения команде (Процедура)

Назначение нестандартного изображения команде (Процедура)


Создание изображений для команд - Процедуры

Настройка интерфейса пользователя
Создание изображений для команд
Понятия
Процедуры
Команды

Редактирование и создание изображения для кнопки

Назначение стандартного изображения команде

Назначение нестандартного изображения команде


Редактирование и создание изображения для кнопки - Процедуры

Настройка интерфейса пользователя
Создание изображений для команд
Понятия
Процедуры
Команды

Редактирование и создание изображения для кнопки

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройка в <имя файла>" выберите команду для отображения в панели "Изображения для кнопок" (в верхнем правом углу).

  3. На панели "Изображения для кнопок" выберите кнопку, внешний вид которой наиболее близок виду создаваемой кнопки. Нажмите кнопку "Изменить".

    4. Если требуется создать изображение заново, выберите любое изображение из списка на панели "Изображения для кнопок". Нажмите "Изменить", чтобы вызвать редактор кнопок. В редакторе кнопок нажмите кнопку "Очистить" слева.

  4. Для редактирования и создания изображений используются кнопки, на которых изображены карандаш, прямая линия, круг и ластик. Для выбора цвета используется палитра. Если в ней нет нужного цвета, можно нажать кнопку "Другие", чтобы выбрать цвет в диалоговом окне "Выбор цвета" (вкладка "Вся палитра").
    • Кнопка с карандашом. Окрашивает отдельные пикселы в выбранный цвет. Для того чтобы окрасить несколько пикселов одновременно, нужно вести карандаш по изображению, не отпуская кнопку мыши.
    • Кнопка с прямой линией. Используется для построения линий выбранного цвета. Для определения первой конечной точки отрезка нажмите и удерживайте нажатой левую кнопку мыши. Для построения отрезка переместите мышь. Для завершения построения отрезка отпустите кнопку мыши.
    • Кнопка с изображением круга. Используется для построения окружностей и эллипсов выбранного цвета. Для определения центра окружности нажмите и удерживайте нажатой левую кнопку мыши. Для определения радиуса переместите мышь. Для завершения построения окружности отпустите кнопку мыши.
    • Кнопка с ластиком. Изменяет цвет отдельных пикселов на белый.

    Примечание Отредактировать кнопки подменю нельзя.

  5. Чтобы сохранить кнопку в файле BMP, нажмите кнопку "Сохранить". Для сохранения изображения под другим именем выберите "Сохранить как". Сохраните изображение новой кнопки в следующей папке:

    6. C:\Documents and Settings\<имя пользовательского профиля>\Application Data\Autodesk\<имя программы>\<номер версии>\<язык>\Support\Icons

    Примечание Изображение кнопки можно сохранить только в формате BMP (*.bmp, *.rle, или *.dib).

    При сохранении изображения кнопки редактор кнопок по умолчанию использует папку, определенную в поле "Папка для пользовательских значков" на вкладке "Файлы" диалогового окна "Параметры". Файлы значков кнопок, помещенные в эту папку, могут быть перенесены в новые версии программы с помощью диалогового окна "Перенос пользовательских настроек".


Назначение стандартного изображения команде - Процедуры

Настройка интерфейса пользователя
Создание изображений для команд
Понятия
Процедуры
Команды

Назначение стандартного изображения команде

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса в панели "Список команд" выберите любую команду для отображения в панели "Изображения для кнопок" (в верхнем правом углу) и панели "Свойства" (в нижнем правом углу).

  3. В панели "Изображения для кнопок" выберите одну из трех опций назначения изображения: крупное, малое или оба.

  4. Выберите изображение в списке изображений и имя этого изображения будет присвоено свойству изображения ("Малое изображение" и/или "Большое изображение") для выбранной команды.


Назначение нестандартного изображения команде - Процедуры

Настройка интерфейса пользователя
Создание изображений для команд
Понятия
Процедуры
Команды

Назначение нестандартного изображения команде

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса в панели "Список команд" выберите любую команду для отображения в панели "Изображения для кнопок" (в верхнем правом углу) и панели "Свойства" (в нижнем правом углу).

  3. В панели "Свойства" выберите поле возле свойства "Малое изображение". Справа от этого свойства будет отображена овальная кнопка.
  4. Нажмите овальную кнопку рядом со свойством.

  5. В диалоговом окне "Выбор файла изображения" найдите файл изображения, который требуется использовать для этой команды.
  6. Повторите шаги с 3 по 6 применительно к свойству "Большое изображение" для этой команды.


Создание изображений для команд - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Создание изображений для команд
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
TOOLTIPS | Управляет отображением подсказок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание подсказок в строке состояния - Понятия

Настройка интерфейса пользователя
Создание подсказок в строке состояния
Понятия
Процедуры
Команды

Сообщения справки строки состояния - это элементарные описательные сообщения, которые отображаются в строке состояния (в нижней части области рисования) при наведении устройства указания на параметр меню или кнопку панели инструментов. Можно добавлять новые или изменять существующие описания для меню и кнопок при обновлении свойства описания для соответствующей команды.

См. также

Создание сообщений справки строки состояния (Процедура)


Создание сообщений справки строки состояния - Процедуры

Настройка интерфейса пользователя
Создание подсказок в строке состояния
Понятия
Процедуры
Команды

Создание сообщений справки строки состояния

  1. Выберите в меню "Сервис" » "Настройка", » "Интерфейс"
  2. В редакторе настройки пользовательского интерфейса перейдите на вкладку "Настройка".
  3. В панели "Список команд" выберите команду, в которую требуется добавить сообщение справки.

    4. Панель свойств отображается в правой части диалогового окна.

  4. В поле "Описание" панели "Свойства" для выбранной команды введите текст описания.

  5. Нажмите кнопку "Применить".

    6. При следующем вызове команды добавленный тип описания будет отображаться в строке состояния, если навести курсор мыши на кнопку панели инструментов или пункт меню.


Создание подсказок в строке состояния - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Создание подсказок в строке состояния
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание макросов - Понятия

Настройка интерфейса пользователя
Создание макросов
Понятия
Процедуры
Команды

С помощью макроса меню описывается действие, которое будет выполнено при выборе какого-либо элемента интерфейса. Макрос реализует задачу построения, для выполнения которой пользователю потребовалось бы произвести несколько операций. Макрос может содержать команды, специальные символы, а также программные коды на языке DIESEL (Direct Interpretively Evaluated String Expression Language) или AutoLISP.

Примечание По мере появления новых версий AutoCAD может измениться последовательность запросов для некоторых команд (а иногда даже имена команд). Поэтому после обновления версии AutoCAD, возможно, потребуется внести некоторые изменения в пользовательские макросы.

Добавить макросы к элементам интерфейса можно с помощью редактора настроек пользовательского интерфейса. Выберите существующую команду или создайте новую в панели "Список команд". Введите макросы в разделе "Макросы" панели "Свойства". Для макросов нет ограничений по длине. Однако следует учитывать правила использования специальных символов, а также другие аспекты и ограничения.

Основные сведения о макросах

Макрос, описывающий элемент интерфейса, может состоять даже из одной команды (например, круг) и специальных символов (например, ^C^C).

Например, макрос ^C^C_круг \1 строит окружность с радиусом, равным 1 единице. Компоненты, определяющие этот макрос, описаны в следующей таблице.

Компоненты макроса CIRCLE
Компонент
Тип компонента
Результат

^C^C

Специальный управляющий символ

Отменяет все команды, выполняющиеся в текущий момент времени

_

Специальный управляющий символ

Автоматически переводит следующую за ним команду на нужный язык

КРУГ

Команда

Запускает команду КРУГ

\

Специальный управляющий символ

Создает паузу для ввода пользователем точки центра

1

Специальный управляющий символ

Задает радиус окружности (1)

Список специальных символов для макросов см. в разделе Использование в макросах специальных управляющих символов.

Отмена выполняющихся команд

Прежде чем выполнить макрос, убедитесь, что ни одна из программ AutoCAD не запущена. Чтобы автоматически отменить команду перед выполнением макроса, введите ^C^C в начале тела макроса, что соответствует двойному нажатию клавиши ESC. Хотя большинство команд можно отменить с помощью ^C, для отмены выполнения команд нанесения размеров и возврата к командной строке необходима последовательность ^C^C. Таким образом, в данном случае лучше использовать ^C^C.

Проверка символов макроса

При написании макросов значимым является каждый символ, даже пробел.

Если в конце тела макроса поставить пробел, AutoCAD выполнит макрос так, как если бы пользователь ввел команду (например, круг) а затем нажал ПРОБЕЛ для ее завершения.

Завершение макроса

Для завершения некоторых макросов требуются специальные символы. Чтобы завершить некоторые команды (например, ТЕКСТ), требуется нажать клавишу ENTER, а не ПРОБЕЛ. Кроме того, иногда для завершения команды необходимо несколько пробелов (или ENTER), но некоторые текстовые редакторы не позволяют создавать строки, завершающиеся пробелами.

Для решения этих проблем приняты два специальных соглашения.

  • Точка с запятой (;) в макросе меню имитирует нажатие клавиши ENTER в командной строке.
  • После строк, заканчивающихся каким-либо специальным символом, обратной косой чертой (\), знаком плюс (+) или точкой с запятой (;) AutoCAD не добавляет символ пробела.

Запись, заканчивающаяся символом обратной косой черты (\), переводит макрос в состояние ожидания пользовательского ввода.

Сравним следующие макросы:

ucs
ucs ;

В первом случае макрос имитирует ввод команды пск в командной строке и нажатие клавиши ПРОБЕЛ. Далее появляется подсказка:

Начало ПСК или [Грань/Именованная/Объект/Предыдущая/Вид/Мир/X/Y/Z/Z ось] <Мир>:

Во втором случае в командной строке вводится команда пск, ПРОБЕЛ и точка с запятой, которая воспринимается как ENTER и подтверждает значение, предлагаемое по умолчанию ("Мир").

Подавление эхо-вывода и запросов в макросах

Символы макроса дублируются в командной строке, как если бы они были введены с клавиатуры. Они также отображаются в элементе интерфейса пользователя Дублирование на экране называется “эхо-выводом“. “Эхо-вывод“ можно подавить с помощью системной переменной MENUECHO . Если эхо-вывод и запросы для пункта меню включены, их можно отключить в макросе с помощью последовательности ^P.

Создание длинных макросов

Можно создать макрос любой длины, для которого не требуется использование специальных символов в конце строки. В панели "Свойства" в редакторе настройки пользовательского интерфейса можно использовать макросы любой длины.

  • Использование в макросах специальных управляющих символов
    В макросах можно использовать специальные символы, включая управляющие символы. Символ крышки (^) в макросе имитирует нажатие клавиши CTRL на клавиатуре. Комбинируя его с алфавитными символами, можно из макросов меню производить, например, включение/отключение сетки (^G) или прерывание команды (^C).
  • Пауза для пользовательского ввода
    Чтобы ввести информацию с клавиатуры или с помощью устройства указания в процессе выполнения макроса, в теле макроса поставьте символ обратной косой черты (\) в том месте, где необходимо сделать паузу для ввода.
  • Поддержка иностранных языков в макросах
    Для разработки меню, которые могут быть использованы и в неанглоязычных версиях программы AutoCAD, перед командой на английском языке необходимо вставить знак подчеркивания (_). Стандартные команды и их опции переводятся автоматически на нужный язык, если перед командами на английском языке вставлен знак подчеркивания.
  • Повторение команд в макросе
    Если перед командой вставить символ звездочки (*), эта команда будет вызываться до выбора другой команды.
  • Метод выбора объектов "Единственный"
    Метод выбора объектов "Единственный" отменяет повторение запроса о выборе объектов в командной строке. После выбора одного объекта и ответа на другие запросы команда завершается.
  • Использование макроса для перестановки элементов интерфейса пользователя
    Можно заменить назначения активных меню, кнопок мыши, кнопок планшета, меню планшета или экранных меню. Можно подставлять как элемент интерфейса пользователя того же типа, определенный в основном файле НПИ, так и элемент из частичного файла НПИ.
  • Использование условных выражений в макросах
    Условные выражения можно добавлять в макрос путем использования команды, содержащей макровыражения на языке DIESEL.
  • Использование AutoLISP в макросах
    Создание команд, использующих AutoLISP, является более совершенным способом использования функции настройки AutoCAD.


Создание макросов - Процедуры

Настройка интерфейса пользователя
Создание макросов
Понятия
Процедуры
Команды

Нет процедур для этой темы.


Создание макросов - Команды

Настройка интерфейса пользователя
Создание макросов
Понятия
Процедуры
Команды
Команды
ВЫБРАТЬ | Занесение выбранных объектов в текущий набор
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
НПИВЫГР | Выгружает файл НПИ
НПИЗАГР | Загружает файл НПИ
Системные переменные
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
PICKADD | Управляет дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов)
PICKAUTO | Управляет автоматическим созданием рамки выбора объектов в ответ на запрос "Выберите объекты".
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование в макросах специальных управляющих символов - Понятия

Настройка интерфейса пользователя
Использование в макросах специальных управляющих символов
Понятия
Процедуры
Команды

В макросах можно использовать специальные символы, включая управляющие символы. Символ крышки (^) в макросе имитирует нажатие клавиши CTRL на клавиатуре. Комбинируя его с алфавитными символами, можно из макросов меню производить, например, включение/отключение сетки (^G) или прерывание команды (^C).

Для команды "Адрес" в макросе используется символ обратной косой черты (\ ), который переводит программу в режим ожидания пользовательского ввода, а точка с запятой (;) имитирует нажатие клавиши ENTER.

text \.4 0 DRAFT Inc;;;Main St.;;;Город, Штат;

Макрос запускает команду ТЕКСТ и запрашивает начальную точку текста, после чего проставляется адрес, состоящий из трех строк. Первая из трех точек с запятой (;;;) завершает текстовую строку, вторая снова вызывает команду ТЕКСТ, третья задает размещение текста по умолчанию под предыдущей строкой.

В следующей таблице приведены символы, используемые в макросах.

Специальные символы, используемые в макросах
Символ | Описание
; | Имитация нажатия ENTER
^M | Имитация нажатия ENTER
^I | Имитация нажатия TAB
[пробел] | Вставляет пробел. Пробел между элементами последовательностей в команде имитирует нажатие клавиши ПРОБЕЛ
\ | Пауза для пользовательского ввода (не может использоваться с ускорителями)
_ | Обращение к непереведенному (английскому) варианту команды или опции AutoCAD
=* | Вывод на экран раскрывающегося, контекстного или графического меню верхнего уровня
*^C^C | Повторяет команду до тех пор, пока не будет выбрана другая команда
$ | Вводит условное макровыражение на языке DIESEL ($M=)
^B | Включает или отключает режим "Шаг" (CTRL+B)
^C | Отмена команды (ESC)
^D | Включает или отключает режим "Динамическая ПСК" (CTRL+D)
^E | Устанавливает следующую изометрическую плоскость (CTRL+E)
^G | Включает или отключает режим "Сетка" (CTRL+G)
^H | Имитация нажатия BACKSPACE
^O | Включение и отключение режима "Орто"
^P | Переключение переменной MENUECHO
^Q | Эхо-вывод подсказок, сообщений и данных, выводимых на принтер (CTRL+Q)
^T | Включает или отключает планшет (CTRL+T)
^V | Смена текущего видового экрана
^Z | Символ "ноль", подавляющий автоматическое добавление пробела в конце текста команды


Создание макросов

Настройка интерфейса пользователя
Создание макросов
Понятия
Процедуры
Команды

Нет процедур.


Использование в макросах специальных управляющих символов - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Использование в макросах специальных управляющих символов
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
НПИВЫГР | Выгружает файл НПИ
НПИЗАГР | Загружает файл НПИ
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Пауза для пользовательского ввода - Понятия

Настройка интерфейса пользователя
Пауза для пользовательского ввода
Понятия
Процедуры
Команды

Чтобы ввести информацию с клавиатуры или с помощью устройства указания в процессе выполнения макроса, в теле макроса поставьте символ обратной косой черты (\) в том месте, где необходимо сделать паузу для ввода.

circle \1

В этом примере при вводе "\1" программа предлагает пользователю ввести точку центра, а затем строит круг с радиусом, равным единице. Следует обратить внимание на то, что после обратной косой черты (\) пробел не ставится.

-layer off \;

В этом примере макрос вызывает команду СЛОЙ (-layer), вводит параметр "Откл.", а затем программа переходит в режим ожидания ввода имени слоя (\). Макрос отключает слой и завершает команду СЛОЙ (;).

Примечание Обычно команда СЛОЙ продолжает выдавать запросы, и выход из нее осуществляется с помощью пробела или клавиши ENTER. В макросах точка с запятой (;) является эквивалентом нажатия клавиши ENTER.

Обычно макрос меню возобновляет свою работу сразу после того, как введен параметр, например, координаты точки. Поэтому нельзя создать такой макрос, который воспринимал бы переменное число параметров (как при выборе объектов), а затем возобновлял свою работу. Однако существует исключение для команды ВЫБРАТЬ: в ней обратная косая черта (\) задерживает выполнение команды ВЫБРАТЬ до тех пор, пока набор объектов не будет полностью сформирован. Рассмотрим пример:

select \change previous ;properties color red ;

С помощью команды ВЫБРАТЬ осуществляется выбор одного или нескольких объектов (select \). Затем происходит вызов команды ИЗМЕНИТЬ (change). В качестве аргумента ей передается созданный набор (опция "Previous" - "Предыдущий"), и цвет выбранных объектов изменяется на красный (properties color red).

Примечание Символ обратной косой черты (\) переводит макрос в состояние ожидания пользовательского ввода. Для других целей в макросе его использовать нельзя. При необходимости задания путей в качестве разделителей необходимо вводить обычную косую черту (/), например /путь/файл.

Выполнение макроса может не возобновиться после первого ввода в следующих случаях.

  • При задании режима объектной привязки перед указанием точки.
  • При использовании координатных фильтров X/Y/Z выполнение возобновляется только после получения всех координат.
  • При обращении к команде ВЫБРАТЬ выполнение возобновляется только после окончания выбора объектов.
  • Если пользователь в ответ вводит имя прозрачной команды, выполнение возобновляется только после ее завершения и получения ответа на первоначальный запрос.
  • Если пользователь в ответ выбирает другую команду (для задания опций или выполнения прозрачной команды), исходный макрос приостанавливается до тех пор, пока не будет завершен вновь выбранный. Затем выполнение макроса будет продолжено.

Примечание Если вызов команды производится из пункта меню, подразумевается, что системные переменные PICKADD и PICKAUTO имеют значения 1 и 0 соответственно. Это обеспечивает совместимость с предыдущими версиями AutoCAD и упрощает настройку, так как избавляет от необходимости беспокоиться о значениях этих переменных.


Пауза для пользовательского ввода - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Пауза для пользовательского ввода
Понятия
Процедуры
Команды

Команды
ВЫБРАТЬ | Занесение выбранных объектов в текущий набор
Системные переменные
PICKADD | Управляет дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов)
PICKAUTO | Управляет автоматическим созданием рамки выбора объектов в ответ на запрос "Выберите объекты".
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Поддержка иностранных языков в макросах - Понятия

Настройка интерфейса пользователя
Поддержка иностранных языков в макросах
Понятия
Процедуры
Команды

Для разработки меню, которые могут быть использованы и в неанглоязычных версиях программы AutoCAD, перед командой на английском языке необходимо вставить знак подчеркивания (_). Стандартные команды и их опции переводятся автоматически на нужный язык, если перед командами на английском языке вставлен знак подчеркивания.


Поддержка иностранных языков в макросах - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Поддержка иностранных языков в макросах
Понятия
Процедуры
Команды

Команды
ВЫБРАТЬ | Занесение выбранных объектов в текущий набор
Системные переменные
PICKADD | Управляет дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов)
PICKAUTO | Управляет автоматическим созданием рамки выбора объектов в ответ на запрос "Выберите объекты".
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Повторение команд в макросе - Понятия

Настройка интерфейса пользователя
Повторение команд в макросе
Понятия
Процедуры
Команды

Если перед командой вставить символ звездочки (*), эта команда будет вызываться до выбора другой команды.

Бывают ситуации, когда один и тот же пункт меню требуется вызвать несколько раз, перед тем как перейти к другой команде. В макросе команду можно вызывать до тех пор, пока не будет вызвана другая команда. Однако это не относится к выбору опций.

Если макрос начинается с последовательности *^C^C, команда будет вызываться до тех пор, пока ее выполнение не буде прервано нажатием клавиши ESC на клавиатуре или выбором другой команды.

Примечание Не следует использовать комбинацию ^C (прерывание) в макросах, начинающихся с *^C^C; это исключает возможность сделать макрос повторяемым.

Приведенный ниже пример иллюстрирует повторный вызов команд в макросе:

*^C^Cmove Single
*^C^Ccopy Single
*^C^Cerase Single
*^C^Cstretch Single Crossing
*^C^Crotate Single
*^C^Cscale Single

Каждый макрос в этом примере вызывает команду, а затем выводит запрос на выбор объекта. Также выводятся другие необходимые для выполнения команды запросы, после чего команда завершается и запускается повторно.

Примечание Повторение макросов не работает в меню мозаики изображений.


Повторение команд в макросе - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Повторение команд в макросе
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Метод выбора объектов "Единственный" - Понятия

Настройка интерфейса пользователя
Метод выбора объектов "Единственный"
Понятия
Процедуры
Команды

Метод выбора объектов "Единственный" отменяет повторение запроса о выборе объектов в командной строке. После выбора одного объекта и ответа на другие запросы команда завершается.

Рассмотрим следующий пример:

*^C^Cerase single

Этот макрос прерывает текущую команду и вызывает команду СТЕРЕТЬ (erase) в режиме выбора "Единственный" (single). После выбора этой команды можно либо выбрать один объект для удаления, либо нажать в пустом месте чертежа и выбрать объекты рамкой. Объекты стираются, а выполнение команды (из-за того, что она начинается со звездочки) повторяется, благодаря чему пользователь может продолжить стирание объектов. Для выхода из этого режима нажмите клавишу ESC.


Метод выбора объектов "Единственный" - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Метод выбора объектов "Единственный"
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Использование макроса для перестановки элементов интерфейса пользователя - Понятия

Настройка интерфейса пользователя
Использование макроса для перестановки элементов интерфейса пользователя
Понятия
Процедуры
Команды

Можно заменить назначения активных меню, кнопок мыши, кнопок планшета, меню планшета или экранных меню. Можно подставлять как элемент интерфейса пользователя того же типа, определенный в основном файле НПИ, так и элемент из частичного файла НПИ.

Функции элементов различных типов нельзя менять друг на друга (например, функции кнопок меню и кнопок мыши). В пределах одного типа вместо элемента интерфейса пользователя можно подставлять любой другой элемент.

Примечание Единственный тип, при обращении с которым требуется осторожность - это тип планшетных меню. Следует учитывать, что различные меню этого типа могут иметь различное количество макросов.

Для подстановки элементов в макросах используется следующий синтаксис:

$раздел=группа_меню.имя_меню

Далее приведено описание синтаксиса макроса для подстановки элементов.

Синтаксиса макроса для подстановки элементов.

$

Загружает элемент интерфейса

раздел

Указывает тип элемента. Допустимые имена:

A1-A4 для меню AUX от 1 до 4

B1-B4 для меню BUTTONS (кнопочное) от 1 до 4

P0-P16 для раскрывающихся меню от 0 до 16

I для меню мозаики изображений

S для экранных меню

T1-T4 для планшетных меню от 1 до 4

инфо_группа

Имя информационной группы, к которой принадлежит меню имя_меню (не обязательно, если имя_меню находится в основном файле НПИ).

имя_меню

меню BUTTONS (кнопочное) от 1 до 4 Это основное имя или псевдоним загружаемого фрагмента

Ниже приведены примеры обращения к подменю:

$S=PARTS
$T1=EDITCMDS

Подменю можно вызывать в ходе выполнения команды, не прерывая ее. меню TABLET (планшетное) от 1 до 4

$S=ARCSTUFF ARC
ARC $S=ARCSTUFF

Каждая команда вызывает команду ДУГА, осуществляет переключение к экранному подменю ARCSTUFF, после чего программа ожидает ввода параметров дуги. После ссылки на подменю необходимо ввести пробел для отделения ее от других команд.

Раскрывающееся меню может находиться либо в строке меню, либо в активном контекстном меню.


Использование макроса для перестановки элементов интерфейса пользователя - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Использование макроса для перестановки элементов интерфейса пользователя
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Использование условных выражений в макросах - Понятия

Настройка интерфейса пользователя
Использование условных выражений в макросах
Понятия
Процедуры
Команды

Условные выражения можно добавлять в макрос путем использования команды, содержащей макровыражения на языке DIESEL.

Для этого используется формат:

$M=выражение

При использовании в начале макроса $M= программа AutoCAD интерпретирует строку как выражение DIESEL, а выражение - как выражение DIESEL. В следующем примере приведено определение условного выражения в макросе:

FILLMODE $M=$(-,1,$(getvar,fillmode))

Макрос переключает состояние переменной FILLMODE. Для этого текущее значение FILLMODE вычитается из 1, а полученное значение затем возвращается в переменную FILLMODE. Можно использовать этот метод, чтобы переключать системные переменные, допустимыми значениями для которых являются 1 или 0.

Прерывание выполнения макроса, содержащего условные выражения

Если для выполнения проверок “если-то” используется строка на языке DIESEL, условия могут возникать в тех случаях, когда нельзя использовать обычные, прерывающие работу пробел или точку с запятой (в результате нажатия ENTER). Если в конец макроса добавлены символы ^Z, AutoCAD не будет добавлять пробел (ENTER) в конец выражения.

Как и другие управляющие символы, символ ^Z, используемый здесь, является строкой, состоящей из символа крышки ^ и буквы Z . Символ не является результатом нажатия клавиш CTRL+Z.

В следующих примерах символ ^Z используется в качестве указателя конца макроса.

^C^C$M=$(if,$(=,$(getvar,tilemode),0),$S=mview _mspace )^Z
^C^C$M=$(if,$(=,$(getvar,tilemode),0),$S=mview _pspace )^Z

Если бы в конце макроса не стоял символ ^Z, AutoCAD автоматически добавляла бы пробел (ENTER) для повтора последней введенной команды.

См. также

Использование в макросах специальных управляющих символов

DIESEL


Использование условных выражений в макросах - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Использование условных выражений в макросах
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
FILLMODE | Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование AutoLISP в макросах - Понятия

Настройка интерфейса пользователя
Использование AutoLISP в макросах
Понятия
Процедуры
Команды

Создание команд, использующих AutoLISP, является более совершенным способом использования функции настройки AutoCAD.

Переменные AutoLISP и выражения можно использовать для создания макросов, выполняющих сложные задачи. Для эффективного использования AutoLISP в макросах следует поместить код AutoLISP в отдельный файл MNL. AutoCAD загружает файл MNL при загрузке файла НПИ с тем же именем из той же папки.

Можно указать дополнительные файлы AutoLISP для загрузки в редактор настройки пользовательского интерфейса. Создание команд, использующих AutoLISP, является более совершенным способом использования функции настройки AutoCAD. Внимательно изучите следующие примеры, а также информацию в документах Справка по AutoLISP и Руководство разработчика AutoLISP (В меню "Справка": "Дополнительные ресурсы" » "Документация для разработчиков). MNL-файлы загружаются в память вместе с файлами меню, носящими то же имя.

Вызов макроса

Для программного выполнения макроса раскрывающегося меню используйте следующий синтаксис.

(menucmd "Gгруппа_меню.element_ID=|")

Использование такого синтаксиса имеет эффект только в том случае, если макрос меню является частью меню, находящегося в троке меню AutoCAD и готового к использованию. Дополнительную информацию о синтаксисе см. в документации Справка по AutoLISP

Установленные значения

Приложение, использующее заданные настройки для вставки блока, приводит следующие команды: [Set WINWID][Set WALLTHK][Insert Window]

^C^C^P(setq WINWID (getreal"Enter window width: ")) ^P
^C^C^P(setq WALLTHK (getreal"Enter wall thickness: ")) ^P
^C^C_INSERT window XScale !WINWID YScale !WALLTHK

Здесь производится вставка блока “Window“, масштаб которого по оси X равен текущей ширине окна, а по оси Y - текущей толщине стены. В этом примере фактические значения извлекаются из заданных пользователем символов AutoLISP WINWID и WALLTHK. Поскольку возможность поворота зависит от пользователя, данное окно может быть повернуто на стене.

Изменение размера ручек

При использовании следующих команд регулировку размера ручек можно выполнять сразу.

^P(setvar"gripsize"(1+(getvar"gripsize")))(redraw)(princ)
^P(setvar"gripsize"(1-(getvar"gripsize")))(redraw)(princ)

Для добавления проверки корректности к этим командам значение системной переменной GRIPSIZE не может быть меньше 0 и больше 255.

Подсказка для пользовательского ввода

Следующий элемент запрашивает задание двух точек и рисует полилинию в виде прямоугольника, в углах которой находятся указанные точки.

^P(setq a (getpoint "Enter first corner: "));\+
(setq b (getpoint "Enter opposite corner: "));\+
pline !a (list (car a)(cadr b)) !b (list (car b)(cadr a)) c;^P


Использование AutoLISP в макросах - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Использование AutoLISP в макросах
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
НПИВЫГР | Выгружает файл НПИ
НПИЗАГР | Загружает файл НПИ
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка панелей инструментов - Понятия

Настройка интерфейса пользователя
Настройка панелей инструментов
Понятия
Процедуры
Команды

Для повышения эффективности рисования или использования рабочего пространства можно настроить панель инструментов, что также просто, как ее размещение или изменение размеров в области чертежа. Также можно создавать или редактировать панели инструментов и их подменю, добавляя элементы управления или команды и создавая или редактируя кнопки панелей инструментов.

  • Создание и редактирование панелей инструментов
    Даже незначительные изменения панелей инструментов могут повысить эффективность работы с чертежом. Например, можно выносить часто используемые кнопки на одну панель, удалять или скрывать никогда не используемые кнопки или изменять основные свойства панели.
  • Добавление или замена элементов управления панели инструментов
    Элементы управления панели инструментов представляют собой раскрывающиеся списки определенных параметров панели, в которой они выбираются. Например, в панели "Слои" содержатся элементы управления, позволяющие определять настройки слоев. В редакторе настройки пользовательского интерфейса можно добавлять, удалять и изменять положение элементов управления в панели инструментов.


Настройка панелей инструментов - Процедуры

Настройка интерфейса пользователя
Настройка панелей инструментов
Понятия
Процедуры
Команды

Создание панели

Создание подменю панели инструментов заново

Создание подменю из другой панели

Добавление команды на панель

Изменение положения кнопки на панели

Удаление кнопки с панели

Изменение свойств панели инструментов

Добавление элемента управления на панель инструментов

Замена элемента управления на панели инструментов


Настройка панелей инструментов - Команды

Настройка интерфейса пользователя
Настройка панелей инструментов
Понятия
Процедуры
Команды
Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
TOOLTIPS | Управляет отображением подсказок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание и редактирование панелей инструментов - Понятия

Настройка интерфейса пользователя
Создание и редактирование панелей инструментов
Понятия
Процедуры
Команды

Даже незначительные изменения панелей инструментов могут повысить эффективность работы с чертежом. Например, можно выносить часто используемые кнопки на одну панель, удалять или скрывать никогда не используемые кнопки или изменять основные свойства панели.

Показать: Создание панели инструментов

Нажмите стрелку "Воспроизведение" под следующим изображением для запуска анимации.

В анимации ниже показано, как создавать пользовательскую панель инструментов и замещать в ней стандартные и пользовательские команды. В анимации не показано, как создавать пользовательские команды и назначать командам изображения. Подробней о создании пользовательских команд см. в разделе Создание, редактирование и повторное использование команд. Подробней о назначении команде изображения см. в разделе Создание изображений для команд.

Также можно задавать текст подсказки, который будет отображаться при наведении курсора на кнопку панели.

Пользователь может добавлять на панели инструментов свои кнопки, удалять неиспользуемые кнопки, а также настраивать расположение кнопок на панелях по своему усмотрению. Кроме того, существует возможность создания собственных панелей инструментов, а также создания и редактирования изображений для кнопок панели.

Примечание При создании панели необходимо определить, в каких рабочих пространствах она должна отображаться. По умолчанию новая панель отображается во всех рабочих пространствах.

В следующей таблице приведены свойства панели "Стандартная" в том виде, в каком они отображаются на панели "Свойства".

Свойства панели "Стандартная"
Элемент панели свойств | Описание | Пример
Имя | Строка, используемая в качестве заголовка панели. | Стандартная
Описание | Описание элемента, не отображается в пользовательском интерфейсе. | Панель "Стандартная"
По умолчанию вкл. | Отображение или скрытие панели при первой загрузки файла НПИ. Допустимые значения "Скрыть" или "Показать". | Показать
Ориентации | Тип панели: плавающая или закрепленная (сверху, снизу, слева или справа) при первой загрузке файла НПИ. | Сверху
Координата Х по умолчанию | Положение от левой границы экрана плавающей панели инструментов или положение закрепленной панели. Если панель закреплена, значение 0 соответствует крайнему левому положению в области закрепления. | 0
Координата Х по умолчанию | Положение от верхней границы экрана плавающей панели инструментов или положение закрепленной панели. Если панель закреплена, значение 0 соответствует крайнему верхнему положению в области закрепления. | 0
Рядов | Указывает, во сколько рядов будут располагаться на панели отображаемые элементы, если панель плавающая. | 1
Псевдонимы | Указывает псевдоним панели. Нажмите кнопку [...], чтобы открыть диалоговое окно "Псевдонимы". Псевдоним используется для создания программных ссылок на панель. | TB_STANDARD, Стандартная
Код элемента | Метка, уникально определяющая панель инструментов. | ID_TbStandard

Примечание Свойства "По умолчанию вкл.", "Ориентация", "Координата Х по умолчанию", "Координата Х по умолчанию" и "Ряды" используются только при первой загрузке файла НПИ. Затем для управления свойствами отображения панели инструментов можно использовать рабочее пространство. Подробней см. в описании процедуры Изменение свойств панели инструментов .

Предупреждение Не изменяйте псевдонимы панели, используемой в качестве подменю, иначе могут нарушится связи между меню и подменю.

Подменю - это набор инструментов, объединенных на панели под одной общей кнопкой. Кнопки подменю обозначаются черным треугольником в нижнем правом углу. Для создания подменю можно перетащить одну панель инструментов в другую или создать его заново. В следующей таблице приведены свойства подменю "Зумирование", отображаемые в панели "Свойства".

Свойства подменю "Зумирование" панели "Стандартная"
Элемент панели свойств | Описание | Пример
Имя | Строка, которая не отображается в пользовательском интерфейсе, если свойству "Использовать собственную кнопку" назначено значение "Да". | Зумирование
Описание | Описание элемента, не отображается в пользовательском интерфейсе. |
Панель "Источник" | Значение только для чтения, которое определяет панель инструментов, на которую ссылается создаваемое подменю. | TB_ZOOM
Использовать свою кнопку | Управляет тем, будет ли последняя нажатая кнопка панели устанавливаться как активная или нет. Возможные значения: "Да" или "Нет". | Нет
Малое изображение | Идентификатор строки ресурса малого изображения (16 × 16-битовое изображение). Строка должна содержать буквенно-цифровые символы. Использование знаков пунктуации за исключением дефиса (-) или символа подчеркивания (_) запрещено. Она также может определять растровое изображение, заданное пользователем. Нажмите кнопку [...], чтобы открыть диалоговое окно "Выбор файла изображения". | RCDATA_16_ZOOM
Большое изображение | Идентификатор строки ресурса большого изображения (32 × 32-битовое изображение). Если размер указанного растрового изображения отличается от 32 × 32, программа масштабирует его до этого размера. Строка должна содержать буквенно-цифровые символы. Использование знаков пунктуации за исключением дефиса (-) или символа подчеркивания (_) запрещено. Она также может определять растровое изображение, заданное пользователем. Нажмите кнопку [...], чтобы открыть диалоговое окно "Выбор файла изображения". | RCDATA_16_ZOOM

При создании новой панели или подменю сначала необходимо присвоить им имя. На вновь созданной панели нет ни команд, ни кнопок. Панель будет игнорироваться программой до тех пор, пока в нее не будет добавлена хотя бы одна команда. На новую панель инструментов из можно перетаскивать команды и добавлять кнопки из существующих панелий или из списка команд в панели "Список команд" в редакторе настроек пользовательского интерфейса.

См. также

Создание панели (Процедура)

Создание подменю панели инструментов заново (Процедура)

Создание подменю из другой панели (Процедура)

Добавление команды на панель (Процедура)

Изменение положения кнопки на панели (Процедура)

Удаление кнопки с панели (Процедура)

Изменение свойств панели инструментов (Процедура)


Создание и редактирование панелей инструментов - Процедуры

Настройка интерфейса пользователя
Создание и редактирование панелей инструментов
Понятия
Процедуры
Команды

Создание панели

Создание подменю панели инструментов заново

Создание подменю из другой панели

Добавление команды на панель

Изменение положения кнопки на панели

Удаление кнопки с панели

Изменение свойств панели инструментов


Создание панели - Процедуры

Настройка интерфейса пользователя
Создание и редактирование панелей инструментов
Понятия
Процедуры
Команды

Создание панели

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройки в <имя файла> " нажмите правую кнопку мыши на панелях инструментов. Выберите "Создать" » "Панель".

    3. Новая панель (с именем Панель1) будет помещена внизу дерева "Панели инструментов".

  3. Выполните одно из следующих действий:
    • Введите новое имя вместо текста "Панель1".
    • Нажатием правой кнопки мыши выберите "Панель1". Выберите "Переименовать". Введите новое имя панели.
  4. Выберите в дереве новую панель и обновите панель "Свойства":
    • В поле "Пояснение" введите текстовое пояснение для панели.
    • В поле "По умолчанию вкл." выберите "Показать" или "Скрыть". Если выбрать "Показать", эта панель инструментов будет отображаться во всех рабочих пространствах.
    • В поле "Ориентация" выберите "Плавающая", "Верх", "Низ", "Слева" или "Справа".
    • В поле "Координата X по умолчанию" введите значение координаты.
    • В поле "Координата Y по умолчанию" введите значение координаты.
    • В поле "Ряды" введите число рядов для незакрепляемой панели инструментов.
    • В поле "Псевдонимы" введите для этой панели псевдоним.

  5. В панели "Список команд" перетащите команду, которую необходимо разместить под именем панели инструментов в панели "Настройки в <имя файла>".

  6. По завершении добавления команд в новую панель нажмите кнопку OK или продолжите настройку.


Создание подменю панели инструментов заново - Процедуры

Настройка интерфейса пользователя
Создание и редактирование панелей инструментов
Понятия
Процедуры
Команды

Создание подменю панели инструментов заново

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройка в <имя файла>" нажмите значок "плюс" (+) рядом с узлом структуры "Панели инструментов".
  3. Нажмите правую кнопку мыши на панели инструментов, в которую необходимо добавить подменю. Выберите "Создать" » "Подменю".

    4. Новое подменю панели (с именем Панель1) будет помещено под выбранной панелью.

  4. Нажатием правой кнопки мыши выберите "Панель1". Выберите "Переименовать". Введите новое имя панели.

    5. Примечание Одно только переименование панели не изменит имени подменю. Необходимо отдельно выбрать и переименовать подменю, если требуется, чтобы оно имело то же имя, что и панель.

  5. На панели "Список команд" перетащите команду, которую необходимо разместить под именем подменю панели инструментов в панели "Настройки в <имя файла>".

  6. По завершении добавления команд в новое подменю нажмите кнопку OK.


Создание подменю из другой панели - Процедуры

Настройка интерфейса пользователя
Создание и редактирование панелей инструментов
Понятия
Процедуры
Команды

Создание подменю из другой панели

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройка в <имя файла>" нажмите значок "плюс" (+) рядом с узлом структуры "Панели инструментов".
  3. Нажмите значок "плюс" (+) около панели инструментов, в которую необходимо добавить подменю.

  4. Определите панель, которую необходимо добавить в качестве подменю. Перетащите эту панель на развернутую панель.
  5. Нажмите ОК.


Добавление команды на панель - Процедуры

Настройка интерфейса пользователя
Создание и редактирование панелей инструментов
Понятия
Процедуры
Команды

Добавление команды на панель

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Список команд" перетащите команду, которую требуется добавить, под имя панели инструментов в панели "Настройки в <имя файла>".
  3. Нажмите значок "плюс" (+) слева от панели для отображения только что добавленной команды.

  4. По завершении добавления команд в панель нажмите кнопку OK.


Изменение положения кнопки на панели - Процедуры

Настройка интерфейса пользователя
Создание и редактирование панелей инструментов
Понятия
Процедуры
Команды

Изменение положения кнопки на панели

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройки в <имя файла> выберите панель инструментов, на которой требуется изменить положение кнопок.
  3. Нажмите значок "плюс" (+) около панели для ее раскрытия.
  4. Перетащите имя кнопки, положение которой в списке инструментов необходимо изменить.

    5. При появлении разделительной полосы можно поместить эту кнопку между двумя кнопками. При появлении левой стрелки эту кнопку можно поместить под другой кнопкой.

  5. По завершении изменения положения кнопок нажмите кнопку OK.


Удаление кнопки с панели - Процедуры

Настройка интерфейса пользователя
Создание и редактирование панелей инструментов
Понятия
Процедуры
Команды

Удаление кнопки с панели

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройки в <имя файла> выберите панель инструментов, на которой требуется удалить кнопки.
  3. Нажмите значок "плюс" (+) слева от панели для ее раскрытия.
  4. Нажатием правой кнопки мыши выберите имя кнопки, которую необходимо удалить. Нажмите кнопку "Удалить".

  5. По завершении удаления кнопок нажмите кнопку OK.


Изменение свойств панели инструментов - Процедуры

Настройка интерфейса пользователя
Создание и редактирование панелей инструментов
Понятия
Процедуры
Команды

Изменение свойств панели инструментов

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройки в <имя файла> выберите панель инструментов, свойства которой требуется изменить.

    3. Примечание Изменения свойств панели инструментов влияет только на исходное отображение панели инструментов после загрузки файла НПИ. Для управления внешним видом панели рекомендуется использовать рабочее пространство.

  3. В панели "Свойства" внесите необходимые изменения.

    4. Примечание Перед попыткой изменить псевдонимы на панели необходимо понять принцип их действия. Для получения дополнительной информации о псевдонимах см. раздел Псевдоимена команд.

  4. По завершении изменения свойств нажмите кнопку OK.


Создание и редактирование панелей инструментов - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Создание и редактирование панелей инструментов
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
TOOLTIPS | Управляет отображением подсказок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Добавление или замена элементов управления панели инструментов - Понятия

Настройка интерфейса пользователя
Добавление или замена элементов управления панели инструментов
Понятия
Процедуры
Команды

Элементы управления панели инструментов представляют собой раскрывающиеся списки определенных параметров панели, в которой они выбираются. Например, в панели "Слои" содержатся элементы управления, позволяющие определять настройки слоев. В редакторе настройки пользовательского интерфейса можно добавлять, удалять и изменять положение элементов управления в панели инструментов.

Далее в таблице перечислены элементы управления панелей инструментов, имеющиеся в редакторе настроек пользовательского интерфейса, а также их описания. Элементы управления в левом столбце таблицы не всегда представлены в виде текста, выводимого в программе в качестве подсказок (например, текст "Отмена кнопки Skinny" выводится в подсказке программы как "Отменить"). Обращайтесь к этой таблице в случае необходимости изменить элемент управления на панели инструментов.

Элементы управления для панелей инструментов
Элемент управления | Описание
Управление размерными стилями | Раскрывающийся список, в котором содержится описание текущего размерного стиля.
Управление слоями | Раскрывающийся список, обеспечивающий управление содержащимися в чертеже слоями.
Элемент управления типом линии | Раскрывающийся список, в котором содержится описание текущего типа линии.
Элемент управления толщиной линии | Раскрывающийся список, в котором содержится описание текущей толщины линий.
Элемент управления именованных видов | Раскрывающийся список, в котором отображаются именованные виды.
Элемент управления цветом OPT | Раскрывающийся список, в котором содержится описание текущего цвета.
Элемент управления стилями печати | Раскрывающийся список, в котором содержится описание текущего стиля печати.
Элемент управления повтора кнопки Skinny | Кнопка панели инструментов "Стандартная", при нажатии на которую повторяется предыдущее действие.
Имя блока ссылки | Отображает имя внешней ссылки, вхождение которой находится в состоянии редактирования.
Управление стилями таблиц | Раскрывающийся список, в котором устанавливаются настройки текущего стиля таблиц.
Стиль текста | Раскрывающийся список, в котором устанавливаются настройки текущего текстового стиля.
Управление ПСК | Раскрывающийся список, в котором содержится описание текущей ПСК.
Элемент управления отмены кнопки Skinny | Кнопка панели инструментов "Стандартная", отменяющая предыдущее действие.
Вид | Раскрывающийся список, в котором содержится описание стандартных 3D видов.
Управление масштабом видового экрана | Раскрывающийся список, в котором содержатся допустимые масштабы видового экрана на листе.
Управление рабочими пространствами | Раскрывающийся список, в котором устанавливаются настройки текущего рабочего пространства.

См. также

Настройка панелей инструментов

Добавление элемента управления на панель инструментов (Процедура)

Замена элемента управления на панели инструментов (Процедура)


Добавление или замена элементов управления панели инструментов - Процедуры

Настройка интерфейса пользователя
Добавление или замена элементов управления панели инструментов
Понятия
Процедуры
Команды

Добавление элемента управления на панель инструментов

Замена элемента управления на панели инструментов


Добавление элемента управления на панель инструментов - Процедуры

Настройка интерфейса пользователя
Добавление или замена элементов управления панели инструментов
Понятия
Процедуры
Команды

Добавление элемента управления на панель инструментов

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройки в <имя файла> нажмите значок "плюс" (+) рядом с панелью инструментов, к которой требуется добавить элемент управления.
  3. В панели "Список команд" в списке "Категории" выберите "Элементы управления".

    4. На панели "Список команд" отображаются только элементы управления.

  4. В списке команд перетащите элемент управления в необходимую позицию на панели "Настройки в <имя файла>".

  5. Нажмите ОК.


Замена элемента управления на панели инструментов - Процедуры

Настройка интерфейса пользователя
Добавление или замена элементов управления панели инструментов
Понятия
Процедуры
Команды

Замена элемента управления на панели инструментов

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройки в <имя файла> нажмите значок "плюс" (+) рядом с панелью инструментов, содержащей элемент управления, которые требуется изменить.
  3. Выберите элемент управления.

  4. На панели "Свойства" в поле "Элемент управления" нажмите стрелку для вывода списка элементов управления.

  5. Выберите исходный элемент управления, который необходимо заменить выбранным элементом.
  6. Нажмите ОК.


Добавление или замена элементов управления панели инструментов - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Добавление или замена элементов управления панели инструментов
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание раскрывающихся и контекстных меню - Понятия

Настройка интерфейса пользователя
Создание раскрывающихся и контекстных меню
Понятия
Процедуры
Команды

В раскрывающемся меню под строкой меню отобразится список. Меню быстрого вызова (также называемые контекстными меню) появляются на перекрестье или рядом с ним или курсором при нажатии правой кнопкой мыши в окне рисования, текстовом окне, окне команд или на панелях.

Каждое раскрывающееся меню может содержать до 999 команд. Каждое контекстное меню может содержать до 499 команд. Ограничение числа команд распространяется на все меню согласно уровням иерархии. Если число команд превышает указанные пределы (что мало вероятно), программа игнорирует лишние команды. Собственно контекстные меню отображаются при нажатии правой кнопки мыши. В следующей таблице приведены свойства меню "Файл", отображающиеся в панели "Свойства. Свойства раскрывающегося меню и контекстного меню совпадают.

Свойства меню "Файл"
Элемент панели свойств | Описание | Пример
Имя | Строка-заголовок меню в строке меню. | &Файл
Описание | Описание элемента, не отображается в пользовательском интерфейсе. |
Псевдонимы | Указывает псевдонимы для контекстного меню. Нажмите кнопку [...], чтобы открыть диалоговое окно "Псевдонимы". Псевдоним используется для программной ссылки на контекстное меню. | POP1, FILE
Код элемента | Метка, уникально определяющая меню. | ID_MnFile
Псевдонимы раскрывающихся меню

Раскрывающимся меню могут быть присвоены псевдонимы с номерами в пределах от POP1 до POP499. Меню с псевдонимами POP1-POP16 загружаются по умолчанию при загрузке меню. Для отображения других меню они должны быть добавлены в рабочее пространство.

Примечание При создании раскрывающегося меню или контекстного меню необходимо добавить команду в меню. В противном случае меню не сохранится в файл.

  • Создание раскрывающегося меню
    На вкладке "Настройка" редактора настроек пользовательского интерфейса можно создавать раскрывающиеся меню, добавлять подменю и команды. Порядок действий аналогичен работе с инструментальными панелями и подменю с незначительными различиями.
  • Создание контекстного меню
    Контекстные меню отображаются в месте расположения курсора при нажатии правой кнопки указывающего устройства. Набор предлагаемых функций зависит от того, в какой области экрана находится курсор, а также от других факторов (наличие выбранного объекта, выполняемая команда и т.п.). Для отображения контекстных меню можно также использовать сценарии.
  • Создание подменю
    Подменю создаются так же, как и меню.
  • Обращение к раскрывающимся и контекстным меню
    Включить или отключить отдельные пункты раскрывающихся и контекстных меню можно таким же образом, как и обычные подменю. Это называется адресацией в меню.
  • Подстановка и вставка раскрывающихся меню
    С помощью редактора настройки пользовательского интерфейса можно использовать рабочие пространства для управления подстановкой раскрывающихся меню. Однако можно также программно выполнить подстановку раскрывающегося меню (например, когда пользователь загружает приложение, требующее дополнительного меню). Подстановка меню выполняет активизацию меню непосредственно из другого меню.


Создание раскрывающихся и контекстных меню - Процедуры

Настройка интерфейса пользователя
Создание раскрывающихся и контекстных меню
Понятия
Процедуры
Команды

Создание раскрывающегося меню

Добавление команды к раскрывающемуся меню

Создание контекстного меню

Создание подменю


Создание раскрывающихся и контекстных меню - Команды

Настройка интерфейса пользователя
Создание раскрывающихся и контекстных меню
Понятия
Процедуры
Команды
Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
НПИВЫГР | Выгружает файл НПИ
НПИЗАГР | Загружает файл НПИ
ПАНЕЛЬ | Отображение, скрытие и настройка панелей
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание раскрывающегося меню - Понятия

Настройка интерфейса пользователя
Создание раскрывающегося меню
Понятия
Процедуры
Команды

Можно добавлять команды в меню и для каждой из них можно создавать или добавлять изображения.

Примечание При создании меню необходимо определить, в каких рабочих пространствах оно должно отображаться. По умолчанию новое меню отображается во всех рабочих пространствах.

Показать: Создание раскрывающегося меню

Нажмите стрелку "Воспроизведение" под следующим изображением для запуска анимации.

В анимации ниже показано, как создавать раскрывающееся меню и замещать в нем стандартные и пользовательские команды. В анимации не показано, как создавать пользовательские команды и назначать командам изображения. Подробней о создании пользовательских команд см. в разделе Создание, редактирование и повторное использование команд. Подробней о назначении команде изображения см. в разделе Создание изображений для команд.

См. также

Создание раскрывающегося меню (Процедура)

Добавление команды к раскрывающемуся меню (Процедура)


Создание раскрывающегося меню - Процедуры

Настройка интерфейса пользователя
Создание раскрывающегося меню
Понятия
Процедуры
Команды

Создание раскрывающегося меню

Добавление команды к раскрывающемуся меню


Создание раскрывающегося меню - Процедуры

Настройка интерфейса пользователя
Создание раскрывающегося меню
Понятия
Процедуры
Команды

Создание раскрывающегося меню

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в меню "Настройки в <имя файла> " нажмите правой кнопкой мыши "Меню". Выберите "Создать" » "Подменю".

    3. Новое меню (под именем Меню1) будет помещено в нижней части дерева меню.

  3. Выполните одно из следующих действий:
    • Введите новое имя над текстом подменю "Меню1".
    • Нажатием правой кнопки мыши выберите "Меню1". Выберите "Переименовать". Введите новое имя меню.
  4. Выберите новое меню в области структуры и обновите панель "Свойства" следующим образом.
    • В поле "Пояснение" введите текстовое пояснение для меню.
    • В поле "Псевдонимы" новому меню автоматически присвоится псевдоним согласно числу загруженных меню. Например, если меню назначен псевдоним POP12, это значит, что уже загружено одиннадцать меню. Просмотрите или измените псевдоним.
    • (Дополнительно) Если имя изменяется на основе выражения DIESEL, это выражение должно быть записано в поле "Имя".

  5. В панели "Список команд" перетащите команду в положение строго под экранным меню в панели "Настройки в <имя файла>".

    6. Примечание Можно изменить имя команды после того. как она добавлена к меню. Это позволяет определить, каким образом пользователь может обращаться к пунктам меню, используя клавишу ALT на клавиатуре. Для этого выберите элемент меню в узле "Меню", а затем измените свойство "Имя" в панели "Свойства".

  6. По завершении добавления команд нажмите кнопку OK.


Добавление команды к раскрывающемуся меню - Процедуры

Настройка интерфейса пользователя
Создание раскрывающегося меню
Понятия
Процедуры
Команды

Добавление команды к раскрывающемуся меню

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройки в <имя файла> выберите меню, к которому требуется добавить команду.
  3. В панели "Список команд" перетащите команду, которую необходимо добавить, в положение строго под экранным меню в панели "Настройки в <имя файла>".

    4. Примечание Можно изменить имя команды после того, как она добавлена к меню. Это позволяет определить, каким образом пользователь может обращаться к пунктам меню, используя клавишу ALT на клавиатуре. Для этого выберите элемент меню в узле "Меню", а затем измените свойство "Имя" в панели "Свойства".

  4. По завершении добавления команд нажмите кнопку OK.

    5. Информацию о создании команды см. в Создание, редактирование и повторное использование команд.


Создание раскрывающегося меню - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Создание раскрывающегося меню
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание контекстного меню - Понятия

Настройка интерфейса пользователя
Создание контекстного меню
Понятия
Процедуры
Команды

Контекстные меню отображаются в месте расположения курсора при нажатии правой кнопки указывающего устройства. Набор предлагаемых функций зависит от того, в какой области экрана находится курсор, а также от других факторов (наличие выбранного объекта, выполняемая команда и т.п.). Для отображения контекстных меню можно также использовать сценарии.

В контекстно-зависимых меню при нажатии правой кнопки мыши отображаются параметры, относящиеся к текущей команде или выбранному объекту.

Псевдонимы контекстных меню

Для ссылок на контекстные меню, используемые в текущей ситуации, используются псевдонимы. В редакторе настроек пользовательского интерфейса псевдонимы дожлны подчиняться соглашениям об именовании. Например, для контекстного меню “Меню по умолчанию “ в разделе "Псевдонимы" панели "Свойства" отображается следующая информация:

POP501, CMDEFAULT

Для контекстного меню "Объектная привязка" должен быть назначен псевдоним POP0. Псевдонимы для контекстно-зависимых меню должны иметь номера от POP500 до POP999.Следующие псевдонимы зарезервированы для внутреннего использования в программе:

Псевдонимы в программе для контекстных меню
Псевдоним | Описание
GRIPS | Определяет контекстное меню выделенной ручки (нажмите правую кнопку в области рисования при выборе ручки на объекте).
CMDEFAULT | Определяет контекстное меню режима по умолчанию (нажмите правую кнопку мыши в области рисования, если не активна ни одна команда и не выбран ни один объект).
CMEDIT | Определяет контекстное меню режима редактирования (нажмите правую кнопку мыши в области рисования, если не активна ни одна команда, не выбран ни один объект и ни одна ручка).
CMCOMMAND | Определяет контекстное меню командного режима (нажмите правую кнопку мыши в области рисования, если команда активна). В дополнение к содержимому меню CMCOMMAND в это меню добавлены параметры командной строки (ключевые слова в квадратных скобках).
SNAP | Определяет меню объектной привязки (нажмите клавишу SHIFT и нажмите правую кнопку мыши в области рисования).

Контекстные меню CMEDIT и CMCOMMAND могут быть сделаны контекстно-чувствительными. Помимо содержимого меню CMEDIT при выборе одного или нескольких указанных типов объектов в меню добавляется меню соответствующего объекта (свое для каждого типа). Для объектов меню используется одно из следующих соглашений по именованию: OBJECT_имя

OBJECTS_имя

Если выбран один объект определенного типа, используется меню OBJECT_имя, если несколько объектов - меню OBJECTS_имя. Если меню OBJECT_имя недоступно, программа использует меню OBJECTS_имя (если оно существует).

Имя объекта - это имя объекта в формате (DXF™) во всех случаях, за исключением вставки объекта. В следующей таблице содержатся имена объектов для блоков, динамических блоков и внешних ссылок.

Имена объектов для вставленных объектов
Имя объекта | Описание
BLOCKREF | Вхождение блока без атрибутов
ATTBLOCKREF | Вхождение блока с атрибутами
DYNBLOCKREF | Вхождение динамического блока без атрибутов
ATTDYNBLOCKREF | Вхождение динамического блока с атрибутами
Ссылка | Внешняя ссылка

Например, для поддержки объектной контекстной команды для одного или нескольких выбранных вхождений блоков добавьте в панели "Свойства" на вкладке "Настройка" в редакторе настройки пользовательского интерфейса следующие свойства:

Свойства для объектов контекстного меню вхождений блоков
Элемент панели свойств | Описание | Пример
Имя | Строка, используемая только в редакторе НПИ, в пользовательском интерфейсе эта строка не отображается. | Меню объектов блоков
Описание | Описание элемента, не отображается в пользовательском интерфейсе. | Контекстное меню объектов блоков
Псевдонимы | Указывает псевдоним для контекстного меню. Нажмите кнопку [...], чтобы открыть диалоговое окно "Псевдонимы". Псевдоним используется для программной ссылки на контекстное меню. | POP512,OBJECTS_BLOCKREF
Код элемента | Метка, уникально определяющая контекстное меню. | PM_0021

Как и меню CMEDIT, меню CMCOMMAND может содержать контекстную информацию. Меню с именем COMMAND_имя добавляется к меню CMCOMMAND. Текст имя_команды может принадлежать любой команде AutoCAD, в том числе любой пользовательской или команды стороннего приложения.

Для многих команд доступ к интерфейсу командной строки осуществляется путем ввода дефиса перед именем команды для предотвращения отображения диалогового окна и запросов в командной строке. Для создания контекстно-зависимых меню, выводящих подсказки в командной строке (например, -ВСТАВИТЬ) контекстному меню необходимо присвоить имя КОМАНДА_-ВСТАВИТЬ.

См. также

Создание контекстного меню (Процедура)


Создание контекстного меню - Процедуры

Настройка интерфейса пользователя
Создание контекстного меню
Понятия
Процедуры
Команды

Создание контекстного меню

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в меню "Настройки в <имя файла> " нажмите правой кнопкой мыши "Контекстные меню". Выберите "Создать" » "Контекстное меню".

    3. Новое контекстное меню (под именем “КонтекстноеМеню1“) будет помещено в нижней части дерева меню.

  3. Выполните одно из следующих действий:
    • Введите новое имя вместо текста "КонтекстноеМеню1".
    • Нажатием правой кнопки мыши выберите надпись "КонтекстноеМеню1". Выберите "Переименовать". Введите новое имя контекстного меню.
  4. В панели "Свойства" выполните следующие действия.
    • В поле "Пояснение" введите текстовое пояснение для контекстного меню.
    • В поле "Псевдонимы" введите для этого меню дополнительный псевдоним. Автоматически присваивается псевдоним, по умолчанию соответствующий следующему доступному номеру POP согласно числу загруженных контекстных меню.

  5. В панели "Список команд" перетащите команду, которую необходимо добавить, в положение строго под контекстным меню в панели "Настройки в <имя файла>".

  6. Таким же образом добавьте команды в список нового контекстного меню, пока он не заполнится.
  7. Нажмите ОК.


Создание контекстного меню - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Создание контекстного меню
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание подменю - Понятия

Настройка интерфейса пользователя
Создание подменю
Понятия
Процедуры
Команды

Подменю создаются так же, как и меню.

В следующей таблице описаны буквенно-цифровые символы, которые можно использовать в редакторе настройки пользовательского интерфейса. Остальные специальные символы зарезервированы для дальнейшего расширения этого ряда.

Специальные символы для подменю
Символ | Описание | Пример
$( | Вычисление в команде строкового макроса языка DIESEL (если последовательность $( стоит в начале строки). |
~ | Делает команду недоступной. |
!. | Помечает команду флажком. |
& | Размещенный перед каким-либо символом, указывает, что символ должен быть подчеркнут, а соответствующая ему клавиша является клавишей быстрого вызова для пункта меню. | О&бразец отображается в меню как "Образец" (с подчеркнутой буквой б).
\t | Весь текст, идущий после данной комбинации, отодвигается и выравнивается по правому краю меню. | При нажатии "Справка"\tF1 справка отображается в левой части раскрывающегося меню, а при нажатии F1 - в правой.

См. также

Создание подменю (Процедура)


Создание подменю - Процедуры

Настройка интерфейса пользователя
Создание подменю
Понятия
Процедуры
Команды

Создание подменю

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройки в <имя файла> нажмите значок "плюс" (+) рядом с узлом "Меню". Выберите меню, куда требуется добавить подменю.

  3. Нажмите на меню правую кнопку мыши. Выберите "Создать" » "Подменю".

    4. Новое подменю с названием "Меню1" располагается в нижней части меню, выбранного для добавления подменю.

  4. Выполните одно из следующих действий:
    • Введите новое имя над текстом подменю "Меню1".
    • Нажатием правой кнопки мыши выберите "Меню1". Выберите "Переименовать". Введите новое имя подменю.
  5. В панели "Свойства" выполните следующие действия.
    • В поле "Пояснение" введите текстовое пояснение для подменю.

  6. В панели "Список команд" перетащите команду, которую необходимо разместить под именем подменю в панели "Настройки в <имя файла>".

  7. Таким же образом добавьте команды в список нового подменю, пока он не заполнится.
  8. Нажмите ОК.


Создание подменю - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Создание подменю
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обращение к раскрывающимся и контекстным меню - Понятия

Настройка интерфейса пользователя
Обращение к раскрывающимся и контекстным меню
Понятия
Процедуры
Команды

Включить или отключить отдельные пункты раскрывающихся и контекстных меню можно таким же образом, как и обычные подменю. Это называется адресацией в меню.

К пунктам раскрывающихся и контекстных меню можно обращаться двумя способами: относительно и абсолютно. При относительной адресации указываются группа настройки и код элемента. При абсолютной адресации указывается абсолютное положение пункта в иерархии меню. Рекомендуется использовать относительную адресацию, т.к. она по своей природе динамична и не зависит от текущего состояния меню.

Относительная адресация команд раскрывающегося и контекстного меню

Чтобы выполнить адресацию элемента раскрывающегося или контекстного меню на основании группы настройки и кода элемента, используйте функцию AutoLISP menucmd. С помощью следующего синтаксиса выполняется адресация элемента меню на основании кода элемента.

(menucmd "Gгруппа_меню.код_элемента=значение")

В следующем примере для отключения элемента меню ID_Line, который находится в группе настройки sample, используется синтаксис относительной адресации. Пункт меню можно одновременно сделать недоступным и пометить.

(menucmd "Gsample.ID_Line=~")

Если известно, что находится в основном файле НПИ, можно создать частичный файл НПИ с дополнительным элементом меню, который выполняет адресацию в основной файл. Таким образом, обеспечивается согласованность работы частичных файлов НПИ и файлов основного меню.

Абсолютное обращение к раскрывающимся и контекстным меню

Включить или отключить отдельные пункты меню можно с помощью синтаксиса $Pn=xxx. Для этого используется формат:

$Pn.i=xxx

С помощью $ можно загрузить раздел меню; Pn задает активный раздел меню (от 0 до 16); i задает номер пункта меню; xxx (если присутствует) задает недоступность или пометку.

С помощью синтаксиса $Pn=xxx в следующем примере помечается пункт 1 раздела POP7.

$P7.1=!.

В следующем примере для выполнения адресации элемента раскрывающегося или контекстного меню используется функция AutoLISP menucmd. Следующий синтаксис нельзя будет применять во всех случаях, так как файлы настройки по своей природе динамичны (в результате загрузки частичных файлов НПИ).

(menucmd "P1.2=~")

Синтаксис основывается на заданном положении элемента меню и не работает в случаях, когда новый элемент меню подставлен перед разделом POP1 командой НПИЗАГР.

Несмотря на иерархичность меню, нумерация элементов меню последовательна.

При адресации элементов меню (независимо от их местоположения в иерархической структуре) можно пользоваться следующими формами:

$P@.@=xxx

Выполняет адресацию текущей или наиболее часто выбираемой команды.

$P@.n=xxx

Таким образом обеспечивается согласованность работы базового меню и фрагментов меню.

Доступ к состоянию пунктов из AutoLISP

Функция AutoLISP menucmd воспринимает строки команд $Pn=xxx, но без начального символа $. Для этих функций элемент xxx может иметь специальные значения.

Pn.i=?

Возвращает состояние недоступности и пометки указанного элемента в виде строки (например, ~ для недоступного пункта, !. для помеченного пункта, "" для пункта, который доступен и не помечен).

Pn.i=#?

Возвращает такую же строку, как и Pn.i=?, но с добавлением префикса Pn.i= префикс. Это очень удобно в сочетании с формами @, поскольку возвращается фактический номер меню и номер элемента.

Например, если пятый элемент в разделе POP6 отключен, следующий код вmenucmd возвращает показанные ниже строковые значения.

(menucmd "P6.5=?") возвращает "~"
(menucmd "P6.5=#?") возвращает "P6.5=~"


Создание раскрывающихся и контекстных меню

Настройка интерфейса пользователя
Создание раскрывающихся и контекстных меню
Понятия
Процедуры
Команды

Нет процедур.


Обращение к раскрывающимся и контекстным меню - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Обращение к раскрывающимся и контекстным меню
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Подстановка и вставка раскрывающихся меню - Понятия

Настройка интерфейса пользователя
Подстановка и вставка раскрывающихся меню
Понятия
Процедуры
Команды

С помощью редактора настройки пользовательского интерфейса можно использовать рабочие пространства для управления подстановкой раскрывающихся меню. Однако можно также программно выполнить подстановку раскрывающегося меню (например, когда пользователь загружает приложение, требующее дополнительного меню). Подстановка меню выполняет активизацию меню непосредственно из другого меню.

Подстановка раскрывающихся меню

Так как раскрывающиеся меню являются каскадными, необходимость их подстановки возникает редко. Более того, во многих случаях подстановка меню снижает логичность пользовательского интерфейса. Концепция подстановки раскрывающихся меню не согласуется с требованиями Microsoft® к пользовательскому интерфейсу и не гарантируется в последующих версиях AutoCAD. Существует альтернативный метод подстановки меню, в котором используется относительная (или глобальная) адресация. Применяя его, пользователь может вставить новое меню перед другим, известным ему, а затем удалить известное меню.

Для целей подстановки активным областям раскрывающегося меню присвоены имена от P1 до P16. Заголовок, отображающийся в строке меню, можно изменить путем замены первой строки с помощью команды $Pn=. Чтобы вызвать появление на экране раскрывающегося меню, загруженного в область POPn, следует воспользоваться специальной командой $Pn=*. Ее можно включить в макрос любого пункта меню.

Ниже приведен пример подстановки в позицию P3 меню, которое называется BudsMenu и является частью группы настройки MYMENU.

$P3=MyMenu.BudsMenu

То же самое можно выполнить с помощью функции menucmd AutoLISP, сделав это следующим образом.

(menucmd "P3=MyMenu.BudsMenu")

Чтобы вызвать появление на экране раскрывающегося меню, загруженного в область POPn, следует воспользоваться специальной командой $Pn=*. Ее можно включить в макрос любого пункта меню.

Примечание Концепция подстановки раскрывающихся меню не согласуется с требованиями Microsoft® к пользовательскому интерфейсу и не гарантируется в последующих версиях программы.

Вставка и удаление раскрывающихся меню

Подстановка меню это активизация меню непосредственно из другого меню. Подстановка поддерживается для следующих элементов интерфейса:

  • Кнопки
  • Раскрывающиеся меню
  • Кнопки мыши
  • Меню мозаики изображений
  • Планшетные меню

Синтаксис подстановки фрагментов меню следующий:

$раздел=группа_меню.имя_меню

раздел

B1-4, A1-4, P0-16, T1-4

группа_меню

Имя группы настройки в необходимом файле НПИ

имя_меню

Основная метка или псевдоним

Для вставки и удаления раскрывающихся меню можно использовать функцию AutoLISP menucmd. Ее синтаксис подобен применяемому для подстановки раскрывающихся меню, но в левой части операции присвоения должно быть записано меню, после которого вставляется новое. В правой части назначения находится значок "плюс" (+), далее следует имя группы меню, точка и псевдоним меню, как показано в следующем синтаксисе:

(menucmd "Gимя_группы1.имя_меню1=+группа_меню2.имя_меню2")

Можно также вставить меню с помощью синтаксиса Pn=. Приведенный ниже макрос выполняет вставку меню за имеющимся в позиции P5. (в этом формате также можно использовать функцию menucmd).

(menucmd "P5=+mymenu.new3")

Если для вставки меню используется этот метод, следует помнить, что меню Р6 не обязательно будет вставлено в ожидаемом положении. Для этого имеются две причины.

  • Если в текущей строке меню имеется только три меню, вставка нового меню после меню P5 приведет к тому, что положением нового меню станет P4.
  • Если файл настройки вставить или удалить с помощью команды НПИЗАГР или другого приложения, синхронизация меню может быть нарушена.

Удаление меню производится следующей директивой:

(menucmd "Gгруппа_меню.имя_меню=-")

В следующем примере удаляется меню NEW3, входящее в группу МоиМеню

(menucmd "Gmymenu.new3=-")

Такой способ удаления предпочтительнее, чем Pn=, так как гарантирует удаление того меню, которое требуется. Ниже приведен пример удаления меню из позиции P4.

$P4=-

Примечание Синтаксис Pn следует использовать только внутри функции menucmd. Используйте синтаксис $Pn в макросах.

Управление панелями инструментов при помощи частичных файлов НПИ

Используйте следующий синтаксис в ответ на подсказку "Имя панели инструментов" ПАНЕЛЬ (вариант для командной строки)- в командной строке для управления панелями инструментов с помощью частичных файлов НПИ.

группа_меню.имя_подраздела

Этот синтаксис позволяет обратиться к панели инструментов группа_меню.имя_меню и использовать полный спектр возможностей команды -TOOLBAR для этой инструментальной панели.

Если в любую из этих команд и функций не включена группа меню, программа применяет к основному файлу НПИ параметры по умолчанию.

Необходимо учесть следующие аспекты.

  • Подстановка меню мозаики изображений из внешнего файла настройки невозможна.
  • Разрешается подставлять только элементы настройки одного и того же типа - одно контекстное меню вместо другого, одна панель инструментов вместо другой, и т.д. Попытка смешения типов может привести к совершенно непредсказуемым и ошибочным результатам.


Подстановка и вставка раскрывающихся меню - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Подстановка и вставка раскрывающихся меню
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
НПИВЫГР | Выгружает файл НПИ
НПИЗАГР | Загружает файл НПИ
ПАНЕЛЬ | Отображение, скрытие и настройка панелей
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Задание клавиш быстрого вызова и временной замены - Понятия

Настройка интерфейса пользователя
Задание клавиш быстрого вызова и временной замены
Понятия
Процедуры
Команды

Для часто используемых команд можно воспользоваться специально назначенными комбинациями клавиш (или клавишами быстрого вызова), а клавишами временной замены для выполнения команды или изменения параметра при нажатии клавиши.

Показать: Создание клавиши быстрого вызова

Нажмите стрелку "Воспроизведение" под следующим изображением для запуска анимации.

В анимации ниже показано, как создавать пользовательские клавиши быстрого вызова. В анимации не показано, как создавать пользовательские команды. Подробней о создании пользовательских команды см. в разделе Создание, редактирование и повторное использование команд.

Клавиши быстрого вызова - это комбинация клавиш, используемая для быстрого вызова команд. Например, для открытия файла можно нажать CTRL + O , а для сохранения - CTRL + S. Результат будет тем же, если выбрать "Открыть" и "Сохранить" в меню "Файл. В следующей таблице приведены свойства клавиш быстрого вызова для команды "Сохранить", отображающиеся в панели "Свойства.

Свойства для команды "Сохранить клавишу быстрого вызова"
Элемент панели свойств | Описание | Пример
Имя | Строка, используемая только в редакторе НПИ, в пользовательском интерфейсе эта строка не отображается. | Сохранить
Описание | Описание элемента, не отображается в пользовательском интерфейсе. | Сохраняет текущий чертеж: QSAVE
Макрос | Макрос команды. В нем применяется стандартный синтаксис для макросов. | ^C^C_qsave
Клавиши | Указывается комбинация нажатий клавиш, используемая для выполнения данного макроса. Нажмите кнопку [...], чтобы открыть диалоговое окно "Клавиши быстрого вызова". | CTRL+S
Код элемента | Метка, уникально определяющая команду. | ID_Save

Клавишами временной замены являются клавиши, с помощью которых можно временно включить и отключить режимы рисования, установленные в диалоговом окне "Режимы рисования" (например, режим "Орто", объектные привязки или полярный режим). В следующей таблице показаны свойства временной замены клавиш для режима "Отмена объектной привязки: конечная точка", отображаемые в панели "Свойства".

Свойства временной замены клавиш для режима "Отмена объектной привязки: конечная точка"
Элемент панели свойств | Описание | Пример
Имя | Строка, используемая только в редакторе НПИ, в пользовательском интерфейсе эта строка не отображается. | Отмена объектной привязки: конечная точка
Описание | Описание элемента, не отображается в пользовательском интерфейсе. | Отмена объектной привязки: конечная точка
Клавиши | Указывается комбинация нажатий клавиш, используемая для выполнения временной замены. Нажмите кнопку [...], чтобы открыть диалоговое окно "Клавиши быстрого вызова". | SHIFT+E
Макрос1 (нажатие клавиши) | Макрос, который следует выполнить, если пользователь удерживает нажатой комбинацию клавиш. | ^P'_.osmode 1 $(if,$(eq,$(getvar,osnapoverride),0),'_.osnapoverride 1)
Макрос2 (отпускание клавиши) | Макрос, который следует выполнить, если пользователь отпускает комбинацию клавиш. Если поле оставлено пустым, AutoCAD будет восстанавливать все переменные в их исходное состояние. |

Клавиши быстрого вызова могут быть связаны с любой командой из списка. Пользователь может воспользоваться стандартными комбинациями клавиш или задать собственные.

В следующей таблице приводятся действия по умолчанию для клавиш быстрого вызова.

Клавиши быстрого вызова | Описание
ALT+F11 | Вызов редактора Visual Basic
ALT+F8 | Вызов диалогового окна "Макросы"
CTRL+0 | Включение и отключение режима чистого экрана
CTRL+1 | Включение и отключение палитры "Свойства"
CTRL+2 | Включение/отключение центра управления
CTRL+3 | Открытие/закрытие окна инструментальных палитр
CTRL+4 | Включение/отключение диспетчера подшивок
CTRL+5 | Включение/отключение информационной палитры
CTRL+6 | Включение/отключение диспетчера подключения к БД
CTRL+7 | Включение/отключение диспетчера наборов пометок
CTRL+8 | Включение/отключение палитры калькулятора БыстрКальк
CTRL+9 | Включение/отключение окна команд
CTRL+A | Выбор объектов в чертеже
CTRL+SHITF+A | Включение/отключение групп
CTRL+B | Включение/отключение шаговой привязки
CTRL+C | Копирование объектов в буфер обмена
CTRL+SHIFT+C | Копирование объектов в буфер обмена с базовой точкой
CTRL+D | Включение/отключение динамических ПСК
CTRL+E | Циклическое переключение между изометрическими плоскостями
CTRL+F | Переключение текущих режимов объектной привязки
CTRL+G | Включение и отключение сетки
CTRL+H | Включение/отключение переменной PICKSTYLE
CTRL+I | Включение/отключение системной переменной COORDS
CTRL+J | Повторное выполнение последней команды
CTRL+L | Включение и отключение режима ортогональных построений
CTRL+M | Повторное выполнение последней команды
CTRL+N | Создание нового чертежа
CTRL+O | Открытие существующего файла чертежа
CTRL+P | Вывод текущего чертежа на печать
CTRL+R | Циклическое переключение между видовыми экранами листов
CTRL+S | Сохранение текущего чертежа
CTRL+SHIFT+S | Вызов диалогового окна "Сохранить как"
CTRL+T | Включение и отключение режима "Планшет"
CTRL+V | Вставка данных из буфера обмена
CTRL+SHIFT+V | Вставка данных из буфера обмена в виде одного блока
CTRL+X | Вырезание объектов в буфер обмена
CTRL+Y | Отмена последней выполненной операции "Отменить"
CTRL+Z | Отмена последнего действия
CTRL+[ | Прерывание текущей команды
CTRL+\ | Прерывание текущей команды
CTRL+PAGE UP | Перемещение на следующую вкладку слева от текущей.
CTRL+PAGE DOWN | Перемещение на следующую вкладку справа от текущей
F1 | Вызов справочной системы
F2 | Включение и отключение текстового окна
F3 | Включение и отключение объектной привязки
F4 | Переключение системной переменной TABMODE
F5 | Циклическое переключение между изометрическими плоскостями
F6 | Переключение системной переменной UCSDETECT
F7 | Переключение системной переменной GRIDMODE
F8 | Переключение системной переменной ORTHOMODE
F9 | Переключение системной переменной SNAPMODE
F10 | Включение/отключение полярного отслеживания
F11 | Включение/отключение режима отслеживания объектной привязки
F12 | Включение/отключение динамического ввода

В следующей таблице приводятся действия по умолчанию для временного переопределения клавиш.

Временное переопределение клавиш | Описание
F3 | Включение и отключение объектной привязки
F6 | Переключение системной переменной UCSDETECT
F8 | Переключение системной переменной ORTHOMODE
F9 | Переключение системной переменной SNAPMODE
F10 | Включение/отключение полярного отслеживания
F11 | Включение/отключение режима отслеживания объектной привязки
F12 | Включение/отключение динамического ввода
SHIFT | Переключение системной переменной ORTHOMODE
SHIFT+’ | Переключение системной переменной SNAPMODE
SHIFT+, | Отмена объектной привязки: по центру
SHIFT+. | Включение/отключение полярного отслеживания
SHIFT+/ | Переключение системной переменной UCSDETECT
SHIFT+; | Включение применения объектной привязки
SHIFT+] | Включение/отключение режима отслеживания объектной привязки
SHIFT+A | Включение и отключение объектной привязки
SHIFT+C | Отмена объектной привязки: по центру
SHIFT+D | Отключение привязки и отслеживания
SHIFT+E | Отмена объектной привязки: конечная точка
SHIFT+L | Отключение привязки и отслеживания
SHIFT+M | Отмена объектной привязки: средняя точка
SHIFT+P | Отмена объектной привязки: конечная точка
SHIFT+Q | Включение/отключение режима отслеживания объектной привязки
SHIFT+S | Включение применения объектной привязки
SHIFT+V | Отмена объектной привязки: средняя точка
SHIFT+X | Включение/отключение полярного отслеживания
SHIFT+Z | Переключение системной переменной UCSDETECT

В редакторе настройки пользовательского интерфейса можно просмотреть, распечатать или скопировать список клавиш быстрого вызова и клавиш временной замены. Сочетания клавиш и клавиши временной замены, находящиеся в списке, используются в файлах НПИ, загруженных в программе.

См. также

Настройка интерфейса пользователя

Создание макросов

Для задания сочетания клавиш (Процедура)

Изменение сочетания клавиш (Процедура)

Создание клавиши временной замены (Процедура)

Изменение клавиши временной замены (Процедура)

Для печати списка сочетаний клавиш или клавиш временной замены (Процедура)


Задание клавиш быстрого вызова и временной замены - Процедуры

Настройка интерфейса пользователя
Задание клавиш быстрого вызова и временной замены
Понятия
Процедуры
Команды

Для задания сочетания клавиш

Изменение сочетания клавиш

Создание клавиши временной замены

Изменение клавиши временной замены

Для печати списка сочетаний клавиш или клавиш временной замены


Для задания сочетания клавиш - Процедуры

Настройка интерфейса пользователя
Задание клавиш быстрого вызова и временной замены
Понятия
Процедуры
Команды

Для задания сочетания клавиш

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" нажмите значок "плюс" (+) рядом с узлом "Клавиши быстрого вызова".
  3. Нажмите значок "плюс" (+) около списка "Клавиши быстрого вызова", чтобы развернуть этот список.
  4. На панели "Список команд" перетащите команду в узел "Клавиши быстрого вызова" панели "Настройки в <имя файла>.

    5. В панели "Свойства" отображаются свойства, созданные для нового сочетания клавиш быстрого вызова.

  5. Чтобы открыть диалоговое окно "Сочетания клавиш", в поле "Клавиши" нажмите кнопку [...].

  6. В диалоговом окне "Сочетания клавиш" нажатием кнопки мыши выберите поле "Нажмите новую комбинацию быстрого вызова", чтобы сделать его активным.

  7. Удерживайте нажатой клавишу CTRL вместе с клавишами SHIFT и ALT и нажмите клавишу буквы, цифры, функции или виртуальную клавишу. Допустимы следующие комбинации клавиш:
    • функциональные клавиши (Fn) без модификаторов
    • клавиши цифровой клавиатуры (NUMPADn) без модификаторов
    • CTRL+буква, CTRL+цифра, CTRL+функциональная клавиша, CTRL+виртуальная клавиша
    • CTRL+ALT+буква, CTRL+ALT+цифра, CTRL+ALT+функциональная клавиша, CTRL+ALT+виртуальная клавиша
    • CTRL+SHIFT+буква, CTRL+SHIFT+цифра, CTRL+SHIFT+функциональная клавиша, CTRL+SHIFT+виртуальная клавиша
    • CTRL+SHIFT+ALT+буква, CTRL+SHIFT+ALT+цифра, CTRL+SHIFT+ALT+функциональная клавиша, CTRL+SHIFT+ALT+виртуальная клавиша

      • Примечание Поддерживаются следующие виртуальные клавиши: Escape, Insert, Delete, Home, End, Page Up, Page Down, стрелка влево, стрелка вправо, стрелка вверх и стрелка вниз. Виртуальная клавиша ESC может использоваться сама по себе или в сочетании с модификаторами CTRL+SHIFT+ALT.

    В полях "Нажмите новую комбинацию быстрого вызова" и "Назначена для:" отображаются текущие назначения сочетания клавиш.

  8. Если заменять ранее назначенное сочетание клавиш не нужно, нажмите другое сочетание клавиш. Чтобы назначить сочетание клавиш и закрыть диалоговое окно "Сочетания клавиш", нажмите OK.
  9. В редакторе настройки пользовательского интерфейса нажмите кнопку "OK".


Изменение сочетания клавиш - Процедуры

Настройка интерфейса пользователя
Задание клавиш быстрого вызова и временной замены
Понятия
Процедуры
Команды

Изменение сочетания клавиш

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" нажмите значок "плюс" (+) рядом с узлом "Клавиши быстрого вызова".
  3. Нажмите значок "плюс" (+) около списка "Клавиши быстрого вызова", чтобы развернуть этот список.
  4. Нажмите комбинацию клавиш.

    5. В панели "Свойства" отображаются свойства для выбранного сочетания клавиш быстрого вызова.

  5. Чтобы открыть диалоговое окно "Сочетания клавиш", в поле "Клавиши" нажмите кнопку [...].

  6. Удерживайте нажатой клавишу CTRL вместе с клавишами SHIFT и ALT и нажмите клавишу буквы, цифры, функции или виртуальную клавишу. Допустимы следующие комбинации клавиш:
    • функциональные клавиши (Fn) без модификаторов
    • клавиши цифровой клавиатуры (NUMPADn) без модификаторов
    • CTRL+буква, CTRL+цифра, CTRL+функциональная клавиша, CTRL+виртуальная клавиша
    • CTRL+ALT+буква, CTRL+ALT+цифра, CTRL+ALT+функциональная клавиша, CTRL+ALT+виртуальная клавиша
    • CTRL+SHIFT+буква, CTRL+SHIFT+цифра, CTRL+SHIFT+функциональная клавиша, CTRL+SHIFT+виртуальная клавиша
    • CTRL+SHIFT+ALT+буква, CTRL+SHIFT+ALT+цифра, CTRL+SHIFT+ALT+функциональная клавиша, CTRL+SHIFT+ALT+виртуальная клавиша

      • Примечание Поддерживаются следующие виртуальные клавиши: Escape, Insert, Delete, Home, End, Page Up, Page Down, стрелка влево, стрелка вправо, стрелка вверх и стрелка вниз. Виртуальная клавиша ESC может использоваться сама по себе или в сочетании с модификаторами CTRL+SHIFT+ALT.

    Под полями "Нажмите новую комбинацию быстрого вызова" и "Назначена для:" отображаются текущие назначения сочетания клавиш.

  7. Если замена текущего сочетания клавиш нежелательна, используйте другое сочетание клавиш. Чтобы назначить сочетание клавиш и закрыть диалоговое окно "Сочетания клавиш", нажмите OK.
  8. В редакторе настройки пользовательского интерфейса нажмите кнопку "OK".


Создание клавиши временной замены - Процедуры

Настройка интерфейса пользователя
Задание клавиш быстрого вызова и временной замены
Понятия
Процедуры
Команды

Создание клавиши временной замены

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" нажмите значок "плюс" (+) рядом с узлом "Клавиши быстрого вызова".
  3. На панели "Настройки в <имя файла> нажмите правой кнопкой мыши "Клавиши временной замены". Нажмите "Создать" » "Временно заменить".

    4. Новая временная замена (с именем "Временная_замена1") будет размещена в нижней части дерева "Клавиши временной замены".

  4. Выполните одно из следующих действий:
    • Введите новое имя вместо текста "Временная_замена1".
    • Нажатием правой кнопки мыши выберите надпись "Временная_замена1". Выберите "Переименовать". Введите новое имя временной замены.
  5. Выберите в области структуры новую временную замену и обновите панель "Свойства":
    • В поле "Пояснение" введите описание временной замены.
    • Чтобы открыть диалоговое окно "Сочетания клавиш", в поле "Клавиши" нажмите кнопку [...]. В диалоговом окне "Сочетания клавиш" нажмите кнопку мыши в поле "Нажмите новую комбинацию быстрого вызова", затем нажмите клавишу на клавиатуре. Допустимы следующие комбинации клавиш (клавиши функций Fn) без модифицирующих клавиш, SHIFT+буква или SHIFT+цифра.
    • В поле "Макрос 1 (нажатие клавиши)" введите макрос, который будет выполнен при нажатии клавиши временной замены. Если никакое значение не назначено, по умолчанию для макроса задается ^c^c.
    • В поле "Макрос 2 (отпускание клавиши)" введите макрос, который будет выполнен, если отпустить клавишу временной замены. Если значение не определено, то при отпускании клавиш приложение возвращается в предыдущее состояние (до выполнения временной замены).

      • Примечание Информацию о создании макроса см. в разделе Создание макросов.


Изменение клавиши временной замены - Процедуры

Настройка интерфейса пользователя
Задание клавиш быстрого вызова и временной замены
Понятия
Процедуры
Команды

Изменение клавиши временной замены

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" нажмите значок "плюс" (+) рядом с узлом "Клавиши быстрого вызова".
  3. Нажмите значок "плюс" (+) около списка "Клавиши временной замены", чтобы развернуть этот список.
  4. В панели "Настройки в <имя файла>" нажмите клавишу временной замены, которую нужно изменить.

  5. Внесите необходимые обновления в панель "Свойства":
    • В поле "Пояснение" введите описание клавиши временной замены.
    • Чтобы открыть диалоговое окно "Сочетания клавиш", в поле "Клавиши" нажмите кнопку [...]. В диалоговом окне "Сочетания клавиш" нажмите кнопку мыши в поле "Нажмите новую комбинацию быстрого вызова", затем нажмите клавишу на клавиатуре. В полях "Нажмите новую комбинацию быстрого вызова" и "Назначена для:" отображаются текущие назначения для клавиши. Если выбранная клавиша еще не назначена, нажмите OK.
    • В поле "Макрос 1 (нажатие клавиши)" введите макрос, который будет выполнен при нажатии клавиши временной замены. Если никакое значение не назначено, по умолчанию для макроса задается ^c^c.
    • В поле "Макрос 2 (отпускание клавиши)" введите макрос, который будет выполнен, если отпустить клавишу временной замены. Если значение не определено, то при отпускании клавиш приложение возвращается в предыдущее состояние (до выполнения временной замены).

      • Примечание Информацию о создании макроса см. в Создание макросов.


Для печати списка сочетаний клавиш или клавиш временной замены - Процедуры

Настройка интерфейса пользователя
Задание клавиш быстрого вызова и временной замены
Понятия
Процедуры
Команды

Для печати списка сочетаний клавиш или клавиш временной замены

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. На панели "Настройки в <имя файла> выберите узел "Горячие клавиши".

  3. На панели "Ярлыки" выполните фильтрацию типа и статуса горячих клавиш для печати.
    • В раскрывающемся списке "Тип" выберите тип горячих клавиш для просмотра в списке. Варианты выбора - все клавиши, клавиши быстрого вызова или клавиши временной замены.
    • В списке "Статус" выберите статус горячих клавиш. Варианты выбора - все, активный, неактивный и не назначенный.
  4. На панели "Ярлыки" выберите "Печать".


Задание клавиш быстрого вызова и временной замены - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Задание клавиш быстрого вызова и временной замены
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
TEMPOVERRIDES | Включает и отключает клавиши временной отмены
TOOLTIPS | Управляет отображением подсказок
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание операции при двукратном нажатии - Понятия

Настройка интерфейса пользователя
Создание операции при двукратном нажатии
Понятия
Процедуры
Команды

Операции при двукратном нажатии используются для обеспечения доступа к командам редактирования. Для этого необходимо поместить курсор на объект чертежа и зарегистрировать двойное нажатие кнопки устройства указания. Операции при двойном нажатии являются объектными, что позволяет настроить определенную команду для определенного типа объектов.

Операции при двукратном нажатии выполняют команды, которые выводят на экран либо палитру "Свойства", либо специальный редактор, более эффективный, удобный и наиболее часто применяемый для работы с тем типом объекта на чертеже, на котором был выполнено двукратное нажатие. В следующей таблице представлено определение действия в редакторе НПИ при двойном нажатии элемента "Блок атрибута".

Свойства действия при двойном нажатии элемента "Блок атрибута"
Элемент панели свойств | Описание | Пример
Имя | Строка для определения действия при двойном нажатии в редакторе НПИ. | Блок атрибута
Описание | Описание элемента в редакторе НПИ. |
Имя объекта | Тип объекта, с которым связано действие при двойном нажатии. | ATTBLOCKREF
Код элемента | Уникально определяет действие при двойном нажатии в редакторе НПИ. | DC_0002
Имена объектов, связанных с операциями при двукратном нажатии

Операции при двукратном нажатии связаны со значением свойства "Имя объекта", которое должно соответствовать допустимому имени в формате обмена чертежами DXF ™. Имеется несколько исключений, когда не используется имя DXF. Эти исключения используются для блоков, динамических блоков, внешних ссылок, использующих специальные имена объектов. Например, действие при двойном нажатии с именем “Динамический блок с атрибутом” в файле acad.cui использует имя объекта ATTDYNBLOCKREF.

В следующей таблице содержатся имена объектов для блоков, динамических блоков и внешних ссылок.

Имена объектов для вставленных объектов
Имя объекта | Описание
BLOCKREF | Вхождение блока без атрибутов
ATTBLOCKREF | Вхождение блока с атрибутами
DYNBLOCKREF | Вхождение динамического блока без атрибутов
ATTDYNBLOCKREF | Динамическая ссылка на блоки с атрибутами
XREF | Внешняя ссылка

Примечание Если выбрано несколько объектаов или если операция при двукратном нажатии не связана с типом объекта, используется заданная по умолчанию команда ОКНОСВ.

В следующей таблице показаны некоторые имена объектов, настраиваемые в файле acad.cui. Разверните узел "Операции при двукратном нажатии" в редакторе НПИ, чтобы просмотреть полный список всех определенных действий.

Объект | Команда (макрос)
АТОПР | ДИАЛРЕД
ATTBLOCKREF | АТРЕДАКТ
ATTDYNBLOCKREF | АТРЕДАКТ
BLOCKREF | $M=$(if,$(and,$(>,$(getvar,blockeditlock),0)),^C^C_properties,^C^C_bedit)
DYNBLOCKREF | $M=$(if,$(and,$(>,$(getvar,blockeditlock),0)),^C^C_properties,^C^C_bedit)
ШТРИХ | РЕДШТРИХ
ИЗОБ | ИЗОБРЕГУЛ
КПОЛИЛИНИЯ | ПОЛРЕД
МЛИНИЯ | МЛРЕД
МТЕКСТ | МТРЕД
ПОЛИЛИНИЯ | ПОЛРЕД
СПЛАЙН | РЕДСПЛАЙН
ТЕКСТ | ДИАЛРЕД
ССЫЛКА | ССЫЛРЕД

Примечание Операции при двойном нажатии нельзя создать для объектов OLE и видовых экранов.

См. также

Создание макросов

Создание операции при двукратном нажатии (Процедура)

Изменение операции при двукратном нажатии (Процедура)


Создание операции при двукратном нажатии - Процедуры

Настройка интерфейса пользователя
Создание операции при двукратном нажатии
Понятия
Процедуры
Команды

Создание операции при двукратном нажатии

Изменение операции при двукратном нажатии


Создание операции при двукратном нажатии - Процедуры

Настройка интерфейса пользователя
Создание операции при двукратном нажатии
Понятия
Процедуры
Команды

Создание операции при двукратном нажатии

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в меню "Настройки в <имя файла> " нажмите правой кнопкой мыши узел "Операции при двойном нажатии". Нажмите "Новая операция при двойном нажатии".

    3. Новая операция при двукратном нажатии (названная "ДвойноеНажатие1") помещается в нижней части области структуры "Операции при двойном нажатии".

  3. Выполните одно из следующих действий:
    • Введите новое имя вместо текста "ДвойноеНажатие1".
    • Нажатием правой кнопки мыши выберите "ДвойноеНажатие1". Выберите "Переименовать". Введите новое имя операции при двойном нажатии.
  4. В панели "Свойства" выполните следующие действия.
    • В поле "Пояснение" введите описание операции при двукратном нажатии.
    • В поле "Имя объекта" укажите имя DXF или одно из специальных имен, используемых для вставленного объекта. После выхода из поля значение автоматически преобразуется в верхний регистр.

  5. В панели "Список команд" перетащите команду, которую необходимо добавить, поместив ее строго под операцией при двукратном нажатии в панели "Настройки в <имя файла>".

    6. Примечание Одновременно с одной операцией при двукратном нажатии может быть связана только одна команда.

  6. Нажмите ОК.


Изменение операции при двукратном нажатии - Процедуры

Настройка интерфейса пользователя
Создание операции при двукратном нажатии
Понятия
Процедуры
Команды

Изменение операции при двукратном нажатии

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" нажмите значок "плюс" (+) рядом с узлом "Операции при двойном нажатии".
  3. Нажмите "Операция при двойном нажатии".

    4. В панели "Свойства" отображаются свойства для выбранной операции при двойном нажатии.

  4. В поле "В поле "Имя объекта" укажите имя DXF или одно из специальных имен, используемых для вставленного объекта.

  5. Если необходимо заменить команду, назначенную в данный момент операции при двойном нажатии, перейдите на панель "список команд" и перетащите другую команду в выбранное действие в панели "Настройки в <имя файла>".

  6. В редакторе настройки пользовательского интерфейса нажмите кнопку "OK".


Создание операции при двукратном нажатии - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Создание операции при двукратном нажатии
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
PICKFIRST | Определяет момент выбора объектов: до вызова команды (предварительный выбор) или после
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка кнопок мыши - Понятия

Настройка интерфейса пользователя
Настройка кнопок мыши
Понятия
Процедуры
Команды

Можно изменить стандартные действия указывающих устройств в программе.

С помощью кнопок мыши можно управлять указывающим устройством Windows. В редакторе настройки пользовательского интерфейса можно настроить поведение мыши или другого указывающего устройства. Если у указывающего устройства больше двух кнопок, можно изменить функции второй и третьей кнопок. Функцию первой кнопки любого указывающего устройства изменить в редакторе НПИ невозможно.

С помощью клавиш SHIFT и CTRL можно создать ряд комбинаций, отвечающих потребностям пользователя. Количество команд, распознаваемых указывающим устройством, соответствует количеству кнопок. Раздел кнопок мыши узла дерева упорядочен в соответствии со следующими сочетаниями: щелчок, SHIFT+щелчок, CTRL+щелчок, и CTRL+SHIFT+щелчок. Кнопки планшета имеют последовательную нумерацию. Перетащите команду, чтобы назначить ее для кнопки мыши. Чтобы создать дополнительные кнопки, перетащите команды в узел щелчков.

В следующей таблице приведены свойства нажатия кнопки мыши, отображающиеся в панели "Свойства".

Свойства нажатия кнопки мыши
Элемент панели свойств | Описание | Пример
Псевдонимы | Указывает псевдонимы для кнопки мыши. Нажмите кнопку [...], чтобы открыть диалоговое окно "Псевдонимы". Псевдоним используется для программной ссылки на кнопку мыши. | AUX1
  • Ввод координат в меню кнопок
    Если нажать одну кнопку указывающего устройства с несколькими кнопками программа воспринимает не только номер кнопки, но и координаты перекрестья на экране в момент ее нажатия. Эти координаты можно либо проигнорировать, либо использовать в выполняемой команде, организовав макросы нужным образом.


Настройка кнопок мыши - Процедуры

Настройка интерфейса пользователя
Настройка кнопок мыши
Понятия
Процедуры
Команды

Добавление комбинации нажатий кнопок мыши


Настройка кнопок мыши - Команды

Настройка интерфейса пользователя
Настройка кнопок мыши
Понятия
Процедуры
Команды
Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Ввод координат в меню кнопок - Понятия

Настройка интерфейса пользователя
Ввод координат в меню кнопок
Понятия
Процедуры
Команды

Если нажать одну кнопку указывающего устройства с несколькими кнопками программа воспринимает не только номер кнопки, но и координаты перекрестья на экране в момент ее нажатия. Эти координаты можно либо проигнорировать, либо использовать в выполняемой команде, организовав макросы нужным образом.

Как описано в разделе Пауза для пользовательского ввода, в команду можно вставить символ обратной косой черты (\ ) для перевода в состояние ожидания пользовательского ввода. Для меню, открывающихся по кнопке мыши или дигитайзера, при нажатии кнопки текущие координаты перекрестья будут автоматически восприниматься как пользовательский ввод. Это справедливо только для первого символа обратной косой черты в команде. Если пункт не содержит символа обратной косой черты, координаты перекрестья игнорируются. Рассмотрим следующие команды:

отрезок
отрезок \

Первая кнопка инициирует команду ОТРЕЗОК и выводит на экран запрос "Укажите первую точку" (в обычном режиме). Вторая кнопка тоже запускает команду ОТРЕЗОК, но программа учитывает положение перекрестья курсора в момент нажатия и предлагает пользователю ввести следующую точку.

См. также

Создание макросов

Добавление комбинации нажатий кнопок мыши (Процедура)


Добавление комбинации нажатий кнопок мыши - Процедуры

Настройка интерфейса пользователя
Ввод координат в меню кнопок
Понятия
Процедуры
Команды

Добавление комбинации нажатий кнопок мыши

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса перейдите на вкладку "Настройка".
  3. В панели "Настройки в <имя файла>" нажмите знак "плюс" (+) рядом с элементом "Кнопки мыши", чтобы открыть список.
  4. Нажатием правой кнопки мыши выберите раздел, относящийся к кнопкам мыши. Выберите "Кнопка Создать".

    5. Новая кнопка мыши (с именем "Кнопка n") будет помещена в конце выбранного списка.

  5. В панели "Список команд" перетащите команду, которую необходимо добавить для кнопки мыши в панели "Настройки в <имя файла >".

  6. По завершении нажмите кнопку OK.


Ввод координат в меню кнопок - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Ввод координат в меню кнопок
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка элементов интерфейса предыдущей версии - Понятия

Настройка интерфейса пользователя
Настройка элементов интерфейса предыдущей версии
Понятия
Процедуры
Команды

Выражение “унаследованный от предыдущей версии“ относится к тем элементам интерфейса, которые обычно не используются в текущей версии, но тем не менее поддерживаются программой, поскольку некоторые пользователи предпочитают их соответствующим элементам новой версии.

Элементы интерфейса предыдущей версии:

  • Планшетные меню
  • Кнопки планшета
  • Экранные меню
  • Меню мозаики изображений
  • Создание планшетных меню
    На графическом планшете можно настроить до четырех зон в качестве областей меню для ввода команд.
  • Настройка кнопок планшета
    Чтобы настроить кнопки планшета, следуйте инструкциям для настройки кнопок мыши.
  • Создание экранных меню
    С помощью экранных меню можно открыть интерфейс предыдущей версии для отображения меню в закрепляемом окне. В редакторе настройки пользовательского интерфейса можно создавать и редактировать экранные меню.
  • Создание меню мозаики изображений
    Основное назначение меню мозаики изображений - предоставить пользователю возможность выбора изображения, а не текста. Можно создавать, редактировать или добавлять новые мозаичные изображения и слайды.


Настройка элементов интерфейса предыдущей версии - Процедуры

Настройка интерфейса пользователя
Настройка элементов интерфейса предыдущей версии
Понятия
Процедуры
Команды

Определение рядов и столбцов в меню планшета

Удаление значений, присвоенных меню планшета

Отображение экранного меню

Настройка отображения текущей команды в экранных меню

Добавление команд в экранное меню

Создание подменю в экранном меню

Создание мозаичного слайда

Просмотр мозаичного слайда

Создание библиотеки мозаичных слайдов

Создание меню мозаичных изображений и назначение мозаичного слайда


Настройка элементов интерфейса предыдущей версии - Команды

Настройка интерфейса пользователя
Настройка элементов интерфейса предыдущей версии
Понятия
Процедуры
Команды
Команды
ДСЛАЙД | Создание файла слайда из текущего видового экрана пространства модели или текущего листа
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
ПЛАНШЕТ | Настройка, калибровка, включение и отключение графического планшета
СЛАЙД | Просмотр файла слайда на текущем видовом экране
Системные переменные
MENUCTL | Управляет переключением страниц экранного меню
SCREENBOXES | Сохраняет количество окон экранного меню области рисования
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание планшетных меню - Понятия

Настройка интерфейса пользователя
Создание планшетных меню
Понятия
Процедуры
Команды

На графическом планшете можно настроить до четырех зон в качестве областей меню для ввода команд.

Узлы в редакторе настройки пользовательского интерфейса имеют метки "Меню планшета 1" - "Меню планшета 2" и определяют макросы, связанные с выбором на планшете.

Зоны планшетного меню, определенные с помощью параметра "Нас" (Настроить) команды ПЛАНШЕТ, делятся на клетки равного размера (поля выбора) в соответствии с количеством рядов и столбцов, указанным для каждой зоны. Эти поля выбора планшетного меню четко соответствуют линиям под заголовками разделов планшета, расположенным справа налево и сверху вниз (независимо от наличия в них текста).

Например, если в зоне планшетного меню 5 столбцов и 4 ряда, команда на строке, идущей сразу же за заголовком ряда, соответствует крайней левой клетке в верхнем ряду зоны меню. Программа способна распознать до 32766 команд в каждом разделе планшетного меню, что более чем достаточно для любых приложений.

Пользователь может добавлять свои макросы в ячейку "Макросы" панели "Свойства". Имена команд этой зоны соответствуют 225 клеткам в верхней части шаблона планшета (ряды от A до I , столбцы от 1 до 25). Макрос можно добавить с помощью стандартного синтаксиса командного языка. В следующей таблице приведены свойства нажатия кнопки мыши, отображающиеся в панели "Свойства".

Свойства "Меню планшета 1"
Элемент панели свойств | Описание | Пример
Псевдонимы | Указывает псевдонимы для контекстного меню. Нажмите кнопку [...], чтобы открыть диалоговое окно "Псевдонимы". Псевдоним используется для программной ссылки на меню планшета. | TABLET1, TABLET1STD
Строки | Количество строк, которые можно настроить для меню планшета. | 9
Столбцы | Количество столбцов, которые можно настроить для меню планшета. | 25

См. также

Создание макросов

Определение рядов и столбцов в меню планшета (Процедура)

Удаление значений, присвоенных меню планшета (Процедура)


Создание планшетных меню - Процедуры

Настройка интерфейса пользователя
Создание планшетных меню
Понятия
Процедуры
Команды

Определение рядов и столбцов в меню планшета

Удаление значений, присвоенных меню планшета


Определение рядов и столбцов в меню планшета - Процедуры

Настройка интерфейса пользователя
Создание планшетных меню
Понятия
Процедуры
Команды

Определение рядов и столбцов в меню планшета

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройки в <имя файла> нажмите значок "плюс" (+) рядом с узлом "Предыдущая версия".
  3. Нажмите значок "плюс" (+) рядом с элементом "Меню планшета", чтобы открыть список.
  4. Нажмите значок "плюс" (+) рядом с меню планшета, чтобы открыть список.
  5. Выберите ряд, который требуется определить.
  6. В панели "Список команд" найдите команду, которую необходимо добавить.
  7. Перетащите команду в столбец.
  8. По завершении добавления команд нажмите кнопку OK.


Удаление значений, присвоенных меню планшета - Процедуры

Настройка интерфейса пользователя
Создание планшетных меню
Понятия
Процедуры
Команды

Удаление значений, присвоенных меню планшета

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройки в <имя файла> нажмите значок "плюс" (+) рядом с узлом "Предыдущая версия".
  3. Нажмите значок "плюс" (+) рядом с элементом "Меню планшета", чтобы открыть список.
  4. Нажмите значок "плюс" (+) рядом с меню планшета, чтобы открыть список.
  5. Нажатием правой кнопки мыши выберите ряд или столбец, содержимое которого требуется удалить. Выберите "Удалить назначение".
  6. По завершении добавления команд нажмите кнопку OK.


Создание планшетных меню - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Создание планшетных меню
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
ПЛАНШЕТ | Настройка, калибровка, включение и отключение графического планшета
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка кнопок планшета - Понятия

Настройка интерфейса пользователя
Настройка кнопок планшета
Понятия
Процедуры
Команды

Кнопки планшета - это кнопки, которые находятся на указательном устройстве, также называемом координатной шайбой, которое используется с планшетом для цифрового ввода данных. Координатные шайбы бывают различной формы, размеров и имеют различные конфигурации кнопок. Можно выполнить настройку всех кнопок на координатной шайбе, за исключением первой кнопки.

Некоторые производители оборудования используют слегка отличающиеся схемы расположения кнопок для разных координатных шайб. В одном устройстве первая кнопка может располагаться в верхнем левом углу, а остальные - последовательно поперек и вниз (от кнопки 1 до кнопки F). В другом устройстве первая кнопка тоже может быть слева вверху, но сама схема нумерации может существенно отличаться.

Примечание Очень важно проверить расположение кнопок после их назначения, чтобы убедиться в его правильности. Возможно, чтобы выяснить раскладку кнопок, потребуется обратиться к руководству пользователя, поставляемому вместе с координатной шайбой.

Чтобы настроить кнопки планшета, следуйте инструкциям для настройки кнопок мыши.

Дополнительную информацию о настройке кнопок планшета см. раздел Настройка кнопок мыши.


Настройка элементов интерфейса предыдущей версии

Настройка интерфейса пользователя
Настройка элементов интерфейса предыдущей версии
Понятия
Процедуры
Команды

Нет процедур.


Настройка кнопок планшета - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Настройка кнопок планшета
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание экранных меню - Понятия

Настройка интерфейса пользователя
Создание экранных меню
Понятия
Процедуры
Команды

С помощью экранных меню можно открыть интерфейс предыдущей версии для отображения меню в закрепляемом окне. В редакторе настройки пользовательского интерфейса можно создавать и редактировать экранные меню.

По умолчанию экранное меню отключено. На вкладке "Отображение" диалогового окна "Параметры" включите отображение экранных меню. Кроме того, системная переменная MENUCTL управляет обновлением экранных меню при вводе команд в командной строке.

Примечание В следующих версиях продукта экранные меню поддерживаться не будут.

В редакторе настройки пользовательского интерфейса любое экранное меню состоит из нескольких строк меню, определяющих экранные подменю. Выполните назначение подменю для экранного меню, перетащив его в экранное меню в панели "Настройки в". Выполните назначение команды для меню, перетащив ее из панели "Список команд" на нумерованную строку в меню. Строки меню, которым не присвоена команда, остаются пустыми.

Редактирование свойств экранного меню

Можно изменить свойства экранного меню (см. следующую таблицу).

Свойства экранных меню
Элемент панели свойств | Описание | Пример
Имя | Определяет имя меню. | ЭКРАН
Описание | Описание элемента, не отображается в пользовательском интерфейсе. |
Начальная строка | Задает начальную строку подменю экранного меню. | 1
Число рядов | Задает число рядов в экранном подменю. | 27
Псевдонимы | Задает псевдоним для экранного меню. Если этому псевдониму присвоены несколько описаний, отобразится надпись “Коллекция“. Нажмите кнопку [...], чтобы открыть диалоговое окно "Псевдонимы". | ЭКРАН, S

Для экранного меню AutoCAD, являющегося корневым, в поле "Псевдонимы" определены два псевдонима: "Экран" (начальная панель экранного меню) и Э (заголовок подменю). Назначения строк для других меню определяют порядок расположения параметров в меню. Например, меню "Файл" в строке 3 области структуры экранного меню AutoCAD - это третья позиция экранного меню AutoCAD.

Имена подменю в области структуры соответствуют имени первого элемента подменю. Например, подменю "Создать" кроме самой команды СОЗДАТЬ содержит такие команды, как ОТКРЫТЬ, БСОХРАНИТЬ и СОХРАНИТЬКАК—. В поле "Псевдонимы" определяются меню, которые содержат эти подменю, а в поле "Начальная строка" указывается положение подменю в меню. Подменю "Создать" отображается в позиции 3 экранного меню "Файл". Поэтому в панели "Свойства" его начальной строкой будет строка 3. Если дважды нажать кнопку мыши в поле "Псевдонимы", чтобы открыть диалоговое окно "Псевдонимы", можно увидеть, что его меню присвоено значение 01_FILE.

Контролируя параметры начальной строки, можно определить какие элементы меню отображаются постоянно. Например, поскольку в качестве начальной строки подменю "Создать" определена строка 3, элементы меню строк 1 и 2 экранного меню AutoCAD (параметры меню AutoCAD и ****) также будут отображаться при выводе подменю "Создать".

Таким же образом можно настроить меню, чтобы скрывать или показывать параметры меню в других меню с помощью пустых строк. Например, для подменю "Создать" определено 22 строки, включая пустые строки. Поэтому при выборе подменю "Создать" также будут отображаться подменю "Средства" и "Последний", которым соответствуют строки 25 и 26 экранного меню AutoCAD. Однако параметр строки 22 будет скрыт.

См. также

Создание макросов

Отображение экранного меню (Процедура)

Настройка отображения текущей команды в экранных меню (Процедура)

Добавление команд в экранное меню (Процедура)

Создание подменю в экранном меню (Процедура)


Создание экранных меню - Процедуры

Настройка интерфейса пользователя
Создание экранных меню
Понятия
Процедуры
Команды

Отображение экранного меню

Настройка отображения текущей команды в экранных меню

Добавление команд в экранное меню

Создание подменю в экранном меню


Отображение экранного меню - Процедуры

Настройка интерфейса пользователя
Создание экранных меню
Понятия
Процедуры
Команды

Отображение экранного меню

  1. Выберите в меню "Сервис" » " Параметры".
  2. В поле "Элементы окна" на вкладке "Экран" диалогового окна "Параметры" выберите "Экранное меню".
  3. Нажмите ОК.


Настройка отображения текущей команды в экранных меню - Процедуры

Настройка интерфейса пользователя
Создание экранных меню
Понятия
Процедуры
Команды

Настройка отображения текущей команды в экранных меню

  1. В командной строке введите menuctl.
  2. Выполните одно из следующих действий:
    • Введите 1, чтобы текущая команда отображалась в экранных меню.
    • Введите 0, чтобы текущая команда игнорировалась экранными меню.


Добавление команд в экранное меню - Процедуры

Настройка интерфейса пользователя
Создание экранных меню
Понятия
Процедуры
Команды

Добавление команд в экранное меню

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройки в <имя файла> нажмите значок "плюс" (+) рядом с узлом "Предыдущая версия".
  3. В списке "Предыдущие версии" нажмите значок "плюс" (+) рядом с экранным меню, чтобы открыть список.
  4. В панели "Список команд" найдите команду, которую необходимо добавить. Перетащите команду в экранное меню. Когда команду можно перетащить, рядом с курсором отображается стрелка.
  5. По завершении нажмите кнопку OK.


Создание подменю в экранном меню - Процедуры

Настройка интерфейса пользователя
Создание экранных меню
Понятия
Процедуры
Команды

Создание подменю в экранном меню

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройки в <имя файла> нажмите значок "плюс" (+) рядом с узлом "Предыдущая версия".
  3. В списке "Предыдущие версии" нажатием правой кнопки мыши выберите "Экранное меню". Выберите "Создать экранное меню".

    4. Новое экранное меню (под именем Экранное меню1) будет помещено в нижней части дерева экранных меню.

  4. Выполните одно из следующих действий:
    • Введите новое имя вместо текста "Экранное меню1".
    • Нажатием правой кнопки мыши выберите надпись "Экранное меню1". Выберите "Переименовать". Затем введите новое имя меню.
  5. Выберите новое экранное меню в области структуры и обновите панель "Свойства" следующим образом.
    • В поле "Пояснение" введите текстовое пояснение для экранного меню.
    • В поле "Начальная строка" введите номер строки для первого параметра меню.
    • В поле "Число строк" укажите общее число строк, которое должно быть в экранном меню.
    • В поле "Псевдонимы" введите псевдоним.
  6. В панели "Список команд" перетащите команду в положение строго под экранным меню в панели "Настройки в <имя файла>".
  7. По завершении нажмите кнопку OK.


Создание экранных меню - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Создание экранных меню
Понятия
Процедуры
Команды

Команды
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
MENUCTL | Управляет переключением страниц экранного меню
SCREENBOXES | Сохраняет количество окон экранного меню области рисования
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание меню мозаики изображений - Понятия

Настройка интерфейса пользователя
Создание меню мозаики изображений
Понятия
Процедуры
Команды

Основное назначение меню мозаики изображений - предоставить пользователю возможность выбора изображения, а не текста. Можно создавать, редактировать или добавлять новые мозаичные изображения и слайды.

Диалоговое окно меню мозаики изображений отображает слайды группами по 20 штук, а также прокручивающийся список с левой стороны, где отображаются имена связанных со слайдами файлов или соответствующий текст. Если диалоговое окно мозаики изображений содержит более 20 слайдов, дополнительные слайды добавляются на новую страницу. При этом активизируются кнопки "Далее" и "Предыдущий", с помощью которых можно перемещаться по страницам изображений.

Ниже показано диалоговое окно меню мозаики изображений "3D объекты", где выбрано изображение "Купол".

В редакторе настройки пользовательского интерфейса можно определить меню мозаики изображений. В следующей таблице показаны свойства меню "Изображение 3D объекта", отображающиеся на панели "Свойства".

Свойства меню мозаики изображений 3D объекта
Элемент панели свойств | Описание | Пример
Имя | Строка, используемая только в редакторе НПИ, в пользовательском интерфейсе эта строка не отображается. | 3D объекты
Описание | Описание элемента, не отображается в пользовательском интерфейсе. |
Псевдонимы | Указывает псевдонимы для меню мозаики изображений. Нажмите кнопку [...], чтобы открыть диалоговое окно "Псевдонимы". Псевдоним используется для программной ссылки на меню планшета. | изображение, image_3DObjects

В следующей таблице показаны свойства команды "Купол" в меню "Изображение 3D объекта", отображающиеся на панели "Свойства".

Свойства команды "Купол" в меню мозаики изображений 3D объектов
Элемент панели свойств | Описание | Пример
Имя | Строка, отображаемая в списке в левой части диалогового окна меню мозаики изображений. Строка должна содержать буквенно-цифровые символы. Использование знаков пунктуации за исключением дефиса (-) или символа подчеркивания (_) запрещено. | Купол
Описание | Описание элемента, не отображается в пользовательском интерфейсе. | Создание верхней половины сферической многоугольной сети
Макрос | Макрос команды. В нем применяется стандартный синтаксис для макросов. | ^C^C_ai_dome
Код элемента | Метка, уникально определяющая команду. | ID_Ai_dome
Библиотека слайдов | Файл, содержащий несколько слайдов, созданный с помощью файла slidelib.exe. | acad
Метка слайда | Имя слайда, содержащегося в библиотеке слайдов или изображение слайда, хранящееся отдельно. | Купол

Любой слайд, созданный программой AutoCAD, может быть использован в качестве чертежа. При подготовке слайдов для меню мозаики изображений необходимо принимать во внимание следующие рекомендации.

  • Слайды должны быть как можно более простыми. При открытии меню мозаики изображений следует дождаться, пока все изображения появятся на экране, прежде чем выбирать одно из них. При отображении множества сложных символов используйте простые, узнаваемые изображения, а не полные преобразованные копии.
  • Заполните поле. При создании слайда изображения следует заполнить формируемым изображением весь экран, прежде чем вызвать команду ДСЛАЙД. Если изображение очень широкое и короткое или длинное и узкое, то меню мозаики изображений будет выглядеть лучше, если, прежде чем делать слайд, отцентрировать изображение на экране, используя ПАНОРАМИРОВАНИЕ.

    • Изображения показываются с форматным соотношением 3:2 (3 единицы по ширине на 2 единицы по высоте). Если область рисования имеет другое форматное соотношение, то будет очень сложно создать мозаичные слайды, центрированные в меню мозаики изображений. Если выполняется работа с видовым экраном листа, имеющим форматное соотношение 3:2, можно позиционировать изображение и быть уверенным, что он будет отображаться точно также в меню мозаики изображений.

  • Учитывайте назначение изображений. Не следует использовать изображения в качестве символов каких-либо абстрактных понятий. Фрагменты мозаики, прежде всего, служат для выбора графических символов.

См. также

Создание мозаичного слайда (Процедура)

Просмотр мозаичного слайда (Процедура)

Создание библиотеки мозаичных слайдов (Процедура)

Создание меню мозаичных изображений и назначение мозаичного слайда (Процедура)


Создание меню мозаики изображений - Процедуры

Настройка интерфейса пользователя
Создание меню мозаики изображений
Понятия
Процедуры
Команды

Создание мозаичного слайда

Просмотр мозаичного слайда

Создание библиотеки мозаичных слайдов

Создание меню мозаичных изображений и назначение мозаичного слайда


Создание мозаичного слайда - Процедуры

Настройка интерфейса пользователя
Создание меню мозаики изображений
Понятия
Процедуры
Команды

Создание мозаичного слайда

  1. В AutoCAD нарисуйте символ или блок.
  2. В командной строке ввести дслайд.
  3. Выберите в меню "Файл": » "Зумирование", » "Центр".
  4. В командной строке ввести дслайд.
  5. В диалоговом окне "Создание файла слайда" укажите имя файла.
  6. Сохраните файл и добавьте его в файл библиотеки слайдов. Этот слайд можно назначить новому мозаичному изображению.


Просмотр мозаичного слайда - Процедуры

Настройка интерфейса пользователя
Создание меню мозаики изображений
Понятия
Процедуры
Команды

Просмотр мозаичного слайда

  1. В командной строке ввести слайд.
  2. В диалоговом окне "Выбор файла слайда" выберите файл слайда для просмотра.
  3. Нажмите "Открыть".

    4. Файл слайда должен отобразиться в окне чертежа. Выполните регенерацию чертежа, чтобы удалить слайд с экрана.


Создание библиотеки мозаичных слайдов - Процедуры

Настройка интерфейса пользователя
Создание меню мозаики изображений
Понятия
Процедуры
Команды

Создание библиотеки мозаичных слайдов

  1. Поместите все слайды, которые требуется добавить к библиотеке слайдов, в одну папку.
  2. Выберите в меню "Старт" » "Выполнить".
  3. В диалоговом окне команды "Выполнить" введите в текстовом поле cmd.
  4. Нажмите OK, чтобы открыть окно DOS.
  5. В командной строке введите CD <папка со слайдами>

    6. Пример: CD “c:\slides”

  6. Находясь в папке с файлами слайдов, введите dir *.sld /b > <имя файла>

    7. Пример: dir *.sld /b >“мои_слайды”

    Будет создан текстовый файл с именами файлов слайдов, содержащимися в текущей папке.

  7. Создав текстовый файл со всеми названиями файлов слайдов в текущей папке, введите команду<папка установки AutoCAD>\slidelib.exe <имя файла библиотеки слайдов> < <текстовый файл с названиями слайдов>.

    8. Пример: “C:\Program Files\AutoCAD 2007\slidelib.exe”“моя_библиотека_слайдов” < “мои_слайды”

  8. Выполнив эту операцию, закройте окно DOS.

Предупреждение После создания библиотеки слайдов поместите отдельные файлы слайдов в безопасное местположение, чтобы их не могли нечаянно удалить. Это необходимо на тот случай, если когда-нибудь вновь потребуется создавать библиотеку слайдов.


Создание меню мозаичных изображений и назначение мозаичного слайда - Процедуры

Настройка интерфейса пользователя
Создание меню мозаики изображений
Понятия
Процедуры
Команды

Создание меню мозаичных изображений и назначение мозаичного слайда

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройки в <имя файла> нажмите значок "плюс" (+) рядом с узлом "Предыдущая версия".
  3. В списке "Предыдущие версии" нажатием правой кнопки мыши выберите "Меню мозаики изображений". Выберите "Новое меню мозаики изображений".

    4. Новое меню мозаики изображений (под именем МенюМозаикиИзображений1) будет помещено в нижней части дерева меню.

  4. Выполните одно из следующих действий:
    • Введите новое имя вместо текста "МенюМозаикиИзображений1".
    • Нажатием правой кнопки мыши выберите надпись "МенюМозаикиИзображений1". Выберите "Переименовать". Затем введите новое имя изображения.
  5. В панели "Список команд" перетащите команду к новому меню мозаики изображений в панели "Настройки в <имя файла>".
  6. На панели "Свойства" укажите следующие свойства для нового мозаичного слайда.
    • В поле "Имя" введите текст, который будет отображаться в текстовом окне мозаичного изображения.
    • В поле "Пояснение" введите описание для мозаичного изображения.
    • В поле "Библиотека слайдов" введите имя библиотеки слайдов с мозаичными изображениями, содержащей этот мозаичный слайд. Библиотека мозаичных слайдов должна находиться в одной из папок, указанных в переменной "Путь доступа к вспомогательным файлам". Если библиотеки слайдов нет, а есть файл слайда мозаики изображений, введите его имя в поле библиотеки слайдов мозаики изображений.
    • В окне "Метка слайда" введите имя для файла слайда с изображением, который содержится в библиотеке мозаичных слайдов, показанной в списке "Библиотека слайдов".
  7. По завершении нажмите кнопку OK.


Создание меню мозаики изображений - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Создание меню мозаики изображений
Понятия
Процедуры
Команды

Команды
ДСЛАЙД | Создание файла слайда из текущего видового экрана пространства модели или текущего листа
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
СЛАЙД | Просмотр файла слайда на текущем видовом экране
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Загрузка файла AutoLISP - Понятия

Настройка интерфейса пользователя
Загрузка файла AutoLISP
Понятия
Процедуры
Команды

Файлы AutoLISP (LSP или MNL) содержат сценарии, добавляющие настройки и операции в интерфейс. Файлы AutoLISP можно загружать в файл НПИ на вкладке "Настройка" в редакторе настройки пользовательского интерфейса.

Дополнительную информацию об использовании AutoLISP см. в разделе AutoLISP и Visual LISP.

Файлы MNL, имя и местоположение которых совпадает с именем и местоположением основного, частичного или корпоративного файла НПИ, загружаются автоматически. Эти файлы нельзя удалять.

См. также

Загрузка файла AutoLISP в редактор настройки пользовательского интерфейса (Процедура)


Загрузка файла AutoLISP в редактор настройки пользовательского интерфейса - Процедуры

Настройка интерфейса пользователя
Загрузка файла AutoLISP
Понятия
Процедуры
Команды

Загрузка файла AutoLISP в редактор настройки пользовательского интерфейса

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в меню "Настройки в <имя файла> " нажмите правой кнопкой мыши узел "Файлы LISP". Выберите "Загрузить файл LISP".

  3. В диалоговом окне "Загрузка файла LISP" найдите и выделите файл AutoLISP, который требуется загрузить. Можно выбрать только файлы с расширением LSP.

    4. Хотя файлы с расширением LSP можно загрузить только этим способом, по-прежнему можно загружать другие типы пользовательских программных файлов. Для загрузки других типов пользовательских программных файлов используйте команды AutoCAD, например, NETLOAD, VBALOAD или ARX.

  4. Нажмите "Открыть".


Загрузка файла AutoLISP - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Загрузка файла AutoLISP
Понятия
Процедуры
Команды

Команды
ЗАГПРИЛ | Загрузка и выгрузка приложений; задание набора приложений для автозагрузки
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка рабочего пространства - Понятия

Настройка интерфейса пользователя
Настройка рабочего пространства
Понятия
Процедуры
Команды

Можно настроить рабочее пространство таким образом, чтобы создать среду рисования, в которой бы отображались только выбранные вами панели инструментов, меню и закрепляемые окна.

Опции настройки рабочих пространств включают создание рабочего пространства с помощью редактора настройки пользовательского интерфейса, изменение свойств рабочего пространства и отображение панели инструментов во всех рабочих пространствах.

Создание или измерение рабочего пространства с помощью редактора настройки пользовательского интерфейса

Наиболее удобный способ создания или изменения рабочего пространства - это настройка панелей инструментов и закрепляемых окон, которые наиболее точно отвечают требованиям задач рисования, и сохранение этих настроек в программе в качестве рабочего пространства. Пользователь может получить доступ к такому рабочему пространству всегда, когда требуется в нем что-либо нарисовать.

Можно также настроить рабочее пространство с помощью редактора настройки пользовательского интерфейса. С помощью этого диалогового окна можно создавать или изменять рабочее пространство, используя точные свойства и элементы (панели инструментов, меню и закрепляемые окна), которые другие пользователи всегда могут использовать для выполнения определенных задач. Можно задать файл НПИ, содержащий это рабочее пространство, как корпортивный файл НПИ. При этом рабочее пространство можно использовать совместно с другими пользователями.

Показать: Создание рабочего пространства

Нажмите стрелку "Воспроизведение" под следующим изображением для запуска анимации.

В анимации ниже показано, как создавать рабочее пространство. В анимации показано создание рабочего пространства и как управлять отображением панелей инструментов, меню и закрепляемых окон. Работа с частичными файлами НПИ в анимации не представлена. Подробней о работе с частичными файлами НПИ см. раздел Создание и загрузка частичного файла НПИ.

Подробней о создании корпоративных файлов НПИ см. раздел Создание корпоративного файла НПИ.

Далее представлен пример панели "Содержимое рабочих пространств" в редакторе настройки пользовательского интерфейса. Для создания или изменения выбранного рабочего пространства выберите "Настройка рабочего пространства".

Ниже приведен вид панели "Настройки в<имя файла>" после выбора элемента "Настройка рабочего пространства" на панели "Содержимое рабочего пространства". Около каждого элемента, который можно добавить в рабочее пространство, находится кнопка-флажок. Чтобы добавить элемент в рабочее пространство, установите флажок.

Изменение свойств рабочего пространства

В редакторе настройки пользовательского интерфейса можно определить свойства рабочих пространств, например, имя, описание отображение на вкладке "Модель" или "Лист" и т.п. В следующей таблице приведены свойства "Классического рабочего пространства AutoCAD", отображающиеся в панели "Свойства".

Свойства классического рабочего пространства AutoCAD
Элемент панели свойств | Описание | Пример
Имя | Строка, отображаемая в раскрывающемся поле на панели инструментов "Рабочее пространство", в командной строке при использовании команды РАБОЧЕЕ ПРОСТРАНСТВО, в меню "Средства" в команде "Рабочие пространства" и в редакторе НПИ. | Классическое, AutoCAD
Описание | Рабочее рабочего пространства, не отображается в пользовательском интерфейсе. |
Начало в | Отображение в чертеже при восстановлении рабочего простанства вкладки "Модель", последней активной вкладки "Лист" или текущей активной вкладки или задание вкладки в качестве текущей. | Модель
Вкладки "Модель"/"Лист" | Видимы или нет вкладки "Модель/Лист" в окне чертежа при восстановлении рабочего простанства или установлены как текущие. | Вкл
Экранные меню | Определяет, видимо или нет меню "Экран", если рабочее пространство восстановлено или установлено как текущее. | Откл
Полосы прокрутки | Определяет, отображаются или нет полосы прокрутки, если рабочее пространство восстановлено или установлено как текущее. | Откл
Изменение свойств закрепляемого окна

Для множества окон, которые принято называть закрепляемыми окнами, можно выполнить настройки, делающие их закрепленными, привязанными и плавающими. Можно определить размер, положение или внешний вид этих окон, изменив их свойства в панели "Содержимое рабочих пространств" в редакторе настройки пользовательского интерфейса. В этом окне находятся:

  • Дополнительные параметры тонирования
  • Командная строка
  • Пульт управления
  • Диспетчер подключения к БД
  • DesignCenter
  • Внешние ссылки
  • Информационная палитра
  • Материалы
  • Диспетчер наборов пометок
  • Свойства
  • БЫСТРКАЛЬК
  • Диспетчер подшивки
  • Инструментальная палитра
  • Диспетчер визуальных стилей

В следующей таблице приведены свойства инструментальной палитры, отображающиеся в панели "Свойства.

Свойства закрепляемого окна "Палитры инструментов"
Элемент панели свойств | Описание | Пример
Показать | Состояние видимости закрепляемого окна. Доступные опции: "Да", "Нет" или "Не изменять". Опция "Не изменять" сохраняет последнее используемое состояние закрепляемого окна при восстановлении или задании текущим рабочего пространства. | Да
Ориентации | Состояние фиксации или плавающее состояние закрепляемого окна. Доступные опции: "Плавающее", "Слева", "Справа" или "Не изменять". Опция "Не изменять" сохраняет последнее используемое состояние закрепляемого окна при восстановлении или задании текущим рабочего пространства. Некоторые закрепляемые окна, такие как "Командная строка", также поддерживают дополнительные варианты фиксации: "Верх" и "Низ". | Плавающее
Разрешить закрепление | Возможность пользователю закрепить окно с помощью перетаскивания к одной назначенных зон закрепления. Доступные опции: "Да", "Нет" или "Не изменять". Опция "Не изменять" сохраняет последние используемые настройки закрепляемого окна при восстановлении или задании текущим рабочего пространства. | Да
Автоматически убирать с экрана | Сворачивание закрепляемого окна, если оно не используется. Доступные опции: "Вкл", "Откл" или "Не изменять". Опция "Не изменять" сохраняет последние используемые настройки закрепляемого окна при восстановлении или задании текущим рабочего пространства. | Откл
Прозрачность | Прозрачность закрепляемого окна. Доступные опции: "Да", "Нет" или "Не изменять". Опция "Не изменять" сохраняет последние используемые настройки закрепляемого окна при восстановлении или задании текущим рабочего пространства. | Нет
Степень прозрачности | Непрозрачность закрепляемого окна. Допустимый диапазон значений — от 0 до 100. | 0
Группа по умолчанию | Отображение пользовательских групп палитр. | Все палитры
Высота | Высота закрепляемого окна при перетаскивании. | 598
Ширина | Ширина закрепляемого окна при перетаскивании. | 172
Изменение свойств панели

Панели можно переключать в закрепленный режим и в плавающий режим. Можно определить размер, положение или внешний вид панелей инструментов, изменив их свойства в панели "Содержимое рабочих пространств" в редакторе настройки пользовательского интерфейса.

Импорт рабочего пространства в основной файл НПИ

Рабочие пространства в частичных файлах НПИ игнорируются основным файлом НПИ, даже если частичный файл НПИ загружен в основной. Можно импортировать рабочее пространство в основной файл НПИ с помощью вкладки "Перемещение" редактора настройки пользовательского интерфейса.

Отображение панели инструментов во всех рабочих пространствах

При создании панель инструментов можно добавить во все рабочие пространства, выбрав "Показать" (значение по умолчанию) в поле "По умолчанию вкл." на панели "Свойства". Выбор параметра "Показать" приведет к тому, что панель буде отображаться во всех выбранных рабочих пространствах.

Установка рабочего пространства по умолчанию

Рабочие пространства в фале НПИ могут быть помечены как используемые по умолчанию. Это определяет, какое рабочее пространство в файле НПИ следует восстанавливать при его загрузке в первый раз или после загрузки файла НПИ с помощью команды НПИЗАГР.

См. также

Задание параметров интерфейса в Руководстве пользователя

Создание рабочего пространства с помощью редактора настройки пользовательского интерфейса (Процедура)

Создание рабочего пространства с помощью панели "Рабочее пространство" (Процедура)

Изменение свойств рабочего пространства (Процедура)

Отображение раскрывающихся меню в строке меню (Процедура)

Изменение позиции раскрывающегося меню в строке меню (Процедура)

Отображение панелей (Процедура)

Изменение свойств панели инструментов (Процедура)

Изменение свойств закрепляемого окна (Процедура)

Копирование рабочего пространства (Процедура)

Установка рабочего пространства текущим (Процедура)

Установка рабочего пространства по умолчанию (Процедура)

Восстановление рабочего пространства с помощью атрибута командной строки (Процедура)

Импорт рабочего пространства в основной файл НПИ (Процедура)


Настройка рабочего пространства - Процедуры

Настройка интерфейса пользователя
Настройка рабочего пространства
Понятия
Процедуры
Команды

Создание рабочего пространства с помощью редактора настройки пользовательского интерфейса

Создание рабочего пространства с помощью панели "Рабочее пространство"

Изменение свойств рабочего пространства

Отображение раскрывающихся меню в строке меню

Изменение позиции раскрывающегося меню в строке меню

Отображение панелей

Изменение свойств панели инструментов

Изменение свойств закрепляемого окна

Копирование рабочего пространства

Установка рабочего пространства текущим

Установка рабочего пространства по умолчанию

Восстановление рабочего пространства с помощью атрибута командной строки

Импорт рабочего пространства в основной файл НПИ


Создание рабочего пространства с помощью редактора настройки пользовательского интерфейса - Процедуры

Настройка интерфейса пользователя
Настройка рабочего пространства
Понятия
Процедуры
Команды

Создание рабочего пространства с помощью редактора настройки пользовательского интерфейса

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройки в <имя файла>" нажмите правой кнопкой мыши узел "Рабочие пространства" и выберите "Создать" » "Рабочее пространство".

    3. Новое, пустое рабочее пространство (с именем "РабочееПространство1") помещается в нижнюю часть дерева "Рабочие пространства".

  3. Выполните одно из следующих действий:
    • Введите новое имя вместо текста "РабочееПространство1".
    • Нажатием правой кнопки мыши выберите надпись "РабочееПространство1". Выберите "Переименовать". Затем введите новое имя рабочего пространства.
  4. В панели "Содержимое рабочего пространства" выберите "Настройка рабочего пространства".

  5. На панели "Настройки в <имя файла>" нажав значок "плюс" (+) рядом с узлом, разверните дерево "Панели", дерево "Меню" или дерево "Частичные файлы НПИ".

    6. Примечание В узлах меню, панели инструментов и файла НПИ теперь отображаются флажки. Таким образом, можно легко добавлять элементы в рабочее пространство.

  6. Установите флажок рядом с меню, панелью инструментов или частичным файлом НПИ, если необходимо добавить его в рабочее пространство.

    7. В панели "Содержимое рабочего пространства" выбранные элементы добавляются в рабочее пространство.

  7. В панели "Содержимое рабочего пространства" нажмите кнопку "Выполнено".

  8. По завершении нажмите кнопку OK.


Создание рабочего пространства с помощью панели "Рабочее пространство" - Процедуры

Настройка интерфейса пользователя
Настройка рабочего пространства
Понятия
Процедуры
Команды

Создание рабочего пространства с помощью панели "Рабочее пространство"

  1. Нажмите правую кнопку мыши на панели инструментов, отображаемой в этот момент интерфейсом AutoCAD.

    2. Контекстное меню отображается с доступными панелями инструментов, содержащимися в группе настройке, к которым они принадлежат.

  2. Если панель инструментов не отображается, нажмите "Рабочие пространства".

    3. Слева от любой отображаемой панели имеется флажок.

  3. Выполните необходимые измерения размера, местоположения и измените другие свойства панелей инструментов и закрепляемых окон.
  4. На панели "Рабочие пространства" выберите "Сохранить текущее как".

  5. В диалоговом окне "Сохранить рабочее пространство" введите имя в текстовом поле или выберите существующее имя из раскрывающегося списка, чтобы перезаписать это рабочее пространство.

  6. Нажмите кнопку "Сохранить", чтобы создать или изменить рабочее пространство.

Примечание Панель "Рабочие пространства" отобразится после восстановления рабочего пространства. Если не требуется отображать панель инструментов "Рабочие пространства", выберите в меню "Средства" » "Рабочие простнаства" » "Сохранить текущие как". Открывается диалоговое окно "Сохранение рабочего пространства".


Изменение свойств рабочего пространства - Процедуры

Настройка интерфейса пользователя
Настройка рабочего пространства
Понятия
Процедуры
Команды

Изменение свойств рабочего пространства

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса перейдите на вкладку "Настройка".
  3. В панели "Настройки в <имя файла>" вкладки "Настройка" выберите рабочее пространство, свойства которого необходимо изменить.

  4. В панели "Свойства" выполните любое из следующих действий.
    • В поле "Имя" введите новое имя для рабочего пространства.
    • В поле "Пояснение" введите необходимое пояснение.
    • В поле "Начало в" выберите вариант ("Модель", "Лист", "Не изменять").
    • В поле " Вкладка модели и листа" выберите необходимый параметр ("Вкл", "Откл", "Не изменять").
    • В поле "Экранные меню" выберите необходимый параметр ("Вкл", "Откл", "Не изменять").
    • В поле "Полосы прокрутки" выберите необходимый параметр ("Вкл", "Откл", "Не изменять").

  5. По завершении нажмите кнопку OK.


Отображение раскрывающихся меню в строке меню - Процедуры

Настройка интерфейса пользователя
Настройка рабочего пространства
Понятия
Процедуры
Команды

Отображение раскрывающихся меню в строке меню

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройка в <имя файла>" нажмите значок "плюс" (+) рядом с узлом "Рабочие пространства".
  3. Выберите рабочее пространство, которое требуется изменить.

  4. В панели "Содержимое рабочего пространства" выберите "Настройка рабочего пространства".

  5. На панели "Настройки в <имя файла>", нажав значок "плюс" (+) рядом с узлом "Меню" или узлом дерева "Частичные файлы НПИ", разверните их.
  6. Установите флажок рядом с каждым меню или частичным файлом НПИ, которые необходимо добавить в рабочее пространство.

    7. В панели "Содержимое рабочего пространства" выбранные элементы добавляются в рабочее пространство.

  7. В панели "Содержимое рабочего пространства" нажмите кнопку "Выполнено".

    8. Примечание Не забудьте установить это рабочее пространство текущим, чтобы были видны внесенные изменения.

  8. По завершении нажмите кнопку OK.


Изменение позиции раскрывающегося меню в строке меню - Процедуры

Настройка интерфейса пользователя
Настройка рабочего пространства
Понятия
Процедуры
Команды

Изменение позиции раскрывающегося меню в строке меню

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройка в <имя файла>" нажмите значок "плюс" (+) рядом с узлом "Рабочие пространства".
  3. Выберите рабочее пространство, которое требуется изменить.

  4. На панели "Содержимое рабочих пространств" нажмите и удерживайте нажатой кнопку указателя мыши на раскрывающемся меню, которое требуется переместить, а затем перетащите его в новую позицию.

    5. Между раскрывающимися меню будет отображаться разделяющая полоска, указывающая местоположение, куда переместится раскрывающееся меню, когда кнопка будет отпущена.

  5. Установив разделитель в положение, где требуется вставить раскрывающееся меню, отпустите кнопку указующего устройства.

    6. Примечание Не забудьте установить это рабочее пространство текущим, чтобы были видны внесенные изменения.

  6. По завершении нажмите кнопку OK.


Отображение панелей - Процедуры

Настройка интерфейса пользователя
Настройка рабочего пространства
Понятия
Процедуры
Команды

Отображение панелей

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройка в <имя файла>" нажмите значок "плюс" (+) рядом с узлом "Рабочие пространства".
  3. Выберите рабочее пространство, которое требуется изменить.

  4. В панели "Содержимое рабочего пространства" выберите "Настройка рабочего пространства".

  5. На панели "Настройки в <имя файла>" нажав значок "плюс" (+) рядом с узлом, разверните дерево "Панели" или дерево "Частичные файлы НПИ.
  6. Установите флажок рядом с каждой панелью или частичным файлом НПИ, которые необходимо добавить в рабочее пространство.

    7. В панели "Содержимое рабочего пространства" выбранные элементы добавляются в рабочее пространство.

  7. В панели "Содержимое рабочего пространства" нажмите кнопку "Выполнено".

    8. Примечание Не забудьте установить это рабочее пространство текущим, чтобы были видны внесенные изменения.

  8. По завершении нажмите кнопку OK.


Изменение свойств панели инструментов - Процедуры

Настройка интерфейса пользователя
Настройка рабочего пространства
Понятия
Процедуры
Команды

Изменение свойств панели инструментов

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройка в <имя файла>" нажмите рабочее пространство, содержащее панель инструментов, которую требуется изменить.

  3. В панели "Содержимое рабочего пространства" нажмите на значке "плюс" (+) рядом с элементом "Панели", чтобы открыть список.
  4. Выберите панель, которую необходимо изменить.

  5. В панели "Свойства" выполните любое из следующих действий.
    • В поле "Ориентация" выберите необходимый параметр ("Плавающая", "Верх", "Низ", "Слева" или "Справа").
    • (Только если в поле "Ориентация" задано значение "Плавающая") В поле "Координата Х по умолчанию" введите число. Значение 0 соответствует расположению панели в начале координат в левой части экрана, а по мере увеличения номеров, панель будет смещаться все дальше вправо.
    • (Только если в поле "Ориентация" задано значение "Плавающая") В поле "Координата Y по умолчанию" введите число. Значение 0 соответствует расположению панели в начале координат в верхней части экрана, а по мере увеличения номеров, панель будет смещаться все дальше вниз.
    • (Только если в поле "Ориентация" задано значение "Плавающая") В поле "Ряды" укажите число. Укажите число, которое будет определять, на сколько рядов (если это возможно) должны распределяться отображаемые на панели кнопки. Значение по умолчанию - 0.

  6. По завершении нажмите кнопку OK.


Изменение свойств закрепляемого окна - Процедуры

Настройка интерфейса пользователя
Настройка рабочего пространства
Понятия
Процедуры
Команды

Изменение свойств закрепляемого окна

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройка в <имя файла>" нажмите рабочее пространство, содержащее закрепляемое окно, которое требуется изменить.

  3. В панели "Содержимое рабочего пространства" нажмите на значке "плюс" (+) рядом с элементом "Закрепляемые окна", чтобы открыть список.
  4. Выберите окно, которое необходимо изменить.

  5. В панели "Свойства" выполните любое из следующих действий.
    • В поле "Показать" выберите необходимый параметр ("Нет", "Да" или "Не изменять").
    • В поле "Ориентация" выберите необходимый параметр ("Плавающая", "Верх", "Низ", "Слева" или "Справа").
    • В поле "Разрешить закрепление" выберите необходимый параметр ("Нет", "Да" или "Не изменять").

      • Примечание Чтобы указать необходимость привязки окна, установите в поле "Ориентация" значения "Слева", "Справа", "Верх", "Низ", а также установите значение "Вкл" в поле "Автоматически убирать с экрана".

    • В поле "Автоматически убирать с экрана" выберите необходимый параметр ("Вкл", "Откл" или "Не изменять").
    • В поле "Использовать прозрачность" выберите необходимый параметр ("Нет", "Да" или "Не изменять").
    • В поле "Степень прозрачности" введите численное значение (если требуется).
    • (Только для инструментальных палитр) В поле "Группа по умолчанию" выберите группу инструментальных палитр.
    • В поле "Высота" введите значение высоты. Значение 0 соответствует параметру "Не изменять".
    • В поле "Ширина" введите значение ширины. Значение 0 соответствует параметру "Не изменять".

  6. По завершении нажмите кнопку OK.


Копирование рабочего пространства - Процедуры

Настройка интерфейса пользователя
Настройка рабочего пространства
Понятия
Процедуры
Команды

Копирование рабочего пространства

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" в панели "Настройка в <имя файла>" нажмите значок "плюс" (+) рядом с узлом "Рабочие пространства".
  3. Нажатием правой кнопки мыши выберите рабочее пространство. Выберите "Копировать рабочее пространство".

    4. Дубликат рабочего пространства ( с названием "Копия <имя рабочего пространства>") помещается в нижнюю часть дерева рабочих пространств.

  4. Выполните одно из следующих действий:
    • Введите новое имя поверх текста "Копия <имя рабочего пространства>".
    • Нажатием правой кнопки мыши выберите "Копия <имя рабочего пространства>. Выберите "Переименовать". Введите новое имя для рабочего пространства.
  5. Измените рабочее пространство, если необходимо.
  6. По завершении нажмите кнопку OK.


Установка рабочего пространства текущим - Процедуры

Настройка интерфейса пользователя
Настройка рабочего пространства
Понятия
Процедуры
Команды

Установка рабочего пространства текущим

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" нажмите значок "плюс" (+) рядом с узлом "Рабочие пространства".
  3. Нажатием правой кнопки мыши выберите рабочее пространство, которое необходимо установить как текущее. Нажмите кнопку "Установить".

  4. Нажмите ОК.


Установка рабочего пространства по умолчанию - Процедуры

Настройка интерфейса пользователя
Настройка рабочего пространства
Понятия
Процедуры
Команды

Установка рабочего пространства по умолчанию

  1. Выберите в меню "Сервис" » "Настройка" » "Интерфейс".
  2. В редакторе настройки пользовательского интерфейса на вкладке "Настройка" нажмите значок "плюс" (+) рядом с узлом "Рабочие пространства".
  3. Нажатием правой кнопки мыши выберите рабочее пространство, которое необходимо установить по умолчанию. Нажмите кнопку "Установить по умолчанию".

  4. Нажмите ОК.

Примечание Основной и корпоративный файлы НПИ можно задать в мастере сетевого развертывания. Если для основного файла НПИ имеется рабочее пространство по умолчанию, это рабочее пространство будет установлено в качестве текущего при первой загрузке файла в AutoCAD.


Восстановление рабочего пространства с помощью атрибута командной строки - Процедуры

Настройка интерфейса пользователя
Настройка рабочего пространства
Понятия
Процедуры
Команды

Восстановление рабочего пространства с помощью атрибута командной строки

  1. На рабочем столе Windows нажмите правую кнопку мыши на значке программы. Нажмите кнопку "Свойства".

  2. В поле "Объект " вкладки "Ярлык" диалогового окна "Свойства AutoCAD" измените параметры атрибута, используя следующий синтаксис:

    3. “устройство:путь\acad.exe” [“имя чертежа”] [/атрибут “имя”]

    Например, введите “d:\AuroCAD 2007\acad.exe” /w “Мое_рабочее_пространство”

  3. Нажмите ОК.


Импорт рабочего пространства в основной файл НПИ - Процедуры

Настройка интерфейса пользователя
Настройка рабочего пространства
Понятия
Процедуры
Команды

Импорт рабочего пространства в основной файл НПИ

  1. Выберите в меню "Сервис" » "Настройка" » "Импорт настроек".

    2. Файл НПИ отобразится в панели "Настройки в" (слева) на вкладке "Передача").

  2. На вкладке "Передача" в панели "Настройки в <имя файла>" (справа) нажмите кнопку "Открыть файл настройки".

  3. В диалоговом окне "Открытие файла" найдите и выберите файл частичной настройки, содержащий рабочее пространство, которое требуется добавить.
  4. В правой панели перетащите рабочее пространство из файла НПИ в узел "Рабочие пространства" в основном файле НПИ (левая панель).

  5. Нажмите ОК.


Настройка рабочего пространства - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Настройка рабочего пространства
Понятия
Процедуры
Команды

Команды
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
НПИВЫГР | Выгружает файл НПИ
НПИЗАГР | Загружает файл НПИ
НПИИМПОРТ | Импортирует пользовательские настройки из файла НПИ предприятия или частичного файла CUI в файл acad.cui.
НПИЭКСПОРТ | Экспортирует пользовательские настройки из файла acad.cui а файл частичной адаптации или в файл CUI предприятия.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Вопросы и ответы по настройке интерфейса пользователя - Понятия

Настройка интерфейса пользователя
Вопросы и ответы по настройке интерфейса пользователя
Понятия
Процедуры
Команды

В этом разделе можно найти ответы на наиболее часто задаваемые вопросы о том, как использовать редактор настройки интерфейса пользователя.

Перенос и обновление

Вопрос:как можно перенести настройку из предыдущей версии в новую?

Ответ: в предыдущих версиях для этого использовался текстовый редактор, например, Блокнот. В редакторе НПИ можно использовать вкладку "Передача", чтобы просмотреть и выбрать файл MNS, MNU или НПИ, содержащий настройку меню. Выбрав предыдущий файл настройки, можно перетаскивать элементы интерфейса между двумя файлами НПИ. Подробнее см. раздел Передача настроек .

Команды

Вопрос: как создать новую команду и добавить ее к элементу интерфейса пользователя, например, к раскрывающемуся меню?

Ответ: команды создаются и управляются при помощи панели "Список команд", расположенной в левом нижнем углу вкладки "Настройка" в редакторе НПИ. Подробнее см. раздел Создание команды.

После создания команды ее можно добавить или использовать для создания различных элементов пользовательского интерфейса. Например, для добавления команды в раскрывающееся меню разверните меню в узле "Меню" в панели "Настройки в <имя файла>", в которое требуется добавить команду, а затем перетащите команду в это меню. Подробнее см. раздел Создание раскрывающегося меню.

Раскрывающиеся меню

Вопрос: почему созданные раскрывающиеся меню не отображаются в строке меню?

Ответ: для управления отображением раскрывающихся меню в строке меню используются рабочие пространства. Подробнее см. раздел Отображение раскрывающихся меню в строке меню.

Вопрос: как изменить порядок раскрывающихся меню?

Ответ: для управления позиционированием раскрывающихся меню в строке меню используются рабочие пространства. Подробнее см. раздел Изменение позиции раскрывающегося меню в строке меню.

Панели

Вопрос: почему панели инструментов не остаются на том же месте после перезапуска AutoCAD 2007?

Ответ: это происходит из-за способа загрузки меню во время запуска AutoCAD. Эта проблема возникает только в тех случаях, когда используются частичные файлы НПИ и корпоративные файлы настройки. Чтобы решить эту проблему необходимо использовать новый атрибут командной строки. При этом AutoCAD 2007 повторно инициализирует рабочее пространство после запуска и размещает панели инструментов в нужное положение. Подробнее см. раздел Восстановление рабочего пространства с помощью атрибута командной строки.

Вопрос: почему после переноса значков на панели с помощью вкладки "Передача" редактора НПИ на них отображается облако со знаком вопроса?

Ответ: изображения для пользовательских значков не расположены в папках поддержки AutoCAD. Найдите изображения с помощью проводника Windows и добавьте их к узлу "Путь поиска вспомогательных файлов" на вкладке "Файлы" в диалоговом окне "Настройка" или скопируйте файлы в папку C:\Documents and Settings\<имя пользовательского профиля>\Application Data\Autodesk\<имя программы>\<номер версии>\<язык>\Support\Icons.

Рабочие пространства

Вопрос: почему изменения не отображаются после того как нажата кнопка "Применить"?

Ответ: это происходит из-за того, что рабочее пространство, в котором выполнены изменения, в данный момент не активировано (не является текущим). Для решения данной проблемы необходимо установить это рабочее пространство в качестве текущего, а затем, после применения изменений, они будут отображаться. Дополнительную информацию см. в Установка рабочего пространства текущим.

Корпоративные Файлы НПИ

Вопрос: как редактировать корпоративный файл НПИ, если в редакторе НПИ он доступен только для чтения?

Ответ: корпоративный файл НПИ можно редактировать, если он загружен в качестве основного файла НПИ или в качестве частичного файла НПИ к основному файлу НПИ. Для редактирования рекомендуется загружать этот файл в качестве основного файла НПИ. При создании рабочего пространства, требующего включения элементов пользовательского интерфейса из файла НПИ, назначенного основных, загрузите основной файл НПИ как корпоративный. Выполните измерения в корпоративном файле НПИ. Подробнее см. раздел Изменение корпоративного файла НПИ.


Настройка интерфейса пользователя
Настройка интерфейса пользователя
Понятия
Процедуры
Команды

Нет процедур.


Вопросы и ответы по настройке интерфейса пользователя - Команды

Настройка интерфейса пользователя
Настройка интерфейса пользователя
Вопросы и ответы по настройке интерфейса пользователя
Понятия
Процедуры
Команды

Команды
МЕНЮ | Загружает файл адаптации
НАСТРОЙКА | Параметры данной вкладки служат для пользовательской настройки программы
НПИ | Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.
НПИВЫГР | Выгружает файл НПИ
НПИЗАГР | Загружает файл НПИ
НПИЭКСПОРТ | Экспортирует пользовательские настройки из файла acad.cui а файл частичной адаптации или в файл CUI предприятия.
Системные переменные
ENTERPRISEMENU | Сохраняет имя файла НПИ (если определено), включая путь.
MENUNAME | Хранит имя файла адаптации, включая путь
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


DIESEL - Понятия

DIESEL
Понятия
Процедуры
Команды

Выражения DIESEL (Direct Interpretively Evaluated String Expression Language) всегда принимают на вход и возвращают строки. DIESEL можно использовать в макросах меню и для отображения сведений в строке состояния.

  • Настройка строки состояния
    С помощью переменной MODEMACRO данные можно отобразить в строке состояния.
  • Выражения DIESEL в макросах
    Строковые выражения DIESEL можно использовать в файлах настройки (НПИ) в качестве дополнительного метода создания макросов.
  • USERS1-5 Каталог функций языка DIESEL
    Функции языка DIESEL позволяют получать сведения о состоянии программы, выполнять вычисления и выводить информацию на экран. Каждая функция может иметь не более 10 параметров (в число параметров включается и ее имя). Превышение этого предела приводит к выдаче сообщения об ошибке.
  • Сообщения об ошибках языка DIESEL
    Обычно поиск ошибок в DIESEL-выражениях не требует излишних затрат времени. В выходной поток программы включаются специальные сообщения, формат которых определяется типом допущенной ошибки.


DIESEL - Процедуры

DIESEL
Понятия
Процедуры
Команды

Нет процедур для этой темы.


DIESEL - Команды

DIESEL
Понятия
Процедуры
Команды
Команды
УСТПЕРЕМ | Вывод списка системных переменных, изменение их значений
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
MODEMACRO | Отображает текстовую последовательность в статусной строке; например, имя текущего чертежа, время и дата или специальные режимы.
USERS1-5 | Обеспечивает хранение и получение данных текстовой строки
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Настройка строки состояния - Понятия

DIESEL
Настройка строки состояния
Понятия
Процедуры
Команды

С помощью переменной MODEMACRO данные можно отобразить в строке состояния.

  • Системная переменная MODEMACRO
  • Присвоение значений MODEMACRO
    Для отображения пользовательской информации в строке состояния можно использовать обычные текстовые строки и функции языка DIESEL.
  • Присвоение значений MODEMACRO в AutoLISP
    Для установки значений переменной MODEMACRO может также быть использован AutoLISP.


Настройка строки состояния - Процедуры

DIESEL
Настройка строки состояния
Понятия
Процедуры
Команды

Нет процедур для этой темы.


Настройка строки состояния - Команды

DIESEL
Настройка строки состояния
Понятия
Процедуры
Команды
Команды
УСТПЕРЕМ | Вывод списка системных переменных, изменение их значений
Системные переменные
MODEMACRO | Отображает текстовую последовательность в статусной строке; например, имя текущего чертежа, время и дата или специальные режимы.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Системная переменная MODEMACRO - Понятия

DIESEL
Системная переменная MODEMACRO
Понятия
Процедуры
Команды

В строке состояния отображаются важные информационные сведения; они служат дополнением к основному диалогу с пользователем. Системная переменная MODEMACRO управляет отображением пользовательской информации в строке состояния. Вычисленное значение системной переменной MODEMACRO выводится слева в поле строки состояния, которая расположена в нижней части окна AutoCAD®. Начальным значением переменной является пустая строка; это значение устанавливается при запуске AutoCAD. Переменная не сохраняется нигде — ни в чертеже, ни в файле настройки.

Количество символов, которое может быть отображено в строке состояния, ограничено лишь размером окна AutoCAD и возможностями используемого монитора. Если значение переменной MODEMACRO имеет достаточно большую длину, все остальные элементы строки состояния смещаются вправо. В принципе, они могут даже скрываться за пределами экрана.

С помощью переменной MODEMACRO можно отобразить в строке состояния большинство данных, воспринимаемых программой AutoCAD. Использование этой переменной таит в себе богатые возможности для конфигурирования строки состояния в соответствии с нуждами пользователя.

Значение переменной MODEMACRO задается пользователем. Ей можно присвоить любое строковое значение. Максимальная длина строки - 4095 символов. Для задания значения переменной MODEMACRO можно воспользоваться командой УСТПЕРЕМ или ввести modemacro в командной строке. Модификация значения MODEMACRO, выполняемая вручную, удобна для экспериментов с различными форматами строки состояния; однако, при этом можно ввести не более 255 символов.

Если MODEMACRO присвоена пустая строка (для этого пользователь должен ввести точку в ответ на запрос значения), AutoCAD отображает стандартную строку состояния.


Настройка строки состояния

DIESEL
Настройка строки состояния
Понятия
Процедуры
Команды

Нет процедур.


Системная переменная MODEMACRO - Команды

DIESEL
DIESEL
Системная переменная MODEMACRO
Понятия
Процедуры
Команды

Команды
УСТПЕРЕМ | Вывод списка системных переменных, изменение их значений
Системные переменные
MODEMACRO | Отображает текстовую последовательность в статусной строке; например, имя текущего чертежа, время и дата или специальные режимы.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Присвоение значений MODEMACRO - Понятия

DIESEL
Присвоение значений MODEMACRO
Понятия
Процедуры
Команды

Для отображения пользовательской информации в строке состояния можно использовать обычные текстовые строки и функции языка DIESEL.

Значение переменной MODEMACRO определяет, что должно отображаться в строке состояния. Простейший пример переменной MODEMACRO представляет собой постоянное текстовое значение, однако, в этом случае результативность переменной минимальна. Например, чтобы в строке состояния выводилось название фирмы, которой принадлежит экземпляр программы, можно сделать так:

Команда: modemacro

Новое значение MODEMACRO, или . если нет <"">: Greg's Bank and Grill

В этом случае MODEMACRO всегда отображает один и тот же текст; строка состояния не содержит никаких данных об изменениях внутреннего состояния AutoCAD. Информация обновляется только при следующей модификации MODEMACRO.

Для того чтобы в строке состояния отображались какие-либо текущие параметры AutoCAD, нужно включить в нее макровыражения на языке DIESEL. Макровыражения записываются в следующем формате:

$(функция, арг1, арг2, ...)

Здесь функция это имя DIESEL-функции (аналогичное имени функции AutoLISP), а арг1, арг2 и т.д. ее аргументы, интерпретируемые в соответствии с определением функции. В отличие от функций AutoLISP, макровыражения DIESEL оперируют только одним типом данных - строками. Макросы, которые работают с числами, выражают их в виде строк, преобразуя по мере необходимости.

Описание функций языка DIESEL можно найти в разделе USERS1-5 Каталог функций языка DIESEL.

Создадим более содержательную строку состояния, например, с информацией об имени текущего текстового стиля:

Команда: modemacro

Новое значение MODEMACRO, или . если нет <"">: Стиль: $(getvar, textstyle)

  • Стиль: это текстовая строка, которая будет отображаться в строке состояния.
  • $(getvar,textstyle) DIESEL-функция (getvar) с аргументом, который извлекает имя текущего текстового стиля из системной переменной TEXTSTYLE.

Примечание В тексте некоторых примеров выражения MODEMACRO перенесены на следующую строку из-за своей большой длины. При их вводе, однако, никаких переносов делать не следует.

Чтобы получить значение какой-либо системной переменной, нужно воспользоваться функцией $(getvar, имя_переменной). Текущее значение переменной при этом заменяет то, которое отображалось ранее. При смене текстового стиля инициируется пересчет MODEMACRO. В результате имя нового текущего стиля появляется в строке состояния.

Выражения могут быть вложенными и достаточно сложными. Рассмотрим еще один пример. Пусть в строке состояния требуется отобразить текущий интервал и угол (в градусах) шаговой привязки. Преобразование угла из радиан в градусы и отсечение дробной части может быть осуществлено с помощью вложенных выражений.

Команда: modemacro

Новое значение MODEMACRO, или . если нет <"">: Шаг: $(getvar, snapunit) $(fix,$(*,$(getvar,snapang),$(/,180,3.14159)))

Другой вариант — отображение значений в текущих линейных и угловых форматах единиц.

Команда: modemacro

Новое значение MODEMACRO, или . если нет <"">: Шаг: $(rtos,$(index,0,

$(getvar,snapunit))),$(rtos,$(index,1,$(getvar,snapunit))) $(angtos,

$(getvar,snapang))

$(getvar,snapang)) DIESEL передает все введенные данные непосредственно на выход, пока не встретит знак доллара ($) или строку в кавычках. Строки в кавычках можно использовать для подавления вычисления последовательности символов, которые без кавычек интерпретировались бы как DIESEL-функции. Если требуется использовать кавычки внутри таких строк, нужно повторять их дважды. В следующем примере текущим слоем является LAYOUT, а MODEMACRO иллюстрирует, как происходит получение значения переменной CLAYER:

Команда: modemacro

Новое значение MODEMACRO, или . если нет <"">:?"$(getvar,clayer)= """$(getvar,clayer)""""

В строке состояния выводится:

$(getvar,clayer)="LAYOUT"


Присвоение значений MODEMACRO - Команды

DIESEL
DIESEL
Присвоение значений MODEMACRO
Понятия
Процедуры
Команды

Команды
УСТПЕРЕМ | Вывод списка системных переменных, изменение их значений
Системные переменные
MODEMACRO | Отображает текстовую последовательность в статусной строке; например, имя текущего чертежа, время и дата или специальные режимы.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Присвоение значений MODEMACRO в AutoLISP - Понятия

DIESEL
Присвоение значений MODEMACRO в AutoLISP
Понятия
Процедуры
Команды

Приведенные здесь образцы процедур можно скопировать в файл формата ASCII, который должен загружаться функцией AutoLISP load.

В следующей команде, написанной на AutoLISP, определяется выражение для MODEMACRO, которое несет в себе ту же информацию, что и стандартная строка состояния. Так как в AutoLISP нет возможности переносить строки, для объединения отдельных выражений в одну строку MODEMACRO используется функция AutoLISP strcat.

(defun C:ACADMODE ( )
            (setvar "modemacro"
                (strcat
                 "Слой $(substr,$(getvar,clayer),1,8)"
                 "$(if,$(getvar,orthomode), Орто)"
                 "$(if,$(getvar,snapmode), Шаг)"
                 "$(if,$(getvar,tabmode), Планшет)"
                 "$(if,$(=,$(getvar,tilemode),0),"
                   "$(if,$(=,$(getvar,cvport),1), P)"
                 ")"
              )
            )
)

Эту AutoLISP-процедуру можно записать в файл с именем acadmode.lsp. При его загрузке будет создаваться строка состояния, являющаяся аналогом стандартной строки. Данный пример не является особо полезным применением возможностей MODEMACRO; он включен в руководство лишь в иллюстративных целях.

В следующем образце файла acad.lsp используется функция S::STARTUP для присвоения переменной MODEMACRO значения, определяемого в файле mode1.lsp.

;;; Образец файла acad.lsp, использующий S::STARTUP для загрузки
;;; файла MODE1.LSP, где определяется строка для MODEMACRO
(defun S::STARTUP ( )
            (load "mode1")
            (princ)
)
;;; Далее могут определяться и загружаться другие ;;; AutoLISP-файлы
;;; загружены здесь

Если загружен файл AutoLISP (mode1.lsp), системная переменная MODEMACRO используется для определения содержимого строки состояния, в которой отображается приведенная далее последовательность. L: первые восемь символов имени слоя, имя чертежа и часть пути, а также первая буква имени каждого текущего режима. Независимо от длины имени слоя, положение имени чертежа остается неизменным.

;;; MODE1.LSP
;;;
(setvar "modemacro"
  (strcat
    "L:$(substr,$(getvar,clayer),1,30)"
    "$(substr, ,1,$(-,30,$(strlen,$(getvar,clayer)))) "
;; ^^^^^^^^ Здесь записано 8 пробелов
    "<.."
      "$(if,$(eq,$(getvar,dwgname),UNNAMED),UNNAMED,"
        "$(substr,$(getvar,dwgname),"
          "$(if,$(>,$(strlen,$(getvar,dwgprefix)),29),"
            "$(-,$(strlen,$(getvar,dwgprefix)),29),1"
          "),"
          "$(strlen,$(getvar,dwgname))"
        ")"
      ")"
    ">"
    "$(if,$(getvar,orthomode), O, )"
    "$(if,$(getvar,snapmode), S, )"
    "$(if,$(getvar,tabmode), T, )"
    "$(if,$(and,"
      "$(=,$(getvar,tilemode),0),$(=,$(getvar,cvport),1)),P)"
  )
)

Запись выражений с отступами от начала строки улучшает понимание текста программы (в частности, DIESEL-строк и файлов AutoLISP).


Присвоение значений MODEMACRO в AutoLISP - Команды

DIESEL
DIESEL
Присвоение значений MODEMACRO в AutoLISP
Понятия
Процедуры
Команды

Команды
УСТПЕРЕМ | Вывод списка системных переменных, изменение их значений
Системные переменные
MODEMACRO | Отображает текстовую последовательность в статусной строке; например, имя текущего чертежа, время и дата или специальные режимы.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Выражения DIESEL в макросах - Понятия

DIESEL
Выражения DIESEL в макросах
Понятия
Процедуры
Команды

Эти выражения могут возвращать строковые значения (текстовые строки) в ответ на стандартные команды AutoCAD, процедуры AutoLISP и ObjectARX®, а также другие макросы. Они также могут возвращать строковые значения в меню, что часто используется для изменения вида и содержимого имен пунктов.

С помощью этой строки можно переключаться из пространства листа в пространство модели и обратно (если для переменной TILEMODE установлено значение 0). Выражение вычисляется прозрачно. Если пропустить специальный символ ^P, который переключает переменную MENUECHO, выражение DIESEL будет отображать в командной строке только вызванную команду.

При использовании DIESEL-выражений в пунктах меню требуется соблюдать формат "$раздел=подменю", где раздел - буква M, а подменю - требуемое DIESEL-выражение. Зачастую макросы меню проще реализовать на языке AutoLISP.

В следующих примерах показаны два аналогичных по назначению пункта меню, в одном из которых использован DIESEL, а в другом AutoLISP.

DIESEL-выражение в пункте меню:

^C^C^P$M=$(if,$(=,$(getvar,cvport),1),mspace,pspace)

AutoLISP-выражение в пункте меню:

^C^C^P(if (= (getvar "cvport") 1)(command "mspace")+
(command "pspace"))(princ) ^P

Оба пункта меню позволяют переключаться из пространства листа в пространство модели и обратно (если TILEMODE равна 0), но выражение DIESEL короче и вычисляется прозрачно, не требуя вызова функции AutoLISP princ. Если в обоих случаях пропустить специальный символ ^P, который переключает переменную MENUECHO, выражение DIESEL будет отображать в командной строке только вызванную команду, а выражение AutoLISP всю строку выражения.

Так как значение, возвращаемое выражением DIESEL, является текстовой строкой, его можно использовать в ответах на запросы функций AutoLISP getxxx. Это позволяет вычислять в пунктах меню режимы текущего чертежа и возвращать соответствующие значения в AutoLISP-процедуры.

Приведенный в примере ниже фрагмент меню включен в текущее меню.

  • Приведенная в примере ниже AutoLISP-процедура загружена в память.
  • Фрагмент НПИ включается в текущий файл настройки.
  • Ширина и высота вставляемых обозначений составляет одну единицу.
  • Значение переменной DIMSCALE установлено равным масштабу чертежа (т.е. при вычерчивании в масштабе 1 мм = 10 см масштаб равен 100, а при 1 мм = 2 м масштаб равен 2000).

Если загрузить и выполнить приведенный пример процедуры AutoLISP, AutoCAD вставит символ заданного размера в указанную точку. Символы будут выведены на печать с нужным размером (при условии вычерчивания в масштабе, указанном в переменной DIMSCALE).

Процедура на AutoLISP выглядит так:

(defun C:SYMIN ( )
  (setq sym
    (getstring
      "\nВведите имя символа: ") ; Запрос имени символа
  )
  (menucmd "s=symsize") ; Переключение экранного меню
                               ; на подменю symsize
  (setq
    siz (getreal
      "\nВыберите размер символа: ") ; Запрос размера символа
    p1 (getpoint
      "\nТочка вставки: ") ; Запрос точки вставки
  )
  (command "insert" ; Команда ВСТАВИТЬ
    sym ; с указанными
    p1 siz siz 0) ; параметрами
  (menucmd "s=") ; Возврат к предыдущему
                               ; экранному меню
  (princ) ; Тихий выход
)

Примечание Реальный вариант AutoLISP-процедуры должен включать в себя контроль ошибок для проверки корректности введенных пользователем данных.

Выражения DIESEL, приведенные ниже, умножают указанное пользователем значение на текущее значение переменной DIMSCALE и возвращают полученный масштабный коэффициент.

Этого невозможно достичь с помощью аналогичных кодов AutoLISP, поскольку, как правило, возвращаемые ими значения не воспринимаются в качестве ответов на запросы функций getxxx (например, функции getreal в предыдущем примере).

$M=$(*,$(getvar,dimscale),0.375)
$M=$(*,$(getvar,dimscale),0.5)
$M=$(*,$(getvar,dimscale),0.625)

DIESEL-выражения могут также возвращать строковые значения в имена пунктов раскрывающихся меню, что позволяет делать пункты недоступными или каким-либо другим способом менять их внешний вид. При использовании DIESEL-выражения в раскрывающемся меню следует убедиться, что первым символом пункта является $.

Пусть текущим слоем чертежа является BASE, а в качестве метки используется следующее выражение DIESEL.

$(eval,"Текущий слой: " $(getvar,clayer))

В результате данный пункт раскрывающегося меню будет отображать имя текущего слоя (с немедленным обновлением при его смене).

Текущий слой: BASE

Такой же способ можно использовать для интерактивной модификации имен пунктов раскрывающихся меню. Процедура, написанная на AutoLISP, может, например, присвоить текст с нужным именем одной из переменных USERS1-5, а DIESEL-макрос извлечь его и подставить в меню.

Примечание Ширина раскрывающихся и контекстных меню определяется в момент загрузки файла настройки. Имена пунктов, генерируемые или изменяемые с помощью DIESEL-выражений после загрузки меню, будут усекаться до длины строки меню.

Если есть опасность того, что сгенерированные с помощью DIESEL пункты меню будут иметь избыточную длину, проблему можно решить с помощью описанного ниже подхода. Здесь в пункте меню отображаются первые 10 символов текущего значения системной переменной USERS3 (USERS1-5).

$(eval,"Текущее значение: " $(getvar,users3))+
 $(if, $(eq,$(getvar,users3),""), 10 пробелов )^C^Cusers3

Для увеличения ширины меню нельзя добавлять пробелы в конец имен пунктов, т.к. завершающие пробелы игнорируются при загрузке меню. Пробелы, используемые для увеличения ширины меню, должны находиться исключительно внутри DIESEL-выражений.

В следующем примере одно и то же DIESEL-выражение применено и в имени пункта меню, и в его макросе. Таким образом можно, например, ввести в чертеж текущие значения даты и времени.

$(edtime,$(getvar,date),DDD", "Д М ГГГГ)^C^Ctext +
\\\ $M=$(edtime,$(getvar,date),DDD", "Д М ГГГГ);

Макросы на языке DIESEL можно использовать также для установки пометки на пунктах меню и для перевода их в недоступное состояние. Ниже приведен пример отключения вызова команды СТЕРЕТЬ на время действия всех других команд. После завершения их выполнения пункт возвращается в нормальное состояние.

$(if,$(getvar,cmdactive),~)ERASE

Подобный подход можно использовать для установки пометки возле имени пункта меню и для интерактивной смены символа, который служит для пометки.


DIESEL
DIESEL
Понятия
Процедуры
Команды

Нет процедур.


Выражения DIESEL в макросах - Команды

DIESEL
DIESEL
Выражения DIESEL в макросах
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
USERS1-5 | Обеспечивает хранение и получение данных текстовой строки
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


USERS1-5 Каталог функций языка DIESEL - Понятия

DIESEL
USERS1-5 Каталог функций языка DIESEL
Понятия
Процедуры
Команды

Функции языка DIESEL позволяют получать сведения о состоянии программы, выполнять вычисления и выводить информацию на экран. Каждая функция может иметь не более 10 параметров (в число параметров включается и ее имя). Превышение этого предела приводит к выдаче сообщения об ошибке.

  • + (сложение)
  • - (вычитание)
  • * (умножение)
  • / (деление)
  • = (равно)
  • < (меньше)
  • > (больше)
  • != (не равно)
  • <= (меньше или равно)
  • >= (больше или равно)
  • и
  • angtos
  • edtime
  • eq
  • eval
  • fix
  • getenv
  • getvar
  • if
  • index
  • nth
  • или
  • rtos
  • strlen
  • substr
  • upper
  • xor


USERS1-5 Каталог функций языка DIESEL - Процедуры

DIESEL
USERS1-5 Каталог функций языка DIESEL
Понятия
Процедуры
Команды

Нет процедур для этой темы.


USERS1-5 Каталог функций языка DIESEL - Команды

DIESEL
USERS1-5 Каталог функций языка DIESEL
Понятия
Процедуры
Команды
Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


+ (сложение) - Понятия

DIESEL
+ (сложение)
Понятия
Процедуры
Команды

Возвращает сумму чисел знач1, знач2, ..., знач9.

$(+, знач1 [, знач2,  …, знач9])

Например, если значение текущей 3D высоты равно 5, следующее DIESEL-выражение вернет 15.

$(+, $(getvar,thickness),10)


USERS1-5 Каталог функций языка DIESEL

DIESEL
USERS1-5 Каталог функций языка DIESEL
Понятия
Процедуры
Команды

Нет процедур.


+ (сложение) - Команды

DIESEL
DIESEL
+ (сложение)
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


- (вычитание) - Понятия

DIESEL
- (вычитание)
Понятия
Процедуры
Команды

Возвращает результат вычитания чисел от знач2 до знач9 из знач1.

$(-, знач1 [, знач2 , …, знач9])


- (вычитание) - Команды

DIESEL
DIESEL
- (вычитание)
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


* (умножение) - Понятия

DIESEL
* (умножение)
Понятия
Процедуры
Команды

Возвращает произведение чисел знач1, знач2, …, знач9.

$(*, знач1 [, знач2, …,знач9])


* (умножение) - Команды

DIESEL
DIESEL
* (умножение)
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


/ (деление) - Понятия

DIESEL
/ (деление)
Понятия
Процедуры
Команды

Возвращает частное от деления числа знач1 на знач2, …, знач9.

$(/, знач1 [, знач2, …, знач9])


/ (деление) - Команды

DIESEL
DIESEL
/ (деление)
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


= (равно) - Понятия

DIESEL
= (равно)
Понятия
Процедуры
Команды

Если числа знач1 и знач2 равны, возвращает 1; иначе возвращает 0.

$(=, знач1, знач2)


= (равно) - Команды

DIESEL
DIESEL
= (равно)
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


< (меньше) - Понятия

DIESEL
< (меньше)
Понятия
Процедуры
Команды

Если число знач1 меньше числа знач2, возвращает 1; иначе возвращает 0.

$(< , знач1, знач2)

Следующее выражение получает текущее значениеHPANG; если это значение меньше, чем значение в системной переменной USERR1, возвращает 1. Если в USERR1 содержится значение 10,0, а текущее значение HPANG составляет 15,5, то следующая строка возвращает 0.

$(<, $(getvar,hpang),$(getvar,userr1))


< (меньше) - Команды

DIESEL
DIESEL
< (меньше)
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


> (больше) - Понятия

DIESEL
> (больше)
Понятия
Процедуры
Команды

Если число знач1 больше чем знач2, возвращает 1; иначе возвращает 0.

$(>, знач1, знач2)


> (больше) - Команды

DIESEL
DIESEL
> (больше)
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


!= (не равно) - Понятия

DIESEL
!= (не равно)
Понятия
Процедуры
Команды

Если числа знач1 и знач2 не равны, возвращает 1; иначе возвращает 0.

$(!=, знач1, знач2)


!= (не равно) - Команды

DIESEL
DIESEL
!= (не равно)
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


<= (меньше или равно) - Понятия

DIESEL
<= (меньше или равно)
Понятия
Процедуры
Команды

Если число знач1 меньше или равно числу знач2, строка возвращает 1; в противном случае - 0.

$(<=, знач1, знач2)


<= (меньше или равно) - Команды

DIESEL
DIESEL
<= (меньше или равно)
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


>= (больше или равно) - Понятия

DIESEL
>= (больше или равно)
Понятия
Процедуры
Команды

Если число знач1 больше или равно числу знач2, возвращает 1; иначе возвращает 0.

$(>=, знач1, знач2)


>= (больше или равно) - Команды

DIESEL
DIESEL
>= (больше или равно)
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


и - Понятия

DIESEL
и
Понятия
Процедуры
Команды

Возвращает результат побитовой логической операции И над целыми значениями от знач1 до знач9.

$(and, знач1 [, знач2,…, знач9])


и - Команды

DIESEL
DIESEL
и
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


angtos - Понятия

DIESEL
angtos
Понятия
Процедуры
Команды

Возвращает значение угла в заданном формате и с указанной точностью.

$(angtos, значение [, режим, точность])

Заданное значение представляется как угол в формате, определяемом параметром режим и с указанной точностью (как в аналогичной функции AutoLISP). Возможные значения аргумента режим приводятся в следующей таблице. Если режим и точность отсутствуют, используются значения, заданные в команде ЕДИНИЦЫ.

0 | Градусы
1 | Градусы/минуты/секунды
2 | Грады
3 | Радианы
4 | Топографические единицы


angtos - Команды

DIESEL
DIESEL
angtos
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


edtime - Понятия

DIESEL
edtime
Понятия
Процедуры
Команды

Возвращает дату и время, отформатированные в соответствии с указанным представлением.

$(edtime, время, представление)

Текущая дата AutoCAD по юлианскому календарю, взятая из параметра время (значение которого можно получить, например, из $(getvar,date)), форматируется согласно параметру представление). Параметр представление состоит из строк форматов, которые функция заменяет на значения элементов даты и времени. Символы, не интерпретируемые как строки форматов, копируются в результат $(edtime) буквально. Возможные значения строк форматов приводятся в следующей таблице. Предположим, что сейчас суббота, 5 сентября 1998 г.; текущее время равно 4:53:17.506.

D | 5 | H | 4
DD | 05 | HH | 04
DDD | Суб | MM | 53
DDDD | Суббота | SS | 17
M | 9 | MSEC | 506
MO | 09 | AM/PM | AM
МЕС | Сен | am/pm | am
MONTH | Сентября | A/P | A
YY | 98 | a/p | a
YYYY | 1998 |  |

Фразу AM/PM следует обязательно вводить полностью; если использовать только AM, буква A будет интерпретирована буквально, а буква M вернет номер месяца.

Если в шаблоне представления обнаружен элемент AM/PM, фразы H и HH форматируются согласно 12-часовой шкале (12:00-12:59 1:00-11:59), а не по 24-часовой (00:00-23:59).

В следующем примере текущие значения даты и времени равны значениям из предыдущего. Заметим, что запятая должна быть заключена в кавычки, иначе она будет расценена как разделитель аргументов.

$(edtime, $(getvar,date),DDD"," DD MON YYYY - H:MMam/pm)

Полученная в результате строка выглядит так:

Суб, 5 сен 1998 – 4:53am

Если аргумент время равен 0, вместо него берутся дата и время входа в самый внешний макрос. Это позволяет исключить затраты времени на множественные вызовы функции $(getvar,date), и вместе с тем гарантирует, что строки, составленные из нескольких макросов $(edtime), используют одинаковое время.


edtime - Команды

DIESEL
DIESEL
edtime
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


eq - Понятия

DIESEL
eq
Понятия
Процедуры
Команды

Если строки знач1 и знач2 совпадают, возвращает 1; иначе возвращает 0.

$(eq, знач1, знач2)

Следующее выражение получает имя текущего слоя; если оно совпадает со строкой, хранящейся в системной переменной USERS1 (см. USERS1-5), функция возвращает 1. Так, например, происходит, если USERS1 имеет значение PART12, и слой с таким же именем является текущим.

$(eq, $(getvar,users1),$(getvar,clayer))Возвращает 1


eq - Команды

DIESEL
DIESEL
eq
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


eval - Понятия

DIESEL
eval
Понятия
Процедуры
Команды

Передает строку стр в вычислитель DIESEL-выражений и возвращает результат ее вычисления.

$(eval, стр)


eval - Команды

DIESEL
DIESEL
eval
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


fix - Понятия

DIESEL
fix
Понятия
Процедуры
Команды

Выполняет усечение вещественного значения знач до целого путем отбрасывания дробной части.

$(fix, значение)


fix - Команды

DIESEL
DIESEL
fix
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


getenv - Понятия

DIESEL
getenv
Понятия
Процедуры
Команды

Возвращает значение переменной среды перем.

$(getenv, перем)

Если переменная с указанным именем не определена, функция возвращает пустую строку.


getenv - Команды

DIESEL
DIESEL
getenv
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


getvar - Понятия

DIESEL
getvar
Понятия
Процедуры
Команды

Возвращает значение системной переменной перем.

$(getvar, перем)


getvar - Команды

DIESEL
DIESEL
getvar
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


if - Понятия

DIESEL
if
Понятия
Процедуры
Команды

Вычисление выражений по условию.

$(if, условие, истина [, ложь])

Если условие не равно нулю, вычисляется и возвращается выражение истина. Иначе вычисляется и возвращается выражение ложь. Ветвь, не удовлетворяющая условию, не вычисляется вообще.


if - Команды

DIESEL
DIESEL
if
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


index - Понятия

DIESEL
index
Понятия
Процедуры
Команды

Возвращает заданный номером элемент строки-списка.

$(index, номер, строка)

Подразумевается, что аргумент строка содержит одно или несколько значений, разделенных запятыми (т.е. принятыми для макросов стандартными разделителями). Аргумент номер выбирает одно из значений для возврата (считается, что первый элемент строки имеет номер 0). Функция часто применяется для извлечения координат X, Y или Z точки, полученной из функции $(getvar).

В приложениях ее можно использовать также для извлечения аргументов, переданных в виде строк-списков в системных переменных USERS1-5.


index - Команды

DIESEL
DIESEL
index
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


nth - Понятия

DIESEL
nth
Понятия
Процедуры
Команды

Вычисляет и возвращает аргумент, выбранный по его номеру.

$(nth, номер, арг0 [, арг1,…, арг7])

Если номер равен 0, nth возвращает арг0 и т.д. Следует обратить внимание на разницу между функциями $(nth) и $(index); $(nth)возвращает один из нескольких аргументов функции, в то время как $(index) извлекает одно из значений, разделенных запятыми, из строки, переданной как один аргумент. Аргументы, не выбранные значением номер, не вычисляются.


nth - Команды

DIESEL
DIESEL
nth
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


или - Понятия

DIESEL
или
Понятия
Процедуры
Команды

Возвращает результат побитовой логической операции ИЛИ над целыми значениями от знач1 до знач9.

$(или, знач1 [, знач2,…, знач9])


или - Команды

DIESEL
DIESEL
или
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


rtos - Понятия

DIESEL
rtos
Понятия
Процедуры
Команды

Возвращает вещественное значение в заданном формате и с указанной точностью.

$(rtos, значение [, режим, точность])

Заданное значение представляется как вещественное число в формате, определяемом параметром режим и с указанной точностью (как в аналогичной функции AutoLISP). Если режим и точность отсутствуют, используются значения, заданные в команде ЕДИНИЦЫ.

Заданное значение представляется как вещественное число в формате, определяемом параметром режим и с указанной точностью.Если режим и точность отсутствуют, используются значения, заданные в команде ЕДИНИЦЫ.


rtos - Команды

DIESEL
DIESEL
rtos
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


strlen - Понятия

DIESEL
strlen
Понятия
Процедуры
Команды

Возвращает длину строки в символах.

$(strlen, строка)


strlen - Команды

DIESEL
DIESEL
strlen
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


substr - Понятия

DIESEL
substr
Понятия
Процедуры
Команды

Возвращает подстроку строки, начиная с символа начало, имеющую заданную длину.

$(substr, строка, начало [, длина])

Символы в строке нумеруются, начиная с 1. Если длина отсутствует, функция возвращает всю оставшуюся часть строки.


substr - Команды

DIESEL
DIESEL
substr
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


upper - Понятия

DIESEL
upper
Понятия
Процедуры
Команды

Возвращает строку, преобразованную в верхний регистр по правилам текущей кодовой страницы.

$(upper, строка)


upper - Команды

DIESEL
DIESEL
upper
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


xor - Понятия

DIESEL
xor
Понятия
Процедуры
Команды

Возвращает результат побитовой логической операции ИСКЛЮЧАЮЩЕЕ ИЛИ над целыми значениями от знач1 до знач9.

$(xor, знач1 [, знач2,…, знач9])


xor - Команды

DIESEL
DIESEL
xor
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Сообщения об ошибках языка DIESEL - Понятия

DIESEL
Сообщения об ошибках языка DIESEL
Понятия
Процедуры
Команды

Обычно поиск ошибок в DIESEL-выражениях не требует излишних затрат времени. В выходной поток программы включаются специальные сообщения, формат которых определяется типом допущенной ошибки.

$? | Синтаксическая ошибка (чаще всего — пропущена закрывающая скобка или имеется незавершенная строка)
$(функция,??) | Недопустимые аргументы в функции
$(функция)?? | Неизвестная функция
$(++) | Слишком длинная строка вывода—вычисление прервано


Сообщения об ошибках языка DIESEL - Команды

DIESEL
DIESEL
Сообщения об ошибках языка DIESEL
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
MENUECHO | Устанавливает битовый код управления эхо-выводом и запросами меню
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Слайды и командные сценарии - Понятия

Слайды и командные сценарии
Понятия
Процедуры
Команды

Слайды - это нередактируемые моментальные снимки чертежей AutoCAD, которые можно использовать для различных целей. Сценарий выполняет команды, считываемые из текстового файла. Одним из способов применения сценариев является создание презентаций на основе слайдов.

  • Создание слайдов
    Слайды - это нередактируемые моментальные снимки чертежей AutoCAD. Их используют для создания презентационных роликов, меню мозаики изображений, а также для быстрого ознакомления с внешним видом других чертежей.
  • Создание файлов сценариев
    Сценарием называют текстовый файл, содержащий последовательность команд. Файлы сценариев обычно используются для настройки параметров загрузки и создания презентаций на основе слайдов.


Слайды и командные сценарии - Процедуры

Слайды и командные сценарии
Понятия
Процедуры
Команды

Создание слайда

Просмотр слайда

Создание библиотеки слайдов

Для просмотра слайда из библиотеки

Создание сценария, изменяющего параметры чертежа

Автоматический запуск сценария при открытии программы

Демонстрация слайдов с помощью сценария

Создание сценария с предварительной загрузкой слайдов


Слайды и командные сценарии - Команды

Слайды и командные сценарии
Понятия
Процедуры
Команды
Команды
ВПАКЕТ | Повторное выполнение пакетного файла
ГРАФЭКР | Переключение из текстового окна в графическую область
ДСЛАЙД | Создание файла слайда из текущего видового экрана пространства модели или текущего листа
ЗАДЕРЖКА | Задание паузы при выполнении пакета команд
ОСВЕЖИТЬ | Перерисовка содержимого текущего видового экрана
ПАКЕТ | Выполнение последовательности команд из пакетного файла
ПРОДОЛЖИТЬ | Возобновление выполнения прерванного пакетного файла
СЛАЙД | Просмотр файла слайда на текущем видовом экране
ТЕКСТЭКР | Открытие текстового окна
Системные переменные
FILEDIA | Подавляет отображение диалоговых окон навигации к файлу
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание слайдов - Понятия

Слайды и командные сценарии
Создание слайдов
Понятия
Процедуры
Команды

Слайды - это нередактируемые моментальные снимки чертежей AutoCAD. Их используют для создания презентационных роликов, меню мозаики изображений, а также для быстрого ознакомления с внешним видом других чертежей.

  • Коротко о слайдах
    Слайд - это моментальный снимок чертежа AutoCAD. Хотя слайд и содержит образы графических объектов, он не хранит в себе их описаний.
  • Просмотр слайдов
    Просмотр слайдов по одному производится командой СЛАЙД. Для просмотра последовательности слайдов (например, при создании демонстрационных роликов) используются файлы сценариев.
  • Создание и просмотр библиотек слайдов
    Слайды можно объединять в библиотеки. Хранение слайдов в одной библиотеке позволяет поддерживать целостность их наборов — например, при использовании в одном меню мозаики изображений.


Создание слайдов - Процедуры

Слайды и командные сценарии
Создание слайдов
Понятия
Процедуры
Команды

Создание слайда

Просмотр слайда

Создание библиотеки слайдов

Для просмотра слайда из библиотеки


Создание слайдов - Команды

Слайды и командные сценарии
Создание слайдов
Понятия
Процедуры
Команды
Команды
ДСЛАЙД | Создание файла слайда из текущего видового экрана пространства модели или текущего листа
ОСВЕЖИТЬ | Перерисовка содержимого текущего видового экрана
СЛАЙД | Просмотр файла слайда на текущем видовом экране
Системные переменные
FILEDIA | Подавляет отображение диалоговых окон навигации к файлу
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о слайдах - Понятия

Слайды и командные сценарии
Коротко о слайдах
Понятия
Процедуры
Команды

Слайд - это моментальный снимок чертежа AutoCAD. Хотя слайд и содержит образы графических объектов, он не хранит в себе их описаний. Невозможно ни выполнить импорт слайда в текущий чертеж, ни отредактировать, ни напечатать его. Его допускается только просматривать на экране.

Файлы слайдов можно использовать для:

  • Проведения презентаций в AutoCAD®
  • Просмотра образов других чертежей, не выходя из программы
  • Создание меню мозаичных изображений в диалоговом окне

На слайде сохраняется текущий вид чертежа. На слайде, созданном в пространстве модели, изображается только содержимое текущего видового экрана. В пространстве листа слайд сохраняет все видимые видовые экраны вместе с их содержимым. В слайдовые изображения входят только видимые элементы чертежа. Объекты на отключенных и замороженных слоях и на отключенных видовых экранах не изображаются.

Просматриваемый файл слайда временно заменяет объекты, находившиеся до этого на экране. Рисовать поверх слайда можно, но после любой смены вида (т.е. перерисовки, панорамирования или зумирования) изображение слайда исчезает. На экране AutoCAD восстанавливаются объекты, которые оказались закрыты слайдом; сохраняются также все построения, выполненные поверх него.

Слайды можно выводить на экран по одному или последовательно (с помощью файлов сценариев). Их также можно применять в пользовательских меню. Например, для процедуры вставки часто используемых деталей машин можно реализовать меню мозаики изображений со слайдами, наглядно изображающими разные типы деталей. После того как пользователь выбирает нужный ему слайд, AutoCAD вставляет соответствующий блок в чертеж.

Слайды можно объединять в библиотеки. Хранение слайдов в одной библиотеке позволяет поддерживать целостность их наборов — например, при использовании в одном меню мозаики изображений.

Слайды нельзя редактировать. Для модификации слайда необходимо внести изменения в исходный чертеж и снять слайд заново. Если в системе ранее использовался монитор с низким разрешением, а затем он был заменен на более совершенный, все созданные ранее слайды по-прежнему можно просматривать. AutoCAD перестраивает изображение; однако, до тех пор пока слайд не переснят, всех возможностей нового монитора он все равно не использует.


Создание слайда - Процедуры

Слайды и командные сценарии
Коротко о слайдах
Понятия
Процедуры
Команды

Создание слайда

  1. Отобразите на экране вид, который планируется сохранить на слайде.
  2. В командной строке введитедслайд.
  3. В диалоговом окне "Создание файла слайда" введите имя слайда и выберите путь к нему.

    4. AutoCAD предлагает по умолчанию такое же имя, что и у текущего чертежа, автоматически добавляя расширение .sld.

  4. Нажмите кнопку "Сохранить".

    5. Вид текущего чертежа остается на экране, а полученный из него файл слайда сохраняется в заданной папке.


Коротко о слайдах - Команды

Слайды и командные сценарии
Слайды и командные сценарии
Коротко о слайдах
Понятия
Процедуры
Команды

Команды
ДСЛАЙД | Создание файла слайда из текущего видового экрана пространства модели или текущего листа
ОСВЕЖИТЬ | Перерисовка содержимого текущего видового экрана
СЛАЙД | Просмотр файла слайда на текущем видовом экране
Системные переменные
FILEDIA | Подавляет отображение диалоговых окон навигации к файлу
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Просмотр слайдов - Понятия

Слайды и командные сценарии
Просмотр слайдов
Понятия
Процедуры
Команды

Просмотр слайдов по одному производится командой СЛАЙД. Для просмотра последовательности слайдов (например, при создании демонстрационных роликов) используются файлы сценариев.

Слайды по внешнему виду неотличимы от обычных чертежей, поэтому во время их просмотра следует избегать вызова команд редактирования. Эти команды воздействуют на закрытый слайдом текущий чертеж, а не на сам слайд.

Некоторые команды инициируют перерисовку изображения, что приводит к исчезновению слайда с экрана.


Просмотр слайда - Процедуры

Слайды и командные сценарии
Просмотр слайдов
Понятия
Процедуры
Команды

Просмотр слайда

  1. В командной строке введитеслайд.
  2. В диалоговом окне "Выбор файла слайда" выберите слайд для просмотра и нажмите "OK".

    3. Изображение слайда появится в области рисования.

  3. Из меню "Вид" выберите "Освежить".

    4. Изображение слайда исчезнет


Просмотр слайдов - Команды

Слайды и командные сценарии
Слайды и командные сценарии
Просмотр слайдов
Понятия
Процедуры
Команды

Команды
ОСВЕЖИТЬ | Перерисовка содержимого текущего видового экрана
СЛАЙД | Просмотр файла слайда на текущем видовом экране
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание и просмотр библиотек слайдов - Понятия

Слайды и командные сценарии
Создание и просмотр библиотек слайдов
Понятия
Процедуры
Команды

Слайды можно объединять в библиотеки. Хранение слайдов в одной библиотеке позволяет поддерживать целостность их наборов — например, при использовании в одном меню мозаики изображений.

Библиотеки слайдов можно создать из файлов слайдов с помощью утилиты SLIDELIB. К находящимся в библиотеке слайдам можно обращаться, вводя имя библиотеки и имя слайда.

Не следует удалять исходные слайды после того, как они включены в библиотеку. Программа SLIDELIB не предназначена для обновления библиотек слайдов после их создания. При необходимости добавления или удаления слайда нужно обновить файл списка слайдов и создать библиотеку заново с помощью утилиты SLIDELIB. Чтобы сделать это, требуется наличие всех оригиналов слайдов.


Создание и просмотр библиотек слайдов - Процедуры

Слайды и командные сценарии
Создание и просмотр библиотек слайдов
Понятия
Процедуры
Команды

Создание библиотеки слайдов

Для просмотра слайда из библиотеки


Создание библиотеки слайдов - Процедуры

Слайды и командные сценарии
Создание и просмотр библиотек слайдов
Понятия
Процедуры
Команды

Создание библиотеки слайдов

  1. С помощью текстового редактора, сохраняющего файлы в формате ASCII, создайте список файлов слайдов, включаемых в библиотеку. Примерный вид списка показан ниже:

    2. entrance.sld

    hall.sld

    stairs.sld

    study.sld

    balcony.sld

  2. Сохраните список под произвольным именем с расширением .txt.
  3. Из меню "Пуск" Windows выберите "Все программы" (или "Программы") » "Стандартные" » "Командная строка".
  4. В окне командной строки введите CD <папка со слайдами>, чтобы изменить положение папки.

    5. Пример: CD “c:\slides”

  5. В ответ на запрос введите следующую команду, чтобы создать библиотеку слайдов:

    6. slidelib имя_библиотеки < list.txt

    Например, если файл списка был назван areas.txt, библиотеку с именем house.slb можно создать, введя slidelib house<areas.txt. Утилита SLIDELIB автоматически добавляет расширение . slb.


Для просмотра слайда из библиотеки - Процедуры

Слайды и командные сценарии
Создание и просмотр библиотек слайдов
Понятия
Процедуры
Команды

Для просмотра слайда из библиотеки

  1. В командной строке присвойте системной переменной FILEDIA значение 0.
  2. В командной строке введите слайд.
  3. Для задания слайда введите библиотека(имя_слайда).

    4. Например, введите house (balcony) чтобы открыть слайд balcony из библиотеки house.

  4. Из меню "Вид" выберите "Освежить", чтобы удалить слайд с экрана.


Создание и просмотр библиотек слайдов - Команды

Слайды и командные сценарии
Слайды и командные сценарии
Создание и просмотр библиотек слайдов
Понятия
Процедуры
Команды

Команды
ДСЛАЙД | Создание файла слайда из текущего видового экрана пространства модели или текущего листа
ОСВЕЖИТЬ | Перерисовка содержимого текущего видового экрана
СЛАЙД | Просмотр файла слайда на текущем видовом экране
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание файлов сценариев - Понятия

Слайды и командные сценарии
Создание файлов сценариев
Понятия
Процедуры
Команды

Сценарием называют текстовый файл, содержащий последовательность команд. Файлы сценариев обычно используются для настройки параметров загрузки и создания презентаций на основе слайдов.

  • Коротко о файлах сценариев
  • Вызов сценария при загрузке программы
    Сценарии, вызываемые при загрузке программы, могут использоваться для открытия чертежа и для настройки его параметров.
  • Демонстрация слайдов с помощью сценариев
    С помощью файлов сценариев можно организовать демонстрацию слайдов.


Создание файлов сценариев - Процедуры

Слайды и командные сценарии
Создание файлов сценариев
Понятия
Процедуры
Команды

Создание сценария, изменяющего параметры чертежа

Автоматический запуск сценария при открытии программы

Демонстрация слайдов с помощью сценария

Создание сценария с предварительной загрузкой слайдов


Создание файлов сценариев - Команды

Слайды и командные сценарии
Создание файлов сценариев
Понятия
Процедуры
Команды
Команды
ВПАКЕТ | Повторное выполнение пакетного файла
ГРАФЭКР | Переключение из текстового окна в графическую область
ЗАДЕРЖКА | Задание паузы при выполнении пакета команд
ПАКЕТ | Выполнение последовательности команд из пакетного файла
ПРОДОЛЖИТЬ | Возобновление выполнения прерванного пакетного файла
СЛАЙД | Просмотр файла слайда на текущем видовом экране
ТЕКСТЭКР | Открытие текстового окна
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о файлах сценариев - Понятия

Слайды и командные сценарии
Коротко о файлах сценариев
Понятия
Процедуры
Команды

Сценарием называют текстовый файл, каждая строка которого содержит одну команду.

Сценарий можно вызывать при загрузке программы или во время сеанса работы с помощью команды ПАКЕТ. Сценарий предоставляет простой способ создания презентации (непрерывно сменяющихся на экране изображений) для демонстрации изделий, например, на торговых выставках.

До печати нескольких документов, используя команды файла сценария, системной переменной BACKGROUNDPLOT следует присвоить значение 0.

Файлы сценариев создаются вне программы в текстовом редакторе (Блокнот Microsoft® Windows®) или текстовом процессоре (Microsoft Word), способном сохранять файлы в формате ASCII. При этом имя файла должно иметь расширение .scr.

Каждая строка файла сценария содержит какую-либо команду. Каждый пробел в файле сценария является значимым, так как переменная SPACEBAR воспринимается как сигнал к завершению ввода данных. Необходимо хорошо знать последовательность запросов, чтобы правильно написать файл сценария.

Примечание Необходимо иметь в виду, что последовательности запросов и имена команд могут быть изменены в последующих версиях, и может потребоваться изменить сценарии при обновлении версии программы. По той же причине не следует использовать сокращенные имена команд и опций; добавление новых команд и опций может привести к недоразумениям.

Файлы сценариев могут содержать любые команды, кроме тех, которые используют диалоговые окна. Варианты команд, использующих командную строку предусмотрены для многих команд диалоговых окон.

В файлы сценариев можно включать комментарии. Комментарием считается любая строка, начинающаяся с точки с запятой (;), она игнорируется при обработке файла сценария. Последняя строка файла сценария должна быть пустой.

Имена файлов, содержащие пробелы, необходимо заключать в двойные кавычки. Например, для открытия чертежа my house.dwg из сценария следует использовать следующую запись:

открыть "my house"

В сценариях часто используются такие команды:

'ЗАДЕРЖКА

Задержка выполнения следующей команды на заданное количество миллисекунд

'ГРАФЭКР

Переключение из текстового окна в область рисования

ПРОДОЛЖИТЬ

Возобновление выполнения прерванного файла сценария

ВПАКЕТ

Повторное выполнение файла сценария

'ТЕКСТЭКР

Переключение в текстовое окно

Если вызов команды производится из файла сценария, подразумевается, что параметры системных переменных PICKADD и PICKAUTO имеют значения 1 и 0, соответственно. Это избавляет от необходимости проверять значения данных переменных.

Сценарий воспринимается как группа команд, которую можно отменить одним вызовом команды О. Однако, поскольку каждая выполняемая команда сценария регистрируется в файле журнала отмены, обработка сценария может замедлиться. При необходимости перед запуском сценария (или в начале самого сценария) средство отмены действия команд можно отключить с помощью опций "Управление" - "Ничего" команды ОТМЕНИТЬ. После завершения выполнения сценария средство отмены следует включить (ОТМЕНИТЬ "Управление" - "Все").

Выполнение текущего файла сценария прекращается при вызове другой команды ПАКЕТ.


Создание сценария, изменяющего параметры чертежа - Процедуры

Слайды и командные сценарии
Коротко о файлах сценариев
Понятия
Процедуры
Команды

Создание сценария, изменяющего параметры чертежа

Данный сценарий включает сетку, задает глобальный коэффициент масштаба типов линий 3.0, выбирает в качестве текущего слой 0 и назначает ему цвет "Красный".

  1. В текстовом редакторе введите сетка вкл.
  2. На следующей строке введите лмасштаб 3.0.
  3. На следующей строке введите слой установить 0 цвет красный 0.
  4. Добавте пустую строку.
  5. Сохраните файл в формате ASCII (как TXT-файл) с расширением .SCR.

    6. Файл сценария может содержать комментарии, как показано ниже:

; Включение сетки
сетка вкл
; Установка коэффициента масштаба типов линий
лмасштаб 3.0
; Установка текущего слоя и назначение ему цвета
слой установить 0 цвет красный
; Выше добавлена пустая строка для завершения команды СЛОЙ.


Коротко о файлах сценариев - Команды

Слайды и командные сценарии
Слайды и командные сценарии
Коротко о файлах сценариев
Понятия
Процедуры
Команды

Команды
ВПАКЕТ | Повторное выполнение пакетного файла
ГРАФЭКР | Переключение из текстового окна в графическую область
ЗАДЕРЖКА | Задание паузы при выполнении пакета команд
ПАКЕТ | Выполнение последовательности команд из пакетного файла
ПРОДОЛЖИТЬ | Возобновление выполнения прерванного пакетного файла
СЛАЙД | Просмотр файла слайда на текущем видовом экране
ТЕКСТЭКР | Открытие текстового окна
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Вызов сценария при загрузке программы - Понятия

Слайды и командные сценарии
Вызов сценария при загрузке программы
Понятия
Процедуры
Команды

Сценарии, вызываемые при загрузке программы, могут использоваться для открытия чертежа и для настройки его параметров.

Предположим, что при создании нового чертежа пользователю каждый раз требуется включить отображение сетки, присвоить глобальному масштабу типов линий значение 3.0 и сделать текущим слой 0, назначив ему красный цвет. Для этого можно либо использовать шаблон чертежа, либо написать сценарий и сохранить его в файле setup.scr.

сетка вкл
лмасштаб 3.0
слой установить 0 цвет красный

Первая строка включает сетку. Вторая строка назначает глобальный масштаб типов линий. Третья строка устанавливает текущим слой 0 и присваивает ему красный цвет. AutoCAD подразумевает, что при работе со сценарием необходимо использовать не диалоговое окно команды СЛОЙ, а командную строку. Так, вызов команды СЛОЙ в файле сценария эквивалентен вводу -слой в командной строке. Четвертая (пустая) строка завершает команду СЛОЙ.

Примечание Вызываемые при загрузке программы сценарии VBA и AutoLISP® должны проверять видимость AutoCAD. Если приложение невидимо, то выполнять сценарий не следует, так как приложение может выполнять вывод на печать или публикацию в фоновом режиме. Для проверки видимости AutoCAD служит свойство Visible объекта Application. Подробнее см. информацию об объектной модели AutoCAD.

Для вызова сценария при загрузке AutoCAD используются следующие опции, вводимые в командной строке операционной системы:

ACAD имя_чертежа /b setup

Имена файлов, содержащие пробелы, необходимо заключать в двойные кавычки, например, “guest house”. Вид, отображающийся при открытии чертежа, задается путем ввода имени вида после атрибута /v. Самым последним параметром должен быть файл сценария, задаваемый атрибутом /b.

Добавлять к имени файла расширение (.exe, .dwg, .dwt или .scr) не обязательно. Если AutoCAD не может найти файл сценария с заданным именем, AutoCAD выдает сообщение о том, что не удается открыть файл.

Для создания чертежа с использованием шаблона MyTemplate.dwt программу следует вызвать следующим образом:

ACAD /t MyTemplate /b setup

Данная команда создает новый чертеж и переходит к выполнению последовательности команд настройки из файла setup.scr. После завершения выполнения файла сценария выводится стандартная подсказка "Команда:". При создании нового чертежа с использованием шаблона по умолчанию можно опустить атрибут /t и имя файла шаблона.

Примечание Возможность создания нового чертежа с заданным именем больше не поддерживается. Присвоение имени возможно только при сохранении файла чертежа.


Вызов сценария при загрузке программы - Процедуры

Слайды и командные сценарии
Вызов сценария при загрузке программы
Понятия
Процедуры
Команды

Автоматический запуск сценария при открытии программы


Автоматический запуск сценария при открытии программы - Процедуры

Слайды и командные сценарии
Вызов сценария при загрузке программы
Понятия
Процедуры
Команды

Автоматический запуск сценария при открытии программы

  1. Из меню "Пуск" выберите "Выполнить".
  2. В диалоговом окне "Запуск программы" введите acad имя_чертежа /b имя_сценария.

    3. Для создания нового файла нужно вместо имени файла чертежа ввести атрибут /t и имя файла шаблона: /t шаблон_чертежа.

    Для открытия чертежа с определенным видом нужно после имени чертежа поставить ключ /v и имя требуемого вида: /v имя_вида.

    Файл сценария должен быть самым последним параметром в строке вызова. Задание расширений имен файлов не обязательно.

  3. Нажмите ОК.

    4. AutoCAD открывает файл чертежа и выполняет команды, записанные в файле сценария. После завершения выполнения файла сценария выводится стандартная подсказка "Команда:".


Вызов сценария при загрузке программы - Команды

Слайды и командные сценарии
Слайды и командные сценарии
Вызов сценария при загрузке программы
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Демонстрация слайдов с помощью сценариев - Понятия

Слайды и командные сценарии
Демонстрация слайдов с помощью сценариев
Понятия
Процедуры
Команды

С помощью файлов сценариев можно организовать демонстрацию слайдов. Стандартная скорость смены слайдов обусловлена временем, которое AutoCAD затрачивает на доступ к диску для чтения файла. Существует, однако, возможность предварительной загрузки слайда в память, в то время как аудитория рассматривает предыдущий слайд. Уже находящийся в памяти слайд отображается практически мгновенно.

Для того чтобы слайд был загружен предварительно, перед его именем в команде СЛАЙД нужно поставить звездочку. Следующая команда СЛАЙД обнаруживает его и выводит на экран, не спрашивая об имени файла.

По умолчанию каждый слайд виден на экране, пока не истекло время загрузки следующего. Дополнительную задержку можно ввести с помощью команды ЗАДЕРЖКА. Ее параметром является количество миллисекунд.

Повторное выполнение сценария можно остановить нажатием клавиши ESC. Для продолжения выполнения прерванного сценария служит команда ПРОДОЛЖИТЬ.

Перед выполнением продолжительного файла сценария рекомендуется вызвать команду ОТМЕНИТЬ с параметром "Управление" и выбрать значение "Ничего", чтобы отключить ведение журнала отмены.


Демонстрация слайдов с помощью сценариев - Процедуры

Слайды и командные сценарии
Демонстрация слайдов с помощью сценариев
Понятия
Процедуры
Команды

Демонстрация слайдов с помощью сценария

Создание сценария с предварительной загрузкой слайдов


Демонстрация слайдов с помощью сценария - Процедуры

Слайды и командные сценарии
Демонстрация слайдов с помощью сценариев
Понятия
Процедуры
Команды

Демонстрация слайдов с помощью сценария

  1. Создайте библиотеку слайдов. Подробнее см. раздел Создание библиотеки слайдов .
  2. Создайте сценарий — текстовый файл в формате ASCII. Подробнее см. раздел Создание сценария с предварительной загрузкой слайдов.
  3. В командной строке введитепакет.
  4. В диалоговом окне "Выбор файла сценария" выберите файл сценария и нажмите кнопку "Открыть".


Создание сценария с предварительной загрузкой слайдов - Процедуры

Слайды и командные сценарии
Демонстрация слайдов с помощью сценариев
Понятия
Процедуры
Команды

Создание сценария с предварительной загрузкой слайдов

В данном примере отображается три слайда (файлы slide1.sld, slide2.sld, и slide3.sld). Каждый слайд виден на экране, пока не будет загружен с диска следующий.

  1. В первой строке файла сценария ввести слайд slide1.

    2. Первая строка запускает демонстрацию и загружает slide1.

  2. Во второй строке введите слайд *slide2.

    3. Звездочка (*) перед именем слайда во второй строке осуществляет предварительную загрузку slide2.

  3. В третьей строке введитезадержка 2000.

    4. Третья строка задает двухсекундную паузу, чтобы зрители могли рассмотреть slide1.

  4. В четвертой строке введитеслайд. В пятой строк введите слайд *slide3. В шестой строке введитезадержка 2000.

    5. Строки с четвертой по шестую выводят на экран slide2, загружают slide3 и задают задержку для просмотра slide2.

  5. В седьмой строке введите слайд. В восьмой строке введите задержка 3000.

    6. Седьмая и восьмая строки выводят slide3 и задают задержку для просмотра slide3.

  6. В последней строке введите впакет для циклического выполнения сценария.
  7. Повторное выполнение сценария можно остановить нажатием клавиши ESC. Для продолжения прерванного сценария служит команда продолжить.

    8. Файл сценария может содержать комментарии, как показано ниже:

; Начало презентации, загрузка слайда SLIDE1
СЛАЙД SLIDE1
; Предварительная загрузка слайда SLIDE2
СЛАЙД *SLIDE2
; Пауза для возможности рассмотреть слайд SLIDE1
ЗАДЕРЖКА 2000
; Вывод слайда SLIDE2
СЛАЙД
; Предварительная загрузка слайда SLIDE3
СЛАЙД *SLIDE3
; Пауза для возможности рассмотреть слайд SLIDE2
ЗАДЕРЖКА 2000
; Вывод слайда SLIDE3
СЛАЙД
; Пауза для возможности рассмотреть слайд SLIDE3
ЗАДЕРЖКА 3000
; Циклическое выполнение перечисленных выше команд
ВПАКЕТ


Демонстрация слайдов с помощью сценариев - Команды

Слайды и командные сценарии
Слайды и командные сценарии
Демонстрация слайдов с помощью сценариев
Понятия
Процедуры
Команды

Команды
ВПАКЕТ | Повторное выполнение пакетного файла
ГРАФЭКР | Переключение из текстового окна в графическую область
ЗАДЕРЖКА | Задание паузы при выполнении пакета команд
ПАКЕТ | Выполнение последовательности команд из пакетного файла
ПРОДОЛЖИТЬ | Возобновление выполнения прерванного пакетного файла
СЛАЙД | Просмотр файла слайда на текущем видовом экране
ТЕКСТЭКР | Открытие текстового окна
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Введение в интерфейсы программирования - Понятия

Введение в интерфейсы программирования
Понятия
Процедуры
Команды

В AutoCAD управление чертежами и базами данных возможно не только с использованием меню и командной строки, но также с помощью интерфейсов прикладного программирования (API). В зависимости от разрабатываемого приложения и опыта программирования можно использовать тот или иной тип интерфейса.

Здесь представлены следующие интерфейсы программирования: ActiveX® Automation, VBA (Visual Basic® for Applications), AutoLISP®, Visual LISP™, ObjectARX™, и .NET В зависимости от разрабатываемого приложения и опыта программирования можно использовать тот или иной тип интерфейса.

  • ActiveX Automation
    ActiveX Automation - это разработанная компанией Microsoft® технология, которая основана на архитектуре компонентной объектной модели (COM). Этот интерфейс позволяет производить настройку AutoCAD, использовать хранящиеся в чертежах данные совместно с другими приложениями, а также автоматизировать выполнение различных задач.
  • AutoCAD VBA
    Microsoft Visual Basic for Applications (VBA) является объектно-ориентированным языком программирования с собственной средой разработки и обладает широкими возможностями. Основное отличие VBA от VB (Visual Basic) состоит в том, что VBA работает одновременно с AutoCAD, предоставляя быструю среду для программного управления AutoCAD.
  • AutoLISP и Visual LISP
    AutoLISP основан на языке программирования LISP, который является простым и в то же время достаточно мощным. В AutoCAD имеется встроенный интерпретатор LISP, который позволяет вводить коды AutoLISP в командной строке или загружать их из внешних файлов. Интегрированная среда разработки Visual LISP (VLISP) предназначена для ускорения процесса создания программ на AutoLISP.
  • ObjectARX
    Технология ObjectARX предоставляет средства для разработки приложений, совместно использующих данные программируемых объектов. Можно пользоваться приложениями ObjectARX от сторонних разработчиков или написать свои собственные.
  • .NET
    В среде Microsoft .NET Framework с помощью таких языков программирования, как VB .NET и C#, можно создавать приложения, взаимодействующие с AutoCAD.


Введение в интерфейсы программирования - Процедуры

Введение в интерфейсы программирования
Понятия
Процедуры
Команды

Нет процедур для этой темы.


Введение в интерфейсы программирования - Команды

Введение в интерфейсы программирования
Понятия
Процедуры
Команды
Команды
ARX | Загрузка, выгрузка и предоставление информации о приложениях ObjectARX
NETLOAD | Загрузка приложения .NET
VBAIDE | Вызов редактора Visual Basic
VBALOAD | Загружает глобальный проект в текущий сеанс работы
VBAMAN | Загрузка, выгрузка, сохранение, создание, вложение и извлечение проектов VBA
VBARUN | Запуск VBA-макроса
VBASTMT | Выполнение выражения VBA в командной строке AutoCAD
VBAUNLOAD | Глобальная выгрузка проекта VBA
ЗАГПРИЛ | Загрузка и выгрузка приложений; задание набора приложений для автозагрузки
МЕНЮЗАГР | Устар.
Системные переменные
ACADLSPASDOC | Управление режимом загрузки файла acad.lsp: либо в каждый чертеж, либо только при открытии первого чертежа в сеансе.
LISPINIT | Указывает, сохраняются ли функции и переменные AutoLISP при открытом чертеже в однодокументном интерфейсе
PICKADD | Управляет дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов)
PICKAUTO | Управляет автоматическим созданием рамки выбора объектов в ответ на запрос "Выберите объекты".
SDI | Управляет режимом работы программы (одно- или многодокументный интерфейс)
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


ActiveX Automation - Понятия

Введение в интерфейсы программирования
ActiveX Automation
Понятия
Процедуры
Команды

ActiveX Automation - это разработанная компанией Microsoft® технология, которая основана на архитектуре компонентной объектной модели (COM). Этот интерфейс позволяет производить настройку AutoCAD, использовать хранящиеся в чертежах данные совместно с другими приложениями, а также автоматизировать выполнение различных задач.

  • Коротко об ActiveX
    Можно создавать объекты AutoCAD и управлять ими из любого приложения, выполняющего функцию контроллера автоматизации. Интерфейс Automation позволяет работать с другими приложениями на макроуровне, что невозможно в AutoLISP.
  • Запуск приложения из командной строки
    С помощью файла acad.pgp можно определить новую команду AutoCAD, которая вызывает внешнюю команду для запуска нужного приложения.
  • Запуск приложения из меню или с помощью панели инструментов
    Создав новую команду для запуска внешнего приложения, ее можно вызывать из меню или панели инструментов.


ActiveX Automation - Процедуры

Введение в интерфейсы программирования
ActiveX Automation
Понятия
Процедуры
Команды

Нет процедур для этой темы.


ActiveX Automation - Команды

Введение в интерфейсы программирования
ActiveX Automation
Понятия
Процедуры
Команды
Команды
NETLOAD | Загрузка приложения .NET
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко об ActiveX - Понятия

Введение в интерфейсы программирования
Коротко об ActiveX
Понятия
Процедуры
Команды

Можно создавать объекты AutoCAD и управлять ими из любого приложения, выполняющего функцию контроллера автоматизации. Интерфейс Automation позволяет работать с другими приложениями на макроуровне, что невозможно в AutoLISP.

С помощью интерфейса Automation программа AutoCAD обеспечивает доступ к своим программируемым объектам, определяемым объектной моделью AutoCAD. Это позволяет создавать, редактировать и управлять ими из внешних приложений. Любое приложение, которое может работать с объектной моделью AutoCAD, называется контроллером автоматизации. Наиболее часто для управления приложениями с помощью технологии автоматизации используется Visual Basic for Applications (VBA). Эта реализация языка Visual Basic является составной частью большинства приложений, входящих в продукт Microsoft Office. Для управления AutoCAD можно использовать эти приложения или любые другие контроллеры автоматизации, такие как Visual Basic, .NET и Delphi.

Реализация интерфейса ActiveX для AutoCAD имеет два следующих преимущества.

  • Программный доступ к чертежам AutoCAD можно осуществлять из самых разных сред программирования. До разработки ActiveX Automation были доступны только интерфейсы AutoLISP и C++.
  • Существенно упростилось совместное использование данных с другими приложениями, например, Microsoft Excel и Microsoft Word.

Можно, например, выдать запрос в командной строке, изменить настройки, создать набор объектов или найти нужные объекты чертежа. Тип используемых средств для создания контроллера следует выбирать с учетом сложности манипуляций, которые будут выполняться с объектами чертежа.

Используя Automation, можно создавать объекты AutoCAD и управлять ими из любого приложения, выполняющего функцию контроллера автоматизации. Интерфейс Automation позволяет работать с другими приложениями на макроуровне, что невозможно в AutoLISP. Таким образом, Automation может служить средством объединения возможностей различных приложений в одном приложении.

Все доступные через интерфейс объекты называются объектами Automation. Объекты автоматизации делают доступными методы, свойства и события. Методы являются функциями, с помощью которых можно выполнять манипуляции над объектом. Свойства являются функциями, которые позволяют устанавливать или получать информацию о состоянии объекта. События - это операции или вызовы, инициированные пользователем, на которые отвечает программа.

Приложение практически любого назначения имеет возможность работать с объектами Automation непосредственно в среде AutoCAD. В качестве таких приложений могут выступать отдельные исполняемые exe-файлы, библиотеки динамической компоновки (DLL-файлы), а также макросы, созданные в таких приложениях, как Microsoft Word или Microsoft Excel. Однако на практике наиболее вероятно применение отдельных исполняемых exe-файлов. При использовании приложений сторонних разработчиков необходимо следовать прилагаемым к ним инструкциями по установке и использованию продукта.

См. также

Руководство разработчика ActiveX и VBA

Справка по ActiveX и VBA


ActiveX Automation

Введение в интерфейсы программирования
ActiveX Automation
Понятия
Процедуры
Команды

Нет процедур.


Коротко об ActiveX - Команды

Введение в интерфейсы программирования
Введение в интерфейсы программирования
Коротко об ActiveX
Понятия
Процедуры
Команды

Команды
NETLOAD | Загрузка приложения .NET
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Запуск приложения из командной строки - Понятия

Введение в интерфейсы программирования
Запуск приложения из командной строки
Понятия
Процедуры
Команды

С помощью файла acad.pgp можно определить новую команду AutoCAD, которая вызывает внешнюю команду для запуска нужного приложения. В приведенном ниже примере определяется команда ЗПРИЛ1, которая вызывает приложение app1. exe из папки c:\vbapps\ . (Этот фрагмент кода необходимо добавить в раздел внешних команд файла acad.pgp.)

ЗПРИЛ1, start c:\vbapps\app1, 0

Если при запуске приложения требуется задавать определенные параметры, можно воспользоваться следующим примером:

RUNAPP2, start c:\vbapps\app2, 0, *Параметры: ,

В этом примере определяется команда ЗПРИЛ2, при выполнении которой запрашиваются параметры, передаваемые впоследствии запускаемому приложению.

Другой способ запуска приложений, использующих Automation, заключается в применении функции AutoLISP startapp. При этом после запуска внешнего приложения управление его выполнением из AutoLISP невозможно. Однако с помощью AutoLISP можно вызывать различные приложения в зависимости от значения тех или иных параметров.


Запуск приложения из командной строки - Команды

Введение в интерфейсы программирования
Введение в интерфейсы программирования
Запуск приложения из командной строки
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Запуск приложения из меню или с помощью панели инструментов - Понятия

Введение в интерфейсы программирования
Запуск приложения из меню или с помощью панели инструментов
Понятия
Процедуры
Команды

Создав новую команду для запуска внешнего приложения, ее можно вызывать из меню или панели инструментов.

Этот макрос можно вызвать из элемента интерфейса в файле настройки (НПИ). Если планируется использовать только одно или два приложения, пункты меню для их вызова можно добавить в одно из стандартных раскрывающихся меню. Если требуется использовать несколько приложений, для них можно создать свое раскрывающееся меню или панель инструментов. Подробнее о создании, редактировании и загрузке файлов настройки см. раздел Настройка интерфейса пользователя.


Запуск приложения из меню или с помощью панели инструментов - Команды

Введение в интерфейсы программирования
Введение в интерфейсы программирования
Запуск приложения из меню или с помощью панели инструментов
Понятия
Процедуры
Команды

Команды
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


AutoCAD VBA - Понятия

Введение в интерфейсы программирования
AutoCAD VBA
Понятия
Процедуры
Команды

Microsoft Visual Basic for Applications (VBA) является объектно-ориентированным языком программирования с собственной средой разработки и обладает широкими возможностями. Основное отличие VBA от VB (Visual Basic) состоит в том, что VBA работает одновременно с AutoCAD, предоставляя быструю среду для программного управления AutoCAD.

  • Основные сведения о AutoCAD VBA
  • Использование приложений AutoCAD VBA
    Загрузка VBA-проекта осуществляется командой VBALOAD. После загрузки модули и макросы проекта становятся доступными в диалоговом окне «Макросы».
  • Автоматическая загрузка и выполнение проектов VBA
    Можно автоматически загружать проекты VBA при запуске AutoCAD.


AutoCAD VBA - Процедуры

Введение в интерфейсы программирования
AutoCAD VBA
Понятия
Процедуры
Команды

Нет процедур для этой темы.


AutoCAD VBA - Команды

Введение в интерфейсы программирования
AutoCAD VBA
Понятия
Процедуры
Команды
Команды
VBAIDE | Вызов редактора Visual Basic
VBALOAD | Загружает глобальный проект в текущий сеанс работы
VBAMAN | Загрузка, выгрузка, сохранение, создание, вложение и извлечение проектов VBA
VBARUN | Запуск VBA-макроса
VBASTMT | Выполнение выражения VBA в командной строке AutoCAD
VBAUNLOAD | Глобальная выгрузка проекта VBA
ЗАГПРИЛ | Загрузка и выгрузка приложений; задание набора приложений для автозагрузки
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Основные сведения о AutoCAD VBA - Понятия

Введение в интерфейсы программирования
Основные сведения о AutoCAD VBA
Понятия
Процедуры
Команды

VBA может служить средством интеграции различных приложений, в которые встроена поддержка VBA. Таким образом, AutoCAD, может управлять другими приложениями, например, Microsoft Word или Excel, используя их библиотеки объектов.

Чтобы дополнить AutoCAD VBA такими компонентами, как модуль работы с внешними базами данных или средство подготовки отчетов, можно отдельно приобрести пакет Visual Basic 6, являющийся самостоятельным продуктом.

Процесс разработки с помощью AutoCAD VBA

Передача сообщений от VBA к AutoCAD осуществляется с помощью интерфейса AutoCAD ActiveX Automation Interface. С помощью макроса AutoCAD VBA среда Visual Basic может работать одновременно с AutoCAD и осуществлять программный контроль AutoCAD через интерфейс ActiveX Automation. Связка AutoCAD, ActiveX Automation и VBA является очень мощным средством программирования. Оно позволяет не только управлять объектами AutoCAD, но и обмениваться данными с другими приложениями.

Результатом интеграции VBA и AutoCAD является легкое в использовании средство визуального программирования, которое можно использовать для настройки AutoCAD. С его помощью можно, например, разработать приложение, которое автоматически извлекает значения атрибутов, вставляет результаты в книгу Excel и выполняет другие требуемые манипуляции с данными.

Принципы программирования на VBA для AutoCAD основываются на трех базовых составляющих. Первой составляющей является сама программа AutoCAD, которая обладает большим набором объектов, различных данных и команд. AutoCAD является приложением с открытой архитектурой и имеет интерфейсы различных уровней. Для эффективного использования VBA желательно иметь навыки программирования под AutoCAD. Однако следует отметить, что положенный в основу VBA объектно-ориентированный подход к программированию существенно отличается от используемого в AutoLISP.

Второй составляющей является интерфейс ActiveX Automation, который определяет порядок передачи сообщений (взаимодействия) с объектами AutoCAD. Программирование на VBA требует понимания принципов организации интерфейса ActiveX Automation. Описание интерфейса ActiveX Automation применительно к AutoCAD приводится в документации Руководство разработчика ActiveX и VBA (в меню AutoCAD "Справка" нажмите "Дополнительные ресурсы" » "Документация для разработчиков").

Третьей составляющей является, собственно, сама среда VBA. VBA имеет свой собственный набор объектов, ключевых слов, констант и т.д., которые используются при написании, отладке и выполнении программ. В комплект поставки AutoCAD входит обширная справочная система по VBA от Microsoft.

Управление AutoCAD с помощью интерфейса ActiveX/VBA по сравнению с использованием средств API обладает рядом преимуществ.

  • Скорость. Приложения ActiveX работают быстрее программ AutoLISP.
  • Простота в использовании. Язык и среда разработки VBA легки в освоении и использовании. Установка VBA производится вместе с AutoCAD.
  • Взаимодействие с приложениями Windows. ActiveX и VBA разработаны для использования в приложениях Windows и предоставляют прекрасные возможности для организации взаимодействия и обмена данными между различными приложениями.
  • Быстрота разработки. Благодаря быстроте проектирования интерфейса приложений с помощью VBA, данная среда может служить прекрасным средством для создания приложений-прототипов, даже если окончательная реализация планируется на другом языке программирования.
  • Распространенность. Во всем мире миллионы программистов пользуются языком Visual Basic. Наличие AutoCAD ActiveX/VBA дает возможность выполнять настройку AutoCAD и разрабатывать для него приложения программистам, уже владеющим языком Visual Basic 6 или собирающимся его изучать.


AutoCAD VBA

Введение в интерфейсы программирования
AutoCAD VBA
Понятия
Процедуры
Команды

Нет процедур.


Основные сведения о AutoCAD VBA - Команды

Введение в интерфейсы программирования
Введение в интерфейсы программирования
Основные сведения о AutoCAD VBA
Понятия
Процедуры
Команды

Команды
VBAIDE | Вызов редактора Visual Basic
VBALOAD | Загружает глобальный проект в текущий сеанс работы
VBAMAN | Загрузка, выгрузка, сохранение, создание, вложение и извлечение проектов VBA
VBARUN | Запуск VBA-макроса
VBASTMT | Выполнение выражения VBA в командной строке AutoCAD
VBAUNLOAD | Глобальная выгрузка проекта VBA
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование приложений AutoCAD VBA - Понятия

Введение в интерфейсы программирования
Использование приложений AutoCAD VBA
Понятия
Процедуры
Команды

Загрузка VBA-проекта осуществляется командой VBALOAD. После загрузки модули и макросы проекта становятся доступными в диалоговом окне «Макросы».

В отличие от приложений Microsoft, которые используют для хранения проектов, макросов и программ VBA непосредственно документы, AutoCAD для этих целей использует специальные файлы с расширением .dvb. Это обеспечивает возможность взаимодействия интерфейсов VBA с AutoCAD аналогично тому, как это делается в AutoLISP и ObjectARX. Благодаря тому, что проекты VBA хранятся в отдельных файлах, в одном сеансе AutoCAD приложения VBA могут открывать и закрывать различные чертежи.

Примечание Двоичный формат файлов проектов VBA в AutoCAD не совместим с форматом проектов Visual Basic 6 (файлами VBP). Однако из интегрированной среды разработки IDE (integrated development environment) VBA можно экспортировать и импортировать формы, модули и классы, используя для этого команды ИМПОРТ и ЭКСПОРТ.

Загрузка VBA-проекта осуществляется командой VBALOAD. После загрузки модули и макросы проекта становятся доступными в диалоговом окне "Макросы". Для выполнения модуля VBA служит команда VBARUN. Если не загружено ни одного проекта VBA, данные опции недоступны. При выводе процедур в списке с именами макросов используется следующий синтаксис:

модуль.макрос

В диалоговом окне "Макросы" перечнем отображаемых в списке модулей можно управлять с помощью списка "Макросы из".

Использование командной строки для запуска макросов VBA

Для выполнения макросов из командной строки AutoCAD следует вызвать команду -VBARUN (дефис перед именем команды VBARUN означает вызов варианта команды, использующего интерфейс командной строки). Макросы VBA можно вызывать из командной строки, сценариев, а также из других средств программирования AutoCAD. Единственным аргументом команды должно быть имя модуля и макроса VBA, отделенные точкой (модуль.макрос). Образец вызова выглядит следующим образом:

-vbarun <модуль. макрос>

Необходимость использования синтаксиса вида модуль.макрос обусловлена тем, что различные модули могут содержать макросы с одинаковыми именами.


Использование приложений AutoCAD VBA - Команды

Введение в интерфейсы программирования
Введение в интерфейсы программирования
Использование приложений AutoCAD VBA
Понятия
Процедуры
Команды

Команды
VBAIDE | Вызов редактора Visual Basic
VBALOAD | Загружает глобальный проект в текущий сеанс работы
VBAMAN | Загрузка, выгрузка, сохранение, создание, вложение и извлечение проектов VBA
VBARUN | Запуск VBA-макроса
VBASTMT | Выполнение выражения VBA в командной строке AutoCAD
VBAUNLOAD | Глобальная выгрузка проекта VBA
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Автоматическая загрузка и выполнение проектов VBA - Понятия

Введение в интерфейсы программирования
Автоматическая загрузка и выполнение проектов VBA
Понятия
Процедуры
Команды

Можно автоматически загружать ранее созданные проекты VBA при каждом запуске AutoCAD. При этом содержащиеся в таких проектах макросы стразу же становятся доступными. Кроме того, для автоматической загрузки нужных приложений может использоваться команда ЗАГПРИЛ.

acvba.arx — Автоматическая загрузка VBA

Работа с VBA возможна только после загрузки arx-модуля VBA в память, что происходит при первом выполнении любой из команд AutoCAD VBA. Для того, чтобы arx-модуль VBA автоматически загружался при запуске AutoCAD, следующую строку нужно добавить в файл acad.rx:

acvba.arx

Для автоматического выполнения макроса его следует добавить в файл acad.dvb и назвать AcadStartup. Макрос с именем AcadStartup из файла acad.dvb выполняется автоматически при загрузке модуля VBA.

acad.dvb — Автоматическая загрузка проекта VBA

Файл acad.dvb удобно использовать для загрузки отдельных объектов VBA при каждом запуске AutoCAD. При каждом запуске нового сеанса AutoCAD производится поиск и загрузка файла acad.dvb.

Если какой-либо макрос файла acad.dvb должен выполняться при создании нового или открытии имеющегося чертежа, в файл acaddoc.lsp следует добавить приведенный ниже код:

(defun S::STARTUP ( )
  (command "_-vbarun" "updatetitleblock")
)

Имя проекта в данном примере - updatetitleblock.


Автоматическая загрузка и выполнение проектов VBA - Команды

Введение в интерфейсы программирования
Введение в интерфейсы программирования
Автоматическая загрузка и выполнение проектов VBA
Понятия
Процедуры
Команды

Команды
VBAIDE | Вызов редактора Visual Basic
VBALOAD | Загружает глобальный проект в текущий сеанс работы
VBAMAN | Загрузка, выгрузка, сохранение, создание, вложение и извлечение проектов VBA
VBARUN | Запуск VBA-макроса
VBASTMT | Выполнение выражения VBA в командной строке AutoCAD
VBAUNLOAD | Глобальная выгрузка проекта VBA
ЗАГПРИЛ | Загрузка и выгрузка приложений; задание набора приложений для автозагрузки
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


AutoLISP и Visual LISP - Понятия

Введение в интерфейсы программирования
AutoLISP и Visual LISP
Понятия
Процедуры
Команды

AutoLISP основан на языке программирования LISP, который является простым и в то же время достаточно мощным. В AutoCAD имеется встроенный интерпретатор LISP, который позволяет вводить коды AutoLISP в командной строке или загружать их из внешних файлов. Интегрированная среда разработки Visual LISP (VLISP) предназначена для ускорения процесса создания программ на AutoLISP.

  • Коротко об AutoLISP и Visual LISP
  • Работа с приложениями AutoLISP
    AutoLISP-приложения хранятся в текстовых ASCII-файлах, которые можно редактировать. Перед использованием AutoLISP-приложения его необходимо загрузить в память.
  • Автоматическая загрузка и выполнение процедур AutoLISP
    Можно автоматически загружать процедуры VBA при запуске AutoCAD. Может также потребоваться, чтобы определенные функции и команды выполнялись автоматически в требуемые моменты сеанса.


AutoLISP и Visual LISP - Процедуры

Введение в интерфейсы программирования
AutoLISP и Visual LISP
Понятия
Процедуры
Команды

Нет процедур для этой темы.


AutoLISP и Visual LISP - Команды

Введение в интерфейсы программирования
AutoLISP и Visual LISP
Понятия
Процедуры
Команды
Команды
ЗАГПРИЛ | Загрузка и выгрузка приложений; задание набора приложений для автозагрузки
Системные переменные
ACADLSPASDOC | Управление режимом загрузки файла acad.lsp: либо в каждый чертеж, либо только при открытии первого чертежа в сеансе.
LISPINIT | Указывает, сохраняются ли функции и переменные AutoLISP при открытом чертеже в однодокументном интерфейсе
PICKADD | Управляет дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов)
PICKAUTO | Управляет автоматическим созданием рамки выбора объектов в ответ на запрос "Выберите объекты".
SDI | Управляет режимом работы программы (одно- или многодокументный интерфейс)
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко об AutoLISP и Visual LISP - Понятия

Введение в интерфейсы программирования
Коротко об AutoLISP и Visual LISP
Понятия
Процедуры
Команды

В результате совершенствования AutoLISP появилась интегрированная среда разработки Visual LISP (VLISP), которая включает в себя компилятор, отладчик и ряд других средств, повышающих производительность. В языке появились новые возможности, которые позволяют взаимодействовать с объектами с использованием интерфейса ActiveX. Кроме того, на VLISP с помощью реакторов объектов можно обрабатывать различные события.

В отличие от ObjectARX или VBA, в Visual LISP для каждого чертежа, открытого в многодокументной среде AutoCAD, имеется свое пространство имен и собственная среда. Пространство имен каждого чертежа является изолированным, что позволяет избегать конфликтов имен переменных, процедур AutoLISP среди одновременно открытых чертежей. Например, следующее выражение по-разному устанавливает значение переменной а для различных документов.

(setq a (getvar "DWGNAME"))

В Visual LISP имеется механизм загрузки символов и переменных из одного пространства имен в другое. Дополнительную информацию о пространствах имен см. в документации Руководство разработчика AutoLISP ( в меню AutoCAD "Справка" выберите "Дополнительные ресурсы" » " Документация для разработчиков").

Приложения и процедуры AutoLISP могут взаимодействовать с AutoCAD различными способами. Они могут запрашивать необходимую информацию у пользователя, непосредственно обращаться к встроенным командам AutoCAD, создавать и изменять объекты в базе данных чертежа. В AutoCAD с помощью процедур AutoLISP можно создавать новые команды для решения конкретных задач. Некоторые из стандартных команд AutoCAD написаны на языке AutoLISP.

Приложения Visual LISP могут загружаться из файлов трех форматов:

  • LSP-файлы (с расширением .lsp)—Текстовый файл ASCII, содержащий код программы AutoLISP.
  • FAS-файлы (с расширением .fas)—двоичная скомпилированная версия одного файла программы LSP.
  • VLX-файлы (с расширением .vlx)—скомпилированный набор одного или нескольких файлов LSP или DCL-файлов.

Примечание Если существует несколько приложений AutoLISP с одинаковыми именами, загружается то из них, которое имеет наиболее позднюю дату изменения. То же самое происходит при загрузке файлов с расширениями LSP, FAS или VLX, если не указано полное имя файла, включая его расширение.

Поскольку AutoCAD может выполнять код AutoLISP непосредственно, его компиляция не требуется. Несмотря на то, что в Visual LISP имеется интегрированная среда разработки, для ознакомления с AutoLISP можно использовать командную строку: вводя в ней выражения, можно сразу же видеть результаты их выполнения. Это делает AutoLISP удобным языком для экспериментирования как для новичков, так и для опытных программистов.

Пользователи, не имеющие намерений писать собственные приложения на AutoLISP, тем не менее, могут найти много полезных процедур, входящих в комплект поставки AutoCAD. Имеется также большое число условно-бесплатных процедур и приложений, поставляемых сторонними разработчиками. Умение загружать и использовать такие приложения позволяет значительно повысить производительность работы.

Примечание Если вызов команды производится с помощью функции command языка AutoLISP, подразумевается, что системные переменные PICKADD и PICKAUTO имеют значения 1 и 0, соответственно. Это обеспечивает совместимость с предыдущими версиями AutoCAD и упрощает настройку, так как пропадает необходимость проверки параметров этих переменных.

Дополнительную информацию о программировании на AutoLISP см. в документации Руководство разработчика AutoLISP , а о функциях AutoLISP и Visual LISP - в документации Справка по AutoLISP (в меню AutoCAD "Справка" выберите "Дополнительные ресурсы" » " Документация для разработчиков"). В программах на AutoLISP можно использовать диалоговые окна. Документация о программируемых диалоговых окнах содержится только в документации Руководство разработчика AutoLISP.


AutoLISP и Visual LISP

Введение в интерфейсы программирования
AutoLISP и Visual LISP
Понятия
Процедуры
Команды

Нет процедур.


Коротко об AutoLISP и Visual LISP - Команды

Введение в интерфейсы программирования
Введение в интерфейсы программирования
Коротко об AutoLISP и Visual LISP
Понятия
Процедуры
Команды

Команды
Нет. |
Системные переменные
PICKADD | Управляет дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов)
PICKAUTO | Управляет автоматическим созданием рамки выбора объектов в ответ на запрос "Выберите объекты".
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Работа с приложениями AutoLISP - Понятия

Введение в интерфейсы программирования
Работа с приложениями AutoLISP
Понятия
Процедуры
Команды

AutoLISP-приложения хранятся в текстовых ASCII-файлах с расширением .lsp. Каждый такой файл обычно начинается с заголовка, в котором описываются все процедуры файла и порядок их использования, а также приводятся дополнительные специальные указания. В заголовке также могут быть приведены данные об авторе и условиях использования программы, оформленные в виде комментариев. Строки комментариев начинаются с символа точки с запятой (;). Для просмотра и редактирования таких файлов можно использовать любой текстовый редактор или текстовый процессор, который сохраняет тексты в формате ASCII.

Перед использованием AutoLISP-приложения его необходимо загрузить в память. Для этого можно использовать команду ЗАГПРИЛ или функцию load языка AutoLISP. При загрузке приложения AutoLISP выполняется загрузка AutoLISP-кода из LSP-файла в память системы.

Для загрузки с помощью функции load из командной строки необходимо вводить AutoLISP-выражение. В случае успешного завершения функция load возвращает в командной строке значение самого последнего выражения, содержащегося в файле. Обычно в этом качестве выступает либо имя самой последней определенной в файле функции, либо подсказка по использованию функции. Если функция load завершается неудачно, AutoLISP выдает сообщение об ошибке. Подобная ситуация при выполнении функции load может возникнуть вследствие ошибок в LISP-коде или при ошибочном вводе в командной строке имени файла. Формат использования функции load имеет следующий вид:

(load имя_файла [при_ошибке])

Функция load имеет два аргумента: обязательный - имя_файла и необязательный - при_ошибке. При загрузке файла AutoLISP из командной строки обычно задается только аргумент имя_файла. В следующем примере иллюстрируется загрузка AutoLISP файла newfile.lsp.

Команда: (load "newfile")

Расширение имени файла .lsp не обязательно. Такой формат ввода можно использовать для любых LSP-файлов, хранящихся по текущему библиотечному пути.

Для загрузки AutoLISP файла, находящегося не по библиотечному пути, аргумент имя_файла должен включать в себя также полный путь к файлу.

Команда: (load "d:/files/morelisp/newfile")

Примечание Для отделения имен папок при вводе пути следует использовать одну прямую косую черту (/) или две обратных косых черты (\\). Это связано с тем, что в AutoLISP символ обратной косой черты (\\) имеет специальное назначение.

См. также

Коротко об организации файлов


Работа с приложениями AutoLISP - Команды

Введение в интерфейсы программирования
Введение в интерфейсы программирования
Работа с приложениями AutoLISP
Понятия
Процедуры
Команды

Команды
ЗАГПРИЛ | Загрузка и выгрузка приложений; задание набора приложений для автозагрузки
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Автоматическая загрузка и выполнение процедур AutoLISP - Понятия

Введение в интерфейсы программирования
Автоматическая загрузка и выполнение процедур AutoLISP
Понятия
Процедуры
Команды

Можно автоматически загружать процедуры VBA при запуске AutoCAD. Может также потребоваться, чтобы определенные функции и команды выполнялись автоматически в требуемые моменты сеанса.

  • Коротко об автоматической загрузке процедур AutoLISP
  • Файл ACAD.LSP
    Пользователь может создать файл acad.lsp для регулярного использования программ на AutoLISP. При запуске AutoCAD производится поиск файла поддержки acad.lsp. Если файл acad.lsp найден, он загружается в память.
  • Файл ACADDOC.LSP
    Файл acaddoc.lsp предназначен для выполнения инициализации каждого документа (чертежа). Этот файл удобно использовать для автоматической загрузки библиотек AutoLISP-процедур при создании нового чертежа или открытии имеющегося.
  • MNL-файл и AutoLISP-функции для меню
    Во время загрузки файла настройки AutoCAD производит поиск файла MNL с таким же именем. При обнаружении нужного файла производится его загрузка в память. Данный механизм позволяет обеспечить загрузку функций AutoLISP, необходимых для работы меню, в программе AutoCAD.
  • Предотвращение ошибок AutoLISP при выполнении файлов автозагрузки
    Если в процессе выполнения AutoLISP-файла автозагрузки происходит ошибка, то оставшаяся часть файла игнорируется и не загружается.
  • Функция S::STARTUP: выполнение после завершения инициализации чертежа
    Для выполнения операций по настройке после инициализации чертежа можно написать функцию S::STARTUP.


Автоматическая загрузка и выполнение процедур AutoLISP - Процедуры

Введение в интерфейсы программирования
Автоматическая загрузка и выполнение процедур AutoLISP
Понятия
Процедуры
Команды

Нет процедур для этой темы.


Автоматическая загрузка и выполнение процедур AutoLISP - Команды

Введение в интерфейсы программирования
Автоматическая загрузка и выполнение процедур AutoLISP
Понятия
Процедуры
Команды
Команды
ЗАГПРИЛ | Загрузка и выгрузка приложений; задание набора приложений для автозагрузки
Системные переменные
ACADLSPASDOC | Управление режимом загрузки файла acad.lsp: либо в каждый чертеж, либо только при открытии первого чертежа в сеансе.
LISPINIT | Указывает, сохраняются ли функции и переменные AutoLISP при открытом чертеже в однодокументном интерфейсе
SDI | Управляет режимом работы программы (одно- или многодокументный интерфейс)
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко об автоматической загрузке процедур AutoLISP - Понятия

Введение в интерфейсы программирования
Коротко об автоматической загрузке процедур AutoLISP
Понятия
Процедуры
Команды

AutoCAD автоматически загружает содержимое трех определяемых пользователем файлов, acad.lsp, acaddoc.lsp и файла MNL, связанных с текущим файлом настройки. По умолчанию загрузка файла acad.lsp производится один раз в начале нового сеанса AutoCAD, в то время как загрузка файла acaddoc.lsp производится для каждого документа (или чертежа). Это позволяет связать загрузку файла acad.lsp с запуском приложения, а загрузку файла acaddoc.lsp с открытием документа (или чертежа). Описанный способ загрузки можно изменить, модифицировав значение системной переменной ACADLSPASDOC.

Если в одном из этих файлов определена специальная функция S::STARTUP, она автоматически исполняется сразу же после инициализации чертежа. Описание функции S::STARTUP можно найти в разделе Функция S::STARTUP: выполнение после завершения инициализации чертежа. Кроме того, перечень приложений для автоматической загрузки можно выбрать с помощью команды ЗАГПРИЛ. В последнем случае редактирование файлов не требуется.

Файлы автозагрузки acad.lsp и acaddoc.lsp не поставляются с AutoCAD. При необходимости пользователь должен создать их самостоятельно.

Автозагрузчик команд

При автоматической загрузке команды с помощью функции load или command независимо от фактического использования этой команды под весь ее AutoLISP-код сразу же выделяется память. Функция autoload языка AutoLISP позволяет сделать команду доступной без загрузки ее кода в память. При добавлении следующего кода в файл acaddoc.lsp происходит автоматическая загрузка команд КОМАНДА1, КОМАНДА2 и КОМАНДА3 из файла cmds. lsp и команды НОВАЯКОМ из файла newcmd. lsp.

(autoload "CMDS" '("КОМАНДА1" "КОМАНДА2" "КОМАНДА3"))
(autoload "NEWCMD" '("НОВАЯКОМ"))

После первого ввода в командной строке имени автоматически загруженной команды AutoLISP загружает полное описание этой команды из соответствующего файла. В AutoLISP также имеется функция autoarxload для приложений ObjectARX. Дополнительную информацию о функциях autoload и autoarxload см. в руководстве Справка по AutoLISP (в меню AutoCAD "Справка" выберите "Дополнительные ресурсы" » " Документация для разработчиков").

Примечание Если существует несколько файлов автозагрузки AutoLISP с одинаковыми именами, загружается тот из них, который имеет наиболее позднюю дату изменения. То же самое происходит при загрузке файлов с расширениями LSP, если не указано полное имя файла (с расширением).

См. также

Загрузка файла AutoLISP

Функция S::STARTUP: выполнение после завершения инициализации чертежа


Автоматическая загрузка и выполнение процедур AutoLISP

Введение в интерфейсы программирования
Автоматическая загрузка и выполнение процедур AutoLISP
Понятия
Процедуры
Команды

Нет процедур.


Коротко об автоматической загрузке процедур AutoLISP - Команды

Введение в интерфейсы программирования
Введение в интерфейсы программирования
Коротко об автоматической загрузке процедур AutoLISP
Понятия
Процедуры
Команды

Команды
ЗАГПРИЛ | Загрузка и выгрузка приложений; задание набора приложений для автозагрузки
Системные переменные
ACADLSPASDOC | Управление режимом загрузки файла acad.lsp: либо в каждый чертеж, либо только при открытии первого чертежа в сеансе.
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Файл ACAD.LSP - Понятия

Введение в интерфейсы программирования
Файл ACAD.LSP
Понятия
Процедуры
Команды

Пользователь может создать файл acad.lsp для регулярного использования программ на AutoLISP. При запуске AutoCAD производится поиск файла поддержки acad.lsp. Если файл acad.lsp найден, он загружается в память.

Загрузка файла acad.lsp производится один раз при запуске нового сеанса AutoCAD. Это связано с тем, что файл acad.lsp предназначен для автозагрузки специальных приложений. Поэтому все переменные и функции, определенные в файле acad.lsp, доступны только для самого первого чертежа. Если требуется, чтобы некоторые процедуры были доступны для всех открываемых документов, их следует поместить в файл acaddoc.lsp.

Режимом загрузки файлов acad.lsp и acaddoc.lsp можно управлять с помощью системной переменной ACADLSPASDOC. Если для системной переменной ACADLSPASDOC установлено значение, равное 0 (значение по умолчанию), файл acad.lsp загружается только один раз, а именно при запуске приложения. Если ACADLSPASDOC равна 1, файл acad.lsp загружается при открытии или создании каждого чертежа.

Значение системной переменной ACADLSPASDOC игнорируется при работе в однодокументном режиме SDI (single document interface). Если системная переменная SDI имеет значение 1, системная переменная LISPINIT управляет повторной инициализацией AutoLISP при открытии нового чертежа. Если LISPINIT равна 1, функции и переменные AutoLISP действуют только для текущего чертежа; при открытии нового чертежа все они выгружаются из памяти, после чего выполняется повторная загрузка файла acad.lsp. В случае, когда системная переменная SDI равна 0, изменение значения LISPINIT не оказывает никакого действия.

В файле acad.lsp может размещаться код AutoLISP одной или нескольких процедур или только последовательность вызовов функции load. Последний способ более предпочтителен, так как при этом упрощается возможная модификация перечня загружаемых процедур и приложений. Если приведенный ниже код сохранить как файл acad.lsp, файлы mysessionapp1.lsp, databasesynch.lsp и drawingmanager.lsp будут загружаться при каждом запуске программы AutoCAD.

(load "mysessionapp1")
(load "databasesynch")
(load "drawingmanager")

Предупреждение lsp, содержащий функции на языке AutoLISP, которые необходимы для нормальной работы AutoCAD. Данный файл загружается в память непосредственно перед загрузкой файла acad.lsp.

См. также

Коротко об организации файлов

Предотвращение ошибок AutoLISP при выполнении файлов автозагрузки


Файл ACAD.LSP - Команды

Введение в интерфейсы программирования
Введение в интерфейсы программирования
Файл ACAD.LSP
Понятия
Процедуры
Команды

Команды
ЗАГПРИЛ | Загрузка и выгрузка приложений; задание набора приложений для автозагрузки
Системные переменные
ACADLSPASDOC | Управление режимом загрузки файла acad.lsp: либо в каждый чертеж, либо только при открытии первого чертежа в сеансе.
LISPINIT | Указывает, сохраняются ли функции и переменные AutoLISP при открытом чертеже в однодокументном интерфейсе
SDI | Управляет режимом работы программы (одно- или многодокументный интерфейс)
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Файл ACADDOC.LSP - Понятия

Введение в интерфейсы программирования
Файл ACADDOC.LSP
Понятия
Процедуры
Команды

Файл acaddoc.lsp предназначен для выполнения инициализации каждого документа (чертежа). Этот файл удобно использовать для автоматической загрузки библиотек AutoLISP-процедур при создании нового чертежа или открытии имеющегося.

Каждый раз при открытии чертежа программа AutoCAD производит поиск файла acaddoc.lsp по библиотечному пути. При обнаружении такого файла производится его загрузка в память. Загрузка файла acaddoc.lsp производится для каждого чертежа независимо от значения системных переменных ACADLSPASDOC и LISPINIT.

В большинстве случаев пользователю достаточно иметь один файл acaddoc.lsp для всех AutoLISP-процедур, работающих непосредственно с документами. AutoCAD выполняет поиск файла acaddoc.lsp в порядке, заданном в стандартных библиотечных путях. Поэтому при работе с различными типами чертежей в каждой папке с чертежами можно хранить свой файл acaddoc.lsp для загрузки требуемого набора процедур AutoLISP.

В файле acaddoc.lsp может храниться код для одной или нескольких процедур или серии запросов функции load . Последний способ более предпочтителен, так как при этом упрощается возможная модификация перечня загружаемых процедур и приложений. Если, например, файл acaddoc.lsp имеет приведенное ниже содержимое, файлы mydocumentapp1.lsp, build.lsp и counter.lsp будут загружаться при открытии каждого документа.

(load "mydocumentapp1")
(load "build")
(load "counter")

Предупреждение lsp. lsp, содержащий функции на языке AutoLISP, которые необходимы для нормальной работы AutoCAD. Данный файл загружается в память непосредственно перед загрузкой файла acaddoc.lsp.

См. также

Коротко об организации файлов

Предотвращение ошибок AutoLISP при выполнении файлов автозагрузки


Файл ACADDOC.LSP - Команды

Введение в интерфейсы программирования
Введение в интерфейсы программирования
Файл ACADDOC.LSP
Понятия
Процедуры
Команды

Команды
ЗАГПРИЛ | Загрузка и выгрузка приложений; задание набора приложений для автозагрузки
Системные переменные
ACADLSPASDOC | Управление режимом загрузки файла acad.lsp: либо в каждый чертеж, либо только при открытии первого чертежа в сеансе.
LISPINIT | Указывает, сохраняются ли функции и переменные AutoLISP при открытом чертеже в однодокументном интерфейсе
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


MNL-файл и AutoLISP-функции для меню - Понятия

Введение в интерфейсы программирования
MNL-файл и AutoLISP-функции для меню
Понятия
Процедуры
Команды

Во время загрузки файла настройки AutoCAD производит поиск файла MNL с таким же именем. При обнаружении нужного файла производится его загрузка в память. Данный механизм позволяет обеспечить загрузку функций AutoLISP, необходимых для работы меню, в программе AutoCAD.

Данный механизм позволяет обеспечить загрузку функций AutoLISP в программе AutoCAD, необходимых для работы меню. Например, файл адаптации AutoCAD по умолчанию acad.cui зависит от содержимого файла acad.mnl. Этот файл содержит определения функций AutoLISP, вызываемых в макросах меню. MNL-файл загружается после файла acaddoc.lsp.

Примечание Если файл настройки загружается с помощью функции command на языке AutoLISP, которая имеет формат (command "menu" "newmenu"), то соответствующий файл MNL загружается только после запуска всей процедуры AutoLISP.

В данном примере для выдачи сообщения использована функция princ. Первый вызов функции princ приводит к появлению в командной строке следующего сообщения:

Утилиты "Newmenu"… загружены.

Второй вызов princ используется для завершения функции AutoLISP. Без второго вызова princ сообщение в командной строке появится дважды. Как уже упоминалось ранее, можно использовать аргумент при_ошибке при вызове функции load для повышения надежности процедур.


MNL-файл и AutoLISP-функции для меню - Команды

Введение в интерфейсы программирования
Введение в интерфейсы программирования
MNL-файл и AutoLISP-функции для меню
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Предотвращение ошибок AutoLISP при выполнении файлов автозагрузки - Понятия

Введение в интерфейсы программирования
Предотвращение ошибок AutoLISP при выполнении файлов автозагрузки
Понятия
Процедуры
Команды

Если в процессе выполнения AutoLISP-файла автозагрузки происходит ошибка, то оставшаяся часть файла игнорируется и не загружается.

Если файлы, указанные в файле загрузки, не существуют или отсутствуют по библиотечному пути AutoCAD, это обычно вызывает ошибки. Для предотвращения прерывания выполнения файла автозагрузки при возникновении ошибки можно использовать аргумент при_ошибке функции load. В следующем примере иллюстрируется использование данного аргумента:

(princ (load "mydocapp1" "\nФайл MYDOCAPP1.LSP не загружен."))
(princ (load "build" "\nФайл BUILD.LSP не загружен."))
(princ (load "counter" "\nФайл COUNTER.LSP не загружен."))
(princ)

При успешном завершении функция load возвращает значение последнего выражения, содержащегося в файле. Обычно в этом качестве выступает либо имя самой последней определенной в файле функции, либо подсказка по использованию функции. В случае неуспешного выполнения функция возвращает значение аргумента при_ошибке. В предыдущем примере возвращаемое функцией load значение передается функции princ, в результате чего это значение отображается в командной строке.

Например, если ошибка возникает при загрузке файла AutoCAD mydocapp1.lsp, то с помощью функции princ будет отображено приведенное ниже сообщение, после чего AutoCAD продолжит загрузку оставшихся двух файлов:

Файл MYDOCAPP1.LSP не загружен.

В файлах acad.lsp, acaddoc.lsp и MNL-файлах функция command обязательно должна вызываться из конструкции defun. Для задания последовательности команд, выполняемой в момент запуска сеанса работы с чертежом, необходимо пользоваться функцией S::STARTUP.

См. также

Функция S::STARTUP: выполнение после завершения инициализации чертежа


Предотвращение ошибок AutoLISP при выполнении файлов автозагрузки - Команды

Введение в интерфейсы программирования
Введение в интерфейсы программирования
Предотвращение ошибок AutoLISP при выполнении файлов автозагрузки
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Функция S::STARTUP: выполнение после завершения инициализации чертежа - Понятия

Введение в интерфейсы программирования
Функция S::STARTUP: выполнение после завершения инициализации чертежа
Понятия
Процедуры
Команды

Для выполнения операций по настройке после инициализации чертежа можно написать функцию S::STARTUP.

Все автоматически загружаемые файлы LISP (acad.lsp, acaddoc.lsp и MNL) размещаются в памяти до завершения полной инициализации чертежа. Обычно это не создает проблем, за исключением тех случаев, когда используется функция command; надежная работоспособность данной функции возможна только после завершения инициализации чертежа.

Если пользовательская функция S::STARTUP содержится в файлахacad.lsp,acaddoc.lsp , или MNL, то она выполняется при каждом создании нового или открытии имеющегося чертежа. Таким образом, для выполнения операций по настройке можно написать функцию S::STARTUP и поместить ее в автоматически загружаемый LISP-файл.

Пусть, например, требуется переопределить стандартную команду ШТРИХ таким образом, чтобы при вводе ее имени вызывалась команда КШТРИХ и выдавалось соответствующее сообщение. Для этого в файл acaddoc.lsp нужно добавить следующий код:

(defun C:ШТРИХ ( )
  (alert "Вызывается команда КШТРИХ!")
  (princ "\nДля вызова встроенной команды ШТРИХ введите ВСТРШТРИХ.\n")
  (command "КШТРИХ")
  (princ)
)
(defun C:ВСТРШТРИХ ( )
  (command ".ШТРИХ")
  (princ)
)
(defun-q S::STARTUP ( )
  (command "нетком" "штрих")
  (princ "\nПереопределение ШТРИХ на КШТРИХ!\n")
)

Перед завершением инициализации чертежа с помощью функции defun задаются новые описания команд ШТРИХ и ВСТРШТРИХ. После завершения инициализации чертежа вызывается функция S::STARTUP, которая отключает стандартное описание команды ШТРИХ.

Примечание Для того чтобы функция S::STARTUP не переопределяла функции с таким же именем из других файлов, ее следует определить с помощью функции defun-q, а не defun.

Так как функция с именем S::STARTUP может быть определена в различных файлах (acad.lsp, acaddoc.lsp, файлах MNL или любых других файлах AutoLISP), то определенную ранее функцию S::STARTUP можно переопределить. В следующем примере приводится способ определения данной функции, позволяющий избежать подобных ситуаций.

(defun-q MYSTARTUP ( )

... автоматически выполняемая функция ...

)
(setq S::STARTUP (append S::STARTUP MYSTARTUP))

В результате такого определения код предыдущей загруженной функции S::STARTUP добавляется к коду новой функции S::STARTUP. Этот способ определения можно использовать независимо от ранее существовавшей функции S::STARTUP.


Функция S::STARTUP: выполнение после завершения инициализации чертежа - Команды

Введение в интерфейсы программирования
Введение в интерфейсы программирования
Функция S::STARTUP: выполнение после завершения инициализации чертежа
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


ObjectARX - Понятия

Введение в интерфейсы программирования
ObjectARX
Понятия
Процедуры
Команды

Технология ObjectARX предоставляет средства для разработки приложений, совместно использующих данные программируемых объектов. Можно пользоваться приложениями ObjectARX от сторонних разработчиков или написать свои собственные.

  • Коротко об ObjectARX
  • Работа с приложениями ObjectARX
    Для загрузки приложения ObjectARX служит параметр "Загрузить" команды ARX. После загрузки приложения все определенные в нем команды можно вызывать из командной строки AutoCAD.
  • Автоматическая загрузка приложений ObjectARX
    Некоторые приложения ObjectARX используют файл acad.rx, в котором содержится список программных файлов ObjectARX, автоматически загружаемых при запуске AutoCAD.


ObjectARX - Процедуры

Введение в интерфейсы программирования
ObjectARX
Понятия
Процедуры
Команды

Нет процедур для этой темы.


ObjectARX - Команды

Введение в интерфейсы программирования
ObjectARX
Понятия
Процедуры
Команды
Команды
ARX | Загрузка, выгрузка и предоставление информации о приложениях ObjectARX
ЗАГПРИЛ | Загрузка и выгрузка приложений; задание набора приложений для автозагрузки
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко об ObjectARX - Понятия

Введение в интерфейсы программирования
Коротко об ObjectARX
Понятия
Процедуры
Команды

ObjectARX® (AutoCAD Runtime Extension) представляет собой среду программирования, позволяющую разрабатывать компилированные приложения AutoCAD. Среда программирования ObjectARX включает ряд библиотек динамической компоновки (DLL), которые работают в едином адресном пространстве с AutoCAD и взаимодействуют непосредственно с внутренними структурами данных и кодами AutoCAD. Эти библиотеки используют преимущества открытой архитектуры AutoCAD, и расширяют классы объектов и возможности AutoCAD благодяра прямому доступу к структурам баз данных AutoCAD, графической системе и ядру геометрических построений. Кроме того, с помощью библиотек DLL можно создавать новые команды, которые будут использоваться аналогично встроенным командам AutoCAD.

Библиотеки ObjectARX можно использовать совместно с другими интерфейсами программирования AutoCAD, например, AutoLISP или VBA, обеспечивая таким образом интеграцию различных интерфейсов программирования приложений.

Описание интерфейса программирования ObjectARX приводится в документации Руководство для разработчика ObjectARX. Это руководство является частью набора ObjectARX Software Development Kit, который можно загрузить на сайте компании Autodesk, в разделе "Development Tools". Для получения дополнительной информации выберите "Дополнительные ресурсы" » "Документация для разработчиков" в меню "Справка", а затем выберите ObjectARX.


ObjectARX

Введение в интерфейсы программирования
ObjectARX
Понятия
Процедуры
Команды

Нет процедур.


Коротко об ObjectARX - Команды

Введение в интерфейсы программирования
Введение в интерфейсы программирования
Коротко об ObjectARX
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Работа с приложениями ObjectARX - Понятия

Введение в интерфейсы программирования
Работа с приложениями ObjectARX
Понятия
Процедуры
Команды

Для загрузки приложения ObjectARX служит параметр "Загрузить" команды ARX. После загрузки приложения все определенные в нем команды можно вызывать из командной строки AutoCAD.

Для размещения некоторых приложений ObjectARX требуется большой объем системной памяти. Поэтому после завершения использования каждого подобного приложения его можно выгрузить из памяти с помощью параметра "Выгрузить" команды ARX.

Приложения ObjectARX также можно загружать функцией arxload языка AutoLISP. Синтаксис функции arxload во многом идентичен синтаксису функции load, используемой для работы с файлами AutoLISP. При успешной загрузке приложения ObjectARX функция arxload возвращает имя программы. Вызов функции arxload имеет следующий синтаксис:

(arxload имя_файла [при_ошибке])

Функция arxload имеет два аргумента имя_файла и при_ошибке. Как и у функции load, аргумент имя_файла является обязательным и должен представлять собой полный путь и имя файла загружаемого приложения ObjectARX. Аргумент при_ошибке является необязательным и обычно не используется при загрузке приложений ObjectARX из командной строки. В следующем примере производится загрузка приложения ObjectARX myapp.arx.

(arxload "myapp")

Как и с файлами AutoLISP, AutoCAD производит поиск указанного файла по библиотечному пути поиска. Для загрузки файла, находящегося вне папок, указанных в библиотечном пути, требуется задание полного пути к нему.

Примечание Для разделения имен папок при вводе пути следует использовать одну прямую косую черту (/) или две обратных косых черты (\\). Это связано с тем, что в AutoLISP символ обратной косой черты (\\) имеет специальное назначение.

Попытка повторной загрузки уже находящегося в памяти приложения приводит к появлению ошибки. Перед использованием arxload следует с помощью функции arx проверить, нет ли приложения в списке уже загруженных.

Для выгрузки приложения с помощью AutoLISP служит функция arxunload. На следующем примере можно посмотреть, как производится выгрузка приложения myapp.

(arxunload "myapp")

Использование функции arxunload приводит к выгрузке из памяти не только приложения, но и определенных в нем команд.

См. также

Коротко об организации файлов


Работа с приложениями ObjectARX - Команды

Введение в интерфейсы программирования
Введение в интерфейсы программирования
Работа с приложениями ObjectARX
Понятия
Процедуры
Команды

Команды
ARX | Загрузка, выгрузка и предоставление информации о приложениях ObjectARX
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Автоматическая загрузка приложений ObjectARX - Понятия

Введение в интерфейсы программирования
Автоматическая загрузка приложений ObjectARX
Понятия
Процедуры
Команды

Некоторые приложения ObjectARX используют файл acad.rx, в котором содержится список программных файлов ObjectARX, автоматически загружаемых при запуске AutoCAD.

Для создания и редактирования этого файла можно использовать любой текстовый редактор или текстовый процессор, который сохраняет тексты в формате ASCII. При необходимости этот файл можно изменять, удаляя неиспользуемые или добавляя нужные имена ObjectARX-приложений. Кроме того, перечень приложений для автоматической загрузки можно выбрать с помощью команды ЗАГПРИЛ. В последнем случае редактирование файлов не требуется.

Так как в AutoCAD поиск файла acad.rx производится в порядке, заданном в стандартных библиотечных путях, в каждой папке с чертежами можно хранить свой файл acad.rx. Это позволяет загружать требуемый набор ObjectARX приложений для различных типов чертежей. Пусть, например, трехмерные чертежи хранятся в папке с именем AcadJobs/3d_dwgs. Если эта папка установлена текущей, в нее можно скопировать файл acad.rx и внести в него следующие изменения:

myapp1
другие_приложения

Если поместить новый файл acad.rx в папку AcadJobs/3d_dwgs и запустить программу AutoCAD при условии, что эта папка является текущей, то все указанные в этом файле приложения ObjectARX будут загружены и станут доступными из командной строки. Поскольку исходный файл acad.rx остается в папке программных файлов AutoCAD, файл по умолчанию acad.rx будет загружен при запуске AutoCAD из другой папки, в которой отсутствует файл acad.rx.

С помощью функции arxload приложения ObjectARX можно загружать из MNL-файлов. Это позволяет при загрузке файла меню также загружать все необходимые ObjectARX-приложения, которые должны вызываться из данного меню.

Многие команды AutoCAD, содержащиеся в arx-модулях, можно загружать автоматически. Дополнительную информацию о Коротко об автоматической загрузке процедур AutoLISP и функции autoarxload см. в руководстве Справка по AutoLISP (в меню AutoCAD "Справка" выберите "Дополнительные ресурсы" » "Документация для разработчика".

См. также

Коротко об автоматической загрузке процедур AutoLISP


Автоматическая загрузка приложений ObjectARX - Команды

Введение в интерфейсы программирования
Введение в интерфейсы программирования
Автоматическая загрузка приложений ObjectARX
Понятия
Процедуры
Команды

Команды
ЗАГПРИЛ | Загрузка и выгрузка приложений; задание набора приложений для автозагрузки
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


.NET - Понятия

Введение в интерфейсы программирования
.NET
Понятия
Процедуры
Команды

В среде Microsoft .NET Framework с помощью таких языков программирования, как VB .NET и C#, можно создавать приложения, взаимодействующие с AutoCAD.

  • Обзор .NET
  • Загрузка управляемых приложений в AutoCAD
    Чтобы загрузить управляемое приложение, в командной строке AutoCAD введите NETLOAD и перейдите к требуемому файлу DLL. Управляемые приложения выгружаются только при выходе из программы AutoCAD.


.NET - Процедуры

Введение в интерфейсы программирования
.NET
Понятия
Процедуры
Команды

Нет процедур для этой темы.


.NET - Команды

Введение в интерфейсы программирования
.NET
Понятия
Процедуры
Команды
Команды
NETLOAD | Загрузка приложения .NET
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Обзор .NET - Понятия

Введение в интерфейсы программирования
Обзор .NET
Понятия
Процедуры
Команды

.NET Framework - это независимая от языка среда программирования, разработанная корпорацией Microsoft. Кроме среды выполнения программы в Framework существуют библиотеки классов, которые упрощают разработку безопасных взаимодействующих с другими приложений Windows и приложений на основе Интернет-технологий.

AutoCAD поддерживает разработку приложений .NET с помощью управляемых интерфейсных классов ObjectARX. Полный список доступных управляемых интерфейсных классов см. в ObjectARX SDK в разделах “AutoCAD Managed Class Reference” (Справочное руководство по управляемым классам AutoCAD) и “ObjectARX Managed Wrapper Classes” (Управляемые интерфейсные классы ObjectARX) документации Руководство разработчика ObjectARX. Дополнительную информацию о .NET Framework см. в документации Microsoft.

Управляемые интерфейсные классы поставляются для большинства пакетов ObjectARX SDK, что позволяет создавать приложения на любом языке, поддерживаемом .NET Framework, включая VB .NET и C#. Управляемые классы выполняют функцию баз данных и позволяют создавать приложения, которые могут читать и сохранять файлы чертежей в формате DWG. Они также открывают доступ к элементам пользовательского интерфейса AutoCAD, включая командную строку и функциональные диалоговые окна, редактору AutoCAD, а также к компонентам печати и публикации.


.NET

Введение в интерфейсы программирования
.NET
Понятия
Процедуры
Команды

Нет процедур.


Обзор .NET - Команды

Введение в интерфейсы программирования
Введение в интерфейсы программирования
Обзор .NET
Понятия
Процедуры
Команды

Команды

Нет.

Системные переменные

Нет.

Утилиты

Нет.

Ключевые слова для команд

Нет.


Загрузка управляемых приложений в AutoCAD - Понятия

Введение в интерфейсы программирования
Загрузка управляемых приложений в AutoCAD
Понятия
Процедуры
Команды

Чтобы загрузить управляемое приложение, в командной строке AutoCAD введите NETLOAD и перейдите к требуемому файлу DLL. Управляемые приложения выгружаются только при выходе из программы AutoCAD.


Загрузка управляемых приложений в AutoCAD - Команды

Введение в интерфейсы программирования
Введение в интерфейсы программирования
Загрузка управляемых приложений в AutoCAD
Понятия
Процедуры
Команды

Команды
NETLOAD | Загрузка приложения .NET
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Формы и шрифты - Понятия

Формы и шрифты
Понятия
Процедуры
Команды

Пользователю предоставляется возможность создавать формы, которые могут использоваться в качестве условных обозначений и символов текстовых шрифтов. В данном разделе речь идет о том, как описываются и компилируются формы и шрифты.

  • Коротко о файлах форм
  • Создание файлов описаний форм
    Файлы форм и шрифтов AutoCAD (SHX) - это результат компиляции исходных файлов описаний форм (SHP). Для создания и модификации файлов описаний можно использовать любой текстовый редактор или текстовый процессор, который сохраняет тексты в формате ASCII.


Формы и шрифты - Процедуры

Формы и шрифты
Понятия
Процедуры
Команды

Для компиляции файла формы или шрифта

Добавление описаний верхних и нижних индексов к описанию шрифта


Формы и шрифты - Команды

Формы и шрифты
Понятия
Процедуры
Команды
Команды
ЗАГРУЗИТЬ | Подготовка форм к использованию командой ФОРМА
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коротко о файлах форм - Понятия

Формы и шрифты
Коротко о файлах форм
Понятия
Процедуры
Команды

Формы в AutoCAD - это объекты, используемые подобно блокам. Вначале с помощью команды ЗАГРУЗИТЬ откомпилированный файл описаний форм загружается в чертеж. После этого можно производить вставку форм из этого файла, вызывая команду ФОРМА. Для каждого вхождения формы пользователь задает масштаб и угол поворота. SHP-шрифты AutoCAD описываются точно так же, как и формы; по сути дела, это формы специального типа.

Блоки более универсальны, и применять их гораздо проще, чем формы. Однако формы более эффективны для AutoCAD в отношении хранения и быстроты обработки. В тех случаях, когда достаточно простой элемент нужно вставить в разные места чертежа, удобнее использовать именно пользовательские формы.

Компиляция файлов форм/шрифтов

Формы описываются в специальном формате и хранятся в текстовых файлах с расширением shp. Для создания такого файла нужно использовать любой текстовый редактор или текстовый процессор, который сохраняет тексты в формате ASCII, а затем скомпилировать ASCII-файл. При компиляции файлов описаний форм (SHP) генерируются файлы с расширением SHX.

Откомпилированный файл имеет то же имя, что и файл описания формы, но с расширением SHX. Если в файле описывается шрифт, то на его основе можно создать текстовый стиль, воспользовавшись командой СТИЛЬ. Для последующего нанесения текстовых надписей служат команды ТЕКСТ и МТЕКСТ. Если в файле описываются формы, вначале необходимо загрузить его в чертеж с помощью команды ЗАГРУЗИТЬ. После этого для вставки форм можно пользоваться командой ФОРМА (подобно тому, как вставляются блоки командой ВСТАВИТЬ).

Компиляция шрифтов PostScript

Для того чтобы использовать в AutoCAD шрифты Type 1 PostScript, необходима их предварительная компиляция в файл форм AutoCAD. Это выполняется командой КОМПИЛ, которая принимает на вход как SHP-, так и PFB-файлы и в результате генерирует SHX-файл. Откомпилированные варианты шрифтов PostScript могут занимать много места на диске, поэтому следует компилировать только те шрифты, к которым производятся частые обращения.

AutoCAD не может компилировать и загружать все возможные шрифты Type 1. Процедуры работы с PostScript-шрифтами в AutoCAD рассчитаны только на подмножество шрифтов, разработанных фирмой Adobe. Если в процессе компиляции PostScript-шрифта произошла ошибка, то вполне вероятно, что SHX-файл, если даже и будет получен, не сможет быть загружен в AutoCAD.

Подробная информация о формате шрифтов Adobe Type 1 изложена в документе Формат шрифта Adobe Type1 версии 1.1. Если эти шрифты установлены на компьютер, они становятся доступны для AutoCAD.

Примечание Следует ознакомиться со всеми ограничениями, связанными с наличием авторских прав на шрифты PostScript, и строго соблюдать их. Все эти ограничения распространяются и на полученные в результате компиляции SHX-файлы шрифтов.


Для компиляции файла формы или шрифта - Процедуры

Формы и шрифты
Коротко о файлах форм
Понятия
Процедуры
Команды

Для компиляции файла формы или шрифта

  • В командной строке введите компил.

В диалоговом окне "Выбор файла формы или шрифта" выберите файл описания формы (SHP) или файл шрифта PostScript (PFB). После этого начинается компиляция. Если AutoCAD обнаружит в описаниях форм какие-либо ошибки, на экране появляется сообщение, указывающее тип ошибки и номер неверной строки в файле. Если компиляция прошла успешно, в командной строке выдается следующая информация:

Компиляция завершена.

Файл вывода имя.shx содержит nnn байт.


Коротко о файлах форм - Команды

Формы и шрифты
Формы и шрифты
Коротко о файлах форм
Понятия
Процедуры
Команды

Команды
ЗАГРУЗИТЬ | Подготовка форм к использованию командой ФОРМА
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание файлов описаний форм - Понятия

Формы и шрифты
Создание файлов описаний форм
Понятия
Процедуры
Команды

Файлы форм и шрифтов AutoCAD (SHX) - это результат компиляции исходных файлов описаний форм (SHP). Для создания и модификации файлов описаний можно использовать любой текстовый редактор или текстовый процессор, который сохраняет тексты в формате ASCII.

  • Описания форм
    Файлы форм и шрифтов AutoCAD (SHX) - это результат компиляции исходных файлов описаний форм (SHP). Для создания и модификации файлов описаний можно использовать любой текстовый редактор или текстовый процессор, который сохраняет тексты в формате ASCII.
  • Коды длин и направлений векторов
    Длина и направление каждого вектора формы кодируются одним байтом описания.
  • Специальные коды
    Кроме кодов отрисовки векторов, в байте описания формы можно использовать ряд специальных кодов, предназначенных для создания дополнительных форм и выполнения других операций.
  • Описания текстовых шрифтов
    В описания текстовых шрифтов должна входить специальная форма с номером 0, содержащая информацию о шрифте.
  • Файлы-образцы
    В данном разделе приводится содержимое файлов-образцов, использующихся для включения специальных символов в шрифты, входящие в комплект поставки AutoCAD.
  • Описания больших шрифтов
    В некоторых иностранных языках (например, в японском) используются текстовые шрифты, содержащие тысячи знаков алфавита, отсутствующих в коде ASCII. Для того чтобы иметь возможность работы с такими текстами, в AutoCAD предусмотрен специальный формат файла описания форм, который называется Большой шрифт.
  • Описания шрифтов Unicode
    Одного шрифта Unicode, вследствие гораздо большего количества символов в нем, достаточно для поддержки всех языков и платформ. Формат и синтаксис файлов описания шрифтов Unicode практически идентичны формату и синтаксису файлов описания обычных форм AutoCAD.
  • Верхние и нижние индексы в SHX-файлах
    Для усовершенствования отображения верхних и нижних индексов в текстовых строках нужно внести некоторые изменения в соответствующие файлы описания форм.


Создание файлов описаний форм - Процедуры

Формы и шрифты
Создание файлов описаний форм
Понятия
Процедуры
Команды

Добавление описаний верхних и нижних индексов к описанию шрифта


Создание файлов описаний форм - Команды

Формы и шрифты
Создание файлов описаний форм
Понятия
Процедуры
Команды
Команды
ЗАГРУЗИТЬ | Подготовка форм к использованию командой ФОРМА
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Описания форм - Понятия

Формы и шрифты
Описания форм
Понятия
Процедуры
Команды

Файлы форм и шрифтов AutoCAD (SHX) - это результат компиляции исходных файлов описаний форм (SHP). Для создания и модификации файлов описаний можно использовать любой текстовый редактор или текстовый процессор, который сохраняет тексты в формате ASCII.

Синтаксис в файлах описаний не зависит от того, как будут эти описания использоваться как формы или как текстовые шрифты. Но для тех описаний, которые относятся к шрифтам, первым элементом файла должно быть описание шрифта, а не формы. Если же файл начинается с обычного описания формы, AutoCAD считает, что это — файл форм, а не шрифта.

Умение пользователя создавать собственные описания форм является весьма ценным навыком. Однако, следует помнить, что этот предмет очень сложен, и его изучение требует наличия терпения.

Каждая строка в файле описания форм может содержать до 128 символов. Более длинные строки не могут быть откомпилированы. Так как AutoCAD игнорирует в описаниях пустые строки и текст справа от точки с запятой, в файлы описания форм можно включать комментарии.

У каждого описания формы имеется строка заголовка, за которой следуют одна или несколько строк с байтами описания. Байты разделяются запятыми; в конце описания должен стоять нуль.

*номер_формы,число_байт,имя_формы
байт1,байт2,байт3,...,0

В следующем списке рассматриваются поля описаний форм:

номер_формы

Уникальный в пределах файла номер от 1 до 258 (для шрифтов Unicode до 32768). Перед номером должна следовать звездочка (*). В обычных (не Unicode) шрифтах номера 256, 257 и 258 предназначены для хранения символов градуса, плюса-минуса и диаметра. В шрифтах Unicode эти символы имеют коды соответственно U+00B0, U+00B1 и U+2205 и являются частью набора “Расширенная латиница-А”.

Для описаний текстовых шрифтов (файлов, содержащих описания форм для каждого символа) номерами форм должны являться коды ASCII символов, которым эти формы соответствуют. Для описаний форм номера могут быть произвольными.

число_байт

Количество байт, которыми описывается форма (включая завершающий нуль). Длина каждого описания не должна превышать 2000 байт.

имя_формы

Имя формы. Оно должно быть написано в верхнем регистре. Имена в нижнем регистре игнорируются. Они обычно используются для кратких пояснений к символам шрифта.

байтN

Байт описания формы. Он содержит либо длину и направление вектора, либо один из специальных кодов. Байты описания могут представляться как десятичными, так и шестнадцатеричными значениями. В приведенных в данном разделе примерах (как и в реальных описаниях) используются и те, и другие. Если первым символом байта описания является 0 (нуль), то два следующих символа интерпретируются как шестнадцатеричное число.


Создание файлов описаний форм

Формы и шрифты
Создание файлов описаний форм
Понятия
Процедуры
Команды

Нет процедур.


Описания форм - Команды

Формы и шрифты
Формы и шрифты
Описания форм
Понятия
Процедуры
Команды

Команды
ЗАГРУЗИТЬ | Подготовка форм к использованию командой ФОРМА
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коды длин и направлений векторов - Понятия

Формы и шрифты
Коды длин и направлений векторов
Понятия
Процедуры
Команды

Длина и направление каждого вектора формы кодируются одним байтом описания.

Длина и направление каждого вектора формы кодируются одним байтом описания (в поле байтN). Каждый код длины и направления представляет собой строку из трех символов. Первым символом должен быть 0, наличие которого указывает AutoCAD, что два следующих символа интерпретируются как шестнадцатеричные числа. Второй символ задает длину вектора в единицах чертежа. Длина может принимать значения от 1 (одна единица) до F (15 единиц). Третий символ задает направление вектора. Коды направлений приведены на следующем чертеже:

Все изображенные на чертеже векторы считаются равными по длине. Диагональные векторы "растягиваются" так, чтобы их концы по оси X или Y были выровнены по ближайшему ортогональному вектору. Процесс растягивания подобен шаговой привязке в AutoCAD.

Рассмотрим пример построения формы с именем DBOX и номером 230 (назначенным произвольно).

*230,6,DBOX
014,010,01C,018,012,0

Эта последовательность байтов определяет квадрат с длиной стороны 1 единица и диагональю, проведенной из левого нижнего в правый верхний угол. После того как форма сохранена в файле dbox.shp, необходимо вызвать команду КОМПИЛ и создать с ее помощью файл dbox.shx. Затем готовая форма загружается в чертеж командой ЗАГРУЗИТЬ и вставляется командой ФОРМА, как показано ниже:

Команда: форма

Имя формы или [?]: dbox

Точка вставки: 1,1

Высота <текущая>: 2

Угол поворота <текущий>: 0

Результат вставки показан на чертеже.


Коды длин и направлений векторов - Команды

Формы и шрифты
Формы и шрифты
Коды длин и направлений векторов
Понятия
Процедуры
Команды

Команды
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Специальные коды - Понятия

Формы и шрифты
Специальные коды
Понятия
Процедуры
Команды

Кроме кодов отрисовки векторов, в байте описания формы можно использовать ряд специальных кодов, предназначенных для создания дополнительных форм и выполнения других операций.

Кроме кодов отрисовки векторов, в байте описания формы можно использовать ряд специальных кодов, предназначенных для создания дополнительных форм и выполнения других операций. Для того чтобы задать специальный код, нужно либо вписать 0 (нуль) во второй позиции трехсимвольной спецификации байта (описание длины вектора), либо поставить только номер кода. Например, верными будут как код 008, так и код 8.

Специальные коды
Код | Описание
000 | Конец описания формы
001 | Включение режима отрисовки (опускание пера)
002 | Отключение режима отрисовки (поднятие пера)
003 | Деление длин векторов на следующий байт
004 | Умножение длин векторов на следующий байт
005 | Занесение текущей позиции в стек
006 | Восстановление текущей позиции из стека
007 | Отрисовка субформы, номер которой определяется следующим байтом
008 | Смещение по осям X-Y, заданное следующими двумя байтами
009 | Ряд из нескольких смещений по осям X-Y, оканчивающийся на (0,0)
00A | Октантная дуга, заданная следующими двумя байтами
00B | Дробная дуга, заданная следующими пятью байтами
00C | Дуга, заданная смещением X-Y и прогибом
00D | Несколько дуг, заданных прогибом
00E | Обработка следующей команды только для вертикального текста
  • Коды 0, 1 и 2: Конец формы и управление режимом построения
  • Коды 3 и 4: Управление размером
  • Коды 5 и 6: Сохранение и восстановление позиции
  • Код 7: Субформа
  • Коды 8 и 9: Смещения по X-Y
  • Код 00A: Октантная дуга
  • Код 00B: Дробная дуга
  • Коды 00C и 00D: Дуги, заданные прогибом
  • Код 00E: Флаг вертикального текста


Специальные коды - Процедуры

Формы и шрифты
Специальные коды
Понятия
Процедуры
Команды

Нет процедур для этой темы.


Специальные коды - Команды

Формы и шрифты
Специальные коды
Понятия
Процедуры
Команды
Команды
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коды 0, 1 и 2: Конец формы и управление режимом построения - Понятия

Формы и шрифты
Коды 0, 1 и 2: Конец формы и управление режимом построения
Понятия
Процедуры
Команды

Кодом 0 маркируется конец описания формы.

Коды 1 и 2 управляют режимом построения. Режим отрисовки включается в начале каждой формы. При включенном режиме отрисовки (код 1) происходит отрисовка линий, заданных векторами. При отключенном режиме отрисовки (код 2) происходит перенос пера к новой позиции без проведения линии.


Специальные коды

Формы и шрифты
Специальные коды
Понятия
Процедуры
Команды

Нет процедур.


Коды 0, 1 и 2: Конец формы и управление режимом построения - Команды

Формы и шрифты
Формы и шрифты
Коды 0, 1 и 2: Конец формы и управление режимом построения
Понятия
Процедуры
Команды

Команды
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коды 3 и 4: Управление размером - Понятия

Формы и шрифты
Коды 3 и 4: Управление размером
Понятия
Процедуры
Команды

Коды 3 и 4 управляют относительным размером каждого вектора. Высота, указанная при вводе команды ФОРМА, первоначально считается длиной одного ортогонального вектора (в направлении 0, 4, 8 или C). Код 3 делит длину векторов на следующий байт. Код 4 умножает длину векторов на следующий байт. За кодами 3 и 4 следует байт, в котором содержится целочисленный масштабный коэффициент (от 1 до 255). Если нужно, чтобы реальная высота формы была точно равна значению высоты, заданному при вставке, а согласно описанию в ней укладывается 10 длин векторов, то для масштабирования необходимо использовать комбинацию 3,10. Масштабный коэффициент в пределах одной формы обладает свойством накопления; так, при умножении исходного значения на 2, а затем на 6 результатом будет коэффициент 12. Рекомендуется по окончании отрисовки формы восстанавливать исходный масштабный коэффициент, особенно для субформ и текстовых шрифтов. AutoCAD не выполняет сброс масштабного коэффициента.


Коды 3 и 4: Управление размером - Команды

Формы и шрифты
Формы и шрифты
Коды 3 и 4: Управление размером
Понятия
Процедуры
Команды

Команды
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коды 5 и 6: Сохранение и восстановление позиции - Понятия

Формы и шрифты
Коды 5 и 6: Сохранение и восстановление позиции
Понятия
Процедуры
Команды

Код 5 загружает (сохраняет) в стек, а код 6 извлекает (восстанавливает) из стека текущие координаты пера. С их помощью можно вернуться к некоторой точке описания после отрисовки линий от нее. Необходимо всегда извлекать из стека все, что туда загружено. Стек может хранить не более четырех позиций. Если стек переполнен из-за избыточного количества операций записи или пропущенных операций считывания, при отрисовке формы появляется сообщение:

Переполнение позиционного стека в форме nnn

Аналогично, если попытаться считать из стека больше значений, чем туда было загружено, при отрисовке формы появляется сообщение:

Потеря значимости позиционного стека в форме nnn


Коды 5 и 6: Сохранение и восстановление позиции - Команды

Формы и шрифты
Формы и шрифты
Коды 5 и 6: Сохранение и восстановление позиции
Понятия
Процедуры
Команды

Команды
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Код 7: Субформа - Понятия

Формы и шрифты
Код 7: Субформа
Понятия
Процедуры
Команды

Код 7 производит построение субформы, номер которой определяется следующим байтом. Для не-Unicode-шрифтов за кодом 7 следует номер формы от 1 до 255. Для Unicode-шрифтов за кодом 7 следует номер формы от 1 до 65535. Номера форм Unicode всегда являются двухбайтовыми (подробнее об отличиях шрифтов Unicode от обычных шрифтов см. раздел Описания шрифтов Unicode). Производится отрисовка формы с заданным номером, хранящейся в том же файле. Автоматической установки режима отрисовки для новой формы не происходит. По завершении построения субформы возобновляется отрисовка текущей формы.


Код 7: Субформа - Команды

Формы и шрифты
Формы и шрифты
Код 7: Субформа
Понятия
Процедуры
Команды

Команды
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коды 8 и 9: Смещения по X-Y - Понятия

Формы и шрифты
Коды 8 и 9: Смещения по X-Y
Понятия
Процедуры
Команды

Стандартные коды позволяют выполнять отрисовку линий только в 16 фиксированных направлениях, причем максимальная длина вектора равна 15 единиц. Это ограничение повышает эффективность процедуры построения форм, но подчас существенно ограничивает ее возможности. Коды 8 и 9 служат для проведения нестандартных векторов, которые задаются смещениями по X-Y. Код 8 определяет смещение по осям X-Y , заданное следующими двумя байтами. За кодом 8 должны следовать два байта в формате:

8,X-смещение,Y-смещение

Смещения по X-Y могут принимать значения от -128 до +127. Знак "+" перед величиной смещения не обязателен, и для удобства можно использовать круглые скобки. В следующем примере описывается вектор, соединяющий текущую точку с точкой, отстоящей от нее на 10 единиц влево и на 3 единицы вверх.

8,(-10,3)

После того, как вектор по смещению отрисован, восстанавливается режим построения стандартных векторов.

Код 9 используется для последовательности "нестандартных" векторов. После него может следовать любое количество пар значений смещения по X-Y. Последовательность завершается значением (0,0). В следующем примере описывается построение трех нестандартных векторов с последующим возвратом в обычный режим.

9,(3,1),(3,2),(2,-3),(0,0)

Если не завершить последовательность смещений X-Y парой (0,0), AutoCAD не сможет правильно трактовать идущие далее векторы обычного формата и специальные коды.


Коды 8 и 9: Смещения по X-Y - Команды

Формы и шрифты
Формы и шрифты
Коды 8 и 9: Смещения по X-Y
Понятия
Процедуры
Команды

Команды
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Код 00A: Октантная дуга - Понятия

Формы и шрифты
Код 00A: Октантная дуга
Понятия
Процедуры
Команды

Специальный код 00A (или 10) служит для отрисовки дуги по значениям двух следующих байт. Дуга называется октантной, так как она стягивает один или несколько 45-градусных октантов, причем начало и конец дуги лежат точно на границах октантов. Октанты нумеруются в направлении против часовой стрелки, начиная с положения "три часа", как показано на следующем рисунке.

Описание дуги имеет вид

10,радиус,(-)0SC

Радиус может принимать любое значение от 1 до 255. Второй байт указывает направление дуги (против часовой стрелки, если значение положительно, и по часовой стрелке - если отрицательно), начальный октант (s, значение от 0 до 7) и количество охватываемых дугой октантов (c, значение от 0 до 7, где значение 0 соответствует восьми октантам, т.е. полному кругу). Для удобочитаемости можно использовать круглые скобки. Рассмотрим в качестве примера следующий фрагмент описания формы:

...012,10,(1,-032),01E,...

Отрисовывается единичный вектор вверх-вправо, затем дуга по часовой стрелке (радиусом 1 единица, начиная с октанта 3, с охватом двух октантов), и, наконец, единичный вектор вниз-вправо, как показано на чертеже.


Код 00A: Октантная дуга - Команды

Формы и шрифты
Формы и шрифты
Код 00A: Октантная дуга
Понятия
Процедуры
Команды

Команды
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Код 00B: Дробная дуга - Понятия

Формы и шрифты
Код 00B: Дробная дуга
Понятия
Процедуры
Команды

Специальный код 00B (11) инициирует отрисовку дуги, которая может начинаться и заканчиваться не на границе октанта. В описании используются 5 байт.

11,смещение_начала,смещение_конца,радиус_ст,радиус,(-)0SC

Смещение_начала и смещение_конца задают величины удаления начальной и конечной точек дуги от границ октанта. Радиус_ст - это старшие 8 бит значения радиуса; они остаются нулевыми, если радиус не превышает 255 единиц. Для того чтобы получить значение радиуса дуги, превышающего 255 единиц, нужно умножить радиус_ст на 256 и добавить к полученному числу радиус. Радиус и завершающий байт задаются точно так же, как и для описанной ранее октантной дуги (код 00A).

Смещениеначала определяется путем вычисления разности (в градусах) между начальной границей октанта (кратной 45 градусам) и началом дуги. Затем эта разность умножается на 256 и делится на 45. Если дуга начинается на границе октанта, смещение_начала равно 0.

Смещение_конца вычисляется аналогичным образом, но при этом используется разность (в градусах) между последней границей октанта, пересеченной дугой, и концом дуги. Если дуга заканчивается на границе октанта, смещение_конца равно 0.

Например, дробная дуга радиусом 3 единицы, проведенная между направлениями 55 и 95 градусов, кодируется так:

11,(56,28,0,3,012)

Пояснение к значениям параметров:

смещение_начала = 56, так как ((55 - 45) * 256 / 45) = 56
смещение_конца = 28, так как ((95 - 90) * 256 / 45) = 28
радиус_ст = 0 , так как (радиус < 255)
радиус = 3
начальный октант = 1, так как дуга начинается в октанте 45 градусов
конечный октант = 2 , так как дуга заканчивается в октанте 90 градусов


Код 00B: Дробная дуга - Команды

Формы и шрифты
Формы и шрифты
Код 00B: Дробная дуга
Понятия
Процедуры
Команды

Команды
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Коды 00C и 00D: Дуги, заданные прогибом - Понятия

Формы и шрифты
Коды 00C и 00D: Дуги, заданные прогибом
Понятия
Процедуры
Команды

Специальные коды 00C и 00D (12 и 13) обеспечивают еще один способ включения дуговых сегментов в описания форм. Они аналогичны кодам 8 и 9 в том отношении, что позволяют задавать смещения по X-Y. Однако, в кодах 00C и 00D отрисовка дуг производится на основании коэффициента прогиба относительно вектора смещения. Код 00C отрисовывает один дуговой сегмент, а код 00D несколько дуговых сегментов (полидуг) до тех пор, пока не последует смещение (0,0).

За кодом 00C должны следовать три байта в формате:

0C,X-смещение,Y-смещение,прогиб

Смещения по X и Y и прогиб, который задает кривизну дуги, могут принимать значения от -127 до +127. Если длина смещения равна D, а стрелка прогиба (т.е. расстояние по нормали от середины вектора смещения до дуги) равна H, коэффициент прогиба определяется как ((2* H / D) * 127). Если дуга рисуется от текущего до нового положения по часовой стрелке, знак будет отрицательным.

Полукруг обладает прогибом 127 (или –127). Это - наибольшая дуга, которую можно построить с использованием этих кодов (более крупные дуги необходимо комбинировать из двух последовательно соединенных сегментов). Нулевым прогибом описывается прямолинейный сегмент. Однако следует отметить, что предпочтительнее представлять такие сегменты кодом 8, т.к. это экономит один байт в описании формы.

За кодом полидуги (00D, или 13) следует 0 или тройки параметров, описывающих элементарные дуговые сегменты. Полидуга заканчивается смещением (0,0). Значение прогиба после нулевого смещения задавать не требуется. Например, букву S можно описать так:

13,(0,5,127),(0,5,-127),(0,0)

Сегменты с нулевым прогибом удобны для включения прямолинейных участков в описания полидуг. Это более эффективно, чем завершение полидуги, вставка отдельного прямолинейного сегмента и начало новой полидуги.

Использование числа -128 в дуговых сегментах и полидугах не допускается.


Коды 00C и 00D: Дуги, заданные прогибом - Команды

Формы и шрифты
Формы и шрифты
Коды 00C и 00D: Дуги, заданные прогибом
Понятия
Процедуры
Команды

Команды
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Код 00E: Флаг вертикального текста - Понятия

Формы и шрифты
Код 00E: Флаг вертикального текста
Понятия
Процедуры
Команды

Специальный код 00E (14) используется только в описаниях текстовых шрифтов двойной ориентации (горизонтальной и вертикальной). Когда этот код встречается в описании символа, поведение программы по отношению к следующему коду определяется тем, как ориентирован текст. Если выбрана вертикальная ориентация, следующий код обрабатывается; если горизонтальная — пропускается.

В горизонтальном тексте начальной точкой каждого символа является левый конец его базовой линии. В вертикальном тексте начальной точкой является центр верхней линии символа. В конце каждого символа, как правило, выполняется подъем пера и переход к начальной точке следующего символа. В горизонтальном тексте переход происходит вправо, в вертикальном - вниз. Специальный код 00E (14) предназначен прежде всего для учета различий начальных и конечных точек, что позволяет применять одно и то же описание символа как для горизонтальной, так и для вертикальной ориентации текста. Например, следующее описание прописной буквы D может быть использовано в любой ориентации:

*68,22,ucd
2,14,8,(-2, 6),1,030,012,044,016,038,2,010,1,06C,2,050,
14,8,(-4,-3),0


Код 00E: Флаг вертикального текста - Команды

Формы и шрифты
Формы и шрифты
Код 00E: Флаг вертикального текста
Понятия
Процедуры
Команды

Команды
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Описания текстовых шрифтов - Понятия

Формы и шрифты
Описания текстовых шрифтов
Понятия
Процедуры
Команды

В описания текстовых шрифтов должна входить специальная форма с номером 0, содержащая информацию о шрифте.

В комплект поставки AutoCAD входит большое количество текстовых шрифтов. С помощью команды СТИЛЬ их можно расширять, сжимать и наклонять, добиваясь наиболее приемлемого изображения символов. Символам текста можно задавать любую высоту, писать их под любым углом с вертикальной или горизонтальной ориентацией.

Текстовые шрифты AutoCAD - это те же файлы описаний форм, в которых номер формы для каждого символа соответствует его коду ASCII. Коды от 1 до 31 принадлежат управляющим символам; только один из них используется в шрифтах AutoCAD:

10 (LF)

Переход на новую строку без отрисовки текста (LF). Используется при повторе команды TEXT для размещения строк одна под другой.

*10,5,lf

2,8,(0,-10),0

Переопределяя символ LF, можно регулировать величину межстрочного интервала.

В описания текстовых шрифтов должна входить специальная форма с номером 0, содержащая информацию о шрифте. Синтаксис этой формы таков:

*0,4,имя шрифта
сверху, снизу, режимы, 0

Значение сверху задает число длин элементарных векторов, на которое прописные символы возвышаются над базовой линией, а значение снизу показывает, насколько ниже базовой линии могут опускаться строчные символы. Базовая линия здесь соответствует разметке на линованной бумаге. Эти значения определяют размеры символов текста и используются для масштабирования высоты, заданной в команде ТЕКСТ.

Байт режимы равен 0 для шрифта только с горизонтальной ориентацией и 2 - для шрифта, поддерживающего двойную ориентацию (горизонтально и вертикально). Специальный код 00E (14) может использоваться только тогда, когда байт режимы равен 2.

Стандартные шрифты, поставляемые с AutoCAD, включают несколько дополнительных символов, необходимых для нанесения размеров AutoCAD.

%%d Символ градуса (°)

%%p Символ допуска "плюс"/"минус(±)

%%cСимвол размерности диаметра круга

Кроме этих символов в текстах могут использоваться и управляющие последовательности в формате %% nnn. Подробнее о них см. в описании командыТЕКСТ в документе Справочник команд.

Примечание AutoCAD при рисовании буквенных символов использует их коды ASCII (номера форм), а не имена. Поэтому для экономии памяти имена форм следует писать строчными буквами, как показано в следующем примере. (Имена, набранные в нижнем регистре, в память не записываются.)

*65,11,uca
024,043,04d,02c,2,047,1,040,2,02e,0

Имя формы uca состоит из символов нижнего регистра, поэтому AutoCAD не записывает его в память. Однако, его наличие удобно пользователю для визуальной ориентации в файле. В приведенном примере имя uca указывает, что здесь описан символ A верхнего регистра.


Описания текстовых шрифтов - Команды

Формы и шрифты
Формы и шрифты
Описания текстовых шрифтов
Понятия
Процедуры
Команды

Команды
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Файлы-образцы - Понятия

Формы и шрифты
Файлы-образцы
Понятия
Процедуры
Команды

В данном разделе приводится содержимое файлов-образцов, использующихся для включения специальных символов в шрифты, входящие в комплект поставки AutoCAD.

  • Расширенный одноштриховой Roman
  • Расширенный стандартный шрифт UNICODE


Файлы-образцы - Процедуры

Формы и шрифты
Файлы-образцы
Понятия
Процедуры
Команды

Нет процедур для этой темы.


Файлы-образцы - Команды

Формы и шрифты
Файлы-образцы
Понятия
Процедуры
Команды
Команды
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Файлы-образцы

Формы и шрифты
Файлы-образцы
Понятия
Процедуры
Команды

Нет процедур.


Расширенный одноштриховой Roman - Команды

Формы и шрифты
Формы и шрифты
Расширенный одноштриховой Roman
Понятия
Процедуры
Команды

Команды
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Расширенный стандартный шрифт UNICODE - Понятия

Формы и шрифты
Расширенный стандартный шрифт UNICODE
Понятия
Процедуры
Команды

;;
;; txt.shp - расширенный стандартный шрифт UNICODE
;;
;; Copyright 1997 by Autodesk, Inc.
;;
;; Настоящим выдается разрешение на использование, копирование, изменение и распространение
;; данного программного обеспечения в любых целях и без какой-либо платы при условии отображения
;; указанного выше уведомления об авторском праве во всех копиях, а также при условии,
;; что приведенное ниже уведомление об ограничении прав присутствует во всех сопровождающих документах.
;;
;; Use, duplication, or disclosure by the U.S. Government is subject
;; to restrictions set forth in FAR 52.227-19 (Commercial Computer
;; коммерческого программного обеспечения для ЭВМ) и DFAR 252.227-7013(c)(1)(ii)
;; (Права в отношении технических данных и программного обеспечения для ЭВМ), там где они применимы.
;;
*UNIFONT,6,TXT Copyright 1997, Autodesk, Inc.
6,2,2,0,0,0
*0000A,7,lf
2,0AC,14,8,(9,10),0
*00020,7,spc
2,060,14,8,(-6,-8),0
*00021,17,kexc
2,14,06C,1,014,2,014,1,044,2,020,06C,14,8,(-2,-3),0
*00022,20,kdblqt
2,14,8,(-1,-6),044,1,023,2,010,1,02B,2,04C,030,14,8,(-3,1),0
*00023,27,kns
2,14,8,(-2,-6),024,1,040,2,024,1,048,2,023,1,06C,2,020,1,064,2,
06D,14,8,(-4,-3),0
*00024,25,kds
2,14,8,(-2,-6),014,1,030,012,016,028,016,012,030,2,027,1,06C,2,
040,14,8,(-4,-3),0
*00025,31,kpc
2,14,8,(-2,-6),064,1,01C,010,014,018,2,040,1,8,(-4,-6),2,040,1,
018,014,010,01C,2,020,14,8,(-4,-3),0
*00026,24,kand
2,14,8,(-2,-6),041,1,02A,018,016,014,022,014,016,01A,01C,04E,2,
020,14,8,(-4,-3),0
*00027,28,kapos
2,14,3,2,14,8,(-1,-12),14,4,2,044,1,023,2,06C,020,14,3,2,
14,8,(-5,2),14,4,2,0
*00028,16,klp
2,14,8,(-1,-6),064,020,1,02A,02C,02E,2,020,14,03A,0
*00029,15,krp
2,14,8,(-1,-6),064,1,02E,02C,02A,2,040,14,03A,0
*0002A,27,kas
2,14,8,(-2,-5),021,1,044,2,02E,1,048,2,041,1,04A,2,044,1,04E,2,
02F,14,8,(-4,-3),0
*0002B,19,kpls
2,14,8,(-2,-5),021,1,044,2,02E,1,048,2,06F,14,8,(-4,-3),0
*0002C,28,kcma
2,14,3,2,14,02B,14,4,2,014,010,1,01C,01A,2,012,020,14,3,2,
14,8,(-3,-8),14,4,2,0
*0002D,14,ksub
2,14,8,(-2,-3),034,1,040,2,020,03C,14,048,0
*0002E,12,kper
2,14,01C,1,014,2,02F,14,8,(-2,-3),0
*0002F,17,kdiv
2,14,8,(-2,-6),1,8,(4,6),2,020,06C,14,8,(-4,-3),0
*00030,34,n0
2,14,3,2,14,8,(-3,-12),14,4,2,010,1,016,044,012,010,01E,04C,01A,
018,2,040,14,3,2,14,8,(-7,-6),14,4,2,0
*00031,18,n1
2,14,8,(-1,-6),054,1,012,06C,2,018,1,020,2,020,14,03A,0
*00032,23,n2
2,14,8,(-2,-6),054,1,012,020,01E,01C,01A,028,01A,02C,040,2,020,
14,8,(-4,-3),0
*00033,29,n3
2,14,8,(-2,-6),054,1,012,020,01E,01C,01A,018,2,010,1,01E,01C,01A,
028,016,2,01C,060,14,8,(-4,-3),0
*00034,19,n4
2,14,8,(-2,-6),041,1,048,8,(3,4),06C,2,030,14,8,(-4,-3),0
*00035,23,n5
2,14,8,(-2,-6),014,1,01E,020,012,024,016,038,024,040,2,020,06C,
14,8,(-4,-3),0
*00036,24,n6
2,14,8,(-2,-6),034,1,030,01E,01C,01A,028,016,034,022,010,2,030,
06C,14,8,(-4,-3),0
*00037,16,n7
2,14,8,(-2,-6),064,1,040,06B,2,050,14,8,(-4,-3),0
*00038,32,n8
2,14,8,(-2,-6),010,1,016,014,012,020,012,014,016,028,01A,01C,01E,
2,020,1,01E,01C,01A,028,2,050,14,8,(-4,-3),0
*00039,24,n9
2,14,8,(-2,-6),010,1,010,022,034,016,028,01A,01C,01E,030,2,020,
03C,14,8,(-4,-3),0
*0003A,17,kcol
2,14,04C,044,1,01C,2,01C,1,01C,2,02F,14,8,(-2,-3),0
*0003B,34,ksmc
2,14,3,2,14,8,(-1,-8),14,4,2,010,044,1,01C,2,01C,1,02C,01A,2,012,
020,14,3,2,14,8,(-5,-8),14,4,2,0
*0003C,29,klt
2,14,3,2,14,8,(-3,-12),14,4,2,064,030,1,03A,03E,2,020,14,3,2,
14,8,(-5,-6),14,4,2,0
*0003D,18,keq
2,14,04B,044,1,040,2,02C,1,048,2,060,02C,14,8,(-4,-1),0
*0003E,28,kgt
2,14,3,2,14,8,(-3,-12),14,4,2,064,1,03E,03A,2,050,14,3,2,
14,8,(-7,-6),14,4,2,0
*0003F,36,kqm
2,14,3,2,14,8,(-3,-12),14,4,2,054,1,012,010,01E,01C,01A,01C,2,
01C,1,01C,2,030,14,3,2,14,8,(-7,-6),14,4,2,0
*00040,28,kea
2,14,8,(-2,-6),032,1,01A,018,014,012,010,02C,012,024,016,028,01A,
04C,01E,030,2,020,14,8,(-4,-3),0
*00041,21,uca
2,14,8,(-2,-6),1,024,043,04D,02C,2,047,1,040,2,02E,14,8,(-4,-3),0
*00042,29,ucb
2,14,8,(-2,-6),1,030,012,014,016,028,2,020,1,012,014,016,038,2,
010,1,06C,2,050,14,8,(-4,-3),0
*00043,23,ucc
2,14,8,(-2,-6),040,014,1,01A,028,016,044,012,020,01E,2,02E,03C,
14,8,(-4,-3),0
*00044,22,ucd
2,14,8,(-2,-6),1,030,012,044,016,038,2,010,1,06C,2,050,
14,8,(-4,-3),0
*00045,25,uce
2,14,8,(-2,-6),1,064,040,2,048,03C,1,020,2,028,03C,1,040,2,020,
14,8,(-4,-3),0
*00046,21,ucf
2,14,8,(-2,-6),1,064,040,2,048,03C,1,020,2,03C,040,14,8,(-4,-3),0
*00047,22,ucg
2,14,8,(-2,-6),032,1,010,03C,038,016,044,012,030,2,020,06C,
14,8,(-4,-3),0
*00048,22,uch
2,14,8,(-2,-6),1,064,2,03C,1,040,2,034,1,06C,2,020,14,8,(-4,-3),0
*00049,21,uci
2,14,8,(-1,-6),064,1,020,2,018,1,06C,2,018,1,020,2,020,14,03A,0
*0004A,19,ucj
2,14,8,(-2,-6),014,1,01E,020,012,054,2,020,06C,14,8,(-4,-3),0
*0004B,23,uck
2,14,8,(-2,-6),1,064,2,040,1,03A,018,2,010,1,03E,2,020,
14,8,(-4,-3),0
*0004C,16,ucl
2,14,8,(-2,-6),064,1,06C,040,2,020,14,8,(-4,-3),0
*0004D,17,ucm
2,14,8,(-2,-6),1,064,04D,043,06C,2,020,14,8,(-4,-3),0
*0004E,19,ucn
2,14,8,(-2,-6),1,064,8,(4,-6),064,2,06C,020,14,8,(-4,-3),0
*0004F,17,uco
2,14,8,(-2,-6),1,064,040,06C,048,2,060,14,8,(-4,-3),0
*00050,19,ucp
2,14,8,(-2,-6),1,064,030,01E,01C,01A,038,2,06F,14,8,(-4,-3),0
*00051,25,ucq
2,14,8,(-2,-6),022,1,01E,01A,018,016,044,012,020,01E,03C,01A,01E,
2,020,14,8,(-4,-3),0
*00052,23,ucr
2,14,8,(-2,-6),1,064,030,01E,01C,01A,038,2,010,1,03E,2,020,
14,8,(-4,-3),0
*00053,22,ucs
2,14,8,(-2,-6),014,1,01E,020,012,046,012,020,01E,2,020,05C,
14,8,(-4,-3),0
*00054,19,uct
2,14,8,(-2,-6),064,1,040,2,028,1,06C,2,040,14,8,(-4,-3),0
*00055,20,ucu
2,14,8,(-2,-6),064,1,05C,01E,020,012,054,2,020,06C,14,8,(-4,-3),0
*00056,15,ucv
2,14,06B,064,1,06D,063,2,020,06C,14,8,(-5,-3),0
*00057,24,ucw
2,14,06B,064,1,9,(2,-6),(1,3),(1,-3),(2,6),(0,0),2,020,06C,
14,8,(-5,-3),0
*00058,22,ucx
2,14,8,(-2,-6),1,8,(4,6),2,048,1,8,(4,-6),2,020,14,8,(-4,-3),0
*00059,25,ucy
2,14,8,(-2,-6),064,1,8,(2,-3),03C,2,034,1,8,(2,3),2,020,06C,
14,8,(-4,-3),0
*0005A,19,ucz
2,14,8,(-2,-6),064,1,040,8,(-4,-6),040,2,020,14,8,(-4,-3),0
*0005B,17,klb
2,14,8,(-1,-6),1,064,020,2,06C,1,028,2,040,14,03A,0
*0005C,17,kbkslsh
2,14,8,(-2,-6),064,1,8,(4,-6),2,020,14,8,(-4,-3),0
*0005D,15,krb
2,14,8,(-1,-6),064,1,020,06C,028,2,040,14,03A,0
*0005E,16,kcaret
2,14,8,(-2,-6),044,1,022,02E,2,04D,14,8,(-4,1),0
*0005F,11,kundrl
2,14,028,01C,1,040,2,021,14,04A,0
*00060,27,krvap
2,14,3,2,14,8,(-1,-12),14,4,2,064,1,02D,2,04D,14,3,2,14,8,(-5,2),
14,4,2,0
*00061,24,lca
2,14,04B,020,1,018,016,024,012,010,01E,02C,01A,2,012,1,01E,2,020,
14,8,(-4,-3),0
*00062,25,lcb
2,14,8,(-2,-6),1,064,2,04C,1,022,010,01E,02C,01A,018,026,2,02C,
060,14,8,(-4,-3),0
*00063,17,lcc
2,14,04B,042,1,038,01A,02C,01E,030,2,020,14,8,(-4,-3),0
*00064,25,lcd
2,14,8,(-2,-6),041,1,02A,018,016,024,012,010,02E,2,044,1,06C,2,
020,14,8,(-4,-3),0
*00065,20,lce
2,14,04B,024,1,030,012,016,028,01A,02C,01E,020,2,030,
14,8,(-4,-3),0
*00066,22,lcf
2,14,8,(-2,-6),034,1,030,2,023,1,016,018,01A,05C,2,050,
14,8,(-4,-3),0
*00067,22,lcg
2,14,04B,01C,1,01E,020,012,044,016,028,01A,02C,01E,030,2,020,
14,8,(-4,-5),0
*00068,21,lch
2,14,8,(-2,-6),1,064,2,04C,1,022,010,01E,03C,2,020,14,8,(-4,-3),0
*00069,17,lci
2,14,06C,1,044,2,014,1,014,2,020,06C,14,8,(-2,-3),0
*0006A,35,lcj
2,14,3,2,14,8,(-3,-12),14,4,2,01C,1,01E,010,012,054,2,014,1,014,
2,020,06C,14,3,2,14,8,(-7,-10),14,4,2,0
*0006B,23,lck
2,14,8,(-2,-6),1,064,2,04C,1,020,022,2,02A,1,02E,2,020,
14,8,(-4,-3),0
*0006C,28,lcl
2,14,3,2,14,8,(-1,-12),14,4,2,064,1,05C,01E,2,020,14,3,2,
14,8,(-5,-6),14,4,2,0
*0006D,24,lcm
2,14,04B,1,044,2,01C,1,012,01E,01C,2,014,1,012,01E,03C,2,020,
14,8,(-4,-3),0
*0006E,21,lcn
2,14,8,(-2,-6),1,044,2,02C,1,022,010,01E,03C,2,020,14,8,(-4,-3),0
*0006F,20,lco
2,14,04B,030,1,028,016,024,012,020,01E,02C,01A,2,030,
14,8,(-4,-3),0
*00070,22,lcp
2,14,04B,02C,1,064,2,01C,1,012,020,01E,02C,01A,038,2,060,
14,8,(-4,-5),0,
*00071,22,lcq
2,14,04B,04F,1,064,2,01C,1,016,028,01A,02C,01E,030,2,020,
14,8,(-4,-5),0,
*00072,19,lcr
2,14,04B,1,044,2,02C,1,022,010,01E,2,020,03C,14,8,(-4,-3),0
*00073,18,lcs
2,14,04B,1,030,012,016,028,016,012,030,2,04D,14,8,(-4,-3),0
*00074,21,lct
2,14,8,(-2,-6),044,1,040,2,026,1,05C,01E,012,2,02F,14,8,(-4,-3),0
*00075,20,lcu
2,14,04B,044,1,03C,01E,010,022,2,024,1,04C,2,020,14,8,(-4,-3),0
*00076,14,lcv
2,14,04B,044,1,04D,043,2,04D,14,8,(-4,-3),0
*00077,23,lcw
2,14,04B,044,1,9,(1,-4),(1,4),(1,-4),(1,4),(0,0),2,04D,
14,8,(-4,-3),0
*00078,16,lcx
2,14,04B,1,042,2,048,1,04E,2,020,14,8,(-4,-3),0
*00079,19,lcy
2,14,04B,044,1,04D,2,043,1,06B,018,2,024,060,14,8,(-4,-5),0
*0007A,15,lcz
2,14,04B,044,1,040,04A,040,2,020,14,8,(-4,-3),0
*0007B,19,klbr
2,14,8,(-1,-6),064,020,1,01A,01C,01A,01E,01C,01E,2,020,14,03A,0
*0007C,13,kvbar
2,14,06C,1,064,2,06C,020,14,8,(-2,-3),0
*0007D,18,krbr
2,14,8,(-1,-6),1,012,014,012,016,014,016,2,06C,040,14,03A,0
*0007E,15,ktlde
2,14,04B,034,1,012,02F,012,2,04D,14,8,(-4,-2),0
*00080,4,keuroRef
7,020AC,0
*000A0,7,NoBrkSpc
2,060,14,8,(-6,-8),0
*000A1,18,kiexc
2,14,06C,1,044,2,014,1,014,2,8,(2,-6),14,8,(-2,-3),0
*000A2,23,kcent
2,14,8,(-2,-5),01E,1,8,(2,6),2,01E,1,038,01A,02C,01E,030,2,020,
14,04A,0,
*000A3,23,kpound
2,14,8,(-2,-6),040,1,048,012,044,012,01E,2,02B,1,028,2,06F,
14,8,(-4,-3),0
*000A5,34,kyen
2,14,8,(-2,-6),064,1,8,(2,-3),03C,2,025,1,020,2,027,1,020,2,018,
1,8,(2,3),2,8,(2,-6),14,8,(-4,-3),0
*000A7,45,kpar
2,14,3,2,14,8,(-3,-12),14,4,2,014,1,01E,010,012,016,018,016,012,
2,021,1,016,018,01A,01E,010,01E,01A,2,8,(3,-2),14,3,2,
14,8,(-7,-6),14,4,2,0
*000AA,36,lcau
2,14,8,(-1,-6),2,3,2,8,3,9,1,01A,018,016,024,012,010,01E,02C,01E,
2,049,1,040,2,4,2,8,2,-3,14,8,(-3,1),0
*000AB,21,kfrew
2,14,8,(-2,-5),021,1,026,022,2,020,1,02A,02E,2,02F,14,8,(-4,-2),0
*000B0,19,kdeg
2,14,8,(-1,-6),054,1,012,01E,01A,016,2,05C,040,14,8,(-3,2),0
*000B1,23,kpls-min
2,14,8,(-2,-6),014,1,040,2,027,1,044,2,02A,1,040,2,04D,
14,8,(-4,-2),0
*000B5,24,kmicro
2,14,04B,02C,1,8,(1,6),1,03C,01E,010,023,2,024,1,04C,2,020,
14,8,(-4,-5),0
*000BA,35,lcou
2,14,8,(-1,-6),3,2,2,8,3,12,1,028,01A,02C,01E,020,012,024,016,2,
06B,1,040,2,4,2,8,2,-3,14,8,(-3,1),0
*000BB,22,kffrw
2,14,8,(-2,-5),014,1,022,026,2,020,1,02E,02A,2,040,01C,
14,8,(-4,-2),0
*000BC,41,kquart
2,3,2,14,8,(-5,-12),1,8,(10,12),2,8,(-8,-6),1,064,01A,2,05C,1,
020,2,8,(6,-4),1,048,8,(3,4),06C,2,060,14,8,(-9,-6),4,2,0
*000BD,45,khalf
2,3,2,14,8,(-5,-12),1,8,(10,12),2,8,(-8,-6),1,064,01A,2,05C,1,
020,2,8,(3,-1),1,012,020,01E,01C,01A,028,01A,02C,040,2,040,
14,8,(-9,-6),4,2,0
*000BF,32,kiqm
2,3,2,14,8,(-3,-12),8,(6,2),1,02A,028,026,024,022,024,2,024,1,
024,2,8,(8,-12),14,8,(-7,-6),4,2,0
*000C0,31,uc^
2,14,8,(-2,-6),1,024,022,02E,02C,2,8,(-4,1),1,040,2,8,(-2,4),1,
027,2,8,(6,-6),14,8,(-4,-3),0
*000C1,31,uc^
2,14,8,(-2,-6),1,024,022,02E,02C,2,8,(-4,1),1,040,2,8,(-2,4),1,
021,2,8,(2,-6),14,8,(-4,-3),0
*000C2,32,uc^
2,14,8,(-2,-6),1,024,022,02E,02C,2,8,(-4,1),1,040,2,8,(-4,3),1,
022,02E,2,8,(2,-4),14,8,(-4,-3),0
*000C3,33,uc^
2,14,8,(-2,-6),1,024,022,02E,02C,2,8,(-4,1),1,040,2,8,(-4,4),1,
012,02F,012,2,8,(2,-6),14,8,(-4,-3),0
*000C4,32,uc„
2,14,8,(-2,-6),1,024,043,2,029,1,014,2,040,1,01C,2,027,1,04D,02C,
2,047,1,040,2,02E,14,8,(-4,-3),0
*000C5,25,uc^
2,14,8,(-2,-6),1,024,032,016,01A,03E,02C,2,8,(-4,1),1,040,2,02F,
14,8,(-4,-3),0
*000C6,33,uc^
2,14,8,(-2,-6),1,034,8,(2,3),020,2,8,(-2,-3),1,020,2,03C,1,028,
064,2,04B,1,020,2,04F,14,8,(-4,-3),0
*000C7,29,uc‡
2,14,8,(-2,-6),02E,1,010,014,018,014,2,021,1,01A,028,016,044,012,
020,01E,2,02E,03C,14,8,(-4,-5),0
*000C8,28,uc^
2,14,8,(-2,-6),1,044,040,2,016,1,027,2,04C,018,1,020,2,02A,1,040,
2,020,14,8,(-4,-3),0
*000C9,28,uc^
2,14,8,(-2,-6),1,044,040,2,025,1,029,2,03C,018,1,020,2,02A,1,040,
2,020,14,8,(-4,-3),0
*000CA,29,uc^
2,14,8,(-2,-6),1,044,040,2,016,1,016,01A,2,03C,018,1,020,2,02A,1,
040,2,020,14,8,(-4,-3),0
*000CB,32,uc^
2,14,8,(-2,-6),1,044,040,2,016,1,014,2,028,1,01C,2,03C,018,1,020,
2,02A,1,040,2,020,14,8,(-4,-3),0
*000CC,25,uc^
2,14,8,(-1,-6),044,1,020,2,014,1,027,2,02D,1,04C,2,018,1,020,2,
020,14,03A,0
*000CD,25,uc^
2,14,8,(-1,-6),044,1,020,2,024,1,029,2,01E,1,04C,2,018,1,020,2,
020,14,03A,0
*000CE,26,uc^
2,14,8,(-1,-6),044,1,020,2,014,1,016,01A,2,01E,1,04C,2,018,1,020,
2,020,14,03A,0
*000CF,29,uc^
2,14,8,(-1,-6),044,1,020,2,014,1,014,2,028,1,01C,2,01E,1,04C,2,
018,1,020,2,020,14,03A,0
*000D0,25,uc
2,14,8,(-2,-6),1,064,030,01E,04C,01A,038,2,024,015,1,020,2,01D,
04F,14,8,(-4,-3),0
*000D1,25,uc
2,14,8,(-2,-6),1,044,04E,044,2,048,014,1,012,02F,012,2,8,(2,-6),
14,8,(-4,-3),0
*000D2,25,uc^
2,14,8,(-2,-6),1,044,040,2,016,1,027,2,02C,030,1,04C,048,2,060,
14,8,(-4,-3),0
*000D3,25,uc^
2,14,8,(-2,-6),1,044,040,2,025,1,029,2,01C,030,1,04C,048,2,060,
14,8,(-4,-3),0
*000D4,26,uc^
2,14,8,(-2,-6),1,044,040,2,016,1,016,01A,2,01C,030,1,04C,048,2,
060,14,8,(-4,-3),0
*000D5,27,uc^
2,14,8,(-2,-6),1,044,040,2,024,1,01A,027,01A,2,01C,040,1,04C,048,
2,060,14,8,(-4,-3),0
*000D6,31,uc^
2,14,8,(-2,-6),1,044,2,012,1,014,2,02B,1,040,2,016,1,014,2,02D,1,
04C,048,2,060,14,8,(-4,-3),0
*000D8,29,ucd”
2,14,8,(-2,-6),1,8,(4,6),2,018,1,01E,04C,01A,028,016,044,012,020,
2,8,(3,-6),14,8,(-4,-3),0
*000D9,24,uc^
2,14,8,(-2,-6),064,1,05C,01E,020,012,054,2,01A,1,027,2,050,06C,
14,8,(-4,-3),0
*000DA,24,uc^
2,14,8,(-2,-6),064,1,05C,01E,020,012,054,2,018,1,029,2,050,05C,
14,8,(-4,-3),0
*000DB,25,uc^
2,14,8,(-2,-6),064,1,05C,01E,020,012,054,2,01A,1,016,01A,2,050,
05C,14,8,(-4,-3),0
*000DC,27,uc^
2,14,8,(-2,-6),064,1,05C,01E,020,012,054,2,01A,1,014,2,028,1,01C,
2,05E,14,8,(-4,-3),0
*000DD,25,uc^
2,14,8,(-2,-6),044,1,02E,02C,2,024,1,022,2,025,1,029,2,050,05C,
14,8,(-4,-3),0
*000DE,27,lc
2,14,8,(-2,-6),02C,1,084,2,03C,1,012,020,01E,02C,01A,028,016,2,
8,(6,-1),14,8,(-4,-5),0
*000DF,24,kgers
2,14,8,(-2,-6),1,012,044,012,010,01E,01C,01A,01E,01C,01A,018,2,
040,14,8,(-4,-3),0
*000E0,39,lc…
2,14,8,(-2,-6),020,1,018,016,024,012,010,01E,02C,01A,2,012,1,01E,
2,2,3,2,8,(-3,10),1,047,2,8,(11,-12),4,2,14,8,(-4,-3),0
*000E1,39,lc
2,14,8,(-2,-6),020,1,018,016,024,012,010,01E,02C,01A,2,012,1,01E,
2,2,3,2,8,(-3,12),1,049,2,8,(11,-10),4,2,14,8,(-4,-3),0
*000E2,40,lcƒ
2,14,8,(-2,-6),020,1,018,016,024,012,010,01E,02C,01A,2,012,1,01E,
2,2,3,2,8,(-3,10),1,026,02A,2,8,(11,-10),4,2,14,8,(-4,-3),0
*000E3,40,lcƒ
2,14,8,(-2,-6),020,1,018,016,024,012,010,01E,02C,01A,2,012,1,01E,
2,3,2,8,(-7,10),1,012,02F,012,2,8,(7,-11),4,2,14,8,(-4,-3),0
*000E4,37,lc„
2,14,8,(-2,-6),020,1,018,016,024,2,034,1,01C,2,030,1,014,2,03A,1,
012,010,01E,02C,01A,2,012,1,01E,2,020,14,8,(-4,-3),0
*000E5,38,lc†
2,14,8,(-2,-6),3,2,8,(3,8),1,022,026,02A,02E,2,8,(3,-6),4,2,1,
01A,018,016,024,012,010,01E,02C,01E,2,020,14,8,(-4,-3),0
*000E6,30,lc
2,14,04B,021,1,01A,016,024,012,01E,03C,2,034,1,012,01E,01C,028,2,
01C,1,01E,010,2,020,14,8,(-4,-3),0
*000E7,24,lc‡
2,14,04B,042,1,038,01A,02C,01E,030,2,028,1,01C,010,01C,018,2,041,
14,8,(-4,-5),0
*000E8,27,lcŠ
2,14,8,(-2,-6),024,1,030,012,016,028,01A,02C,01E,020,2,054,1,027,
2,050,06C,14,8,(-4,-3),0
*000E9,26,lc‚
2,14,8,(-2,-6),024,1,030,012,016,028,01A,02C,01E,020,2,064,1,029,
2,05E,14,8,(-4,-3),0
*000EA,27,lcˆ
2,14,8,(-2,-6),024,1,030,012,016,028,01A,02C,01E,020,2,054,1,016,
01A,2,05E,14,8,(-4,-3),0
*000EB,31,lc‰
2,14,8,(-2,-6),024,1,030,012,016,028,01A,02C,01E,020,2,064,010,1,
01C,2,048,1,014,2,06E,14,8,(-4,-3),0
*000EC,18,lc_
2,14,8,(-1,-6),010,1,044,2,025,1,02F,2,020,05C,14,03A,0
*000ED,18,lc
2,14,8,(-1,-6),010,1,044,2,016,1,021,2,020,06C,14,03A,0
*000EE,19,lcЊ
2,14,8,(-1,-6),010,1,044,2,016,1,012,01E,2,020,05C,14,03A,0
*000EF,22,lc‹
2,14,8,(-1,-6),010,1,044,2,016,1,014,2,020,1,01C,2,020,05C,
14,03A,0
*000F0,30,lc
2,14,8,(-2,-6),8,(3,4),1,028,01A,02C,01E,020,012,024,036,2,01C,1,
021,2,8,(3,-6),14,8,(-4,-3),0
*000F1,27,lc
2,14,8,(-2,-6),1,044,2,014,1,012,02F,012,2,04A,1,022,010,01E,03C,
2,020,14,8,(-4,-3),0
*000F2,27,lc•
2,14,8,(-2,-6),030,1,028,016,024,012,020,01E,02C,01A,2,054,1,027,
2,050,06C,14,8,(-4,-3),0
*000F3,26,lc
2,14,8,(-2,-6),030,1,028,016,024,012,020,01E,02C,01A,2,064,1,029,
2,05E,14,8,(-4,-3),0
*000F4,27,lc“
2,14,8,(-2,-6),030,1,028,016,024,012,020,01E,02C,01A,2,054,1,016,
01A,2,05E,14,8,(-4,-3),0
*000F5,32,lc^
2,14,8,(-2,-6),030,1,028,016,024,012,020,01E,02C,01A,2,8,(-3,5),
1,012,02F,012,2,8,(2,-6),14,8,(-4,-3),0
*000F6,35,lc”
2,14,8,(-2,-6),030,1,028,016,024,2,034,1,01C,2,040,1,014,2,
8,(-4,-3),1,012,020,01E,02C,01A,2,030,14,8,(-4,-3),0
*000F7,23,kto
2,14,8,(-2,-5),021,1,014,2,021,1,048,2,022,1,01C,2,04E,
14,8,(-4,-2),0
*000F8,24,lcd”
2,14,04B,010,1,020,012,024,016,028,01A,02C,01E,2,018,1,042,2,04D,
14,8,(-4,-3),0
*000F9,27,lc—
2,14,8,(-2,-6),044,1,03C,01E,010,022,2,038,044,1,02F,2,01E,1,04C,
2,020,14,8,(-4,-3),0
*000FA,26,lc
2,14,8,(-2,-6),044,1,03C,01E,010,022,2,036,1,021,2,02D,1,04C,2,
020,14,8,(-4,-3),0
*000FB,27,lc-
2,14,8,(-2,-6),044,1,03C,01E,010,022,2,036,1,012,01E,2,01E,1,04C,
2,020,14,8,(-4,-3),0
*000FC,32,lc_
2,14,8,(-2,-6),064,010,1,01C,2,01A,1,03C,01E,010,022,2,044,018,1,
01C,2,01E,1,04C,2,020,14,8,(-4,-3),0
*000FD,27,lc^
2,14,8,(-2,-6),044,1,04D,2,8,(-1,5),1,021,2,02D,1,06B,018,2,024,
060,14,8,(-4,-3),0
*000FE,25,uc
2,14,8,(-2,-6),1,064,2,01E,019,1,030,01E,01C,01A,038,2,01F,01C,
050,14,8,(-4,-3),0
*000FF,30,lc˜
2,14,8,(-2,-6),044,1,04D,2,054,018,1,014,2,020,1,01C,2,01E,1,06B,
018,2,024,060,14,8,(-4,-5),0
*00104,26,c164
2,14,8,(-2,-6),1,024,043,04D,02C,2,047,1,040,2,02C,1,01A,01E,2,
022,14,8,(-4,-3),0
*00105,30,c165
2,14,04B,020,1,018,016,024,012,010,01E,02C,01A,2,012,1,01E,3,2,
01A,01E,4,2,2,021,14,8,(-4,-3),0
*00106,28,c143
2,14,8,(-2,-6),040,014,1,01A,028,016,044,012,020,01E,2,038,024,1,
021,2,08C,030,14,8,(-4,-3),0
*00107,30,c134
2,14,04B,042,1,038,01A,02C,01E,030,2,3,2,8,(-5,10),1,021,2,029,
8,(9,-10),4,2,14,8,(-4,-3),0
*0010C,31,c172
2,14,8,(-2,-8),040,014,1,01A,028,016,044,012,020,01E,2,026,1,012,
2,01A,1,016,2,050,08C,14,8,(-4,-3),0
*0010D,29,c159
2,14,8,(-2,-6),042,1,038,01A,02C,01E,030,2,028,054,1,012,2,01A,1,
016,2,050,06C,14,8,(-4,-3),0
*0010E,32,c210
2,14,8,(-2,-8),1,030,012,044,016,038,2,010,1,06C,2,010,074,1,012,
2,01A,1,016,2,050,08C,14,8,(-4,-3),0
*0010F,31,c212
2,14,8,(-2,-6),041,1,02A,018,016,024,012,010,02E,2,044,1,06C,2,
020,064,1,01A,2,010,05C,14,8,(-4,-3),0
*00118,28,c168
2,14,8,(-2,-6),1,064,040,2,048,03C,1,020,2,028,03C,1,040,1,01A,
01E,2,022,14,8,(-4,-3),0
*00119,27,c169
2,14,04B,024,1,030,012,016,028,01A,02C,01E,020,3,2,01A,01E,4,2,2,
014,030,14,8,(-4,-3),0
*0011A,35,c183
2,14,8,(-2,-8),1,064,040,2,048,03C,1,020,2,028,03C,1,040,2,028,
074,1,012,2,01A,1,016,2,050,08C,14,8,(-4,-3),0
*0011B,32,c216
2,14,8,(-2,-6),024,1,030,012,016,028,01A,02C,01E,020,2,018,054,1,
012,2,01A,1,016,2,050,06C,14,8,(-4,-3),0

*00141,29,c157

2,14,8,(-2,-6),064,1,06C,040,2,048,034,1,3,2,8,(4,5),2,8,(8,-11),

4,2,14,8,(-4,-3),0

*00142,47,c136

2,14,3,2,14,8,(-1,-12),14,4,2,064,3,2,010,4,2,1,05C,01E,2,3,2,

8,(-3,5),1,8,(3,4),2,8,(4,-9),4,2,14,3,2,14,8,(-5,-6),14,4,2,0

*00143,24,c227

2,14,8,(-2,-6),1,064,8,(4,-6),064,2,038,014,1,021,2,08C,030,

14,8,(-4,-3),0

*00144,42,c228

2,14,3,2,14,8,(-3,-8),14,4,2,1,044,2,01C,1,012,010,01E,03C,2,

8,(-2,5),1,011,2,019,8,(4,-5),14,3,2,14,8,(-7,-6),14,4,2,0

*00147,27,c213

2,14,8,(-2,-8),1,064,8,(4,-6),064,2,027,1,012,2,01A,1,016,2,050,

08C,14,8,(-4,-3),0

*00148,29,c229

2,14,8,(-2,-6),1,044,2,01C,1,012,010,01E,03C,2,018,054,1,012,2,

01A,1,016,2,040,06C,14,03A,0

*00150,27,c138

2,14,8,(-2,-6),1,064,040,06C,048,2,074,010,1,03C,2,020,1,034,2,

07C,030,14,8,(-4,-3),0

*00151,29,c139

2,14,04B,030,1,028,016,024,012,020,01E,02C,01A,2,074,1,02C,2,028,

1,024,2,07C,050,14,8,(-4,-3),0

*00158,33,c252

2,14,8,(-2,-8),1,064,030,01E,01C,01A,038,2,010,1,03E,2,028,074,1,

012,2,01A,1,016,2,050,08C,14,8,(-4,-3),0

*00159,29,c253

2,14,8,(-2,-6),1,044,2,02C,1,022,010,01E,2,026,1,012,2,01A,1,016,

2,050,06C,14,8,(-4,-3),0

*0015A,27,c151

2,14,8,(-2,-6),014,1,01E,020,012,046,012,020,01E,2,024,038,1,021,

2,08C,030,14,8,(-4,-3),0

*0015B,31,c152

2,14,04B,1,030,012,016,028,016,012,030,2,3,2,8,(-5,2),1,021,2,

029,8,(9,-10),4,2,14,8,(-4,-3),0

*00160,30,c230

2,14,8,(-2,-8),014,1,01E,020,012,046,012,020,01E,2,026,1,012,2,

01A,1,016,2,050,08C,14,8,(-4,-3),0

*00161,29,c231

2,14,8,(-2,-6),1,030,012,016,028,016,012,030,2,027,1,012,2,01A,1,

016,2,050,06C,14,8,(-4,-3),0

*00164,28,c155

2,14,8,(-2,-8),064,1,040,2,028,1,06C,2,074,1,012,2,01A,1,016,2,

050,08C,14,8,(-4,-3),0

*00165,26,c156

2,14,8,(-2,-6),044,1,040,2,026,1,05C,01E,012,2,054,1,01A,2,030,

05C,14,8,(-4,-3),0

*0016E,27,c222

2,14,8,(-2,-9),064,1,05C,01E,020,012,054,2,027,1,012,016,01A,01E,

2,040,07C,14,8,(-4,-3),0

*0016F,31,c133

2,14,8,(-2,-7),044,1,03C,01E,010,022,2,024,1,04C,2,028,054,1,012,

016,01A,01E,2,040,05C,14,8,(-4,-3),0

*00170,28,c235

2,14,8,(-2,-6),064,1,05C,01E,020,012,054,2,016,1,03C,2,028,1,034,

2,07C,050,14,8,(-4,-3),0

*00171,30,uue

2,14,04B,044,1,03C,01E,010,022,2,024,1,04C,2,074,018,1,02C,2,028,

1,024,2,07C,050,14,8,(-4,-3),0

*00179,25,c141

2,14,8,(-2,-6),064,1,040,8,(-4,-6),040,2,038,074,1,021,2,08C,030,

14,8,(-4,-3),0

*0017A,28,c171

2,14,04B,044,1,040,04A,040,2,3,2,8,(-5,10),1,021,2,029,8,(9,-10),

4,2,14,8,(-4,-3),0

*0017B,32,c189

2,14,8,(-2,-6),064,1,040,8,(-4,-6),040,2,084,028,1,3,4,01A,01E,

012,016,4,4,2,040,08C,14,8,(-4,-3),0

*0017C,34,c190

2,14,04B,044,1,040,04A,040,2,3,2,8,(-4,11),3,4,1,01A,01E,012,016,

4,4,2,8,(8,-11),4,2,14,8,(-4,-3),0

*0017D,29,c166

2,14,8,(-2,-8),064,1,040,8,(-4,-6),040,2,028,074,1,012,2,01A,1,

016,2,050,08C,14,8,(-4,-3),0

*0017E,27,c167

2,14,8,(-2,-6),044,1,040,04A,040,2,028,054,1,012,2,01A,1,016,2,

050,06C,14,8,(-4,-3),0

*00410,21,ucra

2,14,8,(-2,-6),1,024,043,04D,02C,2,047,1,040,2,02E,14,8,(-4,-3),0

*00411,24,ucrb

2,14,8,(-2,-6),1,064,030,01C,014,038,03C,030,01E,01C,01A,038,2,

060,14,8,(-4,-3),0

*00412,29,ucrv

2,14,8,(-2,-6),1,030,012,014,016,028,2,020,1,012,014,016,038,2,

010,1,06C,2,050,14,8,(-4,-3),0

*00413,17,ucrg

2,14,8,(-2,-6),1,064,040,01C,2,05C,020,14,8,(-4,-3),0

*00414,23,ucrd

2,14,8,(-2,-6),01C,1,014,050,064,028,04B,02C,050,01C,2,014,020,

14,8,(-6,-3),0

*00415,25,ucre

2,14,8,(-2,-6),1,064,040,2,048,03C,1,020,2,028,03C,1,040,2,020,

14,8,(-4,-3),0

*00416,22,ucr!

2,14,8,(-2,-6),062,2,038,1,06C,2,038,064,1,06E,2,020,

14,8,(-6,-3),0

*00417,27,ucr!

2,14,8,(-2,-6),014,1,01E,020,012,014,016,018,010,012,014,016,028,

01A,2,060,05C,14,8,(-4,-3),0

*00418,20,ucri

2,14,8,(-2,-6),1,042,04C,064,2,048,1,06C,2,060,14,8,(-4,-3),0

*00419,24,ucrikr

2,14,8,(-2,-6),1,042,04C,064,2,018,1,028,2,018,1,06C,2,060,

14,8,(-4,-3),0

*0041A,23,ucrk

2,14,8,(-2,-6),1,064,2,040,1,03A,018,2,010,1,03E,2,020,

14,8,(-4,-3),0

*0041B,17,ukrl

2,14,8,(-2,-6),1,010,063,010,06C,2,020,14,8,(-5,-3),0

*0041C,17,ucrm

2,14,8,(-2,-6),1,064,04D,043,06C,2,020,14,8,(-4,-3),0

*0041D,22,ucrn

2,14,8,(-2,-6),1,064,2,03C,1,040,2,034,1,06C,2,020,14,8,(-4,-3),0

*0041E,23,ucro

2,14,8,(-2,-6),014,1,044,012,020,01E,04C,01A,028,016,2,060,01C,

14,8,(-4,-3),0

*0041F,16,ucrp

2,14,8,(-2,-6),1,064,040,06C,2,020,14,8,(-4,-3),0

*00420,19,ucrr

2,14,8,(-2,-6),1,064,030,01E,01C,01A,038,2,06F,14,8,(-4,-3),0

*00421,23,ucrs

2,14,8,(-2,-6),040,014,1,01A,028,016,044,012,020,01E,2,02E,03C,

14,8,(-4,-3),0

*00422,19,ucrt

2,14,8,(-2,-6),064,1,040,2,028,1,06C,2,040,14,8,(-4,-3),0

*00423,23,ucru

2,14,8,(-2,-6),014,1,01E,020,012,054,04C,038,016,034,2,060,06C,

14,8,(-4,-3),0

*00424,25,ucrf

2,14,8,(-2,-6),020,1,064,018,01A,02C,01E,020,012,024,016,018,2,

040,06C,14,8,(-4,-3),0

*00425,22,ucrx

2,14,8,(-2,-6),1,8,(4,6),2,048,1,8,(4,-6),2,020,14,8,(-4,-3),0

*00426,21,ucr!

2,14,8,(-2,-6),1,064,06C,040,064,06C,010,01C,2,014,020,

14,8,(-5,-3),0

*00427,19,ucrch

2,14,8,(-2,-6),064,1,03C,01E,030,044,06C,2,020,14,8,(-4,-3),0

*00428,21,ucrsh

2,14,8,(-2,-6),1,064,06C,030,044,04C,030,064,06C,2,020,

14,8,(-6,-3),0

*00429,24,ucr!

2,14,8,(-2,-6),1,064,06C,030,044,04C,030,064,06C,010,01C,014,2,

020,14,8,(-7,-3),0

*0042A,23,ucr'

2,14,8,(-2,-6),054,1,014,010,06C,030,012,014,016,038,2,060,03C,

14,8,(-5,-3),0

*0042B,24,ucrs

2,14,8,(-2,-6),1,030,012,014,016,038,03C,064,2,050,1,06C,2,020,

14,8,(-5,-3),0

*0042C,21,ucr]

2,14,8,(-2,-6),1,030,012,014,016,038,03C,064,2,060,06C,

14,8,(-4,-3),0

*0042D,25,ucr'

2,14,8,(-2,-6),014,1,01E,020,012,024,028,020,024,016,028,01A,2,

060,05C,14,8,(-4,-3),00,

*0042E,26,ucr!

2,14,8,(-2,-6),1,064,03C,010,024,012,010,01E,04C,01A,018,016,024,

2,050,03C,14,8,(-4,-3),0

*0042F,22,ucrya

2,14,8,(-2,-6),1,022,020,044,038,01A,02C,01E,030,02C,2,020,

14,8,(-4,-3),0

*00430,25,lcra

2,14,8,(-2,-6),014,1,024,012,020,01E,014,04C,014,01A,028,016,2,

060,01C,14,8,(-4,-3),0

*00431,22,lcrb

2,14,8,(-2,-6),044,030,1,038,04C,030,012,016,038,2,02C,060,

14,8,(-4,-3),0

*00432,24,lcrv

2,14,8,(-2,-6),1,044,020,10,(1,-36),028,030,10,(1,-36),038,2,060,

14,8,(-4,-3),0

*00433,16,lcrg

2,14,8,(-2,-6),1,044,030,2,04C,020,14,8,(-3,-3),0

*00434,24,lcrd

2,14,8,(-2,-6),01C,1,014,010,034,012,010,04C,028,030,01C,2,014,

020,14,8,(-4,-3),00,

*00435,20,lcre

2,14,04B,024,1,030,012,016,028,01A,02C,01E,020,2,030,

14,8,(-4,-3),0

*00436,23,lcrg

2,14,8,(-2,-6),1,042,2,048,1,04E,2,028,1,044,2,040,04C,

14,8,(-4,-3),0

*00437,25,lcrz

2,14,8,(-2,-6),034,1,012,020,01E,01A,018,010,01E,01A,028,016,2,

060,01C,14,8,(-4,-3),0

*00438,17,lcri

2,14,8,(-2,-6),044,1,04C,042,04C,2,020,14,8,(-4,-3),0

*00439,23,lcrii

2,14,8,(-2,-6),044,1,04C,042,04C,2,044,018,1,028,2,050,04C,

14,8,(-4,-3),0

*0043A,19,lcrk

2,14,8,(-2,-6),1,044,02C,020,022,02A,02E,2,020,14,8,(-4,-3),0

*0043B,16,lcrl

2,14,8,(-2,-6),1,043,020,04C,2,020,14,8,(-4,-3),0

*0043C,17,lcrm

2,14,8,(-2,-6),1,044,02E,022,04C,2,020,14,8,(-4,-3),0

*0043D,18,lcrn

2,14,8,(-2,-6),1,044,02C,040,024,04C,2,020,14,8,(-4,-3),0

*0043E,25,lcro

2,14,04B,14,8,(0,-2),014,1,024,012,020,01E,02C,01A,028,016,2,060,

01C,14,8,(-4,-3),0

*0043F,16,lcrp

2,14,8,(-2,-6),1,044,040,04C,2,020,14,8,(-4,-3),0

*00440,20,lcrr

2,14,8,(-2,-6),1,044,030,01E,01C,01A,038,2,060,01C,14,8,(-4,-3),0

*00441,23,lcrs

2,14,8,(-2,-6),040,014,1,01A,028,016,024,012,020,01E,2,020,03C,

14,8,(-4,-3),0

*00442,18,lcrt

2,14,8,(-2,-6),020,1,044,028,040,2,020,04C,14,8,(-4,-3),0

*00443,22,lcru

2,14,8,(-2,-6),014,1,01E,020,012,034,02C,028,026,2,060,04C,

14,8,(-4,-3),0

*00444,25,lcrf

2,14,8,(-2,-6),020,1,044,018,01A,01C,01E,020,012,014,016,018,2,

040,04C,14,8,(-4,-3),0

*00445,20,lcrh

2,14,04B,14,8,(0,-2),1,042,2,048,1,04E,2,020,14,8,(-4,-3),0

*00446,21,lcrc

2,14,8,(-2,-6),044,1,04C,030,044,04C,010,01C,2,014,020,

14,8,(-4,-3),0

*00447,18,lcrch

2,14,8,(-2,-6),044,1,03C,030,034,04C,2,020,14,8,(-3,-3),0

*00448,21,lcrsh

2,14,8,(-2,-6),1,044,04C,020,024,02C,020,044,2,04C,020,

14,8,(-4,-3),0

*00449,24,lcrshch

2,14,8,(-2,-6),1,044,04C,020,024,02C,020,044,04C,010,01C,2,014,

020,14,8,(-5,-3),0

*0044A,21,lcrtvznak

2,14,8,(-2,-6),044,1,010,04C,020,012,016,028,2,050,02C,

14,8,(-4,-3),0

*0044B,24,lcryyy

2,14,8,(-2,-6),1,044,02C,020,01E,01A,028,2,040,1,044,2,04C,020,

14,8,(-4,-3),0

*0044C,19,lcrmznak

2,14,8,(-2,-6),1,044,02C,020,01E,01A,028,2,050,14,8,(-3,-3),0

*0044D,25,lcreee

2,14,8,(-2,-6),014,1,01E,020,012,014,028,020,014,016,028,01A,2,

060,03C,14,8,(-4,-3),0

*0044E,26,lcryu

2,14,8,(-2,-6),1,044,02C,010,014,012,010,01E,02C,01A,018,016,014,

2,050,02C,14,8,(-4,-3),0

*0044F,22,lcrya

2,14,8,(-2,-6),1,022,018,016,012,030,02C,028,020,02C,2,020,

14,8,(-4,-3),0

*020A0,4,keuroRef2

7,0020AC,0

*020A7,32,kpes

2,14,06B,14,010,1,064,020,01E,01C,01A,028,2,8,(4,3),1,05C,01E,

012,2,025,1,028,2,03E,020,14,8,(-6,-3),0

*020AC,45,keuro

3,2,2,14,8,(-4,-12),080,024,1,01C,01A,048,026,044,5,044,022,040,01E,01C

6,2,8,(-1,-1),5,1,050,6,2,024,1,060,2,8,(6,-7),14,8,(-8,-6),4,2,0

*02126,24,komega

2,14,8,(-2,-6),1,010,014,025,024,012,020,01E,02C,02B,01C,010,2,

020,14,8,(-4,-3),0

*02205,28,kdiam

2,14,8,(-2,-6),012,1,016,024,012,020,01E,02C,01A,028,2,01B,1,063,

2,010,03D,03C,14,8,(-4,-3),0

*0221E,18,kinfin

2,14,04B,034,1,01E,022,01E,01A,026,01A,2,06F,14,8,(-4,-1),0

*02264,20,kleq

2,14,8,(-2,-6),014,1,040,2,054,1,049,04F,2,02E,14,8,(-4,-2),0

*02302,16,ktri

2,14,04B,1,024,022,02E,02C,048,2,060,14,8,(-4,-3),0


Расширенный стандартный шрифт UNICODE - Команды

Формы и шрифты
Формы и шрифты
Расширенный стандартный шрифт UNICODE
Понятия
Процедуры
Команды

Команды
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Описания больших шрифтов - Понятия

Формы и шрифты
Описания больших шрифтов
Понятия
Процедуры
Команды

В некоторых иностранных языках (например, в японском) используются текстовые шрифты, содержащие тысячи знаков алфавита, отсутствующих в коде ASCII. Для того чтобы иметь возможность работы с такими текстами, в AutoCAD предусмотрен специальный формат файла описания форм, который называется Большой шрифт.

В некоторых иностранных языках (например, в японском) используются текстовые шрифты, содержащие тысячи знаков алфавита, отсутствующих в коде ASCII. Для того чтобы иметь возможность работы с такими текстами, в AutoCAD предусмотрен специальный формат файла описания форм, который называется Большой шрифт.

  • Описание большого шрифта
    Специальные коды в первой строке файла большого шрифта определяют способ считывания двухбайтовых шестнадцатеричных кодов.
  • Создание файла расширенного большого шрифта
    Для уменьшения размера составных иероглифов Kanji можно создать расширенный большой шрифт. Для представления такого шрифта используется код субформы, за которым сразу следует 0.
  • Использование большого шрифта в чертежах
    Для того чтобы в наносимых на чертеж текстах можно было использовать символы большого шрифта, необходимо выбрать текстовый стиль и задать в нем имя файла большого шрифта.
  • Использование большого шрифта для создания специальных символов
    Для включения специальных символов в текстовые строки лучше использовать возможности большого шрифта, чем включать эти символы в обычные шрифты.


Описания больших шрифтов - Процедуры

Формы и шрифты
Описания больших шрифтов
Понятия
Процедуры
Команды

Нет процедур для этой темы.


Описания больших шрифтов - Команды

Формы и шрифты
Описания больших шрифтов
Понятия
Процедуры
Команды
Команды
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Описание большого шрифта - Понятия

Формы и шрифты
Описание большого шрифта
Понятия
Процедуры
Команды

Специальные коды в первой строке файла большого шрифта определяют способ считывания двухбайтовых шестнадцатеричных кодов.

Шрифт, содержащий сотни или даже тысячи символов, требует иного подхода, чем содержащий набор из 256 символов кода ASCII. Помимо более сложной процедуры поиска нужных символов в файле, AutoCAD необходим способ представления символов как двухбайтовыми, так и однобайтовыми кодами. Обе эти проблемы решаются посредством включения специальных кодов в заголовок файла описания большого шрифта.

Первая строка файла описания большого шрифта должна выглядеть так:

*BIGFONT длина,диапазоны,b1,e1,b2,e2,...

где длина - приблизительное число символов в этом наборе; причем, если оно отличается от точного более чем на 10%, это может отразиться на скорости обработки или размерах файла. Остальная часть строки определяет специальные управляющие коды, обозначающие начало двухбайтового кода. Например, на японских компьютерах символы алфавита Kanji начинаются с шестнадцатеричных кодов из диапазонов 90-AF и E0-FF. Когда операционная система обнаруживает один из этих кодов, она считывает следующий байт и комбинирует два байта в код для одного иероглифа. В строке *BIGFONT параметр диапазоны задает диапазоны кодов, используемых в качестве управляющих; пары b1, e1, b2, e2 и т.д. соответствуют кодам начала (b) и конца (e) каждого диапазона. Таким образом, заголовок для японского большого шрифта может выглядеть так:

*BIGFONT 4000,2,090,0AF,0E0,0FF

В остальном символы *BIGFONT описываются точно так же, как и символы обычного шрифта AutoCAD, но при этом коды символов (номера форм) могут принимать значения до 65535.


Описания больших шрифтов

Формы и шрифты
Описания больших шрифтов
Понятия
Процедуры
Команды

Нет процедур.


Описание большого шрифта - Команды

Формы и шрифты
Формы и шрифты
Описание большого шрифта
Понятия
Процедуры
Команды

Команды
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Создание файла расширенного большого шрифта - Понятия

Формы и шрифты
Создание файла расширенного большого шрифта
Понятия
Процедуры
Команды

Для уменьшения размера составных иероглифов Kanji можно создать расширенный большой шрифт. Для представления такого шрифта используется код субформы, за которым сразу следует 0.

Первая строка файла расширенного большого шрифта ничем не отличается от первой строки файла обычного большого шрифта. Последующие строки файла имеют формат:

*0,5,имя_шрифта
высота_символа, 0, режимы, ширина_символа,0
            .
            .
            .
*номер_формы,число_байт,имя_формы
            .
код,0,примитив#,x_базовая,y_базовая,ширина,высота,
            .
            .
код,0,примитив#,x_базовая,y_базовая,ширина,высота,
            .
ограничитель

Рассмотрим назначение каждого из полей:

высота_символа

Используется совместно с шириной и задает количество единиц в символах шрифта.

ширина_символа

Используется совместно с высотой и задает количество единиц в символах шрифта. Высота_символа и ширина_символа определяют масштабирование шрифтовых примитивов. В данном случае примитивами являются точки, отрезки, многоугольники и цепочки символов, геометрически ориентированные в двумерном пространстве. Иероглиф состоит из нескольких примитивов, которые многократно используются в различных масштабах и комбинациях.

режимы

Байт режимы равен 0 для шрифта только с горизонтальной ориентацией и 2 - для шрифта, поддерживающего двойную ориентацию (горизонтально и вертикально). Специальный код 00E (14) может использоваться только тогда, когда байт режимы равен 2.

номер_формы

Код символа.

число_байт

Размер в байтах. Длина значения — всегда 2 байта. Оно может включать в себя шестнадцатеричные коды или сочетание десятичного и шестнадцатеричного.

имя_формы

Имя символа.

код

Специальный код описания формы. Всегда равен 7, т.к. может описывать субформу.

примитив#

Ссылка на номер субформы. Длина поля — всегда 2 байта.

x_базовая

Координата X начала примитива.

y_базовая

Координата Y начала примитива.

ширина

Масштаб ширины примитива.

высота

Масштаб высоты примитива.

ограничитель

Индикатор конца файла определения формы. Всегда равен 0.

При отрисовке примитива AutoCAD вначале уменьшает его до одной квадратной единицы, а затем умножает его ширину и высоту на соответствующие масштабы, заданные при описании примитива. Коды символов (номера форм) в файле описания большого шрифта могут принимать значения до 65535. В следующей таблице приведено описание полей файла расширенного большого шрифта.

номер_формы | xxxx | 2 байта | Код символа
код | 7,0 | 2 байта | Описание расширенного шрифта
примитив# | xxxx | 2 байта | Ссылка на номер субформы
x_базовая |  | 1 байт | Координата X начала примитива
y_базовая |  | 1 байт | Координата Y начала примитива
ширина |  | 1 байт | Масштаб ширины примитива
высота |  | 1 байт | Масштаб высоты примитива
ограничитель | 0 | 1 байт | Конец описания формы

На следующем чертеже представлен пример матрицы 16 x 16 точек, которую можно использовать для создания расширенного крупного шрифта (например, иероглифов). Расстояние между точками матрицы равно одной единице. Стрелка от выноски указывает на единичный квадрат.

На следующем чертеже показаны некоторые примеры иероглифов. Каждый из них занимает матрицу M×N (не обязательно квадратную), подобную представленной выше. Цифры над иероглифом показывают номер соответствующей формы.

На следующем чертеже показаны примитивы, из которых составляются иероглифы.

Примечание Для описания шрифтов не всегда используются квадратные матрицы; они могут быть и прямоугольными.

Пример: файл описания для расширенного крупного шрифта
*BIGFONT 50,1,080,09e
*0,5,Extended Font
15,0,2,15,0
*08D91,31,unspecified
2,0e,8,-7,-15,
7,0,08cfb,0,0,16,16,7,0,08bca,2,3,12,9,
2,8,18,0,2,0e,8,-11,-3,0
*08CD8,31,unspecified
2,0e,8,-7,-15,
7,0,08be0,0,0,8,16,7,0,08cc3,8,0,8,16,
2,8,18,0,2,0e,8,-11,-3,0
*08ADF,31,unspecified
2,0e,8,-7,-15,
7,0,089a4,0,0,8,16,7,0,08cb3,8,0,8,16,
2,8,18,0,2,0e,8,-11,-3,0
*08CE8,39,unspecified
2,0e,8,-7,-15,
7,0,089a4,0,1,5,14,7,0,08cc3,5,2,5,14,7,0,08c8e,9,0,7,
16,2,8,18,0,2,0e,8,-11,-3,0
*089A4,39,primitive
2,0e,8,-7,-15,2,8,1,14,1,0c0,
2,8,-11,-6,1,0a0,2,8,-12,-7,1,
0e0,2,8,-7,13,1,0dc,2,8,11,-1,
2,0e,8,-11,-3,0
*08BCA,41,primitive
2,0e,8,-7,-15,2,8,1,14,1,0c0,
2,8,-11,-6,1,0a0,2,8,-12,-8,1,
0e0,2,0e5,1,0ec,2,063,1,8,
2,-3,2,06f,2,0e,8,-11,-3,0
*08BE0,81,primitive
2,0e,8,-7,-15,2,8,3,9,1,080,
2,8,-10,-4,1,0c0,2,8,-13,-5,1,
0e0,2,8,-7,9,1,09c,2,8,-1,14,
1,8,-6,-5,2,8,8,5,1,8,6,-5,
2,8,-11,-6,1,8,1,-3,2,8,7,3,
1,8,-1,-3,2,8,-3,15,1,01a,2,
012,1,01e,2,8,10,-14,2,0e,8,
-11,-3,0
*08C8E,44,primitive
2,0e,8,-7,-15,2,8,3,15,1,090,0fc,038,
2,8,-6,11,1,090,2,8,-9,-5,1,
090,2,096,1,0ac,8,-1,-3,01a,01a,2,8,
18,0,2,0e,8,-11,-3,0
*08CB3,61,primitive
2,0e,8,-7,-15,2,042,1,02b,02a,018,2,
0d0,1,012,034,2,069,1,01e,040,2,8,
-8,6,1,02b,2,8,4,5,1,08c,2,8,
-3,8,1,03c,2,8,-5,3,1,0e0,2,8,
-12,5,1,0a0,2,8,6,-14,2,0e,8,
-11,-3,0
*08CC3,34,primitive
2,0e,8,-7,-15,2,0c1,1,06c,0a8,064,0a0,2,8,
-5,9,1,09c,2,8,-7,5,1,0e0,2,8,
4,-11,2,0e,8,-11,-3,0
*08CFB,22,primitive
2,0e,8,-7,-15,2,0d2,1,0cc,0c8,0c4,0c0,2,8,
5,-13,2,0e,8,-11,-3,0


Создание файла расширенного большого шрифта - Команды

Формы и шрифты
Формы и шрифты
Создание файла расширенного большого шрифта
Понятия
Процедуры
Команды

Команды
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование большого шрифта в чертежах - Понятия

Формы и шрифты
Использование большого шрифта в чертежах
Понятия
Процедуры
Команды

Для того чтобы в наносимых на чертеж текстах можно было использовать символы большого шрифта, необходимо выбрать текстовый стиль и задать в нем имя файла большого шрифта.

Для того чтобы в наносимых на чертеж текстах можно было использовать символы большого шрифта, необходимо вызвать команду СТИЛЬ и задать в ней файл большого шрифта. В одном и том же текстовом стиле можно использовать и обычный ASCII-шрифт, и большой шрифт. В этом случае при описании стиля вводятся два имени, разделенные запятой. В приведенном ниже примере используется вариант команды СТИЛЬ с интерфейсом командной строки. Если же работа ведется в диалоговом окне "Текстовые стили", цели можно достичь, установив флажок "Использовать большой шрифт".

Команда: -стиль

Имя текстового стиля или [?] <текущий>: имя_стиля

Укажите полное имя шрифта или имя файла (TTF или SHX): txt,greek

AutoCAD подразумевает, что первым задается обычный шрифт, а вторым - большой.

Если введено имя лишь одного шрифта, AutoCAD использует этот шрифт в качестве обычного, а большой шрифт (если он был задан) удаляется из текстового стиля.

Вставляя запятые перед именами файлов шрифтов или после них, можно переназначить только один из шрифтов, не изменяя другой, как показано в следующей таблице.

обычный, большой | Задаются оба шрифта: обычный и большой
обычный, | Задается только обычный шрифт (большой шрифт не изменяется)
,большой | Задается только большой шрифт (обычный шрифт не изменяется)
обычный | Задается только обычный шрифт (при необходимости большой шрифт удаляется)
ENTER (пустой ввод) | изменений нет

Если команда СТИЛЬ используется для получения списка стилей или для просмотра параметров имеющегося стиля, AutoCAD отображает его шрифты в следующем формате: файл обычного шрифта, запятая и файл большого шрифта. Если был задан только файл большого шрифта, то его имя будет выведено с предшествующей запятой: ,greek.

Для каждого символа текстовой строки AutoCAD сначала пытается найти его описание в файле большого шрифта. Если описание не найдено, то поиск продолжается в файле обычного шрифта.


Использование большого шрифта в чертежах - Команды

Формы и шрифты
Формы и шрифты
Использование большого шрифта в чертежах
Понятия
Процедуры
Команды

Команды
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Использование большого шрифта для создания специальных символов - Понятия

Формы и шрифты
Использование большого шрифта для создания специальных символов
Понятия
Процедуры
Команды

Для включения специальных символов в текстовые строки лучше использовать возможности большого шрифта, чем включать эти символы в обычные шрифты.

Некоторые задачи требуют присутствия в текстовых строках большого количества специальных символов. Эти символы можно включить в обычные шрифты AutoCAD. Однако такой подход имеет ряд следующих ограничений.

  • Шрифт может иметь не более 255 форм.
  • Стандартный набор символов использует около половины имеющихся номеров форм. Свободными являются только следующие коды: от 1 до 9, от 11 до 31, от 130 до 255 (не во всех языках).
  • При использовании нескольких текстовых шрифтов дополнительные символы нужно описывать в каждом из них.
  • Чтобы использовать специальные символы, нужно каждый раз вводить %%nnn, где nnn - это номер формы в файле описания.

Эти проблемы исчезают, если использовать возможности большого шрифта. В этом случае можно выбрать один или несколько редко используемых символов (например, тильду (˜) или вертикальную черту (|)) в качестве управляющих кодов, а специальным символам поставить в соответствие другие символы таблицы. Например, можно использовать файл большого шрифта, показанный ниже, для создания греческих букв путем ввода вертикальной черты (|, код ASCII 124), за которой следует эквивалентная латинская буква. Так как первым байтом всех вновь созданных символов является 124, их коды смещены относительно латинских букв на 31744 (= 124 x 256).

*BIGFONT 60,1,124,124
*0,4,Greek
сверху, снизу, режим, 0
*31809,n,uca
. . . альфа в верхнем регистре, вводится как "|A"
*31810,n,ucb
. . . бета в верхнем регистре, вводится как "|B"
*31841,n,lca
. . . альфа в нижнем регистре, вводится как "|a"
*31842,n,lcb
. . . бета в нижнем регистре, вводится как "|b"
*31868,n,vbar
. . . вертикальная черта, вводится как "||"
. . .


Использование большого шрифта для создания специальных символов - Команды

Формы и шрифты
Формы и шрифты
Использование большого шрифта для создания специальных символов
Понятия
Процедуры
Команды

Команды
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Описания шрифтов Unicode - Понятия

Формы и шрифты
Описания шрифтов Unicode
Понятия
Процедуры
Команды

Одного шрифта Unicode, вследствие гораздо большего количества символов в нем, достаточно для поддержки всех языков и платформ. Формат и синтаксис файлов описания шрифтов Unicode практически идентичны формату и синтаксису файлов описания обычных форм AutoCAD.

Основное различие заключается в синтаксисе заголовка шрифта, который выглядит так:

*UNIFONT,6,имя_шрифта

сверху,снизу,режимы,кодировка,тип,0

Параметры имя_шрифта, сверху, снизу и режимы задаются так же, как и для обычных шрифтов. Смысл двух остальных параметров описан ниже:

кодировка

Кодировка шрифта. Может иметь одно из следующих целых значений:

0 Unicode

1 Упакованный многобайтовый 1

2 Файл формы

тип

Информация о способе внедрения шрифта. Определяет, является ли шрифт лицензионным. Лицензионные шрифты нельзя ни модифицировать, ни распространять. Возможные значения:

0?Шрифт может быть внедрен

1?Шрифт не может быть внедрен

2?Внедрение осуществляется без возможности модификации

Другим важным различием является способ обработки ссылок на субформы (код 7). Если в описании шрифта присутствует такая ссылка, следующие за кодом 7 данные интерпретируются как 2-байтовое значение. Это влияет на общее количество байт данных (число_байт), записанное в заголовке описания формы. Например, в файле romans.shp можно найти такое описание формы:

*00080,4,keuroRef
7,020AC,0

Второе поле в заголовке показывает, сколько байт занимает данное описание. Тем, кто ранее не работал со шрифтами Unicode, может показаться, в этом случае длина должна равняться 3 байтам, а не 4, но если изменить таким образом значение длины, возникнет ошибка компиляции SHP-файла. Даже если номер формы, на которую выполняется ссылка, занимает всего один байт (т.е. меньше или равен 255), компилятор всегда отводит под данное поле 2 байта, так что это необходимо учесть в заголовке.

Еще одно видимое различие между шрифтами Unicode и обычными шрифтами относится к формату записи номеров форм. В описаниях форм шрифтов Unifont, поставляемых с AutoCAD, используются шестнадцатеричные, а не десятичные номера шрифтов. Хотя это и не обязательно, соблюдение данного соглашения намного упрощает ориентацию в файле (особенно при обращении к символам-формам с помощью кода \U+).


Описания шрифтов Unicode - Команды

Формы и шрифты
Формы и шрифты
Описания шрифтов Unicode
Понятия
Процедуры
Команды

Команды
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Верхние и нижние индексы в SHX-файлах - Понятия

Формы и шрифты
Верхние и нижние индексы в SHX-файлах
Понятия
Процедуры
Команды

Для усовершенствования отображения верхних и нижних индексов в текстовых строках нужно внести некоторые изменения в соответствующие файлы описания форм.

SHX-шрифты AutoCAD обладают лишь ограниченными возможностями написания верхних и нижних индексов в текстовых строках. Однако бороться с этим сравнительно просто: нужно внести некоторые изменения в соответствующие файлы описания форм.

Процесс нанесения верхних и нижних индексов проходит в два этапа. Вначале необходимо сместить вверх или вниз “воображаемое перо”, с помощью которого, вектор за вектором, отрисовывается текст. Затем производится уменьшение “масштаба” шрифта. В дополнение к этому требуются еще две обратные операции, которые возвращают шрифт в нормальное состояние. В описание шрифта следует добавить четыре новых символьных клавиши: две для включения/отключения верхних индексов и две - для нижних. Чтобы не трогать уже имеющиеся описания, лучше отвести под переход на уменьшенный шрифт клавиши малой цифровой клавиатуры.


Добавление описаний верхних и нижних индексов к описанию шрифта - Процедуры

Формы и шрифты
Верхние и нижние индексы в SHX-файлах
Понятия
Процедуры
Команды

Добавление описаний верхних и нижних индексов к описанию шрифта

Описанная в данном примере процедура иллюстрирует модификацию шрифта AutoCAD с именем Romans, но такой же метод можно приложить к любому шрифту AutoCAD. К описанию шрифта добавляются четыре новые формы: super_on, super_off, sub_on и sub_off, которые управляют положением и размером следующих за ними символов. Для простоты в данном примере под новые операции задействованы символы квадратных скобок ([и]) и фигурных скобок ({и}). Пользователь может выбрать для данной операции другие символы или использовать номера форм из расширенной части таблицы ASCII (коды от 128 до 256). В последнем случае для размещения новых символов потребуется ввод кода %%nnn (где nnn - это ASCII-код символа).

  1. Отредактируйте файл SHP в текстовом редакторе ASCII.
  2. Найдите описания форм для символов, которые нужно заменить. Для того чтобы новые описания форм вступили в силу, перед каждой строкой, содержащей старое описание, нужно поставить точку с запятой, тогда она будет считаться комментарием. Описание формы может состоять из нескольких строк.

    3. Символы квадратных скобок имеют коды ASCII 91 и 93 (для шрифтов Unicode используются шестнадцатеричные значения 05B и 05D). Символы фигурных скобок имеют коды ASCII 123 и 125 (шестнадцатеричные значения 07B и 07D).

  3. Сложите первое и второе значения из второй строки описания и разделите полученную сумму на 2, как показано в следующем примере:
    4. *UNIFONT,6,расширенный одноштриховой Roman для UNICODE
    21,7,2,0 21 + 7 = 28, затем 28 / 2 = 14. Полученное число будет использоваться в дальнейшем.
  4. Добавить следующие строки в конец SHP-файла:
    5. *91,8,super_on
    2,8,(0,14),003,2,1,0
    *93,8,super_off
    2,004,2,8,(0,-14),1,0
    *123,8,sub_on
    2,8,(0,-14),003,2,1,0
    *125,8,sub_off
    2,004,2,8,(0,14),1,0

    Обратите внимание на значения 14 и –14, использующиеся в этих строках. Это смещения по оси Y для воображаемого пера. Значение 14 - это половина максимальной высоты символов данного шрифта, что является правильным приближенным значением для верхних и нижних индексов. Это значение необходимо вычислять для каждого файла шрифта отдельно, но пользователь может изменить его по своему желанию.

  5. Сохраните файл.
  6. Скомпилируйте SHP-файл с помощью команды КОМПИЛ.

    7. После того как форма откомпилирована и задан нужный стиль, можно вызывать новые команды для поднятия и опускания пера путем ввода символов [, ], {, и }. Символ [ наносит верхний индекс, а символ ] возвращает шрифт в нормальное состояние. Символ { наносит нижний индекс, а символ } возвращает шрифт в нормальное состояние.


Верхние и нижние индексы в SHX-файлах - Команды

Формы и шрифты
Формы и шрифты
Верхние и нижние индексы в SHX-файлах
Понятия
Процедуры
Команды

Команды
МЕНЮВЫГР | Устар.
МЕНЮЗАГР | Устар.
Системные переменные
Нет. |
Утилиты
Нет. |
Ключевые слова для команд
Нет. |


Комментарии пользователя

Данная форма предназначена для ввода замечаний и предложений, которые будут отправлены в группу технической документации компании Autodesk.

Заголовок и расположение раздела (не изменять):
Имя и фамилия (не обязательно):
         E-mail (не обязательно):
Текст комментария:

Замечание: Форма не может служить средством получения советов или технической поддержки. Информация из нее будет использована для улучшения документации по продукту. Благодарим Вас!